Std CloseAllWindows/ru

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std CloseAllWindows and the translation is 0% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский

Std CloseAllWindows

Расположение в меню
Файл → Закрыть всё
Верстаки
All
Быстрые клавиши
...
Представлено в версии
-
См. также
Закрыть, Сохранить как... и Сохранить


Description

The Std CloseAllWindows command closes all windows, thereby closing all documents.

Usage

  1. Select the File → Close All option from the menu.
  2. If there are unsaved documents a dialog box will prompt you to save them:
    • Press the Save button to save the active document. If required enter a filename first.
    • Press the Discard button to discard the active document and lose all changes.

Options

  • When the dialog box is displayed: press Esc or the Cancel button to abort the command.
  • If there are multiple unsaved documents: check the CheckBoxTrue.svg Apply answer to all checkbox to avoid being prompted for each unsaved document separately.

Notes

  • A document can also be closed by right-clicking it in the Tree view and selecting Close document from the context menu.

Preferences

  • The last used file location is stored: Tools → Edit parameters... → BaseApp → Preferences → General → FileOpenSavePath.

Scripting

See also: FreeCAD Scripting Basics.

To close a document use the closeDocument method of the FreeCAD application. For a scripting example see Std New.