Std Alles schließen

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std CloseAllWindows and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎română • ‎русский • ‎한국어

Std CloseAllWindows.svg Std Alles schließen

Menüeintrag
Datei → Alles schließen
Arbeitsbereich
Alle
Standardtastenkürzel
Keiner
Eingeführt in Version
-
Siehe auch
Schließen

Beschreibung

Schließt alle geöffneten Dokumente.

Der Std Alles schließen-Befehl schließt alle Fenster und dadurch alle Dokumente.

Anwendung

Wähle DateiAlles schließen aus der Menüleiste.

  1. Wähle die Datei → Std CloseAllWindows.svg Alles Schließen-Option aus dem Menü.
  2. Falls es nicht gesicherte Dokumente gibt, öffnet sich eine Dialog-Box, die zum Sichern auffordert:
    • Drücke die Speichern-Schaltfläche zum Sichern des aktiven Dokuments. Falls erforderlich, gib zuerst den Dateinamen ein.
    • Drücke die Schließen ohne zu Speichern-Schaltfläche, um das aktive Dokument zu verlassen und alle Änderungen zu verlieren.

Optionen

  • Wenn die Dialog-Box angezeigt wird, drücke Esc oder die Abbrechen-Schaltfläche, um den Befehl abzubrechen.
  • Fall es mehrere nicht gesicherte Dokumente gibt: aktiviere das CheckBoxTrue.svg Antwort auf alle anwenden-Kästchen, um zu vermeiden, für jedes ungesicherte Dokument separat aufgefordert zu werden.

Hinweise

  • Ein Dokument kann auch geschlossen werden, indem es in der Baumansicht mit einem Rechtsklick ausgewählt und Dokument schließen aus dem Kontextmenü benutzt wird.

Einstellungen

  • Der zuletzt verwendete Dateispeicherort wird gespeichert: Werkzeuge → Parameter bearbeiten... → BasisAnwendung → Einstellungen → Allgemein → FileOpenSavePath.

Skripten

Siehe auch: FreeCAD Grundlagen Skripten.

Um ein Dokument zu schließen, benutze die closeDocument-Methode der FreeCAD-Anwendung. Für ein Skripting-Beispiel siehe Std Neu.