Std: Închideți toate documentele

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std CloseAll and the translation is 6% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский

Std CloseAll.png Std_CloseAll

Menu location
File → Close All
Workbenches
All
Default shortcut
...
Introduced in version
-
See also
Close, Save As... e Save

Descriere

Comanda închide toate documentele proiectului, chiar și cele care nu sunt active. Cu această comandă nu ieșiți din FreeCAD.

The Std CloseAllWindows command closes all windows, thereby closing all documents.

Utilizare

Alegeți File Close All din meniul principal. Dacă în proiect există documente nesalvate sau modificate, se afișează un mesaj și sunteți întrebați dacă doriți să le salvați: UnsavedDocument.png

În cazul unui răspuns afirmativ,

  • dacă documentul a fost deja salvat, utilizați numele și setul de adrese,
  • dacă documentul nu a fost salvat niciodată, deschideți fereastra pentru a defini calea și a atribui un nume documentului:

FileSaveAs.png

Comanda Chiudi în schimb, închide doar documentul activ și permite continuarea lucrului cu alte documente ale proiectului.


Link

Comandi per categorie

  1. Select the File → Close All option from the menu.
  2. If there are unsaved documents a dialog box will prompt you to save them:
    • Press the Save button to save the active document. If required enter a filename first.
    • Press the Discard button to discard the active document and lose all changes.

Options

  • When the dialog box is displayed: press Esc or the Cancel button to abort the command.
  • If there are multiple unsaved documents: check the CheckBoxTrue.svg Apply answer to all checkbox to avoid being prompted for each unsaved document separately.

Notes

  • A document can also be closed by right-clicking it in the Tree view and selecting Close document from the context menu.

Preferences

  • The last used file location is stored: Tools → Edit parameters... → BaseApp → Preferences → General → FileOpenSavePath.

Scripting

See also: FreeCAD Scripting Basics.

To close a document use the closeDocument method of the FreeCAD application. For a scripting example see Std New.

Template:Std Base navi/ro