Std Fermer tout

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std CloseAll and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский
Arrow-left.svg Page précédente : Fermer
Page suivante : Enregistrer Std Save.svg Arrow-right.svg

Std Fermer tout

Emplacement du menu
Fichier → Fermer tout
Ateliers
Tous
Raccourci par défaut
Aucun
Introduit dans la version
-
Voir aussi
Std Fermer


Description

La commande Std Fermer tout ferme toutes les fenêtres, fermant ainsi tous les documents.

Utilisation

  1. Sélectionnez l'option Fichier → Fermer tout dans le menu.
  2. S'il y a des documents non enregistrés, une boîte de dialogue vous demandera de les enregistrer:
    • Appuyez sur le bouton Enregistrer pour enregistrer le document actif. Si nécessaire, entrez d'abord un nom de fichier.
    • Appuyez sur le bouton Supprimer pour supprimer le document actif et perdre toutes les modifications.

Options

  • Lorsque la boîte de dialogue s'affiche: appuyez sur Echap ou sur le bouton Annuler pour abandonner la commande.
  • S'il existe plusieurs documents non enregistrés: cochez la case CheckBoxTrue.svg Appliquer la réponse à tous pour éviter d'être invité à chaque fois pour chaque document non enregistré.

Remarques

  • Un document peut également être fermé en cliquant dessus avec le bouton droit de la souris dans la vue en arborescence et en sélectionnant Fermer le document dans le menu contextuel.

Préférences

  • Le dernier emplacement de fichier utilisé est stocké: Outils → Editer les paramètres... → BaseApp → Preferences → General → FileOpenSavePath.

Script

Voir aussi: FreeCAD Script de base.

Pour fermer un document, utilisez la méthode closeDocument de l'application FreeCAD. Pour un exemple de script, voir Std Nouveau.

Arrow-left.svg Page précédente : Fermer
Page suivante : Enregistrer Std Save.svg Arrow-right.svg