Std CloseAll

From FreeCAD Documentation
Jump to navigation Jump to search
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский

Std CloseAllWindows

Menu location
File → Close All
Workbenches
All
Default shortcut
None
Introduced in version
-
See also
Std Close


Description

The Std CloseAllWindows command closes all documents.

Usage

  1. Select the File → Close All option from the menu.
  2. If there are unsaved documents a dialog box will prompt you to save them:
    • Press the Save button to save the active document. If required enter a filename first.
    • Press the Discard button to discard the active document and lose all changes.

Options

  • If there are multiple unsaved documents: check the CheckBoxTrue.svg Apply answer to all checkbox to avoid being prompted for each unsaved document separately.
  • If there are unsaved documents: press Esc or the Cancel button to abort the command.

Preferences

  • The last used file location is stored: Tools → Edit parameters... → BaseApp → Preferences → General → FileOpenSavePath.

Scripting

See also: FreeCAD Scripting Basics.

To close a document use the closeDocument method of the FreeCAD application. For a scripting example see Std New.