Std Schließen

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std CloseActiveWindow and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎română • ‎русский • ‎한국어

Std CloseActiveWindow.svg Std Schließen

Menüeintrag
Datei → Schließen
Arbeitsbereich
Alle
Standardtastenkürzel
Strg+F4
Eingeführt in Version
-
Siehe auch
Alles schließen

Schließt das aktuelle Dokument

Der Std Schließen-Befehl schließt das aktive Fenster. Um ein Dokument zu schließen, müssen alle seine Fenster geschlossen werden.

Anwendung

  1. Es gibt mehrere Wege, den Befehl aufzurufen:
    • Wähle die Datei → Std CloseActiveWindow.svg Schließen-Option aus dem Menü.
    • Benutze den Tastaturkurzbefehl: Ctrl+F4.
  2. Um ein Dokument zu schließen: wiederhole dies für alle dazugehörigen Fenster..
  3. Beim Schließen des letzten Fensters eines nicht gesicherten Dokument öffnet sich eine Dialog-Box, die zum Sichern auffordert:
    • Drücke die Speichern-Schaltfläche. Falls erforderlich, gib zuerst den Dateinamen ein.
    • Drücke die Schließen ohne zu Speichern-Schaltfläche, um das Dokument zu verlassen und alle Änderungen zu verlieren.

Optionen

  • Wenn die Dialog-Box angezeigt wird, drücke Esc oder die Abbrechen-Schaltfläche, um den Befehl abzubrechen.

Hinweise

  • Der Befehl kann nur docked-Fenster schließen.
  • * Ein Dokument kann auch geschlossen werden, indem es in der Baumansicht mit einem Rechtsklick ausgewählt und Dokument schließen aus dem Kontextmenü benutzt wird.

Einstellungen

  • Der zuletzt verwendete Dateispeicherort wird gespeichert: Werkzeuge → Parameter bearbeiten... → BasisAnwendung → Einstellungen → Allgemein → FileOpenSavePath.

Scripting

Siehe auch: FreeCAD Grundlagen Skripten.

Um ein Dokument zu schließen, benutze die closeDocument-Methode der FreeCAD-Anwendung. Für ein Skripting-Beispiel siehe Std Neu.