Std: Închidere document

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std Close and the translation is 6% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский

Std Close.png Std Close

Menu location
File → Close
Workbenches
All
Default shortcut
Ctrl+W
Introduced in version
-
See also
CloseAll

Închide documentul curent

Std Close.png Chiudi

Nome nel codice
Std_Close
Posizione nel menu
File → Chiudi
Ambiente
Tutti
Avvio veloce
Crtl+W
Introdotto nella versione
-
Vedere anche
Chiudi tutto, Salva con nome... e Salva


Descriere

Comanda închide numai documentul activ și vă permite să continuați să lucrați la alte documente ale proiectului.

Dacă documentul nu a fost salvat sau a fost modificat, afișează un mesaj și întreabă dacă doriți să îl salvați:


UnsavedDocument.png

În cazul unui răspuns afirmativ,

  • dacă documentul a fost deja salvat, utilizați numele și setul de adrese,
  • dacă documentul nu a fost salvat niciodată, deschideți fereastra pentru a defini calea și a atribui un nume documentului:
FileSaveAs.png



Comanda Chiudi tutto închide toate documentele proiectului .

Cu această comandaă nu se iese din FreeCAD.


Link

Comandi per categorie

The Std CloseActiveWindow command closes the active window. To close a document all its windows must be closed.

Usage

  1. There are several ways to invoke the command:
    • Select the File → Close option from the menu.
    • Use the keyboard shortcut: Ctrl+F4.
  2. To close a document: repeat this for all windows belonging to it.
  3. When closing the last window of a document that has not been saved, a dialog box will prompt you to save it:
    • Press the Save button to save the document. If required enter a filename first.
    • Press the Discard button to discard the document and lose all changes.

Options

  • When the dialog box is displayed: press Esc or the Cancel button to abort the command.

Notes

  • The command can only close docked windows.
  • A document can also be closed by right-clicking it in the Tree view and selecting Close document from the context menu.

Preferences

  • The last used file location is stored: Tools → Edit parameters... → BaseApp → Preferences → General → FileOpenSavePath.

Scripting

See also: FreeCAD Scripting Basics.

To close a document use the closeDocument method of the FreeCAD application. For a scripting example see Std New.

Template:Std Base navi/ro