Std Close

From FreeCAD Documentation
Jump to navigation Jump to search
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский

Official icon not found Std CloseActiveWindow

Menu location
File → Close
Workbenches
All
Default shortcut
Ctrl+F4
Introduced in version
-
See also
Std CloseAllWindows


Description

The Std CloseActiveWindow command closes the active document.

Usage

  1. There are several ways to invoke the command:
    • Select the File → Close option from the menu.
    • Use the keyboard shortcut: Ctrl+F4.
  2. If the active document has not been saved a dialog box will prompt you to save it:
    • Press the Save button to save the document. If required enter a filename first.
    • Press the Discard button to discard the document and lose all changes.

Options

  • If the active document has not been saved: press Esc or the Cancel button to abort the command.

Notes

  • A document can also be closed by right clicking it in the Tree view and selecting Close document from the context menu.

Preferences

  • The last used file location is stored: Tools → Edit parameters... → BaseApp → Preferences → General → FileOpenSavePath.

Scripting

See also: FreeCAD Scripting Basics.

To close a document use the closeDocument method of the FreeCAD application. For a scripting example see Std New.