Tutorial Randare

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Raytracing tutorial and the translation is 19% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎română • ‎русский

Base ExampleCommandModel.png Tutorial

Topic
Raytracing
Level
Beginner
Time to complete
10 minutes + Render time
Author
Drei
FreeCAD version
0.16 or above
Example File(s)



Introducere

This tutorial is meant to introduce the reader to the basic workflow of the Raytracing Workbench, as well as most of the tools that are available to create a rendered image.

Raytracing tutorial result.png

Requirements

  • FreeCAD version 0.16 or above
  • POV-Ray and/or LuxRender is installed on the system
  • In the case of POV-Ray, it's not enough to have just the binary executable in place, but it also requires the installation of supporting files, and in Ubuntu these are provided by the Recommends-flagged package povray-includes. Potential issues have also been seen with Linux installations requiring local configuration files to be manually created in a user's home folder, as discussed here.
  • In the case of POV-Ray, installation of psicofil's macro is recommended
  • The reader has the basic knowledge to use the Part and PartDesign Workbenches

Procedure

Modeling

In this example a Cube is used as the study object, but models created in the Part or PartDesign Workbenches can be used instead.

  1. Create a new document
  2. Activate the Part Workbench
  3. Create a Cube. You are free to change its properties in any way.

Now we have a model with which to work.

Preparing for the render

  1. Switch to the Raytracing Workbench
  2. Change your View to Perspective. Go to View menu and select Perspective.
  3. Set the location for the renderer. Go to the Edit menu and select Preferences. Click on Raytracing and set the location to the executable.
  4. Set the size of the rendered image. Go to the Edit menu and select Preferences. Click on Raytracing and set the desired image size.

POV-Ray

  1. Select Raytrace New.svg New PovRay project. From the dropdown menu pick RadiosityNormal

LuxRender

  1. Select Raytrace Lux.svg New LuxRender project. From the dropdown menu pick LuxClassic

Setting the camera position

  1. Position the 3D View to the desired location and distance from the model. In this case we will use the Axonometric View.
  2. Select the Project Folder from the Tree View
  3. Select Raytrace ResetCamera.svg Reset camera

Importing the model

  1. Select the model to render.
  2. Select Raytrace NewPartSegment.svg Insert part

Running the Renderer

  1. Select Raytracing Render.png Render.
  2. Set the path to which the image will be stored.
  3. Wait for the rendering to finish. This may take a while.

Viewing the results

FreeCAD will immediately open the image after the render is finished.

We are now finished with the basic workflow for the Raytracing Module. Template:Tutorials navi/ro