Poradnik dla Środowiska pracy Raytracing

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Raytracing tutorial and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎română • ‎русский

Środowisko pracy Raytracing

Środowisko Raytracing zostało zastąpione przez nowe środowisko Render, które ma je zastąpić. Nie należy go mylić z zatrzymanym i przestarzałym Projekt Render. Środowisko pracy Render może być zainstalowane poprzez Menadżer dodatków. Informacja tutaj jest podana, ponieważ domyślnie FreeCAD jest nadal dostarczany (od wersji 0.19-24276) ze środowiskiem Raytracing, i ponieważ nowy moduł powinien w zasadzie działać w ten sam sposób.
Freecad.svg Ćwiczenie
Temat
Raytracing
Poziom trudności
Początkujący
Czas wykonania
10 minut + czas renderowania
Autorzy
Drei
Wersja FreeCAD
0.16 lub nowszy
Pliki z przykładami
Nie dołączono

Wprowadzenie

Ten poradnik ma na celu zapoznanie czytelnika z podstawowym przepływem pracy w środowisku Raytracing, jak również z większością narzędzi, które są dostępne do tworzenia wyrenderowanego obrazu. Uwaga, środowisko Raytracing jest stopniowo zastępowane nowszym Projektem Render, dostępnym poprzez Menedżer dodatków.

Raytracing tutorial result.png

Wymagania

  • FreeCAD w wersji 0.16 lub wyższej.
  • POV-Ray i/lub LuxRender jest zainstalowany w systemie.
  • W przypadku POV-Ray, nie wystarczy mieć tylko binarny plik wykonywalny na miejscu, ale również wymagana jest instalacja wspierających plików. W Ubuntu, są one dostarczane przez pakiet z flagą Recommends povray-includes. Potencjalne problemy były również widziane z instalacjami Linuksa wymagającymi lokalnych plików konfiguracyjnych do ręcznego utworzenia w folderze domowym użytkownika, jak omówiono na forum.
  • W przypadku POV-Ray, zalecana jest instalacja makrodefinicji psicofil's.
  • Czytelnik posiada podstawową wiedzę do korzystania z środowisk pracy Część i Projekt Części.

Sposób postępowania

Modelowanie

W tym przykładzie jako obiekt badania używany jest sześcian, ale zamiast niego mogą być używane modele utworzone w Środowiskach pracy Part lub PartDesign.

  1. Utwórz nowy dokument.
  2. Aktywuj środowisko pracy Projekt Części.
  3. Utwórz sześcian. Możesz dowolnie zmieniać jego właściwości.

Teraz mamy model, z którym możemy pracować.

Przygotowanie do renderingu

  1. Przełącz się do środowiska Raytracing.
  2. Przełączyć widok na Perspektywę. Przejdź do menu Widok i wybierz Perspektywa.
  3. Ustaw lokalizację dla renderera. Przejdź do menu Edycja → Preferencje. Kliknij na Raytracing i ustaw lokalizację na plik wykonywalny.
  4. Ustaw rozmiar renderowanego obrazu. Przejdź do menu Edycja → Preferencje. Kliknij na Raytracing i ustaw żądany rozmiar obrazu.

POV-Ray

  1. Wybierz Raytrace New.svg Nowy projekt PovRay. Z menu głównego wybierz RadiosityNormal.

LuxRender

  1. Wybierz Raytrace Lux.svg Nowy projekt LuxRender. Z rozwijanego menu wybierz LuxClassic.

Ustawianie pozycji ujęcia widoku

  1. Ustaw widok 3D w żądanym miejscu i odległości od modelu. W tym przypadku używamy widoku aksonometrycznego.
  2. Wybierz Folder projektu w widoku drzewa.
  3. Wybierz Raytrace ResetCamera.svg Resetuj ujęcie widoku.

Importowanie modelu

  1. Wybierz model do renderowania.
  2. Wybierz opcję Raytrace NewPartSegment.svg Wstaw część

Uruchomienie Renderowania

  1. Wybierz funkcję Raytrace Render.svg Renderowanie.
  2. Ustaw ścieżkę przechowywania obrazu.
  3. Poczekaj na zakończenie renderowania. Może to chwilę potrwać.

Przeglądanie wyników

FreeCAD natychmiast otworzy obraz po zakończeniu renderowania.

Dzięki temu ćwiczeniu poznaliśmy podstawowy przepływ pracy dla środowiska pracy Raytracing.