Raytracing Tutorium

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Raytracing tutorial and the translation is 69% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎română • ‎русский

Base ExampleCommandModel.png Tutorial

Thema
Raytracing
Niveau
Anfänger
Zeit zum Abschluss
10 Minuten + Renderzeit
Autor
Drei
FreeCAD version
0.16 oder neuer
Beispieldatei(en)


Einführung

Dieses Tutorial soll den Leser in den grundlegenden Arbeitsablauf des Raytracing Arbeitsbereichs sowie in die meisten der Werkzeuge einführen, die zur Erstellung eines gerenderten Bildes zur Verfügung stehen.

Raytracing tutorial result.png

Voraussetzungen

  • FreeCAD Version 0.16 oder neuer
  • POV-Ray und/oder LuxRender ist auf dem System installiert
  • Im Falle von POV-Ray reicht es nicht aus, nur das Programm (binary executable) an der richtigen Stelle zu haben, sondern es erfordert die Installation von unterstützenden Dateien (supporting files), und in Ubuntu werden diese durch das Recommends-gekennzeichnete Paket povray-includes zur Verfügung gestellt. Potenzielle Probleme gab es auch bei Linux-Installationen, die manuell im home-Verzeichnis des Benutzer angelegte lokale Konfigurationsdateien erforderten, wie hier diskutiert.
  • Im Falle von POV-Ray wird die zusätzliche Installation von psicofil's macro empfohlen.
  • Der Leser sollte Grundkenntnisse über die Arbeitsbereiche Part und PartDesign besitzen.

Prozedur

Modellierung

In diesem Beispiel verwenden wir einen einfachen Würfel als Beispielobjekt, aber es kann beim Raytracing auch jedes andere Objekt, das mit den Arbeitsbereichen Part oder PartDesign erstellt wurde, verwendet werden.

  1. Erstelle ein neues Dokument
  2. Aktiviere den Part Arbeitsbereich
  3. Erzeuge einen Würfel. Es steht dir frei, seine Eigenschaften in irgendeiner Weise zu ändern.

Wir haben nun ein Modell, mit dem wir im Folgenden arbeiten können.

Vorbereiten des Renderns

  1. Wechsle in den Raytracing Arbeitsbereich
  2. Ändere deine Ansicht in Perspektive. Gehe zum Menü Ansicht und wähle Perspektive.
  3. Lege den Speicherort für den Renderer fest. Gehe zum Menü Bearbeiten und wähle Einstellungen. Klicke auf Raytracing und stelle den Speicherort für die ausführbare Datei ein.
  4. Lege die Größe des gerenderten Bildes fest. Gehe zum Menü Bearbeiten und wähle Einstellungen. Klicke auf Raytracing und stelle die gewünschte Bildgröße ein.
POV-Ray
  1. Wähle Raytracing New.png Neues PovRay Projekt. Wähle aus dem Auswahlmenü RadiosityNormal
LuxRender
  1. Klicken Sie auf Raytracing Lux.png Neues LuxRender-Projekt. Wähle aus dem Auswahlmenü LuxClassic

Festlegen der Kameraposition

  1. Verschiebe die 3D Ansicht in die von dir gewünschte Position. In diesem Fall wählen wir die "Axonometrische Ansicht".
  2. Wähle den Projektordnerim Modellbaum aus.
  3. Wähle Raytracing ResetCamera.png Kamera zurücksetzen .

Importieren des Modells

  1. Wähle das zu rendernde Modell.
  2. Wähle Raytracing InsertPart.png Teil einfügen .

Ausführen des Renderers

  1. Wähle Raytracing Render.png Render .
  2. Lege den Pfad fest, unter dem das Bild gespeichert wird.
  3. Warten Sie, bis das Rendern beendet ist. Dies kann einige Zeit dauern.

Betrachten der Ergebnisse

FreeCAD öffnet das Bild sofort, nachdem das Rendern abgeschlossen ist.

Wir sind nun fertig mit der grundlegenden Vorgehensweise mit dem Arbeitsbereich Raytracing Arbeitsbereich. Template:Tutorials navi/de