设置用户首选项

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Preferences Editor and the translation is 10% complete.
Outdated translations are marked like this.
Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎українська • ‎中文 • ‎中文(中国大陆)‎ • ‎日本語 • ‎한국어

Introduction

FreeCAD 的首选项位于菜单栏中的 编辑 → 首选项。

FreeCAD 的功能被分为了不同的模块,每个模块负责某个具体工作台的相关工作。FreeCAD 还使用了一种称之为后加载的观念,意即相关组件只有在需要时才被加载进来。或许你已经注意到,当你在 FreeCAD 工具栏中选择一个工作台时,此工作台和它的所有组件都同时被加载进来。这其中包含了它的首选项设置。

如果没有载入任何模块,将会有两项配置部分,一项是对一般的应用设置,另一项则对显示设置。

单击任何首选项显示左下角的重置 按钮,将freecad首选项的“全部”设置为其默认值。

Some advanced preferences can only be changed in the Parameter editor. The Fine-tuning page lists some of them.

一般的首选项设置

在刚启动 FreeCAD 时没有加载工作台,此时出现的是最小首选项窗口。随着其它模块的载入,最小首选项窗口中就会出现新的部分,此时可以对每个工作台的细节进行配置。

通用

Name Description
Change language Selection of the language of the FreeCAD user interface
Size of recent file list Specification how many files should be listed in the recent files list
Enable tiled background If checked, the background of FreeCAD's main window will by default consist of tiles of this image: Background.png

This option only has an effect if no Style sheet is selected.

The image can be changed by adding the folders Gui/Images in the folder:

%APPDATA%/FreeCAD (on Windows),

$HOME/.FreeCAD (on Linux) or

$HOME/Library/Preferences/FreeCAD (on MacOS).

Place a file named background.png in the Images folder, and uncheck/check this option to see the changed file.

Style sheet Selection of a style sheet. Style sheets define how the user interface of FreeCAD looks.
Size of toolbar icons Selection of the size for the toolbar icons
Tree view mode Customization how the tree view is shown in the panel (restart required). The options are:
  • Combo View: combine tree view and property view into one panel.
  • TreeView and PropertyView: split tree view and property view into separate panel.
  • Both: keep all three panels, and you can have two sets of tree view and property view.
Auto load module after start up Selection what workbench will be used directly after starting FreeCAD
Enable splash screen at start up If checked, a splash screen is shown when starting FreeCAD.

The splash screen image can be changed by placing a file named splash_image.png in the Images folder already mentioned under Enable tiled background.

Enable word wrap Words will be wrapped when they exceed the available horizontal space in the Python console. This console is shown using the menu View → Panels → Python console.

Preferences General Tab General.png

文档

On the Document tab you can specify the following:

Name Description
Create new document at start up If checked, FreeCAD will create a new document when started
Document save compression level Specification of the compression level for FCStd files. FCStd files are ZIP-compressed files. Therefore you can rename their suffix .FCStd to .zip and open them with a ZIP archive program.
Using Undo/Redo on documents If checked, all changes in documents are stored so that they can be undone/redone
Maximum Undo/Redo steps Specification how many Undo/Redo steps should be recorded
Allow aborting recomputation If checked, recomputations can be aborted by pressing Esc. This may slightly increase the recomputation time.
Run AutoRecovery at startup If there is a recovery file available FreeCAD will automatically run a file recovery when it is started. This way files can be restored if a crash occurred.
Save AutoRecovery information every Specification how often a recovery file is written.
Save thumbnail into project file when saving document If checked, a thumbnail will be stored when the document is saved. The thumbnail will for example be shown in the list of recent files in the Start workbench. It is possible to select a Size between 128×128 and 512×512 pixels for the thumbnail. Common sizes are the powers of two: 128, 256, 512.
Add the program logo to the generated thumbnail If checked, the FreeCAD program logo FreeCAD-logo.svg will be added to the thumbnail.
Maximum number of backup files to keep when resaving document If checked, backup files will be kept when saving the document. You can specify the number of backup files to keep. Backup files are previously saved versions of the document. The first backup file will have the file suffix .FCStd1, the second .FCStd2 and so on.
Use date and FCBak extension If checked, backup files will get the extension .FCbak and their file names get a date suffix according to the specified date format. For a description of the date format see this site.

With the default settings a backup file will for example get this name TD-Cube.20200315-215654.FCBak (original filename is TD-Cube.FCStd).

Allow duplicate object labels in one document If checked, objects can have the same label.
Disable partial loading of external linked objects If partial loading of external linked objects is enabled, only the referenced objects and their dependencies will be loaded when the linked document is auto opened together with the main document. Such a partially loaded document cannot be edited. Double click the document icon in the tree view to reload it in full. A more detailed explanation of this feature can be found on the Assembly3 documentation page
Author name All created documents will get the specified author name. Keep the author field blank if you do not want to include this information. If the option Set on save is checked, the field Last modified by will be set to the specified author when saving the file. This field can be viewed using the File → Project information menu option.
Company All created documents will get the specified company name
Default license Selection of the license for new documents. For predefined licenses the License URL will automatically be set accordingly. Select Other for a custom license.
License URL Specification of an URL describing the license selected in Default license

Preferences General Tab Document.png

Selection

On the Selection tab (introduced in version 0.19) you can specify the following:

Name Description
Auto switch to the 3D view containing the selected item Enables the Tree view SyncView mode
Auto expand tree item when the corresponding object is selected in 3D view Enables the Tree view SyncSelection mode
Preselect the object in 3D view when mouse over the tree item Enables the Tree view PreSelection mode
Record selection in tree view in order to go back/forward using navigation button Enables the Tree view RecordSelection mode
Add checkboxes for selection in document tree Each document tree item will get a checkbox. This is for example useful for selecting multiple items on a touchscreen.

Preferences General Tab Selection.png

编辑器

The editor preferences settings affect the behavior of the macro editor. This editor can be opened using the menu Macro → Macros... → Edit/Create.

The color and font settings also affect the Python console. This console is shown using the menu View → Panels → Python console.

On the Editor tab you can specify the following:

Name Description
Enable line numbers If checked, the code lines will be numbered
Tab size Specification of the tabulator raster (how many spaces). If it is for example set to 6, pressing Tab will jump to character 7 or 13 or 19 etc., depending on the current cursor position. This setting is only used if Keep tabs is selected.
Indent size Specification of how many spaces will be inserted when pressing Tab. This setting is only used if Insert spaces is selected.
Keep tabs If selected, pressing Tab will insert a tabulator with the raster defined by Tab size
Insert spaces If selected, pressing Tab will insert the amount of spaces defined by Indent size
Display Items Selection of the code type. The color and font settings will be applied to the selected type. The result can be checked in the Preview field.
Family Specification of the font family that should be used for the selected code type
Size Specification of the font size that should be used for the selected code type
Color Specification of the color that should be used for the selected code type

Preferences General Tab Editor.png

输出窗口

The output preferences affect the behavior of the Report view. This panel is shown using the menu View → Panels → Report view.

On the Output tab you can specify the following:

Name Description
Record normal messages If checked, normal messages will be recorded. They will be displayed in the Report view with the color set in Normal messages.
Record log messages If checked, log messages will be recorded. They will be displayed in the Report view with the color set in Log messages.
Record warnings If checked, warnings will be recorded. They will be displayed in the Report view with the color set in Warnings.
Record error messages If checked, error messages will be recorded. They will be displayed in the Report view with the color set in Errors.
Show report view on error If checked, the Report view will be shown automatically when an error is recorded
Show report view on warning If checked, the Report view will be shown automatically when a warning is recorded
Show report view on normal message If checked, the Report view will be shown automatically when a normal message is recorded
Show report view on log message If checked, the Report view will be shown automatically when a log message is recorded
Include a timecode for each entry If checked, each message and warning will receive a timecode
Normal messages Specification of the font color for normal messages
Log messages Specification of the font color for log messages
Warnings Specification of the font color for warning messages
Errors Specification of the font color for error messages
Redirect internal Python output to report view If checked, internal Python output will be redirected from the Python console to the Report view
Redirect internal Python errors to report view If checked, internal Python error messages will be redirected from the Python console to the Report view

Preferences General Tab Output window.png

宏脚本

On the Macro tab you can specify the following:

Name Description
Run macros in local environment If checked, variables defined by macros are created as local variables, otherwise as global Python variables
Macro path Specification of the path for macro files
Record GUI commands If checked, recorded macros will also contain user interface commands
Record as comment If checked, recorded macros will also contain user interface commands, but as comments. This is useful if you don't want to execute these commands when running the macro, but do want to see what has been done while recording.
Show script commands in python console If checked, the commands executed by macro scripts are shown in the Python console. This console is shown using the View → Panels → Python console menu option.
Size of recent macros list Controls the number of recent macros to display in the menu
Shortcut count Controls the number of recent macros that get dynamically assigned shortcuts
Keyboard Modifiers Controls which keyboard modifiers are used for the shortcuts, example Ctrl+Shift+ creates shortcuts in the form of Ctrl+Shift+1, Ctrl+Shift+2, etc.

Preferences General Tab Macro.png

单位

Freecad一直在不断发展,因此这些屏幕的内容可能与上述截图不同。这些设置通常是不言自明的,因此您不会有任何困难去配置FreeCad以满足您的需要。

Name Description
User system Selection of the unit system to be used for all parts of FreeCAD
Number of decimals The number of decimals that should be shown for numbers and dimensions
Minimum fractional inch Minimum fractional inch that should be displayed. This setting is only available if the unit system Building US (ft-in/sqft/cuft) is used.

Preferences General Tab Units.png

显示设置

显示设置会影响显示的外观和鼠标手势。在“3D”选项卡上设置常规外观和鼠标手势;可以在“颜色”选项卡上修改颜色。

3D视图设置

在光标处缩放=

如果设置,缩放操作将在鼠标指针的中心位置。 如果未设置,缩放操作将在当前视图的中心位置。

反转缩放=

反转缩放操作的方向。

On the 3D View tab you can specify the following:

Name Description
Show coordinate system in the corner If checked, the main coordinate system will always be shown at the lower right in opened files
Show axis cross by default introduced in version 0.19 If checked, the axis cross will be shown by default at file opening or creation
Show counter of frames per second If checked, the time needed for the last operation and the resulting frame rate will always be shown at the lower left in opened files
Remember active workbench by tab introduced in version 0.19 If checked, the application will remember the active workbench for each tab in the Main view area independently. When switching to a tab this workbench will be restored automatically.
Use software OpenGL introduced in version 0.19 If checked, OpenGL will use the CPU instead of the GPU. This option is useful for troubleshooting graphics card and driver problems. Changing this option requires a restart of the application.
Use OpenGL VBO (Vertex Buffer Object) If checked, Vertex Buffer Objects (VBO) will be used. A VBO is an OpenGL feature that provides methods for uploading vertex data (position, normal vector, color, etc.) to the graphics card. VBOs offer substantial performance gains because the data resides in the graphics memory rather than the system memory and so it can be rendered directly by the GPU. For more background info see this webpage.
Render Cache introduced in version 0.19 "Render Cache" or "Render Acceleration" is explained in more detail in FreeCAD_assembly3 render-caching. There are 3 options:
  • Auto (default), let Coin3D decide where to cache.
  • Distributed, manually turn on cache for all view provider root nodes.
  • Centralized, manually turn off cache in all nodes of all view providers, and only cache at the scene graph root node. This offers the fastest rendering speed, but slower response to any scene changes.
Anti-Aliasing Selection if and what kind of multisample anti-aliasing is used
Transparent objects introduced in version 0.19 Render type of transparent objects. The types are:
  • One pass (default), rendering is done in one pass. For non-solid objects like faces or meshes this can lead to artifacts. This image shows such an artifact (black triangle) and that the type Backface pass avoids this.
  • Backface pass, has only an effect for non-solid objects. They are then rendered in two passes: Back-facing polygons are rendered in the first pass and the front-facing in the second pass.
Marker size Selection of the size of vertices (points) in the Sketcher workbench. The clickable area of points can be additionally enlarged by increasing the Pick radius.
Pick radius (px) Sets the area for picking elements in the 3D view. Larger value makes it easier to pick things, but can make some small features impossible to select.
Eye to eye distance for stereo modes Specification of the eye-to-eye distance used for stereo projections. The specified value is a factor that will be multiplied with the bounding box size of the 3D object that is currently displayed.
Backlight color If checked, backlight is enabled with the defined color. Backlight is used for rendering back sides of faces. Usually, you don't see them in solids, unless you slice one with a clipping plane, or if the faces aren't oriented correctly. It is only active for objects whose Lighting property (on the View tab) is set to One side. If disabled, back sides of faces of objects in One side lighting mode will be black.

The related Intensity setting specifies the intensity of the backlight.

Camera type Selection of the camera projection type.

Preferences Display Tab 3D View.png

Navigation

On the Navigation tab you can specify the following:

Name Description
Navigation cube If checked, the Navigation cube will always be shown.

Steps by turn defines how many steps (notches) will be applied when using the Navigation cube rotation arrows.

Corner defines where the Navigation cube is displayed on the screen when creating or opening a document.

If Rotate to nearest is checked, the 3D view is rotated to the nearest most logical state when a cube face is clicked. Else a default rotation is used. introduced in version 0.20

Cube size defines the size of the cube. introduced in version 0.20

3D Navigation Selection of a navigation settings set. To see what each set defines, select it and then press the Mouse... button.
Orbit style Selection of the rotation orbit style. When viewing a part in the x-y plane and being in the rotation mode of the 3D navigation, the difference is: If Trackball is selected, moving the mouse horizontally will rotate the part around the y-axis, if Turntable is selected the part will be rotated around the z-axis.
Rotation mode Defines the rotation center. Select Window center, Drag at cursor, or Object center.
Default camera orientation Selection of the camera orientation for new documents. This setting is also used by the Std ViewHome command.
New document scale Affects the initial camera zoom level for new documents. The value you set is the diameter of a sphere that fits in 3D view. Default is 100 mm. It also sets the initial size of origin features (base planes in new PartDesign Bodies).
Enable animation If checked, rotations can be animated. If for example the 3D Navigation set CAD is used and the mouse is moved while the scroll wheel and the right mouse button are pressed, parts are rotated. If one keeps the mouse moving while releasing e.g. the right mouse button, the rotation will continue as animation. To end the animation left-click with the mouse.
Zoom at cursor If checked, zoom operations will be performed at the position of the mouse pointer. Otherwise zoom operations will be performed at the center of the current view. The Zoom step defines how much will be zoomed. A zoom step of 1 means a factor of 7.5 for every zoom step.
Invert zoom If checked, the direction of zoom operations will be inverted
Disable touchscreen tilt gesture If checked, the tilting gesture will be disabled for pinch-zooming (two-finger zooming). This only affects the 3D Navigation set Gesture.

Preferences Display Tab Navigation.png

颜色

On the Colors tab you can specify the following:

Name Description
Enable preselection highlighting If checked, preselection is turned on and the specified color will be used for it. Preselection means that for example edges in parts will be highlighted while hovering over them with the mouse to indicate they can be selected.
Enable selection highlighting If checked, selection highlighting is turned on and the specified color will be used for it
Simple color If selected, the background of the 3D view will have the selected color
Color gradient If selected, the background of the 3D view will have a vertical color gradient. The first color is the color at the top of the 3D view, the second the color at the bottom.
Middle color Is only enabled if Color gradient is selected. If checked, the color gradient will get the selected color as the middle color.
Object being edited Selection of the background color for objects in the tree view that are currently edited
Active container Selection of the background color for active containers in the tree view. For example an active PartDesign Body will get the selected background color.

Preferences Display Tab Colors.png

Mesh view

This tab is only available if the Mesh Workbench has been loaded.

On the Mesh view tab you can specify the following:

Name Description
Default mesh color Selection of the default shape color
Default line color Selection of the default line color
Mesh transparency Specification of the default mesh transparency
Line transparency Specification of the default line transparency
Two-side rendering If checked, the color of the interior side of faces will be the same as the exterior side. If not checked either the backlight color, if enabled, or black will be used instead.
Show bounding-box for highlighted or selected meshes If checked, a yellow bounding box will be displayed for highlighted or selected meshes
Define normal per vertex If checked, Phong shading is used, otherwise flat shading. Shading defines the appearance of surfaces. With flat shading the surface normals are not defined per vertex. This leads to an unrealistic appearance for curved surfaces. While Phong shading leads to a more realistic, smoother appearance.
Crease angle The crease angle is a threshold angle between two faces. It can only be set if the option Define normal per vertex is used.
If face angle ≥ crease angle, facet shading is used
If face angle < crease angle, smooth shading is used

Preferences Display Tab Mesh view.png

Workbenches

This preferences section has a single tab: Unloaded Workbenches.

Unloaded Workbenches

To preserve resources, FreeCAD does not automatically load all available workbenches. And only if a workbench has been loaded will its preferences, if any, appear in the Preferences editor.

The Unloaded Workbenches tab displays a list of installed workbenches that have not yet been loaded. To load one or more workbenches select them in the list and then press the Load Selected button. If a newly loaded workbench has dedicated preference they will appear in a new section in the Preferences editor. Some workbenches add support for additional import and export formats. If there are any related preferences they will appear on one or more new tabs in the Import-Export settings section of the Preferences editor.

For a list of workbench preferences see Workbench preferences

Preferences Workbenches Tab Unloaded Workbenches.png

Import-Export settings

The Import-Export settings affect how files are imported and exported. They are described on the Import Export Preferences page.

工作台首选项

下面链接了更常见工作台的首选项。 有些工作台没有偏好。 其他可选工作台可能未列出。

This section is incomplete and requires mentioning the preference pages of each core workbench


Preferences for the more common workbenches are linked below. Some workbenches have no preferences. Other optional workbenches may not be listed. These links are also listed in Category:Preferences

External workbenches

This section is incomplete and requires mentioning the preference pages of each External workbench


Scripting

Preferences can be accessed from Python scripts using their corresponding path in the Parameter Editor. For example, the Edit → Preferences → Import-Export → DXF → Import options → Join geometry preference appears in Tools → Edit parameters → BaseApp → Preferences → Mod → Draft → dxfCreatePart and has type Boolean. It can therefore be accessed in Python using the following code:

# get:
App.ParamGet("User parameter:BaseApp/Preferences/Mod/Draft").GetBool('dxfCreatePart')
# set:
App.ParamGet("User parameter:BaseApp/Preferences/Mod/Draft").SetBool('dxfCreatePart', True)

Finding which parameter is used to store which option from the Preferences editor can require searching a bit, but the Parameter Editor offers a search facility, which should help.

It is likely a bad idea to modify the preferences of other parts of FreeCAD unless doing so at the user's request. The setter can however be used to set parameters for your own workbench, and the getter can be used to obey existing parameters (e.g. to use colors from the current theme).

Related


Arrow-left.svg Previous: 文档结构