Редактор настроек

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Preferences Editor and the translation is 23% complete.
Outdated translations are marked like this.
Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎українська • ‎中文 • ‎中文(中国大陆)‎ • ‎日本語 • ‎한국어

Введение

Настройки FreeCAD расположены в меню Правка → Настройки.

FreeCAD функционально разделён на различные модули, каждый модуль отвечает за работу конкретного верстака. FreeCAD использует концепцию, называемую "отложенной загрузкой", которая означает, что компоненты загружаются только тогда, когда они необходимы. Вы могли заметить, что когда выбираете верстак на панели инструментов FreeCAD, в этот момент загружается верстак и все его компоненты. Это включает в себя и параметры настроек.

Без загруженных модулей у вас будет доступ к двум разделам конфигурации, отвечающие за основные настройки приложения и за настройки дисплея. Когда вы находитесь в определенном верстаке, настройки этого верстака отображаются в виде нового раздела, а форматы файлов, поддерживаемые верстаком, отображаются в виде новой вкладки в разделе Импорт-Экспорт.

Нажатие на кнопку Reset в левом нижнем углу экрана настроек установит «все» настройки FreeCAD в их значения по умолчанию.

Some advanced preferences can only be changed in the Parameter editor. The Fine-tuning page lists some of them.

Основные настройки

Этот раздел настроек имеет 6 вкладок: Основные, Документ, Редактор кода, Просмотр отчёта, Макрос, Единицы измерения.

Основные

На вкладке «Основная» вы можете указать следующее:

Имя Описание
Изменить язык Выберите язык пользовательского интерфейса FreeCAD
Размер списка последних файлов Укажите, сколько файлов должно быть указано в списке последних файлов.
Включить фон из повторяющегося узора Если этот флажок установлен, фон главного окна FreeCAD по умолчанию будет состоять из плиток этого изображения: Background.png
Name Description
Change language Selection of the language of the FreeCAD user interface
Size of recent file list Specification how many files should be listed in the recent files list
Enable tiled background If checked, the background of FreeCAD's main window will by default consist of tiles of this image: Background.png

Этот параметр действует только в том случае, если выделено в Таблица стилей/ Нет таблицы стилей.

Изображение можно изменить, добавив папки Gui/Images в папку

%APPDATA%/FreeCAD (в Windows),

$HOME/.FreeCAD (в Linux) или

$HOME/Library/Preferences/FreeCAD (в MacOS).

Поместите туда файл с именем background.png и снимите флажок / установите этот флажок чтобы увидеть измененный файл.

Стиль интерфейса Выбор таблицы стилей. Таблицы стилей определяют, как выглядит пользовательский интерфейс FreeCAD.
Размер значков на панелях инструментов Выбор размера для значков панели инструментов
При запуске автоматически загружать верстак Выбор того, какой верстак будет использоваться сразу после запуска FeeCAD
Включение экрана-заставки при запуске Если этот флажок установлен, при запуске отображается заставка FreeCAD.

Изображение заставки можно изменить, добавив папки Gui/Images в папку %APPDATA%/FreeCAD (где %APPDATA% - пользовательская папка приложения FreeCAD вашей операционной системы). Поместите туда файл с именем splash_image.png и перезапустите FreeCAD, чтобы увидеть измененный экран-заставку.

Включить перенос слов Слова будут перенесены, когда они превысят доступное горизонтальное пространство в консоли Python. Эта консоль отображается с помощью меню Вид → Панели → Консоль Python.

Preferences General Tab General.png

Документ

На вкладке «Документ» вы можете указать следующее:

Name Описание
Создавать новый документ при запуске Если отмечено, FreeCAD создаст новый документ при запуске
Уровень сжатия сохраняемого документа Спецификация уровня сжатия для файлов FCStd. Файлы FCStd являются сжатыми файлами ZIP. Поэтому вы можете переименовать их суффикс .FCStd в .zip и открыть их с помощью программы ZIP-архива.
Отмены/Повторы Если этот флажок установлен, все изменения в документах сохраняются, чтобы их можно было отменить/повторить.
Максимум шагов отмен/повторов Укажите, сколько шагов Отмена/Повтор нужно записать
Allow aborting recomputation Allow to aborting the document recomputation by pressing Esc. This may slightly increase the recomputation time.
Запуск автоматического восстановления при запуске Если файл восстановления доступен, FreeCAD автоматически запустит восстановление файла при запуске. Таким образом, файлы могут быть восстановлены в случае сбоя.
Автосохранение каждые Укажите, как часто записывается файл восстановления.
Сохранить миниатюру в файл проекта при сохранении документа Если этот флажок установлен, при сохранении документа также будет сохранена миниатюра. Например, миниатюра будет отображаться в списке последних файлов в Верстаке Start. It is possible to select a Size between 128×128 and 512×512 pixels for the thumbnail. Common sizes are the powers of two: 128, 256, 512.
Добавить логотип программы в генерируемую миниатюру Если установлен этот флажок, логотип программы FreeCAD FreeCAD-logo.svg будет добавлен к миниатюре. Этот параметр действует только в том случае, если используется Сохранить миниатюру в файл проекта при сохранении документа.
Максимальное количество файлов резервных копий, при пересохранении документа Если этот флажок установлен, файлы резервных копий будут сохраняться при сохранении документа. Вы можете указать количество сохраняемых файлов резервных копий. Они содержат ранее сохраненную версию документа. Первый файл резервной копии будет иметь суффикс файла .FCStd1, второй .FCStd2 и т.д.
Use date and FCBak extension If checked, backup files will get the extension .FCbak and their file names get a date suffix according to the specified date format. For a description of the date format see this site.

With the default settings the backup file will get for example this name TD-Cube.20200315-215654.FCBak (original filename is TD-Cube.FCStd).

Разрешить идентичные метки объектов в одном документе Если флажок установлен, объекты могут иметь одинаковую метку/имя. Например, разные части или элементы могут иметь одинаковое имя в одном и том же документе.
Disable partial loading of external linked objects Enable partial loading of external linked document. When enabled, only the referenced objects and their dependencies will be loaded when a linked document is auto opened together with the main document. A partially loaded document cannot be edited. Double click the document icon in the tree view to reload it in full. A more detailed explanation of the feature can be found on the Assembly3 documentation page
Имя автора Все документы, которые будут созданы, получат указанное имя автора. Оставьте поле автора пустым для анонимного автора. Если опция Устанавливать при сохранении отмечена, поле Last updated by будет установлено для указанного автора при сохранении файла. Это поле можно просмотреть с помощью меню Файл → Информация о проекте.
Компания Все документы, которые будут созданы, получат указанное название компании
Лицензия по умолчанию Выбор лицензии по умолчанию для новых документов. Для предопределенной лицензии URL-адрес лицензии будет автоматически установлен соответствующим образом. Выберите «Другое» для собственной или специальной лицензии.
URL адрес лицензии Указание URL-адреса, описывающего лицензию, выбранного в Лицензия по умолчанию
Name Description
Create new document at start up If checked, FreeCAD will create a new document when started
Document save compression level Specification of the compression level for FCStd files. FCStd files are ZIP-compressed files. Therefore you can rename their suffix .FCStd to .zip and open them with a ZIP archive program.
Using Undo/Redo on documents If checked, all changes in documents are stored so that they can be undone/redone
Maximum Undo/Redo steps Specification how many Undo/Redo steps should be recorded
Allow aborting recomputation If checked, recomputations can be aborted by pressing Esc. This may slightly increase the recomputation time.
Run AutoRecovery at startup If there is a recovery file available FreeCAD will automatically run a file recovery when it is started. This way files can be restored if a crash occurred.
Save AutoRecovery information every Specification how often a recovery file is written.
Save thumbnail into project file when saving document If checked, a thumbnail will be stored when the document is saved. The thumbnail will for example be shown in the list of recent files in the Start workbench. It is possible to select a Size between 128×128 and 512×512 pixels for the thumbnail. Common sizes are the powers of two: 128, 256, 512.
Add the program logo to the generated thumbnail If checked, the FreeCAD program logo FreeCAD-logo.svg will be added to the thumbnail.
Maximum number of backup files to keep when resaving document If checked, backup files will be kept when saving the document. You can specify the number of backup files to keep. Backup files are previously saved versions of the document. The first backup file will have the file suffix .FCStd1, the second .FCStd2 and so on.
Use date and FCBak extension If checked, backup files will get the extension .FCbak and their file names get a date suffix according to the specified date format. For a description of the date format see this site.

With the default settings a backup file will for example get this name TD-Cube.20200315-215654.FCBak (original filename is TD-Cube.FCStd).

Allow duplicate object labels in one document If checked, objects can have the same label.
Disable partial loading of external linked objects If partial loading of external linked objects is enabled, only the referenced objects and their dependencies will be loaded when the linked document is auto opened together with the main document. Such a partially loaded document cannot be edited. Double click the document icon in the tree view to reload it in full. A more detailed explanation of this feature can be found on the Assembly3 documentation page
Author name All created documents will get the specified author name. Keep the author field blank if you do not want to include this information. If the option Set on save is checked, the field Last modified by will be set to the specified author when saving the file. This field can be viewed using the File → Project information menu option.
Company All created documents will get the specified company name
Default license Selection of the license for new documents. For predefined licenses the License URL will automatically be set accordingly. Select Other for a custom license.
License URL Specification of an URL describing the license selected in Default license

Preferences General Tab Document.png

Selection

On the Selection tab (introduced in version 0.19) you can specify the following:

Name Description
Auto switch to the 3D view containing the selected item Enables the Tree view SyncView mode
Auto expand tree item when the corresponding object is selected in 3D view Enables the Tree view SyncSelection mode
Preselect the object in 3D view when mouse over the tree item Enables the Tree view PreSelection mode
Record selection in tree view in order to go back/forward using navigation button Enables the Tree view RecordSelection mode
Add checkboxes for selection in document tree Each document tree item will get a checkbox. This is for example useful for selecting multiple items on a touchscreen.

Preferences General Tab Selection.png

Редактор кода

Настройки предпочтений редактора влияют на поведение редактора макросов. Этот редактор можно открыть с помощью меню Макрос → Макросы... → Редактировать/Создать.

Настройки цвета и шрифта также влияют на консоль Python. Эта консоль отображается с помощью меню Вид→Панели→Консоль Python.

На вкладке «Редактор» вы можете указать следующее:

Name Описание
Подсветка синтаксиса Выбор типа кода. Настройки цвета и шрифта будут применены к выбранному типу. Результат можно увидеть в поле «Предпросмотр».
Шрифт Выбор типа шрифта, который должен использоваться для выбранного типа кода
Размер Выбор размера шрифта, который должен использоваться для выбранного типа кода
Цвет Спецификация цвета, который должен использоваться для выбранного типа кода
Показывать номера строк Если флажок установлен, строки кода будут пронумерованы
Шаг табуляции Определение шага табулятора (количество пробелов). Если, например, установлено значение «6», при нажатии Tab будет выполнен переход к символу 7, 13, 19 и т.д., в зависимости от текущей позиции курсора. Этот параметр используется только в том случае, если выбран Символы табуляции.
Размер отступа Укажите, сколько пробелов будет вставлено при нажатии Tab. Этот параметр используется только в том случае, если выбран Заменять на пробелы.
Символы табуляции Если выбрано, нажатие Tab вставит табулятор с растром, определяемым Шаг табуляции
Заменять на пробелы Если выбрано, нажатие Tab вставит количество пробелов, определяемых Размер отступа
Name Description
Enable line numbers If checked, the code lines will be numbered
Tab size Specification of the tabulator raster (how many spaces). If it is for example set to 6, pressing Tab will jump to character 7 or 13 or 19 etc., depending on the current cursor position. This setting is only used if Keep tabs is selected.
Indent size Specification of how many spaces will be inserted when pressing Tab. This setting is only used if Insert spaces is selected.
Keep tabs If selected, pressing Tab will insert a tabulator with the raster defined by Tab size
Insert spaces If selected, pressing Tab will insert the amount of spaces defined by Indent size
Display Items Selection of the code type. The color and font settings will be applied to the selected type. The result can be checked in the Preview field.
Family Specification of the font family that should be used for the selected code type
Size Specification of the font size that should be used for the selected code type
Color Specification of the color that should be used for the selected code type

Preferences General Tab Editor.png

Просмотр отчета

Настройки просмотра отчёта влияют на поведение Report view.

На вкладке «Просмотр отчёта» вы можете указать следующее:

Name Описание
Выводить информационные сообщения (log) Если установлен этот флажок, также будут отображаться информационные сообщения. Они будут выведены на панель Отчет цветом, установленным в Журнал (logs). Эта панель активируется с помощью меню Вид → Панели → Отчет.
Выводить предупреждения (warnings) Если флажок установлен, предупреждения будут отображаться. Они будут выведены на панель Отчет цветом, установленным в Предупреждения (warnings).
Выводить сообщения об ошибках (errors) Если флажок установлен, то будут отображаться сообщения об ошибках. Они будут выведены на панель Отчет цветом, установленным в Ошибки (errors)
Обычные сообщения Задание цвета шрифта для обычных сообщений на панели Отчет.
Журнал (log) Задание цвета шрифта для сообщений журнала на панели Отчет.
Предупреждения (warnings) Задание цвета шрифта для предупреждающих сообщений на панели Отчет.
Ошибки (errors) Задание цвета шрифта для сообщений об ошибках на панели Отчет.
Перенаправить внутренний вывод Python в отчёт Если этот флажок установлен, внутренний вывод Python будет перенаправлен с консоли Python на панель Отчет. Консоль Python отображается с помощью меню Вид → Панели → Консоль Python
Перенаправить внутренние ошибки Python в отчёт Если этот флажок установлен, сообщения об ошибках Python будут перенаправляться из консоли Python на панель Отчет.
Name Description
Record normal messages If checked, normal messages will be recorded. They will be displayed in the Report view with the color set in Normal messages.
Record log messages If checked, log messages will be recorded. They will be displayed in the Report view with the color set in Log messages.
Record warnings If checked, warnings will be recorded. They will be displayed in the Report view with the color set in Warnings.
Record error messages If checked, error messages will be recorded. They will be displayed in the Report view with the color set in Errors.
Show report view on error If checked, the Report view will be shown automatically when an error is recorded
Show report view on warning If checked, the Report view will be shown automatically when a warning is recorded
Show report view on normal message If checked, the Report view will be shown automatically when a normal message is recorded
Show report view on log message If checked, the Report view will be shown automatically when a log message is recorded
Include a timecode for each entry If checked, each message and warning will receive a timecode
Normal messages Specification of the font color for normal messages
Log messages Specification of the font color for log messages
Warnings Specification of the font color for warning messages
Errors Specification of the font color for error messages
Redirect internal Python output to report view If checked, internal Python output will be redirected from the Python console to the Report view
Redirect internal Python errors to report view If checked, internal Python error messages will be redirected from the Python console to the Report view

Preferences General Tab Output window.png

Макрос

На вкладке «Макрос» вы можете указать следующее:

Name Описание
Запуск макросов в локальном окружении Если флажок установлен, переменные, определенные макросами, создаются как локальные переменные, в противном случае они создаются как глобальные переменные Python
Куда записывать макросы Указание пути к макросам
Запись команд графического интерфейса Если флажок установлен, записанные макросы также будет содержать команды интерфейса пользователя
Записывать как комментарий Если этот флажок установлен, записанные макросы также будет содержать команды интерфейса пользователя, но в виде комментариев. Это полезно, если вы не хотите выполнять видимые действия при запуске макроса, а видеть, что можно сделать визуально.
Показать команды скрипта в консоли Python Если этот флажок установлен, команды, выполняемые макросами, отображаются в консоли Python. Эта консоль отображается с помощью меню Вид → Панели → Консоль Python.
Name Description
Run macros in local environment If checked, variables defined by macros are created as local variables, otherwise as global Python variables
Macro path Specification of the path for macro files
Record GUI commands If checked, recorded macros will also contain user interface commands
Record as comment If checked, recorded macros will also contain user interface commands, but as comments. This is useful if you don't want to execute these commands when running the macro, but do want to see what has been done while recording.
Show script commands in python console If checked, the commands executed by macro scripts are shown in the Python console. This console is shown using the View → Panels → Python console menu option.
Size of recent macros list Controls the number of recent macros to display in the menu
Shortcut count Controls the number of recent macros that get dynamically assigned shortcuts
Keyboard Modifiers Controls which keyboard modifiers are used for the shortcuts, example Ctrl+Shift+ creates shortcuts in the form of Ctrl+Shift+1, Ctrl+Shift+2, etc.

Preferences General Tab Macro.png

Единицы измерения

На вкладке «Единицы измерения» вы можете указать следующее:

Name Описание
Пользовательская система Выбор системы единиц, которая должна использоваться для всех частей FreeCAD
Количество десятичных знаков Количество десятичных знаков, которые должны быть указаны для чисел и размеров в FreeCAD
Минимальный часть дюйма Минимальная часть дюйма, которая должна отображаться. Этот параметр доступен только в том случае, если используется система измерения 'Строительные US (Футы-дюймы/кв. футы/куб. футы)' .
Name Description
User system Selection of the unit system to be used for all parts of FreeCAD
Number of decimals The number of decimals that should be shown for numbers and dimensions
Minimum fractional inch Minimum fractional inch that should be displayed. This setting is only available if the unit system Building US (ft-in/sqft/cuft) is used.

Preferences General Tab Units.png

Отображение (настройки дисплея)

Этот раздел настроек имеет две общие вкладки, Трёхмерный вид и Цвета, и дальнейшие вкладки зависят от используемых верстаков.

Трехмерный вид

На вкладке «Трехмерный вид» вы можете указать следующее:

Имя Описание
Показать систему координат в углу Если флажок установлен, основная система координат всегда будет отображаться в правом нижнем углу в открытых файлах
Show axis cross by default introduced in version 0.19 - Показать счетчик кадров в секунду Если этот флажок установлен, время, необходимое для последней операции, и полученная частота кадров [1] всегда будут отображаться в нижнем левом углу в открытых файлах.
Remember active workbench by tab introduced in version 0.19 If checked, the application will remember what is the active workbench for each tab independently. This way, the active workbench will be automatically restored when changing tab in the multiple-document interface (MDI) view.
Использовать объект вершинного буфера (Vertex Buffer) OpenGL Если флажок установлен, будут использоваться объекты буфера вершин (VBO). VBO - это функция OpenGL, которая предоставляет методы для загрузки данных вершин (положение, вектор нормали, цвет и т.д.) на видеокарту. VBO обеспечивает существенный выигрыш в производительности, потому что данные находятся в графической памяти, а не в системной памяти, и поэтому они могут отображаться непосредственно графическим процессором. Для получения дополнительной информации см. эту веб-страницу.
Render Cache introduced in version 0.19 "Render Cache" or "Render Acceleration" is explained in more detail in Link#render-caching. There are 3 options:
  • Auto (default), let Coin3D decide where to cache.
  • Distributed, manually turn on cache for all view provider root nodes.
  • Centralized, manually turn off cache in all nodes of all view providers, and only cache at the scene graph root node. This offers the fastest rendering speed, but slower response to any scene changes.
Сглаживание Выбор используемого типа Multisample сглаживания
Transparent objects introduced in version 0.19 Render type of transparent objects. The types are:
  • One pass (default), rendering is done in one pass. For non-solid objects like faces or meshes this can lead to artifacts. This image shows such an artifact (black triangle) and that the type Backface pass avoids this.
  • Backface pass, has only an effect for non-solid objects. They are then rendered in two passes: Back-facing polygons are rendered in the first pass and the front-facing in the second pass.
Размер метки Выбор размера вершины (точки) в верстаке Sketcher. The clickable area of points can be additionally enlarged by increasing Pick radius (on Colors tab).
Расстояние между глаз для стерео режима Спецификация расстояния между глазами, используемого для стереопроекции. Указанное значение является коэффициентом, который будет умножен на размер ограничивающего прямоугольника трехмерного объекта, который отображается в данный момент.
цвет подсветки Если флажок установлен, подсветка включена с заданным цветом. Backlight is used for rendering back sides of faces (usually, you don't see them in solids, unless you slice one with a clipping plane, or if the faces aren't oriented correctly). It is only active for objects whose Lighting property (on View tab) is set to "One side". If disabled, back sides of faces of objects in "One side" lighting mode will be black.

The related Intensity setting specifies the intensity of the backlight.

Тип камеры Выбор типа проекции камеры.
Name Description
Show coordinate system in the corner If checked, the main coordinate system will always be shown at the lower right in opened files
Show axis cross by default introduced in version 0.19 If checked, the axis cross will be shown by default at file opening or creation
Show counter of frames per second If checked, the time needed for the last operation and the resulting frame rate will always be shown at the lower left in opened files
Remember active workbench by tab introduced in version 0.19 If checked, the application will remember the active workbench for each tab in the Main view area independently. When switching to a tab this workbench will be restored automatically.
Use software OpenGL introduced in version 0.19 If checked, OpenGL will use the CPU instead of the GPU. This option is useful for troubleshooting graphics card and driver problems. Changing this option requires a restart of the application.
Use OpenGL VBO (Vertex Buffer Object) If checked, Vertex Buffer Objects (VBO) will be used. A VBO is an OpenGL feature that provides methods for uploading vertex data (position, normal vector, color, etc.) to the graphics card. VBOs offer substantial performance gains because the data resides in the graphics memory rather than the system memory and so it can be rendered directly by the GPU. For more background info see this webpage.
Render Cache introduced in version 0.19 "Render Cache" or "Render Acceleration" is explained in more detail in FreeCAD_assembly3 render-caching. There are 3 options:
  • Auto (default), let Coin3D decide where to cache.
  • Distributed, manually turn on cache for all view provider root nodes.
  • Centralized, manually turn off cache in all nodes of all view providers, and only cache at the scene graph root node. This offers the fastest rendering speed, but slower response to any scene changes.
Anti-Aliasing Selection if and what kind of multisample anti-aliasing is used
Transparent objects introduced in version 0.19 Render type of transparent objects. The types are:
  • One pass (default), rendering is done in one pass. For non-solid objects like faces or meshes this can lead to artifacts. This image shows such an artifact (black triangle) and that the type Backface pass avoids this.
  • Backface pass, has only an effect for non-solid objects. They are then rendered in two passes: Back-facing polygons are rendered in the first pass and the front-facing in the second pass.
Marker size Selection of the size of vertices (points) in the Sketcher workbench. The clickable area of points can be additionally enlarged by increasing the Pick radius.
Pick radius (px) Sets the area for picking elements in the 3D view. Larger value makes it easier to pick things, but can make some small features impossible to select.
Eye to eye distance for stereo modes Specification of the eye-to-eye distance used for stereo projections. The specified value is a factor that will be multiplied with the bounding box size of the 3D object that is currently displayed.
Backlight color If checked, backlight is enabled with the defined color. Backlight is used for rendering back sides of faces. Usually, you don't see them in solids, unless you slice one with a clipping plane, or if the faces aren't oriented correctly. It is only active for objects whose Lighting property (on the View tab) is set to One side. If disabled, back sides of faces of objects in One side lighting mode will be black.

The related Intensity setting specifies the intensity of the backlight.

Camera type Selection of the camera projection type.

Preferences Display Tab 3D View.png

Navigation

On the Navigation tab you can specify the following:

Name Description
Navigation cube If checked, the Navigation cube will always be shown.

Steps by turn defines how many steps (notches) will be applied when using the Navigation cube rotation arrows.

Corner defines where the Navigation cube is displayed on the screen when creating or opening a document.

If Rotate to nearest is checked, the 3D view is rotated to the nearest most logical state when a cube face is clicked. Else a default rotation is used. introduced in version 0.20

Cube size defines the size of the cube. introduced in version 0.20

3D Navigation Selection of a navigation settings set. To see what each set defines, select it and then press the Mouse... button.
Orbit style Selection of the rotation orbit style. When viewing a part in the x-y plane and being in the rotation mode of the 3D navigation, the difference is: If Trackball is selected, moving the mouse horizontally will rotate the part around the y-axis, if Turntable is selected the part will be rotated around the z-axis.
Rotation mode Defines the rotation center. Select Window center, Drag at cursor, or Object center.
Default camera orientation Selection of the camera orientation for new documents. This setting is also used by the Std ViewHome command.
New document scale Affects the initial camera zoom level for new documents. The value you set is the diameter of a sphere that fits in 3D view. Default is 100 mm. It also sets the initial size of origin features (base planes in new PartDesign Bodies).
Enable animation If checked, rotations can be animated. If for example the 3D Navigation set CAD is used and the mouse is moved while the scroll wheel and the right mouse button are pressed, parts are rotated. If one keeps the mouse moving while releasing e.g. the right mouse button, the rotation will continue as animation. To end the animation left-click with the mouse.
Zoom at cursor If checked, zoom operations will be performed at the position of the mouse pointer. Otherwise zoom operations will be performed at the center of the current view. The Zoom step defines how much will be zoomed. A zoom step of 1 means a factor of 7.5 for every zoom step.
Invert zoom If checked, the direction of zoom operations will be inverted
Disable touchscreen tilt gesture If checked, the tilting gesture will be disabled for pinch-zooming (two-finger zooming). This only affects the 3D Navigation set Gesture.

Preferences Display Tab Navigation.png

Цвета

На вкладке «Цвета» вы можете указать следующее:

Параметр Описание
Включить подсвечивание при наведении курсора Если этот флажок установлен, предварительный выбор включен и будет выделен указанным цветом. Предварительный выбор означает, что, например, ребра в деталях будут выделены при наведении курсора на них, чтобы указать, что они могут быть выбраны.
Включить подсвечивание выделенного Если флажок установлен, подсветка выделения включена и для нее будет использоваться указанный цвет
Укажите радиус (пикс.) Устанавливает размер области для выбора элементов в трехмерном представлении. Большее значение облегчает выбор материала, но делает невозможным выбор некоторых мелких функций.
Один цвет Если выбрано, фон для деталей будет иметь выбранный цвет
Цветовой градиент Если выбрано, фон для деталей будет иметь выбранный вертикальный цветовой градиент. Первый цвет будет цветом верха фона, второй будет цветом низа.
Средний цвет Доступно только если выбрано Цветовой градиент. Если этот флажок установлен, цветовой градиент получит выбранный цвет как средний цвет.
Объект редактируется Выбор цвета фона для объектов в виде дерева, которые в данный момент редактируются
Активный контейнер Выбор цвета фона для активных контейнеров в виде дерева. Например, если в древовидном представлении есть несколько частей и одна часть переключается как активное тело, она получит выбранный цвет фона в древовидном представлении.
Name Description
Enable preselection highlighting If checked, preselection is turned on and the specified color will be used for it. Preselection means that for example edges in parts will be highlighted while hovering over them with the mouse to indicate they can be selected.
Enable selection highlighting If checked, selection highlighting is turned on and the specified color will be used for it
Simple color If selected, the background of the 3D view will have the selected color
Color gradient If selected, the background of the 3D view will have a vertical color gradient. The first color is the color at the top of the 3D view, the second the color at the bottom.
Middle color Is only enabled if Color gradient is selected. If checked, the color gradient will get the selected color as the middle color.
Object being edited Selection of the background color for objects in the tree view that are currently edited
Active container Selection of the background color for active containers in the tree view. For example an active PartDesign Body will get the selected background color.

Preferences Display Tab Colors.png

Mesh view

This tab is only available if the Mesh Workbench has been loaded.

On the Mesh view tab you can specify the following:

Name Description
Default mesh color Selection of the default shape color
Default line color Selection of the default line color
Mesh transparency Specification of the default mesh transparency
Line transparency Specification of the default line transparency
Two-side rendering If checked, the color of the interior side of faces will be the same as the exterior side. If not checked either the backlight color, if enabled, or black will be used instead.
Show bounding-box for highlighted or selected meshes If checked, a yellow bounding box will be displayed for highlighted or selected meshes
Define normal per vertex If checked, Phong shading is used, otherwise flat shading. Shading defines the appearance of surfaces. With flat shading the surface normals are not defined per vertex. This leads to an unrealistic appearance for curved surfaces. While Phong shading leads to a more realistic, smoother appearance.
Crease angle The crease angle is a threshold angle between two faces. It can only be set if the option Define normal per vertex is used.
If face angle ≥ crease angle, facet shading is used
If face angle < crease angle, smooth shading is used

Preferences Display Tab Mesh view.png

Workbenches

This preferences section has a single tab: Unloaded Workbenches.

Unloaded Workbenches

To preserve resources, FreeCAD does not automatically load all available workbenches. And only if a workbench has been loaded will its preferences, if any, appear in the Preferences editor.

The Unloaded Workbenches tab displays a list of installed workbenches that have not yet been loaded. To load one or more workbenches select them in the list and then press the Load Selected button. If a newly loaded workbench has dedicated preference they will appear in a new section in the Preferences editor. Some workbenches add support for additional import and export formats. If there are any related preferences they will appear on one or more new tabs in the Import-Export settings section of the Preferences editor.

For a list of workbench preferences see Workbench preferences

Preferences Workbenches Tab Unloaded Workbenches.png

Настройки импорта-экспорта

The Import-Export settings affect how files are imported and exported. They are described on the Import Export Preferences page.

Настройки верстаков

This section is incomplete and requires mentioning the preference pages of each core workbench


Настройки для более распространенных верстаков приведены ниже. У некоторых верстаков нет настроек. Другие дополнительные верстаки могут быть не перечислены. Эти ссылки так же перечислены в Category:Preferences

Внешние верстаки

This section is incomplete and requires mentioning the preference pages of each External workbench


Scripting

Preferences can be accessed from Python scripts using their corresponding path in the Parameter Editor. For example, the Edit → Preferences → Import-Export → DXF → Import options → Join geometry preference appears in Tools → Edit parameters → BaseApp → Preferences → Mod → Draft → dxfCreatePart and has type Boolean. It can therefore be accessed in Python using the following code:

# get:
App.ParamGet("User parameter:BaseApp/Preferences/Mod/Draft").GetBool('dxfCreatePart')
# set:
App.ParamGet("User parameter:BaseApp/Preferences/Mod/Draft").SetBool('dxfCreatePart', True)

Finding which parameter is used to store which option from the Preferences editor can require searching a bit, but the Parameter Editor offers a search facility, which should help.

It is likely a bad idea to modify the preferences of other parts of FreeCAD unless doing so at the user's request. The setter can however be used to set parameters for your own workbench, and the getter can be used to obey existing parameters (e.g. to use colors from the current theme).

Related