Edytor ustawień

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Preferences Editor and the translation is 100% complete.
Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎українська • ‎中文 • ‎中文(中国大陆)‎ • ‎中文(台灣)‎ • ‎日本語 • ‎한국어

Wprowadzenie

Aby uruchomić Edytor ustawień wybierz menu Edycja → Preferencje. W systemie Mac OS opcja Preferencje ... pojawia się w menu FreeCAD (jest to domyślne miejsce preferencji na Macu).

FreeCAD wykorzystuje koncepcję środowiska pracy, gdzie każde z nich jest odpowiedzialne za konkretne zadania i funkcje. Każde z nich może mieć swoje własne preferencje. Pojawią się one w edytorze Preferencji tylko wtedy, gdy dany moduł został załadowany w bieżącej sesji programu FreeCAD. Aby dowiedzieć się więcej, zobacz stronę Środowiska pracy.

Jeśli nie jest załadowane żadne środowisko pracy, w edytorze Preferencji pojawiają się cztery pozycje: Ogólne, Wyświetlanie, Środowiska pracy i Import-Eksport. Pod nimi pojawią się wszystkie wczytane te środowiska, które mają swoje własne preferencje.

Proszę zwrócić uwagę na to, że kliknięcie przycisku Reset w lewym dolnym rogu ekranu preferencji ustawi wszystkie z opcji FreeCAD na ich wartości domyślne.

Niektóre zaawansowane preferencje mogą być zmienione tylko w Edytorze parametrów. Na stronie Dostrajanie parametrów znajduje się lista niektórych z nich.

Ustawienie ogólne

Ta sekcja menu konfiguracji zawiera 7 zakładek: Ogólne, Dokument, Zaznaczenie, Edytor, Okno raportów, Makrodefinicje i Jednostki.

Informacje ogólne

W zakładce Ogólne możesz wprowadzić następujące dane:

Nazwa Opis
Zmień język Wybierz język interfejsu użytkownika FreeCAD.
Rozmiar aktualnej listy plików Określić, ile plików powinno znajdować się na liście ostatnio używanych plików.
Włączenie kafelkowego tła Jeśli opcja jest zaznaczona, tło głównego okna FreeCAD będzie domyślnie składać się z tych obrazów: Background.png

Ta opcja działa tylko wtedy, gdy nie zaznaczono opcji Styl arkusza.

Obraz można zmienić poprzez dodanie folderów Gui/Images do lokalizacji:

%APPDATA%/FreeCAD (na Windows),

$HOME/.FreeCAD (dla Linux) lub

$HOME/Library/Preferences/FreeCAD (dla MacOS).

Umieść plik o nazwie background.png w folderze Images i odznacz/zaznacz tę opcję, aby zobaczyć zmieniony plik.

Styl arkusza Wybór motywu dla wyglądu programu. Arkusze stylów określają, jak wygląda interfejs użytkownika FreeCAD. Szczegóły techniczne dotyczące arkuszy stylów można znaleźć na stronie motywy.
Rozmiar ikon paska narzędzi Wybór rozmiaru ikon na pasku narzędzi.
Tryb widoku drzewa Dostosowywanie sposobu wyświetlania widoku drzewa w panelu (wymagany restart). Dostępne są następujące opcje:
  • Widok połączony: połączenie widoku drzewa i widoku właściwości w jednym panelu.
  • Widok drzewa oraz widok połączony: podzielenie widoku drzewa i widoku właściwości na oddzielny panel.
  • Obydwa: zachowuje wszystkie trzy panele, a ty możesz mieć dwa zestawy widoku drzewa i widoku właściwości.
Po uruchomieniu załaduj utomatycznie moduł Wybór, jakie Środowisko pracy będzie używane bezpośrednio po uruchomieniu programu FreeCAD
Wlącz ekran powitalny przy uruchamianiu Gdy to pole wyboru jest zaznaczone, podczas uruchamiania wyświetlany jest ekran powitalny programu FreeCAD.

Obraz ekranu powitalnego można zmienić poprzez umieszczenie pliku o nazwie splash_image.png w folderze Images wspomnianym już pod Aktywuj kafle w tle.

Włacz zawijanie wierszy Słowa zostaną zawinięte, gdy przekroczą dostępną przestrzeń poziomą w konsoli Pythona. Konsola jest wyświetlana za pomocą menu Widok → Panele → Konsola Python.

Preferences General Tab General.png

Dokument

W zakładce Dokument można wybrać następujące opcje:

Nazwa Opis
Utwórz nowy dokument w trakcie uruchamiania Jeśli opcja jest zaznaczona, FreeCAD utworzy nowy dokument po uruchomieniu.
Stopień kompresji podczas zapisu Specyfikacja poziomu kompresji dla plików {FCStd. Pliki FCStd} są plikami skompresowanymi w formacie ZIP. Dlatego możesz zmienić ich rozszerzenie {.FCStd na .zip} i otworzyć je za pomocą programu do archiwizacji ZIP.
Użyj cofnij/ponów w dokumentach Jeśli to pole jest zaznaczone, wszystkie zmiany w dokumentach są zapisywane tak, aby można je było cofnąć/odtworzyć.
Maksymalna ilość kroków cofnij/ponów Określa, ile kroków Cofnij/Zmień powinno zostać zarejestrowanych (0-99).
Zezwolenie na przerwanie procesu ponownego przeliczania. Zezwolenie na przerwanie przeliczania dokumentu przez naciśnięcie klawisza Esc. Może to nieznacznie wydłużyć czas ponownego przeliczania.
Uruchomienie funkcji autoodzyskiwania przy starcie Jeśli jest dostępny plik odzyskiwania, FreeCAD automatycznie uruchomi funkcję odzyskiwania pliku w momencie jego uruchomienia. W ten sposób pliki mogą zostać odtworzone, jeśli wystąpi awaria.
Zapisz informacje autoodzyskiwania Określ, jak często będzie zapisywany plik odzyskiwania.
Zapisywanie miniatur do pliku projektu, przy zapisywaniu dokumentu Jeśli to pole jest zaznaczone, po zapisaniu dokumentu zostanie również zapisana miniaturka. Miniaturka będzie wyświetlana na przykład na liście ostatnio zapisanych plików Środowiska pracy Start. Możliwe jest wybranie rozmiaru między 128 × 128 a 512 × 512 pikseli dla miniatury. Typowe rozmiary to potęgi liczby dwa: 128, 256, 512.
Dodaj logo programu do wygenerowanej miniaturki. Jeśli to pole jest zaznaczone, logo programu FreeCAD Freecad.svg zostanie dodane do miniaturki. Ta opcja działa tylko wtedy, gdy opcja Zapisywanie miniatur do pliku projektu jest aktywna.
Maksymalna liczba plików kopii zapasowych do zachowania podczas zapisywania dokumentu Jeśli to pole jest zaznaczone, pliki kopii zapasowej będą zapisywane podczas zapisywania dokumentu. Można określić, ile plików kopii zapasowych będzie przechowywanych. Zawierają one wcześniej zapisaną wersję dokumentu. Pierwszy plik kopii zapasowej będzie miał rozszerzenie .FCStd1, drugi .FCStd2 i tak dalej.
Data używania i rozszerzenie FCBak Jeżeli jest zaznaczone, pliki kopii zapasowych otrzymają rozszerzenie .FCbak, a ich nazwy plików otrzymają przyrostek daty zgodnie z określonym formatem daty. Opis formatu daty znajduje się w this site.

Przy domyślnych ustawieniach plik kopii zapasowej otrzyma np. nazwę TD-Cube.20200315-215654.FCBak (oryginalna nazwa pliku to TD-Cube.FCStd).

Zezwalaj na dublowanie etykiet obiektów w jednym dokumencie Jeśli to pole jest zaznaczone, obiekty mogą mieć tę samą etykietę/nazwę. Na przykład różne części lub elementy mogą mieć wtedy identyczną nazwę w obrębie tego samego dokumentu.
Wyłącz częściowe wczytywanie połączonych obiektów zewnętrznych. Włączyć częściowe załadowanie zewnętrznego dokumentu połączonego. Gdy jest to włączone, tylko obiekty referencyjne i ich zależności będą ładowane, gdy połączony dokument jest automatycznie otwierany razem z dokumentem głównym. Częściowo załadowany dokument nie może być edytowany. Kliknij dwukrotnie ikonę dokumentu w widoku drzewa, aby załadować go w całości. Bardziej szczegółowe objaśnienie funkcji można znaleźć na stronie Assembly3 documentation page
Nazwa autora Wszystkie powstające dokumenty otrzymają określoną nazwę autora. Pole autora należy pozostawić puste na wypadek gdy autor ma pozostać anonimowy. Jeżeli zaznaczona jest opcja Ustaw przy zapisie, pole Last modified by zostanie ustawione na określonego autora w trakcie zapisywania pliku. Informacje te można wyświetlić za pomocą menu Plik → Informacje o projekcie.
Nazwa firmy Wszystkie utworzone dokumenty otrzymają podaną nazwę firmy.
Licencja domyślna Wybór domyślnej licencji dla nowych dokumentów. W przypadku wstępnie zdefiniowanej licencji link URL licencji zostanie automatycznie ustawiony. Wybierz Inne, aby uzyskać licencję własną lub specjalną.
URL licencji Wskazanie adresu URL opisującego licencję wybraną w polu Licencja domyślna

Preferences General Tab Document.png

Zaznaczenie

W zakładce Zaznaczenie (dostępne w wersji 0.19) można określić następujące elementy:

Nazwa Opis
Przełącz automatycznie do widoku 3D zawierającego wybrany element Włącza Tryb synchronizacji widoku w widoku drzewa
Automatycznie rozwiń drzewko gdy odpowiedni obiekt jest zaznaczony w oknie widoku 3D Włącza Tryb synchronizacji zaznaczenia w widoku drzewa
Wyróżnij obiekt w oknie widoku 3D, gdy kursor myszki znajduje się nad pozycją drzewa Włącza Tryb wyboru wstępnego w widoku drzewa
Zapisuj zaznaczenie w widoku drzewa, aby cofnąć/ponowić za pomocą przycisku nawigacji Włącza Tryb zapisu zaznaczenia w widoku drzewa
Dodaj pola wyboru do zaznaczenia w drzewie dokumentu Każdy element widoku drzewa otrzyma pole wyboru. Jest to przydatne na przykład do zaznaczania wielu elementów podczas pracy z ekranem dotykowym.

Preferences General Tab Selection.png

Edytor

Ustawienia edytora preferencji mają wpływ na zachowanie edytora makr. Edytor ten można otworzyć za pomocą menu Makro → Makra... → Edycja/tworzenie.

Ustawienia kolorów i czcionek mają również wpływ na Konsolę Pythona. Konsola ta jest uaktywniana za pomocą menu Widok → Panele → Konsola Pythona.

W zakładce Edytor można ustawić następujące parametry:

Name Description
Elementy wyświetlane Wybór czcionki kodu. Ustawienia kolorów i czcionki zostaną zastosowane do wybranego typu. Wynik można zobaczyć w polu Podgląd.
Rodzina Specyfikacja dla typu czcionek, które należy stosować dla wybranego kodu źródłowego.
Rozmiar Określenie rozmiaru czcionki, którą należy stosować dla wybranego kodu źródłowego.
Kolor Określenie koloru, który powinien być użyty dla wybranego typu kodu.
Włacz numerowanie linii Jeżeli pole jest zaznaczone, to wiersze z kodem będą ponumerowane.
Rozmiar tabulacji Określenie długości tabulatora (ilość spacji). Jeśli wartość została ustawiona na przykład na 6, naciśnięcie Tab spowoduje przejście do znaku 7 lub 13 lub 19 itd. To ustawienie jest używane tylko wtedy, gdy wybrano przestrzegaj tabulacji.
Rozmiar wcięcia Określa ile spacji zostanie wstawionych po naciśnięciu klawisza Tab. To ustawienie jest używane tylko wtedy, gdy jest zaznaczona opcja Wstaw spacje.
Przestrzegaj tabulacji Jeśli opcja zostanie zaznaczona, naciśnięcie Tab spowoduje wstawienie tabulatora z rastrem zdefiniowanym przez rozmiar tabulacji.
Wstaw spacje Jeśli opcja zostanie zaznaczona, wciśnięcie klawisza Tab wprowadzi ilość spacji zdefiniowanych przez rozmiar wcięcia.

Preferences General Tab Editor.png

Okno wyjściowe

Preferencje wyjścia mają wpływ na sposób działania Widoku raportu. Ten panel jest wyświetlany za pomocą menu Widok → Panele → Widok raportu.

W zakładce Okno wyjściowe można zdefiniować, następujące opcje:

Nazwa Opis
Rejestruj wiadomości dziennika Jeśli to pole jest zaznaczone, zapisywane są również informacje z logów. Informacje te będą wyświetlane w panelu Widok raportu w kolorze ustawionym w opcji Wiadomości dziennika. Panel ten jest wyświetlany za pomocą menu Widok → Panele → Widok raportu.
Rejestruj ostrzeżenia Jeśli to pole jest zaznaczone, zapisywane są komunikaty ostrzeżeń. Będą one wyświetlane w panelu Widok raportu w kolorze ustawionym w opcji Ostrzeżenia.
Rejestruj komunikaty błędów Jeśli to pole jest zaznaczone, będą zapisywane komunikaty o błędach. Będą one wyświetlane w panelu Widok raportu w kolorze ustawionym w opcji Błędy.
Wyświetlanie widoku raportu z komunikatem o błędzie lub ostrzeżeniem Jeśli to pole jest zaznaczone, panel widoku raportu pojawi się automatycznie, jak tylko zostanie zarejestrowany błąd lub ostrzeżenie.
Zwykłe wiadomości Określa kolor czcionki dla normalnych wiadomości w panelu Widok raportu.
Wiadomości dziennika Określa kolor czcionki dla komunikatów dziennika w panelu Widok raportu.
Ostrzeżenia Określa kolor czcionki dla komunikatów ostrzeżeń w panelu Widok raportu.
Błędy Określa kolor czcionki dla komunikatów błędów w panelu Widok raportu.
Przekieruj wewnętrzne wiadomości Python do panelu Widok raportu Jeśli to pole jest zaznaczone, wewnętrzne wyjście Pythona zostanie przekierowane z konsoli Pythona do panelu widoku raportu. Konsola Pythona jest wyświetlana z poziomu menu Widok → Panele → konsola Python.
Przekieruj wewnętrzne błędy Python do panelu Widok raportu Jeśli to pole jest zaznaczone, wewnętrzne komunikaty o błędach Pythona zostaną przekierowane z konsoli Pythona do panelu Widok raportu.

Preferences General Tab Output window.png

Makro

W zakładce Makro można zdefiniować następujące opcje:

Nazwa Opis
Uruchom makro w środowisku lokalnym Jeśli pole jest zaznaczone, zmienne zdefiniowane przez makra są tworzone jako zmienne lokalne, w przeciwnym razie są to zmienne globalne Python.
Ścieżka katalogu makra Określenie ścieżki do plików makrodefinicji.
Rejestrowanie poleceń GUI Jeśli pole jest zaznaczone, nagrane makro będzie również zawierać polecenia interfejsu użytkownika.
Rejestruj jako komentarz Jeśli pole jest zaznaczone, nagrane makro będzie również zawierać polecenia interfejsu użytkownika, ale jako komentarze. Jest to przydatne, jeśli nie chcesz wykonywać widocznych akcji podczas uruchamiania makra, ale zobaczyć, co można zrobić w sposób widoczny.
Pokaż polecenia skryptu w konsoli python Jeśli pole jest zaznaczone, polecenia wykonywane przez skrypty makro są wyświetlane w konsoli Pythona. Konsola jest dostępna z poziomu menu Widok → Panele → konsola Python.
Rozmiar listy ostatnich makr Kontroluje liczbę ostatnio wyświetlanych makr w menu.
Liczba skrótów Kontroluje liczbę ostatnich makr, które otrzymują dynamicznie przypisane skróty.
Kombinacje klawiszy Kontroluje, które kombinacje klawiszy są używane dla skrótów, na przykład Ctrl + Shift + tworzy skróty w postaci Ctrl + Shift + 1, Ctrl + Shift + 2 itd.

Preferences General Tab Macro.png

Jednostki

W zakładce Jednostki możesz ustawić następujące parametry:

Nazwa Opis
System jednostek Wybór systemu jednostek, który powinien być używany dla wszystkich części programu FreeCAD.
Ilość miejsc dziesiętnych Liczba miejsc po przecinku, która powinna być wyświetlana dla liczb i wymiarów w programie FreeCAD.
Minimalna część ułamka Minimalna wielkość ułamkowa cala, która powinna być wyświetlana. To ustawienie jest dostępne tylko wtedy, gdy używany jest system jednostek Building US (ft-in/sqft/cuft).

Preferences General Tab Units.png

Ustawienia wyświetlania

Ta sekcja preferencji posiada dwie standardowe zakładki: Widok 3D i Nawigacja i kolory. Czwarta zakładka, Widok siatki, jest dodawana, jeśli załadowano środowisko pracy Siatki.

Widok 3D

W zakładce Widok 3D można skonfigurować następujące opcje:

Nazwa Opis
Pokaż układ współrzędnych Jeśli to pole jest zaznaczone, zawsze będzie wyświetlany główny układ współrzędnych w prawym dolnym rogu ekranu po otwarciu pliku projektu.
Domyślnie pokazuj oznaczenie krzyża osi dostępne w wersji 0.19 Jeśli to pole jest zaznaczone, przy otwieraniu lub tworzeniu pliku domyślnie wyświetlany będzie krzyż osi.
Pokaż licznik klatek na sekundę Jeśli opcja jest zaznaczona, to czas potrzebny na ostatnią operację i wynik w postaci liczby klatek na sekundę zawsze będzie wyświetlany w lewym dolnym rogu ekranu, po otwarciu pliku projektu.
Zapamiętaj aktywne stanowisko pracy z zakładki obok dostępne w wersji 0.19 Jeśli pole jest zaznaczone, aplikacja będzie pamiętać, które Środowisko pracy jest aktywne dla każdej z zakładek niezależnie. W ten sposób aktywne Środowisko pracy zostanie automatycznie przywrócone przy zmianie zakładki w widoku multiple-document interface (MDI).
Pokaz kostkę do nawigacji 3D Jeśli opcja jest zaznaczona, kostka zawsze będzie pokazywana. Powiązane Steps by turn określa, ile kroków (skoków) zostanie zastosowanych przy użyciu strzałek obrotu kostki nawigacyjnej. Powiązane Corner określa, gdzie kostka nawigacji jest wyświetlana na ekranie podczas tworzenia / otwierania dokumentu.
Używaj bufora OpenGL Vertex dla obiektów Jeśli opcja jest zaznaczona, Vertex Buffer Objects (VBO) będzie używany. VBO jest funkcją OpenGL która oferuje procedury przesyłania danych o wierzchołkach (położenie, wektor normalny, kolor itp.) od karty graficznej. VBO oferuje znaczny wzrost wydajności, ponieważ dane znajdują się w pamięci graficznej, a nie w pamięci systemowej i dlatego mogą być renderowane bezpośrednio przez GPU. Więcej informacji na temat tła można znaleźć na tej witrynie.
Render Cache dostępne w wersji 0.19 Render Cache lub Render Acceleration jest wyjaśnione bardziej szczegółowo w Link#render-caching. Istnieją trzy opcje:
  • Auto (domyślnie), niech Coin3D zdecyduje, w której pamięci buforować.
  • Distributed, włącz pamięć podręczną dla wszystkich węzłów głównych źródła widoku.
  • Centralized, wyłącz pamięć podręczną we wszystkich węzłach wszystkich źródeł widoków i buforuj tylko w węźle głównym wykresu sceny. Zapewnia to najszybszą wydajność renderowania, ale wolniejszą reakcję na wszelkie zmiany sceny.
Wygładzanie Wybór, czy i jakiego rodzaju multisample anti-aliasing będzie w użyciu.
Transparent objects dostępne w wersji 0.19 Renderuj obiekty przezroczyste. Dostępne są następujące typy:
  • Jedno przejście (domyślnie), renderowanie odbywa się w jednym przebiegu. Dla obiektów nie będących bryłami, takich jak powierzchnie lub siatki, może to prowadzić do powstania artefaktów. Ten obraz pokazuje taki artefakt (czarny trójkąt) i że typ Przejście od tyłu unika tego.
  • Przejście od tyłu, ma wpływ tylko na obiekty nie będące obiektami stałymi. Są one następnie renderowane w dwóch przebiegach: Wielokąty zwrócone do tyłu są renderowane w pierwszym przejściu, a zwrócone do przodu w drugim przejściu.
Rozmiar znacznika Wybór wielkości wierzchołków (punktów) w Środowisku pracy Sketcher. Obszar możliwy do zaznaczenia punktów można dodatkowo powiększyć poprzez zwiększenie wartości Zwiększ promień (w zakładce Kolory).
Odległość po między oczami dla trybów stereo Określenie odległości między oczami używanej do projekcji stereo. Podana wartość jest współczynnikiem, który zostanie pomnożony przez rozmiar ramki konturu obiektu 3D, który jest aktualnie wyświetlany.
Kolor podświetlenia Jeśli opcja jest zaznaczona, podświetlenie jest włączone przy użyciu zdefiniowanego koloru. Podświetlenie jest używane do renderowania tylnych boków ścian (zazwyczaj nie widać ich w bryłach, chyba, że tniemy jedną z płaszczyzną przycięcia, lub jeśli ściany nie są poprawnie ustawione). Opcja jest aktywna tylko dla obiektów, których właściwość oświetlenia (na zakładce Widok) jest ustawiona na wartość Jedna strona. Jeśli opcja jest wyłączona, tylne strony ścian obiektów w trybie oświetlenia Jedna strona będą czarne.

Powiązane ustawienie Intensywności określa intensywność podświetlenia.

Typ projekcji Wybór typu zastosowanej metody wyświetlania obrazu z kamery.

Preferences Display Tab 3D View.png

Nawigacja

W zakładce Nawigacja można zdefiniować, co następuje:

Nazwa Opis
Kostka nawigacyjna Jeśli opcja jest zaznaczona, kostka nawigacyjna zawsze będzie wyświetlana.

Powiązany parametr kolejne kroki określa, ile kroków (skoków) jest wymaganych podczas używania strzałek obrotu kostki nawigacyjnej.

Powiązana opcja Narożnik określa miejsce wyświetlania kostki nawigacyjnej na ekranie podczas tworzenia i otwierania dokumentu.

Jeśli zaznaczono Obróć do najbliższego, widok 3D jest obracany do najbliższego logicznie stanu po kliknięciu ściany sześcianu. Gdy opcja jest wyłączona, kliknięcie w sześcian spowoduje, że widok znajdzie się zawsze w tej samej pozycji niezależnie od poprzedniej pozycji. dostępne w wersji 0.20

Rozmiar kostki Definiuje rozmiar sześcianu. dostępne w wersji 0.20

Nawigacja 3D Wybór zestawu ustawień nawigacji myszką. Aby zobaczyć, co definiuje każdy zestaw, wybierz zestaw i naciśnij przycisk Myszki....
Styl orbity Wybór stylu orbity obrotu. Podczas oglądania części w płaszczyźnie X-Y, gdy istota jest w trybie obrotu nawigacji 3D, różnica polega na tym: Jeśli wybrano Trackball, poruszanie myszą w poziomie spowoduje obrót części wokół osi Y. Jeżeli wybrano Turntable, część zostanie obrócona wokół osi Z.
Tryb obracania Określa środek obrotu. Wybierz Środek okna, Przyciągnij do kursora lub Środek obiektu.
Domyślna orientacja widoku Wybór orientacji kamery dla nowych dokumentów. Tego ustawienia używa również polecenie Std: Widok domyślny.
Powiększenie w nowym dokumencie Wpływa na początkowy poziom przybliżenia obrazu dla nowych dokumentów. Ustawiona wartość odpowiada średnicy kuli, która zmieści się w oknie widoku 3D. Domyślnie jest to 100mm. Ustawia również wstępny rozmiar elementów początku układu współrzędnych (płaszczyzn bazowych w nowych Projekt części: zawartość).
Włącz animację Jeśli opcja jest zaznaczona, obroty mogą być animowane. Jeśli na przykład styl nawigacji 3D ustawi się na CAD i mysz zostanie przesunięta, gdy kółko przewijania i prawy przycisk myszy zostaną wciśnięte, części zostaną obrócone. Jeśli mysz porusza się podczas zwalniania np. prawego przycisku myszy, obrót będzie kontynuowany jako animacja. Aby zakończyć animację kliknij lewym przyciskiem myszy.
Przybliż przy kursorze Jeśli to pole jest zaznaczone, operacje powiększania będą wykonywane w położeniu kursora myszki. W przeciwnym razie operacje powiększania będą wykonywane na środku bieżącego widoku. Krok powiększenia określa, w jakim stopniu będzie wykonywane powiększenie. Krok powiększenia równy 1 oznacza współczynnik 7,5 dla każdego kroku powiększenia.
Odwróć kierunek przybliżenia Jeśli opcja jest zaznaczona, kierunek wykonywania operacji powiększania zostanie odwrócony.
Wyłączenie gestu pochylenia na ekranie dotykowym Jeśli ta opcja jest zaznaczona, gest pochylania zostanie wyłączony w przypadku przybliżania uszczypnięciem (powiększanie dwoma palcami). Dotyczy to tylko profilu nawigacji myszką ustawionego na Gesture.

Preferences Display Tab Navigation.png

Kolory

W zakładce Kolory możesz sprecyzować następujące funkcje:

Nazwa Opis
Włącz podświetlania elementu wskazanego Jeśli to pole wyboru jest zaznaczone, wybór wstępny jest włączony i wskazany element zostanie podświetlony określonym kolorem. Preselekcja oznacza, że np. krawędzie w częściach zostaną podświetlone podczas wskazywania kursorem myszki, oraz że mogą zostać wybrane.
Włącz podświetlania elementu wybranego Jeśli to pole wyboru jest zaznaczone, podświetlenie wyboru jest aktywne i zostanie zastosowany określony kolor.
Promień obszaru wyboru Ustawia wielkość powierzchni do wybierania elementów w widoku 3D. Większa wartość ułatwia wybieranie elementów, ale może uniemożliwić wybór niektórych małych elementów.
Kolor podstawowy Jeśli opcja zostanie wybrana, tło części będzie miało wybrany kolor.
Kolor gradientu Jeśli opcja zostanie wybrana, tło dla części będzie miało pionowy gradient kolorów. Pierwszy kolor to kolor na górze tła, a drugi to kolor na dole.
Kolor pośredni Funkcja jest włączona tylko wtedy, gdy wybrano Kolor gradientu. Jeśli to pole jest zaznaczone, gradient koloru otrzyma wybrany kolor jako kolor pośredni.
Obiekt w trakcie edycji Wybór koloru tła dla obiektów w widoku drzewa, które są aktualnie edytowane.
Obiekt aktywny Wybór koloru tła dla aktywnych obiektów w widoku drzewa. Na przykład, jeśli w widoku drzewa znajduje się kilka elementów, a jedna część jest przełączona jako active body, otrzyma wybrany kolor tła w widoku drzewa.

Preferences Display Tab Colors.png

Widok siatki

Ta zakładka jest dostępna tylko wtedy, gdy Środowisko pracy Siatka zostało załadowane.

W zakładce Widok siatki można zdefiniować, następujące opcje:

Nazwa Opis
Domyślny kolor siatki Wybór domyślnego koloru dla nowo utworzonych siatek.
Domyślny kolor linii Wybór domyślnego koloru linii dla nowo utworzonych siatek.
Stopień przeźroczystości siatki Określenie domyślnej wartości przezroczystości dla nowo utworzonych siatek.
Stopień przeźroczystości linii Określenie domyślnej wartości przezroczystości dla nowo utworzonych linii siatek.
Rendering dwustronny Jeśli pole jest zaznaczone, dolna strona powierzchni będzie renderowana w ten sam sposób jak strona górna. Jeśli nie jest zaznaczone, zależy to od opcji Włącz podświetlenie kolorem (zobacz sekcję widok 3D). Użyty zostanie kolor podświetlenia lub kolor czarny.
Wyświetlanie ramki ograniczającej dla zaznaczonych lub wybranych siatek Jeśli to pole jest zaznaczone, zostanie wyświetlone żółte pole ograniczające dla zaznaczonych lub wybranych siatek.
Zdefiniuj wektor normalny dla wierzchołka Jeśli to pole jest zaznaczone, Cieniowanie Phong jest używane, w przeciwnym razie stosuje się cieniowanie płaskie. Cieniowanie określa wygląd powierzchni.

W przypadku cieniowania płaskiego nie określa się normalności powierzchni na punkt, co prowadzi do nierzeczywistego wyglądu zakrzywionych powierzchni, natomiast zastosowanie cieniowania Phong prowadzi do uzyskania gładszego wyglądu.

Kąt natarcia Kąt załamania to kąt progowy między dwiema ściankami. Można go ustawić tylko wtedy, gdy opcja Zdefiniuj wektor normalny dla wierzchołka jest używana.
Jeśli kąt nachylenia powierzchni czołowej ≥ kąt załamania, stosuje się cieniowanie ścian.
Jeśli kąt nachylenia powierzchni < kąt załamania, stosuje się gładkie zacienienie.

Preferences Display Tab Mesh view.png

Środowiska pracy

Ta sekcja preferencji ma jedną kartę: Niezaładowane środowiska pracy.

Niezaładowane środowiska pracy

Aby ograniczyć zużycie zasobów, FreeCAD nie ładuje automatycznie wszystkich dostępnych środowisk pracy. I tylko wtedy, gdy środowisko pracy zostało załadowane, jego preferencje, jeśli takowe istnieją, pojawiają się w edytorze Preferencji.

W wersji FreeCAD 0.19 zakładka Niezaładowane środowiska pracy wyświetla listę zainstalowanych środowisk pracy, które nie zostały jeszcze załadowane. Aby załadować jedno lub więcej środowisk, należy zaznaczyć je na liście i nacisnąć przycisk Załaduj wybrane.

W wersji FreeCAD 0.20 zakładka Niezaładowane środowiska pracy wyświetla listę wszystkich zainstalowanych środowisk pracy. Aby załadować środowisko pracy należy nacisnąć jego indywidualny przycisk Wczytaj teraz. Jeśli zaznaczysz pole wyboru CheckBoxTrue.svg Wczytaj automatycznie dla danego środowiska pracy, będzie ono automatycznie ładowane podczas uruchamiania programu FreeCAD. Ładowanie większej ilości środowisk pracy spowolni uruchamianie, ale przełączanie się pomiędzy tymi, które zostały już załadowane jest szybsze.

Jeśli nowo załadowane środowisko pracy posiada dedykowane preferencje, pojawią się one w nowej sekcji w edytorze Preferencji. Niektóre środowiska pracy dodają wsparcie dla dodatkowych formatów importu i eksportu. Jeśli istnieją jakieś powiązane preferencje, pojawią się one na jednej lub więcej nowych zakładkach w sekcji konfiguracji Importu-Eksportu edytora Preferencji.

Aby zapoznać się z listą preferencji Środowiska pracy, zobacz Preferencje Środowiska pracy

Preferences Workbenches Tab Unloaded Workbenches.png

Konfiguracja dla importu i eksportu

Ustawienia Import-Export wpływają na sposób importowania i eksportowania plików do i z FreeCAD. Są one opisane na stronie Preferencje eksportu, importu.

Preferencje Środowisk pracy

Ta sekcja jest niekompletna i wymaga podania stron z opisem preferencji, każdego podstawowego Środowiska pracy.

Preferencje dla bardziej popularnych stołów warsztatowych są linkowane poniżej. Niektóre stoły warsztatowe nie mają preferencji. Inne opcjonalne Środowiska pracy mogą nie być tutaj wymienione. Te linki są również wymienione w Category:Preferences

.

Zewnętrzne Środowiska pracy

Ta sekcja jest niekompletna i wymaga podania stron preferencji dla każdego zewnętrznego Środowiska pracy

.

Tworzenie skryptów

See also: FreeCAD Scripting Basics.

For a scripting example see Std DlgParameter.

Powiązane