Réglage des préférences

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Preferences Editor and the translation is 100% complete.
Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎українська • ‎中文 • ‎中文(中国大陆)‎ • ‎中文(台灣)‎ • ‎日本語 • ‎한국어

Introduction

Pour lancer l'Éditeur de préférences, sélectionnez l'option Édition → Préférences... dans le menu. Sur Mac OS, l'option Préférences... apparaît dans le menu FreeCAD à la place (c'est l'emplacement par défaut des préférences sur Mac).

FreeCAD utilise un concept d'atelier où chaque atelier peut avoir ses propres préférences. Celles-ci n'apparaîtront dans l'éditeur de préférences que si l'atelier a été chargé dans la session FreeCAD en cours. Voir Ateliers ci-dessous pour plus d'informations.

Si aucun atelier n'est chargé, quatre sections apparaissent dans l'éditeur de préférences : Préférences générales, Préférences d'affichage, Ateliers et Options d'Import-Export. Tous les ateliers qui ont été chargés, et qui ont leurs propres préférences, apparaîtront en dessous de ceux-ci.

Veuillez noter qu'en appuyant sur le bouton Reset dans le coin inférieur gauche du dialogue des préférences, vous réinitialiserez toutes les préférences de FreeCAD à leurs valeurs par défaut.

Certaines préférences avancées ne peuvent être modifiées que dans l'Éditeur de paramètres. La page Réglage fin en liste quelques-unes.

Préférences générales

Cette section de préférences a 6 onglets : Général, Document, Sélection, Fenêtre de sortie, Macro et Unités.

Général

Dans l'onglet Général, vous pouvez spécifier les éléments suivants :

Nom Description
Changer la langue Sélectionnez la langue de l'interface utilisateur de FreeCAD
Taille de la liste des fichiers récents Spécification du nombre de fichiers à répertorier dans la liste des fichiers récents
Activer l'arrière-plan en mosaïque Si cette case est cochée, l’arrière-plan de la fenêtre principale de FreeCAD sera par défaut constitué de mosaïques de cette image: Background.png

Cette option n'a d'effet que si aucune Feuille de style n'est sélectionnée.

L'image peut être modifiée en ajoutant les dossiers Gui/Images dans le dossier:

%APPDATA%/FreeCAD (sous Windows),

$HOME/.FreeCAD (sous Linux) ou

$HOME/Library/Preferences/FreeCAD (sous MacOS).

Placez un fichier nommé background.png dans le dossier Images, et décochez/cochez cette option pour voir le fichier modifié.

Feuille de style Sélection d'une feuille de style. Les feuilles de style définissent l'apparence de l'interface utilisateur de FreeCAD. Pour des détails techniques sur les feuilles de style, voir Thèmes.
Taille des icônes de la barre d'outils Sélection de la taille des icônes de la barre d’outils
Mode d'affichage d'arborescence Personnalisation de l'affichage de l'arborescence dans le panneau (redémarrage requis). Les options sont les suivantes :
  • Vue combinée : combine l'arborescence et la vue des propriétés dans un seul panneau.
  • Arborescence et Propriétés : divise l'arborescence et la vue des propriétés en panneau séparé.
  • Les deux : conserve les trois panneaux et vous pouvez avoir deux ensembles d'arborescence et de propriété.
Module de chargement automatique après le démarrage Sélection du plan de travail qui sera utilisé directement après le démarrage de FreeCAD
Active l'écran de démarrage au démarrage Si cette case est cochée, un écran d'accueil est affiché au démarrage de FreeCAD.

L'image de l'écran de démarrage peut être modifiée en plaçant un fichier nommé splash_image.png dans le dossier Images déjà mentionné sous Activer l'arrière-plan en mosaïque.

Activer le retour à la ligne Les mots seront enveloppés lorsqu'ils dépasseront l'espace horizontal disponible dans la console Python. Cette console s’affiche à l’aide du menu Affichage → Panneaux → Console Python.

Preferences General Tab General fr.png

Document

Dans l'onglet Document, vous pouvez spécifier les éléments suivants :

Nom Description
Créer un nouveau document au démarrage Si coché, FreeCAD créera un nouveau document au démarrage
Niveau de compression de sauvegarde du document Spécification du niveau de compression pour les fichiers FCStd. Les fichiers FCStd sont des fichiers compressés ZIP. Par conséquent, vous pouvez renommer leur suffixe .FCStd en .zip et les ouvrir avec un programme d'archive ZIP.
Utilisation des fonctions Annuler/Rétablir sur les documents Si cette case est cochée, toutes les modifications apportées aux documents sont stockées afin de pouvoir être annulées /refaites.
Nombre maximum d'étapes d'annulation/de rétablissement Spécification du nombre d'étapes Annuler/Rétablir à enregistrer
Autoriser l'interruption du recalcul Permet d'interrompre le recalcul du document en appuyant sur Echap. Cela peut augmenter légèrement le temps de recalcul.
Exécuter la récupération automatique au démarrage Si un fichier de récupération est disponible, FreeCAD exécutera automatiquement une récupération de fichier au démarrage. De cette façon, les fichiers peuvent être restaurés en cas de panne.
Enregistrer les informations de récupération automatique tous les Spécification de la fréquence d'écriture d'un fichier de récupération.
Enregistrer la miniature dans le fichier de projet lors de l'enregistrement du document Si cette case est cochée, une miniature sera également stockée lors de l'enregistrement du document. La vignette sera par exemple affichée dans la liste des fichiers récents dans l'atelier Start. Il est possible de sélectionner une 'Taille' entre 128 × 128 et 512 × 512 pixels pour la vignette. Les tailles courantes sont les puissances de deux: 128, 256, 512.
Ajouter le logo du programme à la miniature générée Si cette case est cochée, le logo du programme FreeCAD Freecad.svg sera ajouté à la vignette. Cette option n'a d'effet que si Enregistrer la miniature dans le fichier de projet lors de l'enregistrement du document est utilisé.
Nombre maximal de fichiers de sauvegarde à conserver lors de la réenregistrement de document Si cette case est cochée, les fichiers de sauvegarde seront conservés lors de l'enregistrement du document. Vous pouvez spécifier combien de fichiers de sauvegarde seront conservés. Ils contiennent la version du document précédemment enregistrée. Le premier fichier de sauvegarde aura le suffixe de fichier .FCStd1, le second .FCStd2 et ainsi de suite.
Utiliser la date et l'extension FCBak Si coché, les fichiers de sauvegarde auront l'extension .FCbak et leurs noms de fichiers auront un suffixe de date selon le format de date spécifié. Pour une description du format de date, voir ce site.

Avec les paramètres par défaut, le fichier de sauvegarde obtiendra par exemple ce nom TD-Cube.20200315-215654.FCBak (le nom de fichier d'origine est TD-Cube.FCStd).

Autoriser les étiquettes d'objet en double dans un document Si coché, les objets peuvent avoir le même label/nom. Par exemple, différentes parties ou fonctions peuvent avoir le même nom dans le même document.
Désactiver le chargement partiel des objets liés externes Activez le chargement partiel du document lié externe. Lorsque cette option est activée, seuls les objets référencés et leurs dépendances seront chargés lorsqu'un document lié est ouvert automatiquement avec le document principal. Un document partiellement chargé ne peut pas être modifié. Double-cliquez sur l'icône du document dans l'arborescence pour le recharger complètement. Une explication plus détaillée de la fonctionnalité peut être trouvée sur la page de documentation Assembly3 documentation page.
Nom de l'auteur Tous les documents qui seront créés obtiendront le nom d'auteur spécifié. Laissez le champ auteur vide pour un auteur anonyme. Si l'option Défini lors de la sauvegarde est cochée, le champ Last modified by sera défini sur l'auteur spécifié lors de l'enregistrement du fichier. Ce champ peut être affiché à l'aide du menu Fichier → Project information.
Entreprise Tous les documents qui seront créés recevront le nom de l'entreprise spécifié
Licence par défaut Sélection d'une licence par défaut pour les nouveaux documents. Pour une licence prédéfinie, URL de licence sera automatiquement définie en conséquence. Sélectionnez «Autre» pour une licence propre ou spéciale.
URL de licence Spécification d'une URL décrivant la licence sélectionnée dans Licence par défaut

Preferences General Tab Document.png

Sélection

Dans l'onglet "Sélection" (Introduit dans la version 0.19), vous pouvez spécifier les éléments suivants:

Nom Description
Bascule automatiquement vers la vue 3D contenant l'élément sélectionné Active le Mode Arborescence Vue synchronisation
Déplie automatiquement l'arborescence lorsque l'objet correspondant est sélectionné dans la vue 3D Active le Mode Arborescence Synchroniser la sélection
Présélectionne l'objet dans la vue 3D lorsque la souris est au-dessus d'un élément de l'arborescence Active le Mode Arborescence Préselection
Sauvegarde la sélection dans l'arborescence pour aller en avant/en arrière avec les boutons de navigation Active le Mode Arborescence Enregistrer la sélection
Ajoute des cases à cocher pour la sélection dans l'arborescence du document Chaque Vue par arborescence recevra une case à cocher. Ceci est par exemple utile pour sélectionner plusieurs éléments via un écran tactile.

Preferences General Tab Selection.png

Éditeur

Les paramètres de préférences de l'éditeur affectent le comportement de l'éditeur de macro. L'éditeur peut être ouvert à l’aide du menu Macro → Macros ... → Éditer/Créer.

Les paramètres de couleur et de police affectent également la console Python. Cette console s’affiche à l’aide du menu Affichage → Panneaux → Console Python.

Dans l'onglet Éditeur, vous pouvez spécifier les éléments suivants :

Nom Description
Autoriser les numéros de ligne Si coché, les lignes de code seront numérotées
Taille de la tabulation Spécification de la trame de tabulation (combien d'espaces). Si elle est par exemple fixée à 6, l'appui sur Tab fera sauter au caractère 7 ou 13 ou 19 etc. selon la position actuelle du curseur. Ce paramètre n'est utilisé que si Maintien des tabulations est sélectionné.
Taille de l'indentation Spécification du nombre d'espaces à insérer lorsque vous appuyez sur Tab. Ce paramètre n'est utilisé que si Insérer des espaces est sélectionné.
Maintien des tabulations Si cette option est sélectionnée, l'appui sur Tab insérera une tabulation avec la trame définie par Taille des tabulations.
Insérer des espaces Si cette option est sélectionnée, l'appui sur Tab insérera le nombre d'espaces défini par Taille de l'indent.
Affichage des éléments Sélection du type de code. Les paramètres de couleur et de police seront appliqués au type sélectionné. Le résultat peut être vérifié dans le champ Aperçu.
Famille Spécification de la famille de polices qui doit être utilisée pour le type de code sélectionné.
Taille Spécification de la taille de la police à utiliser pour le type de code sélectionné.
Couleur. Spécification de la couleur qui doit être utilisée pour le type de code sélectionné.

Preferences General Tab Editor.png

Fenêtre de sortie

Les préférences de sortie affectent le comportement de la Vue rapport. Ce panneau est affiché à l'aide du menu Affichage → Panneaux → Vue rapport.

Dans l'onglet Fenêtre de Sortie, vous pouvez spécifier les éléments suivants :

Nom Description
Enregistrer les messages normaux Si cette case est cochée, les messages normaux seront enregistrés. Ils seront affichés dans la Vue rapport avec la couleur définie dans Messages normaux.
Enregistrer les messages du journal Si cette case est cochée, les messages du journal seront enregistrés. Ils seront affichés dans la Vue rapport avec la couleur définie dans Log messages.
Enregistrer les avertissements Si cette case est cochée, les avertissements seront enregistrés. Ils seront affichés dans la Vue rapport avec la couleur définie dans Warnings.
Enregistrer les messages d'erreur Si cette case est cochée, les messages d'erreur seront enregistrés. Ils seront affichés dans la Vue rapport avec la couleur définie dans Errors.
Afficher la vue du rapport en cas d'erreur Si cette option est cochée, la Vue rapport s'affichera automatiquement lorsqu'une erreur est enregistrée.
Afficher la vue du rapport sur les messages Si cette case est cochée, la Vue rapport s'affichera automatiquement lorsqu'un avertissement est enregistré.
Afficher la vue du rapport sur les messages Si cette case est cochée, la Vue rapport s'affichera automatiquement lorsqu'un message normal sera enregistré.
Afficher la vue du rapport sur les messages du journal Si cette case est cochée, la Vue rapport s'affichera automatiquement lorsqu'un message de journal est enregistré.
Inclure un timecode pour chaque entrée Si cette option est cochée, chaque message et avertissement recevra un timecode.
Messages normaux Spécification de la couleur de la police pour les messages normaux
Journal des messages Spécification de la couleur de la police pour les messages de journal.
Avertissements Spécification de la couleur de la police des messages d'avertissement.
Erreurs Spécification de la couleur de la police des messages d'erreur.
Rediriger les messages interne Python vers la Vue rapport Si cette option est cochée, la sortie Python interne sera redirigée de la Console Python vers la Vue rapport.
Rediriger les erreurs internes de Python vers la vue rapport Si cette case est cochée, les messages d'erreur internes de Python seront redirigés de la Console_Python vers la Vue rapport.

Preferences General Tab Output window fr.png

Macro

Dans l'onglet Macro, vous pouvez spécifier les éléments suivants :

Nom Description
Exécuter les macros dans l'environnement local Si cette case est cochée, les variables définies par les macros sont créées comme des variables locales, sinon comme des variables Python globales
Chemin de la macro Spécification du chemin pour les fichiers de macro
Enregistrer les commande de l’interface graphique Si cette case est cochée, les macros enregistrées contiendront également des commandes d'interface utilisateur.
Enregistrer comme un commentaire Si cette case est cochée, les macros enregistrées contiendront également des commandes d'interface utilisateur, mais sous forme de commentaires. Ceci est utile si vous ne voulez pas exécuter ces commandes lors de l'exécution de la macro, mais que vous voulez voir ce qui a été fait pendant l'enregistrement.
Montrer les commandes du script dans la console Python Si cette option est cochée, les commandes exécutées par les scripts de macro sont affichées dans la console Python. Cette console s'affiche à l'aide de l'option de menu Affichage → Panneaux → Console Python.
Taille de la liste des macros récentes Contrôle le nombre de macros récentes à afficher dans le menu.
Nombre de raccourcis Contrôle le nombre de macros récentes auxquelles sont attribués dynamiquement des raccourcis.
Modificateurs de clavier. Contrôle les modificateurs de clavier utilisés pour les raccourcis, par exemple Ctrl+Shift+ crée des raccourcis sous la forme Ctrl+Shift+1, Ctrl+Shift+2, etc.

Preferences General Tab Macro.png

Unités

Dans l'onglet Unités, vous pouvez spécifier les éléments suivants :

Nom Description
Système d'unités Sélection du système d'unités à utiliser pour toutes les parties de FreeCAD.
Nombre de décimales Le nombre de décimales qui doivent être affichées pour les nombres et les dimensions.
Fraction minimale de pouce Le nombre minimum de fractions de pouce à afficher. Ce paramètre n'est disponible que si le système d'unités Building US (ft-in/sqft/cuft) est utilisé.

Preferences General Tab Units.png

Préférences d'affichage

Cette section des préférences comporte trois onglets standard : Vue 3D, Navigation et Couleurs. Un quatrième onglet, Vue du maillage, est ajouté si le Atelier Mesh a été chargé.

Vue 3D

Dans l'onglet Vue 3D, vous pouvez spécifier les éléments suivants :

Nom Description
Afficher le système de coordonnées dans le coin Si cette option est cochée, le système de coordonnées principal sera toujours affiché en bas à droite dans les fichiers ouverts.
Afficher la croix de l'axe par défaut Introduit dans la version 0.19 Si vous cochez cette case, la croix des axes sera affichée par défaut à l'ouverture ou à la création du fichier.
Afficher le compteur d'images par seconde Introduit dans la version 0.19. Si cette case est cochée, le temps nécessaire à la dernière opération et le taux de rafraîchissement résultant ddu nombre d'Images par seconde seront toujours affichés en bas à gauche dans les fichiers ouverts.
Se souvenir de l'atelier actif par onglet Introduit dans la version 0.19 Si cette option est cochée, l'application se souviendra du plan de travail actif pour chaque onglet de la Zone de vue principale indépendamment. Lorsque vous passez à un autre onglet, ce plan de travail est automatiquement restauré.
Utiliser OpenGL Introduit dans la version 0.19 Si cette option est cochée, OpenGL utilisera le CPU au lieu du GPU. Cette option est utile pour résoudre les problèmes de carte graphique et de pilote. La modification de cette option nécessite un redémarrage de l'application.
Utiliser OpenGL VBO (Vertex Buffer Object) Si cette option est cochée, Vertex Buffer Objects (VBO) sera utilisé. Un VBO est une fonctionnalité OpenGL qui fournit des méthodes pour télécharger des données de sommets (position, vecteur normal, couleur, etc.) vers la carte graphique. Les VBO offrent des gains de performance substantiels car les données résident dans la mémoire graphique plutôt que dans la mémoire système et peuvent donc être rendues directement par le GPU. Pour plus d'informations, voir cette page.
Rendu accéléré. Introduit dans la version 0.19 "Render Cache" ou "Render Acceleration" est expliqué plus en détail dans FreeCAD_assembly3 render-caching. Il y a 3 options :
  • Auto (par défaut), laisse Coin3D décider où mettre en cache.
  • Distribué, activer manuellement le cache pour tous les noeuds racine du fournisseur de vue.
  • Centralisé, désactiver manuellement le cache dans tous les noeuds de tous les fournisseurs de vues, et ne mettre en cache que le noeud racine du graphe de scène. Ceci offre la vitesse de rendu la plus rapide, mais une réponse plus lente à tout changement de scène.
Anticrénelage Sélectionne si et quel type d'anticrénelage multisample anti-aliasing est utilisé.
Objets transparents. Introduit dans la version 0.19 Type de rendu des objets transparents. Les types sont :
  • One pass (par défaut), le rendu est effectué en une seule passe. Pour les objets non solides comme les faces ou les maillages, cela peut conduire à des artefacts. Cette image montre un tel artefact (triangle noir) et que le type Passe pour les faces cachées évite cela.
  • Le type Passe pour les faces cachées n'a d'effet que pour les objets non solides. Ils sont alors rendus en deux passes : Les polygones faisant face à l'arrière sont rendus dans la première passe et ceux faisant face à l'avant dans la deuxième passe.
Taille du marqueur Sélection de la taille des vertices (points) dans l'Atelier Sketcher. La zone cliquable des points peut être agrandie en augmentant le Selectionner le rayon.
Selectionner le rayon (px) Définit la zone de sélection des éléments dans la Vue 3D. Une valeur plus grande facilite la sélection des éléments, mais peut rendre impossible la sélection de certains petits éléments.
Distance entre les yeux pour les modes stéréo Spécification de la distance œil à œil utilisée pour les projections stéréo. La valeur spécifiée est un facteur qui sera multiplié par la taille de la bounding box de l'objet 3D actuellement affiché.
Couleur du rétroéclairage Si cette case est cochée, le rétroéclairage est activé avec la couleur définie. Le rétroéclairage est utilisé pour le rendu des faces arrières des visages. Habituellement, vous ne les voyez pas dans les solides, à moins que vous n'en coupiez un avec un plan d'écrêtage, ou que les faces ne soient pas orientées correctement. Elle n'est active que pour les objets dont la propriété Lighting (dans l'onglet Affichage) est définie sur One side. S'il est désactivé, les faces arrière des objets en mode d'éclairage One side seront noires.

Le paramètre connexe Intensité spécifie l'intensité du rétroéclairage.

Type de caméra Sélection du type de projection de la caméra.

Preferences Display Tab 3D View.png

Navigation

Dans l'onglet Navigation, vous pouvez spécifier les éléments suivants :

Nom Description
Cube de navigation Si cette case est cochée, le cube de navigation sera toujours affiché.

Pas par tour définit le nombre de pas nécessaires pour une rotation complète lors de l'utilisation des flèches de rotation du cube de navigation.

Coin définit l'endroit où le cube de navigation est affiché à l'écran lors de la création ou de l'ouverture d'un document.

Si la case Rotation au plus proche est cochée, la vue 3D est tournée vers l'état logique le plus proche lorsqu'une face de cube est cliquée. Lorsqu'elle est désactivée, cliquer sur une face de cube le maintiendra toujours à la même position, quel que soit l'état du cube dans lequel vous vous trouviez lorsque vous avez cliqué sur la face. Introduit dans la version 0.20

Taille du cube définit la taille du cube. Introduit dans la version 0.20

Navigation 3D Sélection d'un ensemble de paramètres pour la Navigation par la souris. Pour voir ce que définit chaque ensemble, sélectionnez-le puis appuyez sur le bouton Souris....
Style d'orbite Sélection du style de l'orbite de rotation. Lorsque l'on visualise une pièce dans le plan x-y et que l'on se trouve dans le mode de rotation de la navigation 3D, la différence est la suivante : Si Trackball est sélectionné, le déplacement horizontal de la souris fera tourner la pièce autour de l'axe des y, si Table tournante est sélectionné, la pièce sera tournée autour de l'axe des z.
Mode de rotation Définit le centre de rotation. Sélectionnez Centre de la fenêtre, Positionner au curseur, ou Centre de l'objet.
Orientation par défaut de la caméra Sélection de l'orientation de la caméra pour les nouveaux documents. Ce paramètre est également utilisé par la commande Std Accueil.
Échelle du nouveau document Affecte le niveau de zoom initial de la caméra pour les nouveaux documents. La valeur que vous définissez est le diamètre d'une sphère qui tient dans la vue 3D. La valeur par défaut est de 100 mm. Elle définit également la taille initiale des caractéristiques d'origine (plans de base dans les nouveaux PartDesign Corps).
Permettre l'animation Si cette case est cochée, les rotations peuvent être animées. Si par exemple on utilise l'ensemble Navigation 3D CAD et que l'on déplace la souris tout en appuyant sur la molette de défilement et le bouton droit de la souris, les pièces sont tournées. Si l'on continue à déplacer la souris tout en relâchant, par exemple, le bouton droit de la souris, la rotation se poursuivra sous forme d'animation. Pour mettre fin à l'animation, cliquez avec le bouton gauche de la souris.
Zoomer au curseur Si cette option est cochée, les opérations de zoom seront effectuées à la position du curseur de la souris. Sinon, les opérations de zoom seront effectuées au centre de la vue actuelle. Le Pas du zoom définit l'ampleur du zoom. Un pas de zoom de 1 signifie un facteur de 7,5 pour chaque pas de zoom.
Inverser le zoom Si cette option est cochée, la direction des opérations de zoom sera inversée.
Désactiver le geste d'inclinaison de l'écran tactile Si cette case est cochée, le geste d'inclinaison sera désactivé pour le zoom par pincement (zoom à deux doigts). Ceci n'affecte que le paramètre Gesture de Navigation 3D.

Preferences Display Tab Navigation.png

Couleurs

Dans l'onglet Couleurs, vous pouvez spécifier les éléments suivants :

Nom Description
Activer la surbrillance de présélection Si cette case est cochée, la présélection est activée et la couleur spécifiée sera utilisée pour celle-ci. La présélection signifie que, par exemple, les bords des pièces seront mis en évidence lorsque vous les survolez avec la souris pour indiquer qu'ils peuvent être sélectionnés.
Activer la surbrillance de la sélection Si cette case est cochée, la mise en évidence de la sélection est activée et la couleur spécifiée sera utilisée pour celle-ci.
Couleur simple Si cette option est sélectionnée, l'arrière-plan de la Vue 3D aura la couleur sélectionnée.
Dégradé de couleurs Si cette option est sélectionnée, l'arrière-plan de la Vue 3D aura un dégradé de couleurs vertical. La première couleur est celle du haut de la vue 3D, la seconde celle du bas.
Couleur intermédiaire N'est activé que si Dégradé de couleurs est sélectionné. Si cette case est cochée, le gradient de couleur prendra la couleur sélectionnée comme couleur centrale.
Objet en cours de modification Sélection de la couleur d'arrière-plan pour les objets de l'arborescence qui sont en cours d'édition.
Contenu actif. Sélection de la couleur de fond pour les conteneurs actifs dans l'arborescence. Par exemple, un PartDesign Corps actif aura la couleur de fond sélectionnée.

Preferences Display Tab Colors.png

Vue maillage

Cet onglet n'est disponible que si l'atelier Mesh a été chargé.

Dans l'onglet Vue du maillage, vous pouvez spécifier les éléments suivants :

Nom Description
Couleur par défaut des maillages Sélection de la couleur de la forme par défaut
Couleur de ligne par défaut Sélection de la couleur de ligne par défaut
Transparence des maillages. Spécification de la transparence du maillage par défaut
Transparence de ligne. Spécification de la transparence de ligne par défaut
Rendu des deux côtés Si cette case est cochée, la couleur de la face intérieure des faces sera la même que celle de la face extérieure. Si cette case n'est pas cochée, la couleur rétroéclairage, si elle est activée, ou le noir seront utilisés à la place.
Afficher le volume capable des mailles en surbrillance ou sélectionnées Si cette option est cochée, une boîte de délimitation jaune sera affichée pour les mailles en surbrillance ou sélectionnées.
Définir la normale par sommet Si cette case est cochée, l'Ombrage de Phong est utilisé, sinon c'est un ombrage plat. L'ombrage définit l'apparence des surfaces. Avec l'ombrage plat, les normales de la surface ne sont pas définies par sommet. Cela donne un aspect irréaliste aux surfaces courbes. L'ombrage Phong donne un aspect plus réaliste et plus lisse.
Angle de pliage. L'angle de pliage est un angle seuil entre deux faces. Il ne peut être défini que si l'option Définir la normale par sommet est utilisée.
Si l'angle de face ≥ l'angle de pliage, l'ombrage de facette est utilisé.
Si l'angle de la face est < à l'angle de pliage, l'ombrage lisse est utilisé.

Preferences Display Tab Mesh view.png

Ateliers

Cette section de préférences comporte un seul onglet : Ateliers disponibles.

Ateliers disponibles

Pour préserver les ressources, FreeCAD ne charge pas automatiquement tous les ateliers disponibles. Et ce n'est que si un atelier a été chargé que ses préférences, le cas échéant, apparaissent dans l'éditeur de préférences.

Dans la version 0.19 de FreeCAD, l'onglet a une étiquette différente : Ateliers disponibles, et l'onglet affiche une liste des ateliers installés qui n'ont pas encore été chargés. Pour charger un ou plusieurs ateliers, sélectionnez-les dans la liste et appuyez sur le bouton Load Selected.

Dans la version 0.20 de FreeCAD, l'onglet Ateliers disponibles affiche une liste de tous les ateliers installés. Pour charger un atelier, appuyez sur son bouton Charger maintenant. Si vous cochez la case Autochargement d'un atelier, celui-ci se chargera automatiquement au démarrage de FreeCAD. Le chargement d'un plus grand nombre d'ateliers rendra le démarrage plus lent, mais le passage d'un atelier à un autre déjà chargé est plus rapide.

Si un atelier nouvellement chargé a des préférences dédiées, elles apparaîtront dans une nouvelle section de l'éditeur de préférences. Certains ateliers prennent en charge des formats d'importation et d'exportation supplémentaires. S'il existe des préférences associées, elles apparaîtront dans un ou plusieurs nouveaux onglets de la section Options d'Import-Export de l'éditeur des préférences.

Pour une liste des préférences de l'atelier, voir Préférences d'ateliers

Preferences Workbenches Tab Unloaded Workbenches.png

Options d'Import-Export

Les paramètres d'Importation-Exportation affectent la façon dont les fichiers sont importés et exportés. Ils sont décrits sur la page Préférences d’import-export.

Préférences d'ateliers

Cette section est incomplète et nécessite de mentionner les pages de préférences de chaque atelier de base

Les préférences pour les ateliers les plus courants sont liées ci-dessous. Certains ateliers n'ont aucune préférence. D'autres ateliers facultatifs peuvent ne pas être répertoriés. Ces liens sont également répertoriés dans Category:Preferences/fr

Ateliers externes

Cette section est incomplète et nécessite de mentionner les pages de préférences de chaque atelier externe

Script

Voir aussi: FreeCAD Script de base.

Pour un exemple de script, voir Std Éditeur des paramètres.

En relation