Voreinstellungseditor

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Preferences Editor and the translation is 62% complete.
Outdated translations are marked like this.
Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎українська • ‎中文 • ‎中文(中国大陆)‎ • ‎中文(台灣)‎ • ‎日本語 • ‎한국어

Einführung

Zum Start des Voreinstellungseditors wähle die Option Bearbeiten → Einstellungen... aus dem Menü. Im Mac OS erscheint die Einstellungen...-Menüoption im FreeCAD-Menü anstatt im Bearbeitungsmenü (ersteres ist der vorgegebene Ort für Einstellungen auf dem Mac).

FreeCAD verwendet ein Arbeitsbereich-Konzept, wobei jeder Arbeitsbereich für bestimmte Aufgaben und Funktionen zuständig ist. Ein Arbeitsbereich kann seine eigenen Voreinstellungen haben. Diese werden nur im Voreinstellungseditor erscheinen, falls der Arbeitsbereich in der aktuellen FreeCAD-Sitzung geladen ist. Siehe Arbeitsbereiche weiter unten für mehr Informationen.

Wenn kein Arbeitsbereich geladen ist, erscheinen vier Abschnitte im Voreinstellungseditor: Allgemein, Anzeige, Arbeitsbereiche und Import/Export. Jeder Arbeitsbereich mit eigenen Voreinstellungen wird unter diesen erscheinen.

Bitte beachte, dass das Drücken der Zurücksetzen-Schaltfläche in der unteren linken Ecke des Voreinstellungsdialogs alle FreeCAD-Einstellungen auf ihren FreeCAD-Standardwert zurücksetzt

Einige fortgeschrittene Einstellungen können nur im Parameter-Editor geändert werden. Die Seite Fine-tuning führt einige auf.

Allgemeine Einstellungen

Dieser Einstellungsbereich hat sieben Reiter: Allgemein, Dokument, Auswahl, Editor, Ausgabefenster, Makro und Einheiten.

Allgemeines

Auf der Registerkarte "Allgemein" können Sie Folgendes festlegen:

Name Beschreibung
Sprache ändern Wähle die Sprache der Benutzeroberfläche von FreeCAD aus.
Größe der Liste der letzten Dateien Gib an, wie viele Dateien in der Liste der letzten Dateien aufgelistet werden sollen.
Aktivieren des gekachelten Hintergrunds Wenn diese Option aktiviert ist, besteht der Hintergrund des Hauptfensters von FreeCAD standardmäßig aus Kacheln dieses Bildes: Background.png

Diese Option hat nur dann einen Effekt, falls keine Formatvorlage ausgewählt ist.

Das Bild kann geändert werden, indem die Ordner Gui/Images im Ordner hinzufügt werden:

%APPDATA%/FreeCAD (in Windows),

$HOME/.FreeCAD (auf Linux) oder

$HOME/Library/Preferences/FreeCAD (auf MacOS).

Stelle eine Datei mit dem Namen background.png in den Ordner Images und die Option abwählen/wählen, um die geänderte Datei anzuzeigen.

Formatvorlage Die Formatvorlagen definieren, wie die Benutzeroberfläche von FreeCAD aussieht. Technische Einzelheiten über die Formatvorlagen sind unter Interface_Customization/de#Themen zu finden.
Größe der Werkzeugleistensymbole Auswahl der Größe für die Werkzeugleistensymbole
Baumansichtsmodus Anpassung, wie die Baumansicht im Paneel angezeigt wird (Neustart erforderlich). Die Optionen sind:
  • Combo Ansicht: Kombiniert die Baumansicht und die Eigenschaftsansicht in einem Paneel.
  • Baumansicht und Eigenschaftsansicht: teile die Baumansicht und die Eigenschaftsansicht in ein separates Paneel.
  • Beide': alle drei Paneele beibehalten, und du kannst zwei Sätze von Baumansicht und Eigenschaftsansicht haben.
Modul nach dem Start automatisch laden Auswahl, welcher Arbeitsbereich direkt nach dem Start von FreeCAD verwendet werden soll
Startbildschirm beim Start aktivieren Wenn diese Option angehakt ist, wird der Startbildschirm beim Start von FreeCAD angezeigt.

Das Begrüßungsbildschirmbild kann geändert werden, indem eine Datei namens splash_image.png in den Ordner Gui/Images} gestellt wird, der unter Gekachelten Hintergrund aktivieren bereits erwähnt wurde.

Enable word wrap Wörter werden umgebrochen, wenn sie den verfügbaren horizontalen Platz in der Python-Konsole überschreiten. Diese Konsole wird über das Menü Ansicht → Paneele → Python Konsole} angezeigt.

Preferences General Tab General de.png

Dokument

Im Reiter Document kann man folgendes festlegen:

Name Description
Create new document at start up If checked, FreeCAD will create a new document when started
Document save compression level Specification of the compression level for FCStd files. FCStd files are ZIP-compressed files. Therefore you can rename their suffix .FCStd to .zip and open them with a ZIP archive program.
Using Undo/Redo on documents If checked, all changes in documents are stored so that they can be undone/redone
Maximum Undo/Redo steps Specification how many Undo/Redo steps should be recorded
Allow aborting recomputation If checked, recomputations can be aborted by pressing Esc. This may slightly increase the recomputation time.
Run AutoRecovery at startup If there is a recovery file available FreeCAD will automatically run a file recovery when it is started. This way files can be restored if a crash occurred.
Save AutoRecovery information every Specification how often a recovery file is written.
Save thumbnail into project file when saving document If checked, a thumbnail will be stored when the document is saved. The thumbnail will for example be shown in the list of recent files in the Start workbench. It is possible to select a Size between 128×128 and 512×512 pixels for the thumbnail. Common sizes are the powers of two: 128, 256, 512.
Add the program logo to the generated thumbnail If checked, the FreeCAD program logo Freecad.svg will be added to the thumbnail.
Maximum number of backup files to keep when resaving document If checked, backup files will be kept when saving the document. You can specify the number of backup files to keep. Backup files are previously saved versions of the document. The first backup file will have the file suffix .FCStd1, the second .FCStd2 and so on.
Use date and FCBak extension If checked, backup files will get the extension .FCbak and their file names get a date suffix according to the specified date format. For a description of the date format see this site.

With the default settings a backup file will for example get this name TD-Cube.20200315-215654.FCBak (original filename is TD-Cube.FCStd).

Allow duplicate object labels in one document If checked, objects can have the same label.
Disable partial loading of external linked objects If partial loading of external linked objects is enabled, only the referenced objects and their dependencies will be loaded when the linked document is auto opened together with the main document. Such a partially loaded document cannot be edited. Double click the document icon in the tree view to reload it in full. A more detailed explanation of this feature can be found on the Assembly3 documentation page
Author name All created documents will get the specified author name. Keep the author field blank if you do not want to include this information. If the option Set on save is checked, the field Last modified by will be set to the specified author when saving the file. This field can be viewed using the File → Project information menu option.
Company All created documents will get the specified company name
Default license Selection of the license for new documents. For predefined licenses the License URL will automatically be set accordingly. Select Other for a custom license.
License URL Specification of an URL describing the license selected in Default license

Preferences General Tab Document.png

Auswahl

Im Reiter Auswahl (eingeführt in Version 0.19) kannst du folgendes festlegen:

Name Description
Auto switch to the 3D view containing the selected item Enables the Tree view SyncView mode
Auto expand tree item when the corresponding object is selected in 3D view Enables the Tree view SyncSelection mode
Preselect the object in 3D view when mouse over the tree item Enables the Tree view PreSelection mode
Record selection in tree view in order to go back/forward using navigation button Enables the Tree view RecordSelection mode
Add checkboxes for selection in document tree Each document tree item will get a checkbox. This is for example useful for selecting multiple items on a touchscreen.

Preferences General Tab Selection.png

Editor

Die Einstellungen der Editor Einstellungen beeinflussen das Verhalten des Makroeditors. Dieser Editor kann über das Menü Makro → Makros..... → Bearbeiten/Erstellen geöffnet werden.

Die Farb- und Schrifteinstellungen wirken sich auch auf die Python-Konsole aus. Diese Konsole wird über das Menü View → Panels → Python console angezeigt.

Im Editor Reiter kannst du Folgendes angeben:

Name Beschreibung
Elemente anzeigen Auswahl des Codetyps. Die Farb- und Schrifteinstellungen werden auf den ausgewählten Typ angewendet. Das Ergebnis ist im Feld Vorschau zu sehen.
Familie Angabe der Schriftfamilie, die für den gewählten Codetyp verwendet werden soll
Größe Angabe der Schriftgröße, die für den gewählten Codetyp verwendet werden soll
Farbe Angabe der Farbe, die für den gewählten Codetyp verwendet werden soll
Zeilennummern einschalten Wenn markiert, werden die Codezeilen nummeriert
Tabulator Größe Angabe des Tabulatorrasters (wie viele Leerzeichen). Wenn es z.B. auf '6' gesetzt ist, wird durch Drücken von Tab zum Zeichen 7 oder 13 oder 19 usw. gesprungen, abhängig von der aktuellen Cursorposition. Diese Einstellung wird nur verwendet, wenn Tabulatoren behalten ausgewählt ist.
Einrückungsgröße Angabe, wie viele Leerzeichen eingefügt werden, wenn Tab gedrückt wird. Diese Einstellung wird nur verwendet, wenn Einfügen Leerzeichen ausgewählt ist.
Tabulatoren behalten Falls ausgewählt, wird durch Drücken von Tab ein Tabulator mit dem durch Tabulatorgröße definierten Raster eingefügt
Leerzeichen einfügen Falls ausgewählt, wird durch Drücken von Tab die durch Einrückungsgröße definierte Anzahl von Leerzeichen eingefügt

Preferences General Tab Editor.png

Ausgabefenster

Die Ausgabeeinstellungen beeinflussen das Verhalten der Berichtansicht. Dieses Paneel wird über das Menü Ansicht → Paneele → Berichtansicht angezeigt.

Im Ausgabe Reiter kannst du Folgendes angeben:

Name Description
Record normal messages If checked, normal messages will be recorded. They will be displayed in the Report view with the color set in Normal messages.
Record log messages If checked, log messages will be recorded. They will be displayed in the Report view with the color set in Log messages.
Record warnings If checked, warnings will be recorded. They will be displayed in the Report view with the color set in Warnings.
Record error messages If checked, error messages will be recorded. They will be displayed in the Report view with the color set in Errors.
Show report view on error If checked, the Report view will be shown automatically when an error is recorded
Show report view on warning If checked, the Report view will be shown automatically when a warning is recorded
Show report view on normal message If checked, the Report view will be shown automatically when a normal message is recorded
Show report view on log message If checked, the Report view will be shown automatically when a log message is recorded
Include a timecode for each entry If checked, each message and warning will receive a timecode
Normal messages Specification of the font color for normal messages
Log messages Specification of the font color for log messages
Warnings Specification of the font color for warning messages
Errors Specification of the font color for error messages
Redirect internal Python output to report view If checked, internal Python output will be redirected from the Python console to the Report view
Redirect internal Python errors to report view If checked, internal Python error messages will be redirected from the Python console to the Report view

Preferences General Tab Output window.png

Makro

Auf der Registerkarte "Makro" kannst Du folgendes festlegen:

Name Beschreibung
Makros in lokaler Umgebung ausführen Wenn angehakt, werden durch Makros definierte Variablen als lokale Variablen erstellt, andernfalls als globale Python Variable
Makro Pfad Angabe eines Pfades zu Makro Dateien
Aufzeichnung von GUI Befehlen Wenn angehakt, enthält Aufgezeichnete Makros auch Benutzeroberflächenbefehle
Aufzeichnung als Kommentar Wenn diese Option angehakt ist, enthält Aufgezeichnete Makros auch Benutzeroberflächenbefehle, jedoch als Kommentare. Dies ist nützlich, wenn du beim Ausführen des Makros keine sichtbaren Aktionen ausführen willst, sondern sehen willst, was sichtbar getan werden könnte.
Skriptbefehle in der Python Konsole anzeigen Wenn diese Option aktiviert ist, werden die von den Makroskripten ausgeführten Befehle in der Python Konsole angezeigt. Diese Konsole wird über das Menü Ansicht → Paneele → Python Konsole angezeigt.
Länge der Liste der aktuellen Makros Steuert die Anzahl der aktuellen Makros im Menu
Verknüpfungsanzahl Steuert die Anzahl der aktuellen Makros, denen dynamisch Kurzbefehle zugeordnet werden
Tastatur Modifikatoren Steuert, welche Tastatur-Modifikatoren für die Kurzbefehle verwendet werden, z.B. erstellt Strg+Shift+ Kurzbefehle in der Form Strg+Shift+1, Strg+Shift+2, etc.

Preferences General Tab Macro.png

Einheiten

Auf der Registerkarte "Einheiten" kannst Du folgendes festlegen:

Name Beschreibung
Benutzer System Auswahl eines Einheitensystems, das für alle Teile von FreeCAD verwendet werden soll
Anzahl der Dezimalstellen Die Anzahl der Dezimalstellen, die für Zahlen und Abmessungen in FreeCAD angezeigt werden sollen
Minimaler Bruchteil eines Zolls Minimaler Zoll Bruchteil , der angezeigt werden sollte. Diese Einstellung ist nur verfügbar, wenn das Einheitensystem Building US (ft-in/sqft/cuft)' verwendet wird.

Preferences General Tab Units.png

Anzeige Einstellungen

Dieser Einstellungsabschnitt enthält drei allgemeine Registerkarten, 3D-Ansicht, Navigation und Farben. Eine vierte, Netze, wird hinzugefügt, wenn der Netze-Arbeitsbereich geladen wurde.

3D Ansicht

Im 3D Ansicht Reiter kannst du Folgendes angeben:

Name Description
Show coordinate system in the corner If checked, the main coordinate system will always be shown at the lower right in opened files
Show axis cross by default introduced in version 0.19 If checked, the axis cross will be shown by default at file opening or creation
Show counter of frames per second If checked, the time needed for the last operation and the resulting frame rate will always be shown at the lower left in opened files
Remember active workbench by tab introduced in version 0.19 If checked, the application will remember the active workbench for each tab in the Main view area independently. When switching to a tab this workbench will be restored automatically.
Use software OpenGL introduced in version 0.19 If checked, OpenGL will use the CPU instead of the GPU. This option is useful for troubleshooting graphics card and driver problems. Changing this option requires a restart of the application.
Use OpenGL VBO (Vertex Buffer Object) If checked, Vertex Buffer Objects (VBO) will be used. A VBO is an OpenGL feature that provides methods for uploading vertex data (position, normal vector, color, etc.) to the graphics card. VBOs offer substantial performance gains because the data resides in the graphics memory rather than the system memory and so it can be rendered directly by the GPU. For more background info see this webpage.
Render Cache introduced in version 0.19 "Render Cache" or "Render Acceleration" is explained in more detail in FreeCAD_assembly3 render-caching. There are 3 options:
  • Auto (default), let Coin3D decide where to cache.
  • Distributed, manually turn on cache for all view provider root nodes.
  • Centralized, manually turn off cache in all nodes of all view providers, and only cache at the scene graph root node. This offers the fastest rendering speed, but slower response to any scene changes.
Anti-Aliasing Selection if and what kind of multisample anti-aliasing is used
Transparent objects introduced in version 0.19 Render type of transparent objects. The types are:
  • One pass (default), rendering is done in one pass. For non-solid objects like faces or meshes this can lead to artifacts. This image shows such an artifact (black triangle) and that the type Backface pass avoids this.
  • Backface pass, has only an effect for non-solid objects. They are then rendered in two passes: Back-facing polygons are rendered in the first pass and the front-facing in the second pass.
Marker size Selection of the size of vertices (points) in the Sketcher workbench. The clickable area of points can be additionally enlarged by increasing the Pick radius.
Pick radius (px) Sets the area for picking elements in the 3D view. Larger value makes it easier to pick things, but can make some small features impossible to select.
Eye to eye distance for stereo modes Specification of the eye-to-eye distance used for stereo projections. The specified value is a factor that will be multiplied with the bounding box size of the 3D object that is currently displayed.
Backlight color If checked, backlight is enabled with the defined color. Backlight is used for rendering back sides of faces. Usually, you don't see them in solids, unless you slice one with a clipping plane, or if the faces aren't oriented correctly. It is only active for objects whose Lighting property (on the View tab) is set to One side. If disabled, back sides of faces of objects in One side lighting mode will be black.

The related Intensity setting specifies the intensity of the backlight.

Camera type Selection of the camera projection type.
  • Perspektivisches Rendern, Objekte werden in einer [1] erscheinen.
  • Orthographisches Rendern, Objekte werden in orthographische Projektion projiziert. Siehe auch [2]

Preferences Display Tab 3D View.png

Navigation

Im Navigation Reiter kannst du Folgendes angeben:

Name Description
Navigation cube If checked, the Navigation cube will always be shown.

Steps by turn defines the number of steps required for a full rotation when using the Navigation cube rotation arrows.

Corner defines where the Navigation cube is displayed on the screen when creating or opening a document.

If Rotate to nearest is checked, the 3D view is rotated to the nearest most logical state when a cube face is clicked. When it is off, clicking to a cube face will and up always to the same position, no matter in what cube state you were when you clicked the face. introduced in version 0.20

Cube size defines the size of the cube. introduced in version 0.20

3D Navigation Selection of a navigation settings set. To see what each set defines, select it and then press the Mouse... button.
Orbit style Selection of the rotation orbit style. When viewing a part in the x-y plane and being in the rotation mode of the 3D navigation, the difference is: If Trackball is selected, moving the mouse horizontally will rotate the part around the y-axis, if Turntable is selected the part will be rotated around the z-axis.
Rotation mode Defines the rotation center. Select Window center, Drag at cursor, or Object center.
Default camera orientation Selection of the camera orientation for new documents. This setting is also used by the Std ViewHome command.
New document scale Affects the initial camera zoom level for new documents. The value you set is the diameter of a sphere that fits in 3D view. Default is 100 mm. It also sets the initial size of origin features (base planes in new PartDesign Bodies).
Enable animation If checked, rotations can be animated. If for example the 3D Navigation set CAD is used and the mouse is moved while the scroll wheel and the right mouse button are pressed, parts are rotated. If one keeps the mouse moving while releasing e.g. the right mouse button, the rotation will continue as animation. To end the animation left-click with the mouse.
Zoom at cursor If checked, zoom operations will be performed at the position of the mouse pointer. Otherwise zoom operations will be performed at the center of the current view. The Zoom step defines how much will be zoomed. A zoom step of 1 means a factor of 7.5 for every zoom step.
Invert zoom If checked, the direction of zoom operations will be inverted
Disable touchscreen tilt gesture If checked, the tilting gesture will be disabled for pinch-zooming (two-finger zooming). This only affects the 3D Navigation set Gesture.

Preferences Display Tab Navigation.png

Farben

Im Farben Reiter kannst du Folgendes angeben:

Name Description
Enable preselection highlighting If checked, preselection is turned on and the specified color will be used for it. Preselection means that for example edges in parts will be highlighted while hovering over them with the mouse to indicate they can be selected.
Enable selection highlighting If checked, selection highlighting is turned on and the specified color will be used for it
Simple color If selected, the background of the 3D view will have the selected color
Color gradient If selected, the background of the 3D view will have a vertical color gradient. The first color is the color at the top of the 3D view, the second the color at the bottom.
Middle color Is only enabled if Color gradient is selected. If checked, the color gradient will get the selected color as the middle color.
Object being edited Selection of the background color for objects in the tree view that are currently edited
Active container Selection of the background color for active containers in the tree view. For example an active PartDesign Body will get the selected background color.

Preferences Display Tab Colors.png

Netzansicht

Diese Registerkarte wird nur angezeigt, wenn Du Dich in der Mesh Arbeitsbereich befindest oder wenn Du Dich schon einmal in diesem Arbeitsbereich befindest.

Im Netzansicht Reiter kannst du Folgendes angeben:

Name Description
Default mesh color Selection of the default shape color
Default line color Selection of the default line color
Mesh transparency Specification of the default mesh transparency
Line transparency Specification of the default line transparency
Two-side rendering If checked, the color of the interior side of faces will be the same as the exterior side. If not checked either the backlight color, if enabled, or black will be used instead.
Show bounding-box for highlighted or selected meshes If checked, a yellow bounding box will be displayed for highlighted or selected meshes
Define normal per vertex If checked, Phong shading is used, otherwise flat shading. Shading defines the appearance of surfaces. With flat shading the surface normals are not defined per vertex. This leads to an unrealistic appearance for curved surfaces. While Phong shading leads to a more realistic, smoother appearance.
Crease angle The crease angle is a threshold angle between two faces. It can only be set if the option Define normal per vertex is used.
If face angle ≥ crease angle, facet shading is used
If face angle < crease angle, smooth shading is used

Preferences Display Tab Mesh view.png

Workbenches

This preferences section has a single tab: Available Workbenches.

Available Workbenches

To preserve resources, FreeCAD does not automatically load all available workbenches. And only if a workbench has been loaded will its preferences, if any, appear in the Preferences editor.

In FreeCAD version 0.19 the tab has a different label: Unloaded Workbenches, and the tab displays a list of installed workbenches that have not yet been loaded. To load one or more workbenches select them in the list and then press the Load Selected button.

In FreeCAD version 0.20 the Available Workbenches tab displays a list of all installed workbenches. To load a workbench press its Load now button. If you check a workbench's Autoload checkbox it will autoload when FreeCAD starts up. Loading more workbenches will make the startup slower, but switching between workbenches that have already been loaded is faster.

If a newly loaded workbench has dedicated preference they will appear in a new section in the Preferences editor. Some workbenches add support for additional import and export formats. If there are any related preferences they will appear on one or more new tabs in the Import-Export settings section of the Preferences editor.

For a list of workbench preferences see Workbench preferences

Preferences Workbenches Tab Available Workbenches.png

Import-Export Einstellungen

Die Import-Export Einstellungen beeinflussen wie Dateien in FreeCAD importiert und exportiert werden. Sie sind auf der Seite Import Export Einstellungen beschrieben.

Arbeitsbereichseinstellungen

Dieser Abschnitt ist unvollständig und erfordert die Erwähnung der Präferenzseiten jedes Kern Arbeitsbereichs

Einstellungen für die gebräuchlicheren Arbeitsbereiche findest Du nachfolgend verknüpft. Einige Arbeitsbereiche haben keine Einstellungen. Andere optionale Arbeitsbereiche sind möglicherweise nicht aufgeführt. Diese Verknüpfungen sind auch unter Category:Preferences aufgezeigt.


Externe Arbeitsbereiche

Dieser Abschnitt ist unvollständig und erfordert die Erwähnung der Seiten zu den Einstellungen jeder Externe Arbeitsbereiche

Skripten

See also: FreeCAD Scripting Basics.

For a scripting example see Std DlgParameter.

Verwandt