Верстак Path

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Path Workbench and the translation is 73% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎русский • ‎中文 • ‎中文(中国大陆)‎ • ‎中文(台灣)‎
Логотип верстака Path

Введение

Workbench Path.svg Верстак Path используется для создания машинных инструкций для станков с ЧПУ из 3D-моделей FreeCAD. Это позволяет изготавливать реальные вещи на станках с ЧПУ, таких как: фрезерные, токарные станки, лазерные резаки и тому подобном оборудовании. Обычно эти инструкции на языке G-кодов. Здесь представлен общий пример моделирования траектории движения инструмента на токарном станке с ЧПУ.

Pathwb.png

Рабочий процесс создания инструкций в верстаке FreeCAD Path выглядит следующим образом:
  • 3D-модель - это базовый объект, обычно созданный с использованием одного или нескольких верстаков Part Design, Part или Draft.
  • В верстаке Path создается Задание. Оно содержит всю информацию, необходимую для генерации G-кода для обработки на станке с ЧПУ: там определен материал, станок имеет определенный набор инструментов и выполняет команды, контролирующие скорость и перемещения (обычно G-Code).
  • Инструменты выбираются в соответствии с требованиями Рабочих Операций.
  • Операции обработки задаются с использованием, например, Контуров и Вырезов. Эти Операции обработки используют внутренний диалект FreeCAD G-Code, независимо от станка с ЧПУ.
  • Экспортируйте задание в g-код, соответствующий вашему станку. Этот шаг называется «постобработка», доступны разные постпроцессоры.

Основные понятия

Верстак Path генерирует G-код, определяющий траектории движения фрезы, необходимую для фрезерования проекта, представленного 3D-моделью на FreeCAD диалекте G-Кода, который впоследствии переводится на соответствующий диалект для целевого контроллера ЧПУ путем выбора соответствующего постпроцессора.

G-код генерируется из директив и операций, содержащихся в Задании на обработку. Job Workflow перечисляет их в порядке их выполнения. Список заполняется путем добавления Path Operations, Path Dressups, Path Partial Commands и Path Modifications из Path меню или кнопок GUI.

Верстак Path предоставляет диспетчер инструментов (библиотека и таблица инструментов), инструменты проверки G-кода и симуляции обработки. Он содержит постпроцессор и позволяет импортировать и экспортировать шаблоны заданий.

Верстак Path имеет внешние зависимости, включая:

  1. Единицы измерения 3D-модели FreeCAD определены в Правка → Предпочтения → Общие → Настройки единиц измерения на вкладке Единицы Измерения. Конфигурация Postprocessor определяет единицы измерения результирующего G-кода.
  2. Путь к файлу макроса и геометрические допуски определяются на вкладке Правка → Параметры → Путь → Параметры задания.
  3. Цвета определяются на вкладке Правка → Настройки → Путь → Цвета пути.
  4. Содержащие параметры тега определены на вкладке Правка → Настройки → Путь → Dressups.
  5. То, что качество базовой 3D-модели соответствует требованиям Path WB, проходит проверку геометрии.

Ограничения

Некоторые текущие ограничения, о которых вам следует знать:

  • Большинство инструментов Path Tools не являются настоящими 3D-инструментами, поскольку поддерживают только 2.5D-обработку. Это означает, что они фактически обрабатывают плоскую форму, но могут вырезать ее до заданной глубины. Однако есть два инструмента, которые создают истинные трехмерные пути: Path 3DPocket.svg 3D Pocket и Path 3DSurface.svg 3D Surface (он все еще является экспериментальной функцией по состоянию на ноябрь 2020 г.).
  • Большая часть верстака Path разработана для простых, стандартных 3-осевых (xyz) фрезерных станков и роутеров с ЧПУ, но операции для токарной обработки находятся в разработке в версии 0.19_pre.
  • Большинство операций в верстаке Path будут создавать пути, основанные лишь на стандартной концевой фрезе, независимо от типа инструмента , назначенного в данном контроллере инструмента, за исключением Path Engrave.svg Engrave и Path 3DSurface.svg 3D Surface.
  • Операции в верстаке Path не знают о зажимных механизмах, используемых для закрепления заготовки на вашем станке. Следовательно, внимательно просмотрите и симулируйте пути, которые вы создаете, перед отправкой кода на ваш станок. При необходимости смоделируйте свои зажимные механизмы в FreeCAD, чтобы лучше проверять создаваемые пути. Ищите возможные столкновения с зажимами или другими препятствиями на пути движения инструмента.

Единицы измерения

Обработка единиц измерения в Path может быть запутанной. Есть несколько моментов, которые нужно понять:

  1. Базовыми единицами FreeCAD для длины и времени являются «мм» и «с» соответственно. Скорость, таким образом, измеряется в «мм/с». Это внутренний формат хранения FreeCAD
  2. В схеме единиц измерения по умолчанию используются единицы измерения по умолчанию. Если вы используете схему по умолчанию и вводите скорость подачи без единиц измерения, она будет восприниматься как «мм/с»
  3. Большинство станков с ЧПУ предполагает, что скорость подачи будет в «мм/мин» или «дюйм/мин». Большинство постпроцессоров автоматически конвертируют единицы при генерации gcode.

Схемы:

  1. Изменение схемы в настройках изменяет строку по умолчанию для полей ввода. Если вы являетесь пользователем Path и предпочитаете проектировать в метрической системе настоятельно рекомендуется использовать схему «Метрические мелкие детали и ЧПУ». Если вы проектируете в единицах США, то будет работать Imperial Decimal и Building US
  2. Изменение предпочитаемой схемы объекта не повлияет на вывод, но поможет избежать ошибок ввода

Вывод:

  1. Генерация правильной единицы измерения в выходном файле является обязанностью постпроцессора и выполняется только в это время.
  2. Единица измерения на выходе полностью не зависимо от выбранной схемы единиц измерения
  3. Постпроцессоры выдают либо метрический (G21) выход, либо Imperial (G20), либо настраиваемый.
  4. Конфигурируемые постпроцессоры по умолчанию для метрики (G21)
  5. Если вы хотите, чтобы ваш настраиваемый постпроцессор выводил имперский gcode (G20), задайте правильный аргумент в конфигурации вывода задания (т.е. --дюймы для linuxcnc). Это может быть сохранено в шаблоне работы и установлено в качестве шаблона по умолчанию, чтобы сделать его автоматическим для всех будущих работ

Проверка траектории:

  1. Если вы используете инструмент Path Inspect для просмотра g-кода, вы увидите подачу в «мм/с», потому что он не подвергается пост-обработке

Высоты и глубины

Многие из команд имеют различные высоты и глубины:

Path-DepthsAndHeights.gif

Визуальная справка по свойствам Depth (установки)

Команды

Некоторые команды являются экспериментальными и недоступны по умолчанию. Для их включения, см. Path experimental.

Команды проекта

  • Path Job.svg Проект: Создаёт новую программу для ЧПУ

Инструментальные команды

  • Path Inspect.svg Inspect G-code: Показывает G-код для проверки
  • Path Simulator.svg CAM Simulator: Показывает операции фрезерной обработки, эмулируя станок
  • Path SelectLoop.svg Finish Selecting Loop: Завершает петлю между двумя выбранными кромками.

Основные операции

  • Path Profile.svg Profile: Создает операцию обработки профиля для всей модели или для одной или нескольких выбранных граней или кромок. introduced in version 0.19
  • Path Pocket Shape.svg Pocket Shape: Создает операцию обработки кармана для одного или нескольких выбранных карманов.
  • Path Drilling.svg Drilling: Создает цикл сверления.
  • Path Face.svg Face: Создает путь обработки поверхности.
  • Path Helix.svg Helix: Создает спиральную траекторию.
  • Path Adaptive.svg Adaptive: Creates an adaptive clearing and profiling operation.
  • Path Engrave.svg Engrave: Creates an engraving path.

3D Operations

Path Dressup

  • Path DressupTag.svg Tag Dressup: Adds a holding tag dressup modification to a selected path.

Дополнительные команды

  • Path Comment.svg Comment: Вставляет комментарий в G-код.
  • Path Stop.svg Stop: Вставить команду полной остановки станка.
  • Path Custom.svg Custom: Вставляет пользовательский G-код.
  • Path Shape.svg From Shape: Создаёт траекторию из существующего объекта Part Experimental.

Модификация траектории

  • Path Copy.svg Copy the operation in the job: Создает параметрическую копию выбранного объекта траектории.
  • Path Array.svg Array: Создает массив путем дублирования выбранного участка траектории.
  • Path SimpleCopy.svg Simple Copy: Создает непараметрическую копию выбранного объекта траектории.

Miscellaneous

Obsolete

ToolBit architecture

Управляйте инструментами и библиотекой инструментов. Основано на архитектуре ToolBit. introduced in version 0.19

Прочее

  • Path FAQ: The Path Workbench shares many concepts with other CAM software packages but has its own peculiarities. If something seems wrong this is a good place to start.
  • Path SetupSheet: You can use a SetupSheet to customize how various property values for operations are calculated.
  • Path Postprocessor Customization: If you have a special machine which cannot use one of the available post-processors you may need to write your own post-processor.
  • Path fourth axis: Experimental four axis milling.
  • Path Development Roadmap: Read this if you are a developer and want to contribute to Path.

Настройки

Скриптование

Смотри Создание сценариев (скриптов) модуля Part

Руководства

Видео