Path Lignes de niveau

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Path Waterline and the translation is 100% complete.
Other languages:
English • ‎français • ‎italiano • ‎polski • ‎português do Brasil
Il s'agit d'une fonctionnalité expérimentale inachevée. Pour utiliser cette fonctionnalité d'activation expérimentale, vous devez activer les fonctionnalités expérimentales

This documentation is not finished. Please help and contribute documentation.

GuiCommand model explains how commands should be documented. Browse Category:UnfinishedDocu to see more incomplete pages like this one. See Category:Command Reference for all commands.

See WikiPages to learn about editing the wiki pages, and go to Help FreeCAD to learn about other ways in which you can contribute.

Arrow-left.svg Page précédente : Path Surface.svg Surface
Page suivante : Limitation de zones Path DressupPathBoundary.svg Arrow-right.svg

Path Waterline.svg Path Lignes de niveau

Emplacement du menu
Path → Waterline
Ateliers
Path
Raccourci par défaut
Aucun
Introduit dans la version
0.19
Voir aussi
Aucun

Description

Cet outil crée une nouvelle opération Lignes de niveau. A partir de 0.19_pre, l'opération Lignes de niveau fonctionne sur l'ensemble du modèle pour générer le G-code de la tâche. Actuellement, dans les paramètres de l'opération, il n'y a pas de fonctionnalité pour sélectionner des zones, des faces ou des régions spécifiques du modèle.

L'opération Lignes de niveau a deux algorithmes : OCL Drop Cutter et Experimental.

  • L'algorithme OCL Drop Cutter s'interface avec OCL.pyd, un module Open Source tiers intitulé OpenCamLib qui génère des chemins d'outils à partir d'un modèle 3D. OpenCamLib n'est pas intégré directement dans FreeCAD.
  • L'algorithme expérimental utilise la classe intégrée Path.Area().

Remarque : Pour utiliser l'opération Lignes de niveau, vous devez :

  1. Installer correctement OpenCamLib.
  2. Activez les Fonctions expérimentales de l'atelier Path.
  3. Vérifiez Édition → Préférences... → Path → Advanced → Enable OCL dependent features.

Utilisation

Les instructions d'utilisation pour plusieurs variantes de Path Lignes de niveau sont présentées ici.

Opération de base

  1. Appuyez sur l'icône Path Waterline.svg Waterline ou sélectionnez l'outil Waterline dans le menu Path.
  2. Sélectionnez le contrôleur d'outil pour l'opération dans la fenêtre contextuelle de dialogue du contrôleur d'outil.
  3. Ajustez les profondeurs d'opération selon les besoins dans l'onglet Profondeurs : Profondeur de début, Profondeur de fin, Descente.
  4. Effectuez des ajustements dans l'onglet Heights si nécessaire.
  5. Configurez les paramètres dans l'onglet Operations en fonction de l'algorithme sélectionné :
    1. OCL Dropcutter
      1. Choisissez la BoundBox : Stock ou BaseBoundBox.
      2. Définissez le mode de calque : passe unique ou multi-pas.
      3. Définissez l'intervalle d'échantillonnage utilisé pour l'analyse OCL.
    2. Expérimental
      1. Choisissez la BoundBox : Stock ou BaseBoundBox.
      2. Définissez le mode de calque : passe unique ou multi-pas.
      3. Définissez le motif de coupe si vous souhaitez effacer chaque couche.
      4. Définissez l'ajustement des limites (allocation de matière).
  6. Si vous souhaitez prévisualiser le résultat avant d'accepter les paramètres, cliquez sur Apply
  7. Cliquez sur le bouton OK pour confirmer et générer des chemins.

Pour obtenir des effets différents ou plus complexes, définissez des propriétés d'opération supplémentaires dans l'onglet Data de la vue Propriétés pour l'opération.

Remarques sur l'algorithme expérimental
  • Il ne gère pas correctement les surplombs.
  • Il ne renvoie que les chemins pour une fraise de type fraise en bout (outil).
  • Il peut ne pas capturer correctement toutes les caractéristiques intérieures.
  • C'est juste ça, expérimental, et pas prêt pour l'intégration grand public. Veuillez inspecter les chemins avec le Path Simulator.svg Path Simulateur d'usinage ou d'autres outils d'inspection g-code tiers, avant de couper avec votre machine.

Formes d'outils (de coupe) disponibles

Lorsque vous utilisez l'algorithme OCL Dropcutter , l'opération Lignes de niveau utilise OpenCamLib [OCL] pour extraire les chemins de la base de la pièce. En tant que tel, une traduction d'outil est nécessaire entre le contrôleur d'outil FreeCAD et OCL afin de terminer l'analyse avec la forme d'outil (cutter) choisie. Ces formes d'outils sont (doivent être) respectées et disponibles pour le Dropcutter OCL tant que les formes d'outils intégrées sont utilisées, qu'il s'agisse d'outils Legacy ou ToolBit:

  • Fraise en bout
  • Fraise à boule
  • Fraise en bout de nez
  • Chanfrein
  • Graveur

Remarques additionnelles

  • Si vous choisissez d'exécuter le simulateur de chemin, Path Simulator.svg Path Simulateur d'usinage dans l'atelier Path, vous pourriez ne pas voir d'enlèvement de matière spécifique à la forme de l'outil. Prudence donc. Un petit travail d'essai utilisant de la mousse ou un autre matériau très peu dense est recommandé pour vérifier que les chemins sont corrects avec le contrôleur d'outil sélectionné.
  • À compter de mai 2020, seule la fraise en bout dispose de tout type de test pour déterminer l'exactitude de la traduction des paramètres de l'outil FreeCAD vers OCL. Veuillez publier tout commentaire concernant une utilisation non-finale dans la section Path/CAM des forums FreeCAD.

Propriétés

Remarque : toutes ces propriétés ne sont pas disponibles dans l'éditeur de fenêtre de tâches. Certaines ne sont accessibles que dans l'onglet Données du panneau Vue de propriétés pour cette opération.

Base

Remarque : il est conseillé de ne pas modifier la propriété Placement des opérations de chemin. Déplacez ou faites pivoter le modèle de tâche de chemin selon vos besoins.

  • DonnéesPlacement : placement global [position et rotation] de l'objet - par rapport à l'origine (ou à l'origine du conteneur d'objet parent)
    • DonnéesAngle : Angle en degrés appliqué à la rotation de l'objet autour de la valeur de la propriété Axis
    • DonnéesAxis : Axe (un ou plusieurs) autour duquel faire pivoter l'objet, défini dans les sous-propriétés : x, y, z
      • DonnéesX : valeur de l'axe x
      • DonnéesY : valeur de l'axe y
      • DonnéesZ : valeur de l'axe z
    • DonnéesPosition : Position de l'objet, définie dans les sous-propriétés : x, y, z - par rapport à l'origine (ou à l'origine du conteneur de l'objet parent)
      • DonnéesX : x valeur de distance
      • DonnéesY : valeur de distance y
      • DonnéesZ : valeur de distance z
  • DonnéesLabel : nom de l'objet fourni par l'utilisateur (UTF-8)

Clearing Options

  • DonnéesAlgorithm : bibliothèque à utiliser pour générer le chemin
  • DonnéesBoundBox : l'opération doit-elle être limitée par l'objet stock ou par la boîte englobante de l'objet de base
  • DonnéesClear Last Layer : paramétrez pour effacer la dernière couche dans l'opération `Multi-pass`.
  • DonnéesCut Mode : La direction dans laquelle le parcours d'outil doit aller autour de la pièce : Climb (ClockWise) ou Conventionnel (CounterClockWise)
  • DonnéesCut Pattern : motif d'effacement à utiliser
  • DonnéesDepth Offset :
  • DonnéesIgnorer Outer Above :
  • DonnéesLayer Mode : mode de complétion de l'opération: simple ou multi-passes
  • DonnéesStep Over :

Depth

  • DonnéesClearance Height : hauteur nécessaire pour eviter les pinces et les obstructions.
  • DonnéesFinal Depth : profondeur finale de l'outil - valeur la plus basse de Z.
  • DonnéesSafe Height : seuil supérieur duquel les mouvements rapides sont autorisés.
  • DonnéesStart Depth : profondeur initiale de l'outil - première profondeur de coupe en Z.
  • DonnéesStep Down : abaissement incrémentiel de l'outil.

Path

  • DonnéesActive : mettre à Falsepour empêcher l'opération de générer du code.
  • DonnéesBase : géométrie de base pour cette opération.
  • DonnéesComment : commentaire facultatif pour cette opération.
  • DonnéesCoolant Mode :
  • DonnéesCycle Time :
  • DonnéesTool Controller : définit le contrôleur d'outil utilisé dans l'opération.
  • DonnéesUser Label : étiquette attribuée par l'utilisateur.

Start Point

  • DonnéesStart Point : point de départ personnalisé pour le chemin de cette opération.
    • DonnéesX : valeur de distance x.
    • DonnéesY : valeur de distance y.
    • DonnéesZ : valeur de distance z.
  • DonnéesUse Start Point : Mis à True, si vous spécifiez manuellement un point de départ.

Disposition de l'éditeur de fenêtre de tâches

Les descriptions des paramètres sont fournies dans la liste des propriétés ci-dessus. Cette section est simplement une représentation des paramètres de l’éditeur de fenêtres pour l’opération.

Localisation de la base

  • Add : ajoute les éléments sélectionnés qui doivent être la base du ou des chemins.
  • Remove : supprime le ou les éléments sélectionnés dans la liste emplacement de base.
  • Edit : efface tous les éléments de la liste d'emplacement de base.

Profondeurs

  • DonnéesStart Depth
  • DonnéesFinal Depth
  • DonnéesStep Down

Hauteurs

  • DonnéesSafe Height
  • DonnéesClearance Height

Opération

  • DonnéesTool Controller
  • DonnéesCoolant Mode
  • DonnéesAlgorithm
  • DonnéesBoundBox
  • DonnéesLayer Mode
  • DonnéesCut Pattern~
  • DonnéesBoundary Adjustment~
  • DonnéesSample Interval~

~ La visibilité change avec d'autres paramètres.

Ressources


Arrow-left.svg Page précédente : Path Surface.svg Surface
Page suivante : Limitation de zones Path DressupPathBoundary.svg Arrow-right.svg