Path Sfacciatura 3D

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Path Surface and the translation is 3% complete.
Outdated translations are marked like this.
Other languages:
English • ‎français • ‎italiano • ‎polski • ‎português do Brasil • ‎română • ‎русский
This is an unfinished experimental feature. Enable Experimental Features

This documentation is not finished. Please help and contribute documentation.

GuiCommand model explains how commands should be documented. Browse Category:UnfinishedDocu to see more incomplete pages like this one. See Category:Command Reference for all commands.

See WikiPages to learn about editing the wiki pages, and go to Help FreeCAD to learn about other ways in which you can contribute.

Arrow-left.svg Previous: Path Pocket 3D.svg Pocket 3D
Next: Waterline Path Waterline.svg Arrow-right.svg

Descrizione

Questo strumento crea una nuova operazione di Sfacciatura 3D. Un'operazione di sfacciatura 3D utilizza l'intera superficie superiore del Modello 3D per generare il codice G per la lavorazione.

The Path Surface.svg 3D Surface operation is also capable of generating basic rotational 3D surfacing paths. The rotational capabilities are limited to the entire model, and do not allow for specific faces or regions to be isolated. The rotational paths are also limited to line cut patterns.

Lo strumento Sfacciatura 3D si interfaccia con OCL.pyd, un modulo Open Source di terze parti denominato OpenCamLib, che genera percorsi utensile da un modello 3D. OpenCamLib non è integrato direttamente in FreeCAD per garantire che la sua licenza non sia violata. Richiede che Experimental Features siano abilitate.

Note: In order to use the 3D Surface operation you must:

  1. Properly install OpenCamLib.
  2. Enable Experimental Features for the Path Workbench.
  3. Check Edit → Preferences... → Path → Advanced → Enable OCL dependent features.

Usage

Usage instructions for multiple variations of the 3D Surface operation are presented here.

Basic Operation

  1. Premere il pulsante Path Surface.svg Sfacciatura 3D.
  2. Selezionare il controller dello strumento l'operazione dalla finestra pop up di dialogo del controller dello strumento.
  3. Impostare la profondità di finitura Finish Depth.
  4. Selezionare tra Dropcutter e Waterline per l'algoritmo dello strumento.
  5. Applica, e poi OK per confermare.

To achieve different, or more complex, effects, adjust additional operation properties within the Data tab of the Properties View for the operation.

Rotational Scans (4th-axis)

  1. Initiate a Basic Operation as described above and set the Scan Type to Rotational.
  2. Note: Face selection is unavailable for Rotational scans, so changes to Base Geometry are ignored.
  3. Locate the Data tab and Properties View for the new 3D Surface operation. A Rotation section should be available with additional properties to adjust, listed below.
    It is recommended that you set the desired rotation properties all at once before recomputing. This is done by clicking the ENTER key immediately after changing a property setting. This process will allow you to change and save multiple properties before recomputing the operation.
  4. Adjust the following settings as needed:
    • Set DatiCutter Tilt to the offset index(angle) [0-90]. (Used for ball mill cutters)
    • Change DatiDrop Cutter Dir to the axis of travel for the cutter(spindle).
    • Change DatiDrop Cutter Extra Offset to extend the BoundBox in the X and Y directions.
    • Set DatiRotation Axis to the desired axis.
    • Adjust DatiStart Index to start index(angle) [0-360].
    • Adjust DatiStop Index to stop index(angle) [0-360].
  5. Click the View-refresh.svg Recompute icon in the tool bar.
  6. Wait for the results...
Notes About Rotational Scans
  • Rotational scans require much more time and processing than Planar scans. Factors affecting processing time include: Sample Interval, Step Over, tool diameter, and model size. Again, rotational scans can take a long time. Some might take 3, 5 or 10 minutes or longer.
  • For time purposes, it is better that you not recompute a rotational scan after every property change; rather, consider one of the following:
    • use the ' change all settings with ENTER key ' technique mentioned in Step 2 above, then View-refresh.svg Recompute the operation.
    • deactivate the operation with the Path OpActiveToggle.svg Active toggle tool, make your changes to the operation's properties, then click the Path OpActiveToggle.svg Active icon again to re-activate the operation - which triggers a recompute internally.
  • The Path Surface.svg 3D Surface operation is still considered an experimental feature as of 2019-06-25. As such, it may contain a few bugs yet to be clearly identified. Please report bugs and issues in the FreeCAD Path/CAM Forum.
  • The built in Path Simulator.svg CAM Simulator does NOT support 4th-axis simulation. You will need to use a third party simulator to inspect or verify paths visually. See the Resources section below for suggestions.
  • You will likely see red rotational lines around your model in the viewport. This is normal in FreeCAD for the time being.
Notes About Scans of complex models

Excessively long processing times (longer than 10 minutes) can occur when processing large complex models. In addition to the factors already mentioned the following steps could help identify potential causes and solutions.

Low Memory
Check how much memory is available while the scan is running using a tool such as the Windows Task Manager, Memory tab. If more than 90% of memory is consistently being used then a small Linear Deflection parameter could be generating a mesh that is too large for the available memory.
To confirm this ...

  1. Create a new Path Surface.svg 3D Surface operation.
  2. Switch to the Model tab and increase the DatiLinear Deflection value. For example change from 2.5um to 20um
  3. Switch back to the Tasks tab to complete setting up the operation.
  4. Click OK button to confirm and generate paths.

To make this value the default for all new Path Surface.svg 3D Surface operations, change the GeometryTolerance parameter.
Tools → Edit Parameters ... → Preferences → Mod → Path → GeometryTolerance .
Note as of version 0.19 the DatiLinear Deflection default = GeometryTolerance / 4

Invalid Geometry
If a model contains invalid geometry the scanning time can increase significantly. A model can be checked using the Check Geometry function in Workbench Part.svgPart Workbench.
To run the tool:

  1. Switch to the Workbench Part.svgPart Workbench and select the model to check
  2. Click on the Part CheckGeometry.svg Part CheckGeometry button available in the Part workbench toolbar OR use the Part → Part CheckGeometry.svg Check geometry entry from the top menu.
  3. Click the Run Check button and review the results.

If the results includes items like BOPAlgo SelfIntersect then the geometry is invalid and should be corrected by adjusting the model.
(Hint: Boolean operations and Loft commands can sometimes introduce Self Intersections)

Available Tool (Cutter) Shapes

This 3D Surface op currently uses OpenCamLib to extract paths from the part base. As such, a tool setting translation is required between the FreeCAD tool controller and OCL in order to complete the scan with your chosen tool(cutter) shape.

These tool shapes are respected and available for this 3D Surface operation:

  • End mill
  • Ball end mill
  • Bull nose end mill
  • Chamfer bit
  • Engraver

Should you choose to run the path simulator in the Path Workbench, it only uses the standard end mill to simulate paths. Therefore, you will not see tool-shape-specific material removal. Material removal is shown using the end mill shape.

NOTE: As of May 2019, only the End Mill has any type of testing to determine accuracy of the FreeCAD-to-OCL tool settings translation. Please post any feedback for non-end-mill usage to the Path/CAM section in the FreeCAD forums.

Properties: Version 0.19

Note : Not all of these Properties are available in the Task Window Editor. Some are only accessible in the Data tab of the Properties View panel for this Operation.

Base

Note: It is suggested that you do not edit the Placement property of path operations. Rather, move or rotate the Path Job model as needed.

  • DatiPlacement: Overall placement[position and rotation] of the object - with respect to the origin (or origin of parent object container)
    • DatiAngle: Angle in degrees applied to rotation of the object around Axis property value
    • DatiAxis: Axis(one or multiple) around which to rotate the object, set in sub-properties: x, y, z
      • DatiX: x axis value
      • DatiY: y axis value
      • DatiZ: z axis value
    • DatiPosition: Position of the object, set in sub-properties: x, y, z - with respect to the origin (or origin of parent object container)
      • DatiX: x distance value
      • DatiY: y distance value
      • DatiZ: z distance value
  • DatiLabel: User-provided name of the object (UTF-8)

Clearing Options

  • DatiBound Box: Should the operation be limited by the stock object or by the bounding box of the base object
  • DatiCut Mode: The direction that the toolpath should go around the part: Climb(ClockWise) or Conventional(CounterClockWise)
  • DatiCut Pattern: Clearing pattern to use
  • DatiCut Pattern Reversed: Reverse the cut order of the stepover paths. For circular cut patterns, begin at the outside and work toward the center
  • DatiDepth Offset: Z-axis offset from the surface of the object
  • DatiLayer Mode: The completion mode for the operation: single or multi-pass
  • DatiPattern Center At: Choose location of the center point for starting the cut pattern
  • DatiPattern Center Custom: Set the start point for the cut pattern
  • DatiProfile Edges: Profile the edges of the selection
  • DatiSample Interval: The Sample Interval. Small values cause long wait times
  • DatiStep Over: Step over percentage of the drop cutter path

Depth

  • DatiClearance Height: The height needed to clear clamps and obstructions
  • DatiFinal Depth: Final Depth of Tool- lowest value in Z
  • DatiSafe Height: The above which Rapid motions are allowed.
  • DatiStart Depth: Starting Depth of Tool- first cut depth in Z
  • DatiStep Down: Incremental Step Down of Tool

Mesh Conversion

  • DatiAngular Deflection: Smaller values yield a finer, more accurate mesh. Smaller values increase processing time a lot
  • DatiLinear Deflection: Smaller values yield a finer, more accurate mesh. Smaller values do not increase processing time much but can increase memory comsumption

Optimization

  • DatiCircular Use G2 G3: Convert co-planar arcs to G2/G3 gcode commands for `Circular` and `CircularZigZag` cut patterns
  • DatiGap Sizes: Feedback: three smallest gaps identified in the path geometry
  • DatiGap Threshold: Collinear and co-radial artifact gaps that are smaller than this threshold are closed in the path
  • DatiOptimize Linear Paths: Enable optimization of linear paths (co-linear points). Removes unnecessary co-linear points from G-Code output
  • DatiOptimize Step Over Transitions: Enable separate optimization of transitions between, and breaks within, each step over path

Path

  • DatiActive: make False, to prevent operation from generating code
  • DatiBase: The base geometry for this operation
  • DatiComment: An optional comment for this Operation
  • DatiCoolant Mode: Coolant mode for this operation
  • DatiCycle Time: Operations Cycle Time Estimation
  • DatiTool Controller: Defines the Tool controller used in the Operation
  • DatiUser Label: User assigned label

Rotation

  • DatiCutter Tilt: Set the cutter (spindle) tilt angle.
  • DatiDrop Cutter Dir: The direction along which dropcutter lines are created
  • DatiDrop Cutter Extra Offset: Additional offset to the selected bounding box - use sub-properties to set values
    • DatiX: x distance value
    • DatiY: y distance value
    • DatiZ: z distance value
  • DatiRotation Axis: Set the axis for model rotation.
  • DatiStart Index: Start index(angle) for rotation
  • DatiStop Index: Stop index(angle) for rotation

Selected Geometry Settings

  • DatiAvoid Last X Faces: Avoid cutting the last 'N' faces in the Base Geometry list of selected faces
  • DatiAvoid Last X Internal Features: Do not cut internal features on avoided faces
  • DatiBoundary Adjustment: Positive values push the cutter toward, or beyond, the boundary. Negative values retract the cutter away from the boundary
  • DatiBoundary Enforcement: If true, the cutter will remain inside the boundaries of the model or selected face(s)
  • DatiHandle Multiple Features: Choose how to process multiple Base Geometry features
  • DatiInternal Features Adjustment: Positive values push the cutter toward, or into, the feature. Negative values retract the cutter away from the feature
  • DatiInternal Features Cut: Cut internal feature areas within a larger selected face

Start Point

  • DatiStart Point: The custom start point for the path of this operation, set in sub-properties: x, y, z
    • DatiX: x axis value
    • DatiY: y axis value
    • DatiZ: z axis value
  • DatiUse Start Point: Make True, if specifying a Start Point

Surface

  • DatiScan Type: Planar: Flat, 3D surface scan. Rotational: 4th-axis rotational scan.

Waste

  • DatiIgnore Waste: Ignore areas that proceed below specified depth.
  • DatiIgnore Waste Depth: Depth used to identify waste areas to ignore.
  • DatiRelease From Waste: Cut through waste to depth at model edge, releasing the model.

Tasks Window Editor Layout

Descriptions for the settings are provided in the Properties list above. This section is simply a layout map of the settings in the window editor for the Operation.

Base Location

  • Base Geometry import selection: Use this list to select Base Geometry to be imported from the selected, existing operation
  • Import: imports the selected operation's Base Geometry into the current operations Base Geometry list
  • Base Geometry list for current operation: List of Base Geometry for current operation, if any selected
  • Add: adds selected element(s) which should be the base(s) for the path(s)
  • Remove: remove the selected item(s) in the Base Location list
  • Edit: clear all items in the Base Location list

Depth

  • DatiStart Depth
  • DatiFinal Depth
  • DatiStep Down

Height

  • DatiSafe Height
  • DatiClearance Height

Operation

  • DatiTool Controller
  • DatiCoolant Mode
  • DatiBoundBox
  • DatiScan Type
  • DatiLayer Mode
  • DatiBoundBox extra offset X
  • DatiBoundBox extra offset Y
  • DatiDrop Cutter Direction
  • DatiDepth Offset
  • DatiStep Over
  • DatiSample Interval
  • DatiOptimize Output Enabled
  • DatiUse Start Point
  • DatiBoundary Enforcement
  • DatiOptimize Linear Paths

Resources


Arrow-left.svg Previous: Path Pocket 3D.svg Pocket 3D
Next: Waterline Path Waterline.svg Arrow-right.svg