Path Rainure

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Path Slot and the translation is 100% complete.
Other languages:
English • ‎français • ‎italiano
Il s'agit d'une fonctionnalité expérimentale inachevée. Path Fonctions expérimentales


Arrow-left.svg Page précédente : Path Pocket.svg Poche
Page suivante : Perçage Path Drilling.svg Arrow-right.svg


Path Slot.svg Path Rainure

Emplacement du menu
Path → Slot
Ateliers
Path
Raccourci par défaut
Introduit dans la version
0.19
Voir aussi

Description

Cet outil crée une opération de rainurage simple en utilisant différentes méthodes de saisie. Les entrées comprennent:

  • sélection d'une ou plusieurs faces ou arêtes.
  • sélection de deux sommets.
  • saisie de deux points personnalisés.

L'objet Path Rainure est conçu pour faire partie d'une Path Job.svg Path Tâche.

Utilisation

  1. Sélectionnez la géométrie de référence sur le modèle:.
    • une ou plusieurs faces ou arêtes.
    • deux sommets.
    • rien pour utiliser deux points personnalisés entrés dans la vue des propriétés de l'onglet Données: Point1 personnalisé et Point2 personnalisé.
  2. Appelez la commande Slot en utilisant plusieurs méthodes:
    • En appuyant sur le bouton Path Slot.svg Slot dans la barre d'outils.
    • En utilisant la PathPath Slot.svg Slot dans le menu supérieur.
  3. Ajustez les propriétés souhaitées. Les descriptions des propriétés disponibles se trouvent ci-dessous.

Notes d'utilisation

  • Tous les emplacements:
    • Le début et la fin d'un chemin d'emplacement peuvent être étendus ou raccourcis. Utilisez les propriétés `Extend Path Start` et `Extend Path End`.
    • Utilisez la propriété `Layer Mode` pour couper la fente en mode `Single-pass` à la profondeur finale, ou en mode `Multi-pass` en utilisant la propriété `Step Down` disponible.
    • Activez la propriété `Reverse Direction` pour inverser la direction du chemin de coupe.
  • Fentes linéaires:
    • Actuellement, il n'est pas possible de décaler les fentes linéaires latéralement (parallèlement à la trajectoire de déplacement). Exemple: Supposons que vous ayez un diamètre d'outil inférieur à la largeur de la zone de rainure que vous effacez. Le comportement actuel de cette opération est de créer un chemin de fente unique au centre de la fente désignée, ce qui aura pour résultat que la zone de fente ne sera pas complètement effacée. Certains utilisateurs souhaiteraient que l'opération crée plusieurs chemins décalés latéralement pour effacer toute la zone de logement; cette opération n'est pas prévue, alors - utilisez l'opération Pocket pour un tel effacement.
    • Créez une fente linéaire personnalisée en utilisant les propriétés `Custom Point1` et `Custom Point2` sans sélection de géométrie. Exemple: Lancez une opération de slot dans l'interface graphique et cliquez sur `OK` pour enregistrer. Recherchez et modifiez maintenant les propriétés `Custom Point1` et `Custom Point2` dans l'onglet Data de l'opération Slot nouvellement créée. Recalculez l'opération pour mettre à jour le chemin.
  • Arc/fentes circulaires:
    • Création de rainures en arc/circulaire
      1. Vous devrez sélectionner un arc inférieur de la fente. Cela produira un chemin directement sur l'arête de l'arc que vous avez sélectionnée.
      2. Vous devrez ensuite éditer la propriété `Extend Radius` dans l'onglet Data de l'opération. À l'aide de l'éditeur d'expression, définissez-le sur `OpToolDiameter / 2.0` ou sur la version négative `OpToolDiameter / -2.0` selon vos besoins, selon que vous avez sélectionné l'arc intérieur ou extérieur de l'emplacement.
      3. Recalculez l'opération.
      4. Gardez à l'esprit que si le diamètre de la fraise n'est pas égal à la largeur de la fente, le chemin ne sera pas au bon endroit. Dans ce cas, ajustez la valeur de la propriété `Extend Radius` mentionnée ci-dessus.
    • Actuellement, les utilisateurs ne peuvent pas créer un arc/chemin circulaire personnalisé. Une troisième propriété `Custom Center` devra être ajoutée, ainsi que des modifications supplémentaires à la base de code.

Propriétés

Remarque : toutes ces propriétés ne sont pas disponibles dans l'éditeur de fenêtre de tâches. Certaines ne sont accessibles que dans l'onglet Données du panneau Vue de propriétés pour cette opération.

Base

Remarque: il est conseillé de ne pas modifier la propriété Placement des opérations de chemin. Déplacez ou faites pivoter le modèle de tâche de chemin selon vos besoins.

  • DonnéesPlacement: placement global [position et rotation] de l'objet - par rapport à l'origine (ou à l'origine du conteneur d'objet parent)
    • DonnéesAngle: angle en degrés appliqué à la rotation de l'objet autour de la valeur de la propriété Axis
    • DonnéesAxis: axe(s) autour duquel faire pivoter l'objet, défini dans les sous-propriétés: x, y, z
      • DonnéesX: valeur de l'axe x
      • DonnéesY: valeur de l'axe y
      • DonnéesZ: valeur de l'axe z
    • DonnéesPosition: position de l'objet, définie dans les sous-propriétés: x, y, z - par rapport à l'origine (ou à l'origine du conteneur d'objet parent)
      • DonnéesX: valeur de distance x
      • DonnéesY: valeur de distance y
      • DonnéesZ: valeur de distance z
  • DonnéesLabel: nom d'objet fourni par l'utilisateur (UTF-8)

Profondeur

  • DonnéesClearance Height: hauteur nécessaire pour supprimer les pinces et les obstructions.
  • DonnéesFinal Depth: profondeur finale de l'outil - valeur la plus basse de Z.
  • DonnéesFinish Depth: le maximum de matériau retiré lors du passage final. La hauteur (épaisseur) du dernier niveau de coupe - "pour une meilleure finition".
  • DonnéesSafe Height: hauteur au-dessus de laquelle les mouvements rapides sont autorisés. (Hauteur de sécurité rapide entre les sites).
  • DonnéesStart Depth: profondeur de départ de l'outil - Profondeur de la première coupe en Z.
  • DonnéesStep Down: abaissement incrémental de l'outil pendant l'opération.
Path-DepthsAndHeights.gif

Référence visuelle pour les propriétés de profondeur (paramètres)


Tracé

  • DonnéesActive: mettre à False pour empêcher l'opération de générer du code.
  • DonnéesBase: géométrie de base pour cette opération.
  • DonnéesComment: commentaire facultatif pour cette opération.
  • DonnéesCoolant Mode: mode de refroidissement pour cette opération.
  • DataCycle Time: estimation du temps de cycle pour cette opération.
  • DonnéesTool Controller: définit le contrôleur d'outil utilisé dans l'opération.
  • DonnéesUser Label: étiquette attribuée par l'utilisateur.


Rainure

  • DonnéesCustom Point1: entrez un point de départ personnalisé pour le chemin de la rainure.
  • DonnéesCustom Point2: entrez un point de fin personnalisé pour le chemin de de la rainure.
  • DonnéesCut Pattern: définissez le motif de nettoyage géométrique à utiliser pour l'opération.
  • DonnéesExtend Path End: positif étend la fin du chemin, négatif raccourcit.
  • DonnéesExtend Path Start: positif étend le début du chemin, négatif raccourcit.
  • DonnéesExtend Radius: pour les arcs/arêtes circulaires, décalez le rayon de la trajectoire.
  • DonnéesLayer Mode: terminez l'opération en une seule passe en profondeur ou en plusieurs passes jusqu'à la profondeur finale.
  • DonnéesPath Orientation: choisissez l'orientation du chemin en fonction de la ou des entités sélectionnées.
  • DonnéesReference1: choisissez le point à utiliser sur la première entité sélectionnée.
  • DonnéesReference2: choisissez le point à utiliser sur la deuxième entité sélectionnée.
  • DonnéesReverse Direction: activez cette option pour inverser la direction de coupe du chemin de la rainure.

Point de départ

  • DonnéesStart Point: point de départ personnalisé pour le chemin de cette opération.
    • DonnéesX: valeur de distance x.
    • DonnéesY: valeur de distance y.
    • DonnéesZ: valeur de distance z.
  • DonnéesUse Start Point: Mis à True, si vous spécifiez manuellement un point de départ. Définissez le point de départ dans le champ Point de départ des données de propriété.


Présentation de l'éditeur de fenêtre de tâches

Les descriptions des paramètres sont fournies dans la liste des propriétés ci-dessus. Cette section est simplement une représentation des paramètres de l’éditeur de fenêtres pour l’opération.

Géométrie de base

  • Add: ajoute les éléments sélectionnés qui devraient être la ou les bases du ou des chemins
  • Delete: supprime les éléments sélectionnés dans la liste Géométrie de base.
  • Clear: efface tous les éléments de la liste Géométrie de base.

Profondeurs

  • DonnéesStart Depth
  • DonnéesFinal Depth
  • DonnéesStep Down

Hauteurs

  • DonnéesSafe Height
  • DonnéesClearance Height

Opération

  • DonnéesTool Controller: l'outil et ses paramètres à utiliser pour cette opération
  • DonnéesCoolant Mode: mode de refroidissement pour cette opération.
  • DonnéesStart Reference **: choisissez le point à utiliser sur la première entité sélectionnée.
  • DonnéesEnd Reference **: choisissez le point à utiliser sur la deuxième entité sélectionnée.
  • DonnéesExtend Path End: positif étend la fin du chemin, négatif raccourcit.
  • DonnéesExtend Path Start: positif étend le début du chemin, négatif raccourcit.
  • DonnéesLayer Mode: terminez l'opération en une seule passe en profondeur ou en plusieurs passes jusqu'à la profondeur finale.
  • DonnéesPath Orientation **: choisissez l'orientation du chemin en fonction des entités sélectionnées.
  • DonnéesReverse Direction: activez cette option pour inverser la direction de coupe du chemin de la fente.

** la visibilité change en fonction de la géométrie de base sélectionnée.


Script

Voir aussi: FreeCAD Script de base.

Exemple:

#Place code example here.
Arrow-left.svg Page précédente : Path Pocket.svg Poche
Page suivante : Perçage Path Drilling.svg Arrow-right.svg