Path Profilage

From FreeCAD Documentation
(Redirected from Path ProfileFace/fr)
Jump to navigation Jump to search
This page is a translated version of the page Path Profile and the translation is 100% complete.
Other languages:
English • ‎français • ‎italiano • ‎română • ‎русский
Arrow-left.svg Page précédente : Path Engrave.svg Gravure
Page suivante : Hélice Path Helix.svg Arrow-right.svg

Path Profile.svg Path Profilage

Emplacement du menu
Path → Profilage
Ateliers
Path
Raccourci par défaut
Aucun
Introduit dans la version
0.19
Voir aussi
Aucun

Description

L'outil Path Profile.png Profile crée une opération de contour basée sur les fonctions sélectionnées du modèle. L'outil a été introduit dans la version 0.19. Il propose trois opérations qui étaient gérées par des outils distincts dans les versions précédentes.

Toutes les opérations créent des objets qui font partie d'une Path Job.svg Path Tâche.

Voici les opérations disponibles:

Opération de contour

Une opération Contour est la valeur par défaut. Elle crée une simple découpe de contour externe d'objets 3D complexes basés sur Workbench Part.svg Part. Le modèle entier de la Tâche sert d'entrée pour l'opération, que la géométrie du corps soit sélectionnée ou non lorsque la commande Contour est appelée.

Opération Profile Face

Une opération Profile Face crée un tracé de contour simple à partir d'une ou plusieurs faces sélectionnées d'un objet.

Opération Profile Edges

Une opération Profile Edges crée un tracé de contour simple à partir des arêtes sélectionnées.


Path profile example.jpg

Utilisation

  1. Il existe plusieurs façons d'appeler la commande:
    • Appuyez sur le bouton Path Profile.svg Profile
    • Utilisez l'entrée Path → Profile dans le menu Path
  2. Activez la section Géométrie de base en cliquant sur son onglet et sélectionnez des entités dans le modèle de tâche.
    • Si aucune caractéristique n'est sélectionnée, l'outil Path Profile.svg Profile utilise par défaut une opération Contour, contourant l'ensemble modèle.
    • Si des faces sont sélectionnées, le résultat est une opération Profile Face.
    • Si les bords sont sélectionnés, le résultat est une opération Profile Edges.
      REMARQUE: Cette opération a reçu des améliorations pour permettre la fonctionnalité sur certains bords ouverts (non loop) sélections. Reportez-vous à la section Notes d'utilisation ci-dessous pour plus d'informations sur les meilleures pratiques de profilage des bords ouverts.
  3. Activez la section Opération en cliquant sur son onglet et ajustez les paramètres de l'opération comme vous le souhaitez.
  4. (Facultatif) Cliquez sur le bouton Appliquer pour prévisualiser l'opération avec les paramètres actuels.
  5. Cliquez sur les boutons OK ou Annuler pour créer ou annuler l'opération.


Remarque importante: Path Profilage ne prend pas en charge les autres détails de l'objet. Vous devez ajuster les propriétés, en particulier la profondeur finale, avec soin, une erreur pourrait endommager votre pièce.


Un point de départ peut être activé à partir de l'onglet Opération dans l'éditeur de fenêtre de tâches, en utilisant un emplacement défini dans Property View → Data → Start Point.


Apportez des ajustements supplémentaires à l'opération en modifiant les propriétés de l'opération dans l'onglet Données de la vue des propriétés. Les propriétés avancées seront situées ici, le cas échéant.

Notes d'utilisation

  • L'opération Path Profile.svg Profil est capable de profiler bords ouverts (une ou plusieurs arêtes continues qui ne forme une boucle vue de la vue de dessus)
    • Il est préférable de sélectionner les bords supérieurs (bords les plus élevés) pour la sélection. La sélection des bords inférieurs est imprévisible et renverra probablement des chemins indésirables dans de nombreuses situations.
    • Les bords sélectionnés doivent former un bord continu tel que vu de la vue de dessus. Les bords supérieurs sélectionnés peuvent avoir des hauteurs différentes, à condition qu'ils se connectent à une coordonnée commune (X, Y) - des hauteurs Z différentes sont acceptables dans certains ** cas.
      **Dans certains cas, l'utilisateur devra inclure dans sa sélection l'arête de connexion verticale droite entre deux arêtes adjacentes de hauteurs différentes partageant une coordonnée commune (X, Y).
    • Les bords supérieurs étant sélectionnés, la profondeur finale de l'opération devra être définie manuellement.
    • Lors du profilage des bords ouverts, la propriété `Side` ou` Cut Side` est désactivée en interne même si elle sera probablement visible dans la fenêtre de l'éditeur de tâches et la liste Propriétés dans l'onglet Données.
  • Lors du profilage du modèle entier (un contour complet du modèle), la propriété `Side` ou` Cut Side` est codée en dur sur `Outside` même si elle peut être disponible pour une entrée utilisateur.

Propriétés

Remarque : toutes ces propriétés ne sont pas disponibles dans l'éditeur de fenêtre de tâches. Certaines ne sont accessibles que dans l'onglet Données du panneau Vue de propriétés pour cette opération.

Base

Remarque: il est conseillé de ne pas modifier la propriété Placement des opérations de chemin. Déplacez ou faites pivoter le modèle de tâche de chemin selon vos besoins.

  • DonnéesPlacement: emplacement global [position et rotation] de l'objet - par rapport à l'origine (ou à l'origine du conteneur de l'objet parent).
    • DonnéesAngle: angle en degrés appliqué à la rotation de l'objet autour de la valeur de la propriété Axis.
    • DonnéesAxis: axe (un ou plusieurs) autour duquel faire pivoter l'objet, défini dans les sous-propriétés: x, y, z.
      • DonnéesX: valeur de l'axe x.
      • DonnéesY: valeur de l'axe y.
      • DonnéesZ: valeur de l'axe z.
    • DonnéesPosition: position de l'objet, définie dans les sous-propriétés: x, y, z - par rapport à l'origine (ou à l'origine du conteneur de l'objet parent).
      • DonnéesX: valeur de distance x.
      • DonnéesY: valeur de distance y.
      • DonnéesZ: valeur de distance z.
  • DonnéesLabel: nom de l'objet fourni par l'utilisateur (UTF-8).

Profondeur

  • DonnéesClearance Height: hauteur nécessaire pour supprimer les pinces et les obstructions.
  • DonnéesFinal Depth: profondeur finale de l'outil - valeur la plus basse de Z.
  • DonnéesFinish Depth: maximum de matériau retiré lors du passage final. La hauteur (épaisseur) du dernier niveau de coupe - "pour une meilleure finition".
  • DonnéesSafe Height: hauteur au-dessus de laquelle les mouvements rapides sont autorisés. (Hauteur de sécurité rapide entre deux endroits)
  • DonnéesStart Depth: profondeur de départ de l'outil - Profondeur de la première coupe en Z.
  • DonnéesStep Down: abaissement incrémental de l'outil pendant l'opération.
Path-DepthsAndHeights.gif

Référence visuelle pour les propriétés de profondeur (paramètres)

Tracé

  • DonnéesActive: mettre à Falsepour empêcher l'opération de générer du code.
  • DonnéesBase: géométrie de base pour cette opération.
  • DonnéesComment: commentaire facultatif pour cette opération.
  • DonnéesCoolant Mode: mode de refroidissement pour cette opération.
  • DonnéesCycle Time: estimation du temps de cycle pour cette opération.
  • DonnéesTool Controller: définit le contrôleur d'outil utilisé dans l'opération.
  • DonnéesUser Label: étiquette attribuée par l'utilisateur.

Profilage

  • DonnéesDirection: direction dans laquelle la trajectoire d'outil doit contourner la pièce: dans le sens horaire [CW] ou dans le sens antihoraire [CCW].
  • DonnéesExpand Profile: étend l'effacement du profil au-delà du décalage supplémentaire.
  • DonnéesExpand Profile Step Over: définit le pourcentage de passage, en fonction du diamètre de l'outil.
  • DonnéesHandle Multiple Features: choix de comment traiter plusieurs entités Géométrie de base.
  • DonnéesOffsetExtra: valeur supplémentaire pour rester à l'écart du profil final - bon pour l'ébauche du parcours d'outil.
  • DonnéesProcess Circles: vérifie si vous souhaitez que cette opération de profil s'applique également aux trous cylindriques, qui sont normalement percés.
  • DonnéesProcess Holes: vérifie si cette opération de profil doit également traiter les trous dans la géométrie de base. Notez que cela n'inclut pas les trous cylindriques.
  • DonnéesProcess Perimeter: Vérifie si cette opération de profil doit également traiter le périmètre extérieur des formes géométriques de base.
  • DonnéesSide: (coupe le côté) côté du bord que l'outil doit couper. Cela n'a d'importance que si «Use Compensation» est True (coché).
  • DonnéesUse Compensation: si cette case est cochée, l'opération de profil est décalée du rayon de l'outil. La direction du décalage est déterminée par le côté de coupe.

Rotation

  • DonnéesAttempt Inverse Angle: tente automatiquement l'angle inverse si la rotation initiale est incorrecte.
  • DonnéesEnable Rotation: active la rotation pour accéder aux poches ou aux zones qui ne sont pas normales à l'axe Z.
  • DonnéesInverse Angle: inverse l'angle de rotation. Exemple: change une rotation de -22,5 à 22,5 degrés.
  • DonnéesLimit Depth To Face: applique la profondeur Z de la face sélectionnée comme valeur la plus basse pour la profondeur finale. Des valeurs utilisateur plus élevées pour la profondeur finale seront observées.
  • DonnéesReverse Direction: inverse l'orientation de l'opération de 180 degrés.

Point de départ

  • DonnéesStart Point: point de départ personnalisé pour le chemin de cette opération.
    • DonnéesX: valeur de distance x.
    • DonnéesY: valeur de distance y.
    • DonnéesZ: valeur de distance z.
  • DonnéesUse Start Point: Mis à True, si vous spécifiez manuellement un point de départ. Définissez le point de départ dans le champ Point de départ des données de propriété.


Présentation de l'éditeur de fenêtre de tâches

Les descriptions des paramètres sont fournies dans la liste des propriétés ci-dessus. Cette section est simplement une représentation des paramètres de l’éditeur de fenêtres pour l’opération.

Géométrie de base

  • Add: ajoute les éléments sélectionnés qui doivent être la base du ou des chemins.
  • Delete: supprime le ou les éléments sélectionnés dans la liste emplacement de base.
  • Clear: efface tous les éléments de la liste d'emplacement de base.

Profondeurs

  • DonnéesStart Depth
  • DonnéesFinal Depth
  • DonnéesStep Down

Hauteurs

  • DonnéesSafe Height
  • DonnéesClearance Height

Opération

  • DonnéesTool Controller
  • DonnéesCoolant Mode
  • DonnéesCut Side **
  • DonnéesDirection
  • DonnéesExtra Offset
  • DonnéesEnable Rotation
  • DonnéesUse Start Point
  • DonnéesUse Compensation
  • DonnéesProcess Holes **
  • DonnéesProcess Circles **
  • DonnéesProcess Perimeter **

** La disponibilité change en fonction des sélections dans la section Géométrie de base.


Script

Voir aussi: FreeCAD Script de base.

Exemple:


#Place code example here.
Arrow-left.svg Page précédente : Path Engrave.svg Gravure
Page suivante : Hélice Path Helix.svg Arrow-right.svg