PartDesign Preferenze

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page PartDesign Preferences and the translation is 18% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português do Brasil • ‎русский

Introduction

La finestre delle preferenze di PartDesign si trovano nell'editor delle preferenze, Modifica → Preferenze → Part design.

Available preferences

Sono disponibili due schede: Generale e Visualizzazione della forma.

Generale

Nella scheda "Generale" è possibile specificare quanto segue:

Nome Descrizione
Controlla automaticamente il modello dopo una operazione booleana Se selezionato, dopo una operazione booleana controlla se la Boundary representation (BRep) del modello è valida. Questo viene fatto internamente dalla funzione Controlla la geometria.
Affina automaticamente il modello dopo una operazione booleana Se selezionato, dopo una operazioone booleana il modello viene ripulito utilizzando la funzione Affina forma.
Ridefinisci automaticamente il modello dopo un'operazione basata su uno schizzo Se selezionato, dopo che uno schizzo di un oggetto è stato modificato il modello viene ripulito utilizzando la funzione Affina forma.
Aggiungi il nome dell'oggetto base Questa opzione non ha attualmente alcun effetto.
Name Description
Automatically check model after boolean operation If checked, the Boundary representation (BRep) of the model is validated after boolean operations
Automatically refine model after boolean operation If checked, the model is refined after boolean operations
Automatically refine model after sketch-based operation If checked, the model is refined after changes to source sketches of objects

Preferences Part design Tab General.png

Visualizzazione della figura

Nella scheda Visualizzazione della figura è possibile specificare quanto segue:

Nome Descrizione
Deviazione massima secondo il riquadro di delimitazione del modello Maximum deflessione lineare degli oggetti tessellati dalla loro superficie.
Massima deflessione angolare Maximum deflessione angolare da una sezione alla sezione successiva di oggetti tessellati.
Name Description
Maximum deviation depending on the model bounding box Maximum linear deflection of the tesselated objects from their surface
Maximum angular deflection Maximum angular deflection from one tesselated object section to the next section

Preferences Part design Tab Shape view.png

Shape appearance

On the Shape appearance tab you can specify the following:

Name Description
Shape color Color for new shapes. If the option Random is set, a random color is used instead.
Line color Line color for new shapes
Line width Line thickness for new shapes
Vertex color Color for new vertices
Vertex size Size for new vertices
Bounding box color Color of bounding boxes in the 3D view
Two-side rendering If checked, the color of the interior side of faces will be the same as the exterior side. If not checked either the backlight color, if enabled, or black will be used instead.
Text color Text color for document annotations. There is currently no dialog to add annotations to documents. Annotations can only be added using the Python console with this command:

obj=App.ActiveDocument.addObject("App::Annotation", "Label")

This console is shown using the menu View → Panels → Python console.

Preferences Part design Tab Shape appearance.png

Tesselation

Al fine di visualizzare un oggetto in modo efficiente la sua superficie viene tessellata, cioè viene visualizzato con alcune piccole deviazioni dalla sua superficie reale. Questo vale non solo per i modelli di PartDesign, ma anche per altri oggetti di FreeCAD.

Il limite inferiore per la tassellatura è 0,01%. Se si vuole davvero passare più tempo di attesa dell'elaborazione del modello si può ridurre ulteriormente il limite inferiore aprendo il menu Strumenti → Modifica parametri .... Questo apre l'editor dei parametri in cui si può accedere a BaseApp → Preferenze → Mod → Part.

Fare clic con il tasto destro del mouse su Deviazione mesh scegliere nel menu contestuale Modifica valore. Impostare il valore di tessellatura minima desiderata. Ricordare che il valore è in%, ovvero per un valore di 0,005% si deve inserire "0,00005". Il valore più piccolo possibile è 1e-7. Nota: Nel menu delle preferenze vedrà ancora 0,01% anche se si imposta un valore più basso.