PartDesign Einstellungen

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page PartDesign Preferences and the translation is 18% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português do Brasil • ‎русский

Introduction

Der Einstellungsbildschirm des PartDesign Arbeitsbereichs befindet sich im Einstellungseditor, Bearbeiten → Einstellungen → Part design.

Available preferences

Es gibt zwei Reiter: Allgemein und Formansicht.

Allgemein

Im Reiter Allgemein kannst Du folgendes angeben:

Name Beschreibung
Modell nach boolescher Bearbeitung automatisch prüfen Wenn gekreuzt, nach einer booleschen Bearbeitung wird es geprüft wenn die Darstellung der Grenze (BRep) des Modells gültig ist . Dies wird intern durch die Funktion ÜberprüfeGeometrie durchgeführt.
Automatically refine model after boolean operation If checked, Das Modell wird mit der Funktion verfeinert VerfeinernForm nach einer booleschen Bearbeitung.
Automatische Verfeinerung des Modells nach skizzenbasierter Bearbeitung. Wenn gekreuzt, wird das Modell mit der Funktion VerfeinernForm verfeinert, nachdem eine Skizze eines Objekts geändert wurde.
Name des Basisobjekts hinzufügen Diese Option hat derzeit keine Auswirkungen.
Name Description
Automatically check model after boolean operation If checked, the Boundary representation (BRep) of the model is validated after boolean operations
Automatically refine model after boolean operation If checked, the model is refined after boolean operations
Automatically refine model after sketch-based operation If checked, the model is refined after changes to source sketches of objects

Preferences Part design Tab General.png

Formansicht

Im Reiter Formansicht kannst Du folgendes angeben:

Name Beschreibung
Maximale Abweichung je nach Modellbegrenzungsrahmen Maximum linear deflection der tessellierten Objekte von ihrer Oberfläche
Maximale Winkelablenkung Maximum angular deflection von einem tessellierten Objektabschnitt zum nächsten Abschnitt
Name Description
Maximum deviation depending on the model bounding box Maximum linear deflection of the tesselated objects from their surface
Maximum angular deflection Maximum angular deflection from one tesselated object section to the next section

Preferences Part design Tab Shape view.png

Shape appearance

On the Shape appearance tab you can specify the following:

Name Description
Shape color Color for new shapes. If the option Random is set, a random color is used instead.
Line color Line color for new shapes
Line width Line thickness for new shapes
Vertex color Color for new vertices
Vertex size Size for new vertices
Bounding box color Color of bounding boxes in the 3D view
Two-side rendering If checked, the color of the interior side of faces will be the same as the exterior side. If not checked either the backlight color, if enabled, or black will be used instead.
Text color Text color for document annotations. There is currently no dialog to add annotations to documents. Annotations can only be added using the Python console with this command:

obj=App.ActiveDocument.addObject("App::Annotation", "Label")

This console is shown using the menu View → Panels → Python console.

Preferences Part design Tab Shape appearance.png

Tesselation

Um ein Objekt effizient darzustellen, ist seine Oberfläche tesselliert, d.h. es wird mit einigen kleinen Abweichungen von seiner realen Oberfläche dargestellt. Dies gilt nicht nur für PartDesign Modelle, sondern auch für andere Objekte in FreeCAD.

Es gibt eine untere Grenze für die Tessellierung von 0,01%. Wenn du die zusätzliche Zeit wirklich nutzen willst, kannst du die Untergrenze noch weiter reduzieren, indem du das Menü Werkzeuge → Parameter bearbeiten... öffnest. Dies öffnet den Parametereditor, in dem du zu BaseApp → Einstellungen → Mod → Part navigierst.

Rechtsklick auf Netzabweichung und wähle im Kontextmenü Wert ändern. Setze den Wert auf die minimale Tesselation deiner Wahl. Bitte beachte, dass der Wert in % angegeben wird, d.h. für einen Wert von 0,005% musst du "0,00005" eingeben. Der kleinstmögliche Wert ist 1e-7. Hinweis: Im Menü Einstellungen siehst du auch dann noch 0.01%, wenn du einen niedrigeren Wert einstellst.