Навигация в 3D пространстве

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Mouse navigation and the translation is 100% complete.
Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎українська • ‎中文 • ‎中文(中国大陆)‎

Обзор

Каждый стиль навигации определяет собой методы для навигации в трёхмерном пространстве, а так же методы взаимодействия с трехмерными объектами (перемещение, вращение и т.п.). FreeCAD поддерживает несколько стилей навигации и управления. По умолчанию установлен CAD стиль навигации, он очень простой и практичный, но FreeCAD так же предлагает альтернативные стили навигации, которые вы можете выбрать по своим предпочтениям. Назначенный пользователем стиль навигации будет использоваться для всех верстаков.

Дополнительные сведения о способах выбора объектов см. в разделе Методы выбора объектов.

Дополнительные сведения о способах преобразования объектов см. на странице описания команды Преобразование.

Выбор стиля навигации

  1. Выполните одно из следующих действий:
    • Нажмите на кнопку NavigationCAD dark.svg в Строке состояния.
    • Щелкните правой кнопкой мыши в пустую область в 3D Виде, и выберите Стили навигации в контекстном меню.
    • Откройте Редактор настроек через пункт главного меню Редактировать → Настройки... В нем выберите раздел Отображение → вкладку Навигация → пункт Трехмерная навигация.
  2. Выберите стиль из списка.
  3. При необходимости укажите стиль Ващения: нажмите на кнопку NavigationCAD dark.svg в Строке состояния и выберите в контекстом меню пункт Настройки → Вращение. Подробности см. в описании Редактора настроек.
  4. При необходимости укажите Режим вращения. Подробности см. в описании Редактора настроек.
  5. Если выбран стиль навигации CAD: при необходимости укажите параметр настроек Включить анимацию. Подробности см. в описании Редактора настроек.

Доступные стили навигации

Навигация Blender

Стиль навигации Blender основан на модели управления используемой в редакторе Blender.

Выбор Перемещение Масштабирование Вращение
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Shift+Mouse MMB hold.svg Mouse LMB+RMB hold.svg Mouse MMB rotate.svg Mouse MMB hold.svg
Нажмите левую кнопку мыши над объектом, который хотите выбрать. Удерживайте Shift и среднюю кнопку мыши для перемещения объекта.

Либо, удерживайте левую и правую кнопки мыши, а затем переместите указатель.

Используйте колёсико мыши для приближения или отдаления. Нажмите среднюю кнопку мыши и перемещайте указатель в нужном направлении.

Навигация CAD

Это стиль навигации по умолчанию и позволяет пользователю простейшее управление видом, не требуя использования клавиатуры, кроме как для множественного выделения.

Выбор Перемещение Масштабирование Вращение
обычное
Вращение
альтернативным методом
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse MMB+RMB hold.svg
Нажмите левую кнопку мыши над объектом, который вы хотите выбрать.

Для выбора сразу нескольких объектов зажмите клавишу Ctrl.

Удерживая среднюю кнопку мыши, перемещайте указатель. Используем колёсико мыши для приближения и отдаления.

При нажатии средней кнопки мыши вид центрируется по положению указателя.

Удерживая среднюю кнопку мыши, нажмите и удерживайте левую кнопку мыши, затем перемещайте указатель.

Если кнопки будут отпущены до того, как вы остановите движение мыши, Вид продолжит вращение, в случае если включен поворотный просмотр объекта.

Двойное нажатие средней кнопкой мыши устанавливает новый центр вращения.

Удерживая среднюю кнопку мыши, нажмите и удерживайте правую кнопку мыши, затем перемещайте указатель.

При этом методе средняя кнопка мыши может быть отпущена после того как правая кнопка осталась нажатой.

Пользователи, использующие мышь правой рукой могут счесть этот метод проще исходного.

Ctrl+Mouse RMB.svg Ctrl+Shift+Mouse RMB.svg Shift+Mouse RMB.svg
Режим перемещения: удерживая кнопку Ctrl, один раз нажимаем правую кнопку мыши, затем перемещаем указатель. Режим приближения: удерживая клавиши Ctrl и Shift, нажмите правую кнопку, и перемещайте указатель. Режим вращения: удерживая клавишу Shift, нажмите правую кнопку мыши, затем перемещайте указатель.

Навигация Gesture (Жестами)

Этот стиль был разработан специально для работы с сенсорным экраном с помощью стилуса или жестами. Тем не менее он также может применяться при управлении мышью, кроме того данный стиль управления рекомендуется использовать при управлении трекпадом в Mac.

Выбор Перемещение Масштабирование Вращение Наклонить вид
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png Rotate cursor.png
Mouse LMB.svg Mouse RMB hold.svg Mouse MMB rotate.svg Mouse LMB hold.svg Mouse LMB+RMB hold.svg
Нажмите левую кнопку мыши над объектом, который хотите выбрать. Удерживайте правую кнопку мыши и перемещайте указатель. Используйте колёсико мыши для масштабирования. Удерживайте левую кнопку мыши и тяните указатель.

В режиме Sketcher и некоторых других это действие заблокировано. Удерживайте Alt при нажатии кнопки мыши для перехода в режим вращения.

Чтобы установить точку фокуса камеры для вращения, кликните новую точку средней кнопкой мыши. Взамен, нацельте указатель в новую точку и нажмите кнопку H на клавиатуре.

Удерживайте левую и правую кнопку мыши и тяните указатель в сторону.
Touch Tap.svg Touch Two-Finger-Drag.svg Touch Tap-Hold-Drag.svg Touch Pinch.svg Touch One-Finger-Drag.svg Touch Rotate.svg
Коснитесь пальцем экрана для выбора. Коснитесь экрана двумя пальцами и перемещайте их в нужном направлении.

Или, коснитесь экрана одним пальцем, удерживайте его некоторое время, а потом перемещайте в нужном направлении. Это равносильно перемещению с помощью правой кнопки мыши.

Сдвиньте пальцы для масштабирования (т.е. потяните два пальца к/от друг друга). Потяните одним пальцем для вращения.

Удерживайте вдобавок Alt в режиме Sketcher.

Вращайте воображаемую линию между двумя точками касания.

Начиная с версии v0.18 этот метод по умолчанию отключён. Для разрешения Правка → Настройки → Отображение, и снимите метку "Отключить жест наклона для сенсорного экрана".

Навигация Maya-Gesture (Жестами в стиле Maya)

В стиле навигации MayaGesture, перемещение, масштабирование и вращение Вида выполняется при зажатой клавише ALT и нажатии одной из трех кнопок мыши, поэтому этот стиль навигации полноценно можно использовать только с трехкнопочной мышью. В данном стиле также можно использовать жесты из обычного стиля навигации жестами, так как этот стиль был разработан на его основе.

Выбор Перемещение Масштабирование Вращение
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Alt+Mouse MMB hold.svg Alt+Mouse RMB hold.svg Mouse MMB rotate.svg Alt+Mouse LMB hold.svg
Нажмите левую кнопку мыши над объектом который вы хотите выбрать. Удерживая клавишу Alt и среднюю кнопку мыши, перемещайте указатель. Удерживая клавишу Alt и правую кнопку мыши, перемещайте указатель.

Или, используйте для приближения и отдаления колёсико мыши.

Удерживая Alt и левую кнопку мыши, перемещайте указатель.

Навигация OpenCascade

Стиль навигации OpenCascade основан на модели управления используемой в OpenCascade.

Выбор Перемещение Масштабирование Вращение
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Ctrl+Mouse MMB hold.svg Mouse MMB hold.svg Mouse MMB rotate.svg Ctrl+Mouse LMB hold.svg Ctrl+Mouse RMB hold.svg


Нажмите левую кнопку мыши над объектом, который хотите выбрать. Удерживая среднюю кнопку мыши, перемещайте указатель. Используйте колёсико мыши для приближения и отдаления.

Или, удерживая Ctrl и левую кнопку мыши, перемещайте указатель.

Удерживая Ctrl и правую кнопку мыши, перемещайте указатель.

Навигация OpenInventor

Стиль навигации OpenInventor основан на модели управления используемой в редакторе Open Inventor. Для выбора объектов, необходимо удерживать нажатой клавишу Shift или Ctrl.

Данный стиль управления отличен от того, что применен в Autodesk Inventor.

Выбор Перемещение Масштабирование Вращение
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Shift+Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse LMB hold.svg
Удерживая Shift, нажмите левую кнопку мыши над объектом, который хотите выбрать.

Вместо этого удерживайте нажатой клавишу Ctrl, чтобы выбрать несколько объектов.

Удерживая среднюю кнопку мыши, перемещайте указатель. Используем колёсико мыши для приближения и отдаления.

Или, зажмите и удерживайте среднюю и левую кнопку мыши, затем перемещайте указатель.

Удерживая левую кнопку мыши, перемещайте указатель.

Навигация OpenSCAD

Стиль навигации OpenSCAD основан на модели управления используемой в редакторе OpenSCAD.

представлено в версии 0.20

Выбор Перемещение Масштабирование Вращение
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Mouse RMB hold.svg Mouse MMB hold.svg Shift+Mouse RMB hold.svg Mouse LMB hold.svg
Нажмите левую кнопку мыши над объектом, который хотите выбрать. Удерживайте правую кнопку мыши и перемещайте указатель. Удерживая среднюю кнопку мыши, перемещайте указатель.

Или, удерживая Shift и правую кнопку мыши, перемещайте указатель.

Удерживайте левую кнопку мыши и перемещайте указатель.

Навигация Revit

Стиль навигации Revit основан на модели управления используемой в редакторе Revit.

Выбор Перемещение Масштабирование Вращение
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse LMB+RMB hold.svg Mouse MMB rotate.svg Shift+Mouse MMB hold.svg Mouse MMB+RMB hold.svg


Нажмите левую кнопку мыши над объектом, который хотите выбрать. Удерживая среднюю кнопку мыши, перемещайте указатель.

Или, удерживая левую и правую кнопку мыши, перемещайте указатель.

Используйте для приближения и отдаления колёсико мыши. Удерживая Shift и среднюю кнопку мыши, перемещайте указатель.

Или, удерживая среднюю кнопку мыши, нажмите и удерживайте правую кнопку, затем перемещайте указатель.

Навигация TinkerCAD

Стиль навигации TinkerCAD основан на модели управления используемой в редакторе TinkerCAD.

представлено в версии 0.20

Выбор Перемещение Масштабирование Вращение
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse RMB hold.svg
Нажмите левую кнопку мыши над объектом, который хотите выбрать. Удерживая среднюю кнопку мыши, перемещайте указатель. Используйте колёсико мыши для приближения и отдаления. Удерживая правую кнопку мыши, перемещайте указатель.

Навигация Touchpad

В режиме навигации тачпадом, перемещение, масштабирование и вращение Вида требует использования вместе с тачпадом модифицирующих клавиш.

Выбор Перемещение Масштабирование Вращение
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Touchpad LB.svg Shift+Touchpad.svg PageUp, PageDown Alt+Touchpad.svg
Нажмите левую кнопку над объектом, который хотите выбрать. Удерживайте Shift и двигайте объект. Используйте PageUp и PageDown для приближения или отдаления. Удерживайте клавишу Alt и перемещайте указатель.
Ctrl+Shift+Touchpad.svg Shift+Touchpad LB hold.svg
Или, зажмите Ctrl + Shift и нажмите левую кнопку мыши, после чего перемещайте указатель. Или, удерживайте клавиши Shift стрелку влево, после чего перемещайте указатель.

Поддержка оборудования

В FreeCAD так же поддерживает некоторые устройства 3D ввода.

Рекомендуемый стиль управления для MacOS

На MacBook с трекпадом навигация жестами работает хорошо, но жесты имеют особое значение:

  • Масштабирование: касание и перемещение двумя пальцами.
  • Вращение: касание и перемещение тремя пальцами.
  • Перемещение: Ctrl + касание и перемещение тремя пальцами.

Разработка собственного стиля навигации

Руководство по добавлению нового стиля навигации с помощью мыши в FreeCAD ориентирует разработчиков, которые хотят разработать собственный стиль навигации с помощью мыши. Требуется знание синтаксиса C++.