Navigation par la souris

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Mouse navigation and the translation is 100% complete.
Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎українська • ‎中文 • ‎中文(中国大陆)‎
Arrow-left.svg Page précédente : Premiers pas
Page suivante : Méthodes de sélection Arrow-right.svg

Présentation

La navigation par la souris dans FreeCAD consiste en des commandes utilisées pour naviguer visuellement dans l'espace 3D et interagir avec les objets affichés. FreeCAD supporte plusieurs styles de navigation à la souris. Le style de navigation par défaut est appelé Mode CAD. Il est très simple et pratique mais FreeCAD fournit également plusieurs autres styles de navigation à choisir. Le style sélectionné est utilisé pour tous les ateliers.

Pour plus d'informations sur la sélection d'objets, voir Méthodes de sélection.

Pour plus d'informations sur la manipulation des objets, voir Std Transformation manipulation.

Sélection d'un style de navigation

  1. Faites l'une des choses suivantes :
    • Appuyez sur le bouton NavigationCAD.svg de la Barre d'état.
    • Cliquez du bouton droit de la souris sur une zone vide dans la Vue 3D et sélectionnez Styles de navigation dans le menu contextuel.
    • Utilisez les Réglages des préférences. Dans le menu, sélectionnez Edition → Préférences et ensuite Affichage → Navigation → Navigation 3D.
  2. Sélectionnez un style dans la liste.
  3. Modifiez éventuellement le Style d'orbite : appuyez sur le bouton NavigationCAD.svg dans la Barre d'état puis choisissez Paramètres → Style d'orbite. Voir Réglages des préférences.
  4. Vous pouvez également modifier le Mode de rotation. Voir Réglages des préférences.
  5. Si le mode de navigation CAD est sélectionné : modifiez éventuellement le paramètre Permettre l'animation. Voir Réglages des préférences.

Styles de navigation disponibles

Mode Blender

Le style de navigation Blender s'inspire de Blender.

Sélection Mouvement panoramique Zoom Rotation de la vue
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Maj+Mouse MMB hold.svg Mouse LMB+RMB hold.svg Mouse MMB rotate.svg Mouse MMB hold.svg
Cliquez avec le bouton gauche de la souris sur l'objet que vous souhaitez sélectionner. Maintenez la touche Maj enfoncée, appuyez ensuite sur le bouton central de la souris et déplacez le pointeur.

Vous pouvez également maintenir enfoncé les boutons gauche et droit de la souris, et déplacer le pointeur.

Utilisez la molette de la souris pour zoomer et dézoomer. Appuyez sur le bouton central de la souris, et déplacez le pointeur.

Mode CAD

C'est le style de navigation par défaut. Il permet à l'utilisateur un contrôle simple de la vue et ne nécessite pas l'utilisation de touches du clavier, sauf pour effectuer des sélections multiples.

Sélection Mouvement panoramique Zoom Rotation
1ère méthode
Rotation
2è méthode
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse MMB+RMB hold.svg
Cliquez avec le bouton gauche de la souris sur l'objet que vous souhaitez sélectionner.

Maintenez la touche Ctrl enfoncée pour sélectionner plusieurs objets.

Maintenez le bouton central de la souris enfoncé et déplacez le pointeur pour déplacer l'objet. Utilisez la molette de la souris pour zoomer et dézoomer.

En cliquant sur le bouton central de la souris, la vue est recentrée sur l'emplacement du curseur.

Maintenez le bouton central de la souris enfoncé, appuyez ensuite sur le bouton gauche de la souris, puis déplacez le pointeur.

Si les boutons sont relâchés avant que vous n'arrêtiez le mouvement de la souris, la vue continue de tourner, si cette option est activée.

Double cliquer avec le bouton central de la souris définit un nouveau centre de rotation.

Maintenez le bouton central de la souris enfoncé, appuyez ensuite sur le bouton droit de la souris, puis déplacez le pointeur.

Avec cette méthode, le bouton central de la souris peut être relâché si vous maintenez le bouton droit de la souris enfoncé.

Les utilisateurs qui utilisent la souris avec leur main droite peuvent trouver cette méthode plus facile que la première.

Ctrl+Mouse RMB.svg Ctrl+Maj+Mouse RMB.svg Maj+Mouse RMB.svg
Pan mode: maintenez la touche Ctrl enfoncée, appuyez simultanément sur le bouton droit de la souris, puis déplacez le pointeur. Mode zoom: maintenez les touches Ctrl et Maj enfoncées, appuyez simultanément sur le bouton droit de la souris, puis déplacez le pointeur. Mode rotation: maintenez la touche Maj enfoncée, appuyez simultanément sur le bouton droit de la souris, puis déplacez le pointeur.

Mode Gesture

Ce style a été conçu pour être utilisé avec un écran tactile et un stylo. Néanmoins, il peut également être utilisé avec une souris et il est recommandé de l'utiliser avec un Mac doté d'un pavé tactile.

Sélection Mouvement panoramique Zoom Rotation de la vue Basculement de la vue
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png Rotate cursor.png
Mouse LMB.svg Mouse RMB hold.svg Mouse MMB rotate.svg Mouse LMB hold.svg Mouse LMB+RMB hold.svg
Cliquez avec le bouton gauche de la souris sur l'objet que vous souhaitez sélectionner. Maintenez le bouton droit de la souris enfoncé et déplacez le pointeur. Utilisez la molette de la souris pour zoomer et dézoomer. Maintenez le bouton gauche de la souris enfoncé et déplacez le pointeur.

Dans l'atelier Sketcher et d'autres modes d'édition, ce comportement est désactivé. Maintenez la touche Alt enfoncée tout en appuyant sur le bouton de la souris pour passer en mode de rotation.

Pour fixer le point de focus pour la rotation de la caméra, cliquez sur ce point avec le bouton central de la souris. Sinon, pointez le curseur sur ce point et appuyez sur la touche H du clavier.

Maintenez les boutons gauche et droit de la souris enfoncés, et déplacer le pointeur latéralement.
Touch Tap.svg Touch Two-Finger-Drag.svg Touch Tap-Hold-Drag.svg Touch Pinch.svg Touch One-Finger-Drag.svg Touch Rotate.svg
Cliquez pour sélectionner. Faites glisser avec deux doigts.

Vous pouvez également cliquer et maintenir, puis glisser. Cela simule le panoramique avec le bouton droit de la souris.

Pincez ou écartez avec deux doigts. Glissez avec un doigt pour tourner.

Maintnez la touche Alt enfoncée si vous êtes dans Sketcher.

Faites pivoter la ligne imaginaire formée par deux points de contact.

Dans la v0.18 ce mode est désactivé par défaut. Pour l'activer, allez dans Édition → Préférences → Affichage, et décochez la case "Désactiver gestuelle de basculement écran tactile".

Mode MayaGesture

Dans le mode de navigation MayaGesture, le panoramique, le zoom et la rotation de la vue nécessitent la touche Alt ainsi qu'un bouton de la souris; une souris à trois boutons est donc nécessaire. Il est également possible d'utiliser des gestes car ce mode a été développé par rapport au mode de navigation Gesture.

Sélection Mouvement panoramique Zoom Rotation de la vue
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Alt+Mouse MMB hold.svg Alt+Mouse RMB hold.svg Mouse MMB rotate.svg Alt+Mouse LMB hold.svg
Cliquez avec le bouton gauche de la souris sur l'objet que vous souhaitez sélectionner. Maintenez la touche Alt et le bouton central de la souris enfoncés, puis déplacez le pointeur. Maintenez la touche Alt et le bouton droit de la souris enfoncés, puis déplacez le pointeur.

Vous pouvez également utilisez la molette de la souris pour zoomer et dézoomer.

Maintenez la touche Alt et le bouton gauche de la souris enfoncés, puis déplacez le pointeur.

Mode OpenCascade

Le style de navigation OpenCascade s'inspire d'OpenCascade.

Sélection Mouvement panoramique Zoom Rotation de la vue
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Ctrl+Mouse MMB hold.svg Mouse MMB hold.svg Mouse MMB rotate.svg Ctrl+Mouse LMB hold.svg Ctrl+Mouse RMB hold.svg


Cliquez avec le bouton gauche de la souris sur l'objet que vous souhaitez sélectionner. Appuyez sur le bouton central de la souris, puis déplacez le pointeur. Utilisez la molette de la souris pour zoomer et dézoomer.

Vous pouvez également maintenir la touche Ctrl et le bouton gauche de la souris enfoncés, puis déplacer le pointeur.

Maintenez la touche Ctrl et le bouton droit de la souris enfoncés, puis déplacer le pointeur.

Mode OpenInventor

Le mode de navigation OpenInventor (anciennement Inventor) s'inspire d'Open Inventor. Pour sélectionner des objets, vous devez maintenir la touche Ctrl enfoncée.

Ce mode n'est pas basé sur Autodesk Inventor.

Sélection Mouvement panoramique Zoom Rotation de la vue
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Ctrl+Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse LMB hold.svg
Maintenez la touche Ctrl enfoncée, cliquez ensuite avec le bouton gauche de la souris sur l'objet que vous souhaitez sélectionner. Appuyez sur le bouton central de la souris, puis déplacez le pointeur. Utilisez la molette de la souris pour zoomer et dézoomer.

Alternativement : Maintenez le bouton central de la souris enfoncé, pressez ensuite le bouton gauche de la souris, puis déplacez le pointeur.

Appuyez sur le bouton gauche de la souris, puis déplacez le pointeur.

Mode OpenSCAD

Le style de navigation OpenSCAD s'inspire d'OpenSCAD.

Introduit dans la version 0.20

Sélection Mouvement panoramique Zoom Rotation de la vue
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Mouse RMB hold.svg Mouse MMB hold.svg Maj+Mouse RMB hold.svg Mouse LMB hold.svg
Appuyez le bouton gauche de la souris sur un objet que vous voulez sélectionner. Maintenir le bouton droit de la souris, puis déplacer le pointeur. Maintenir le bouton central de la souris, puis déplacer le pointeur.

Vous pouvez également maintenir Maj et le bouton droit de la souris enfoncés, puis déplacer le pointeur.

Maintenir le bouton gauche de la souris, puis déplacer le pointeur.

Mode Revit

Le style de navigation Revit s'inspire de Revit.

Sélection Mouvement panoramique Zoom Rotation de la vue
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse LMB+RMB hold.svg Mouse MMB rotate.svg Maj+Mouse MMB hold.svg Mouse MMB+RMB hold.svg


Cliquez avec le bouton gauche de la souris sur l'objet que vous souhaitez sélectionner. Appuyez sur le bouton central de la souris, puis déplacez le pointeur.

Vous pouvez également maintenir enfoncé les boutons gauche et droit de la souris, et déplacer le pointeur.

Utilisez la molette de la souris pour zoomer et dézoomer. Maintenez la touche Maj et le bouton central de la souris enfoncés, puis déplacez le pointeur.

Vous pouvez également maintenir enfoncé le bouton central de la souris, puis aussi le bouton droit, et déplacer le pointeur.

Mode TinkerCAD

Le style de navigation TinkerCAD s'inspire de TinkerCAD.

Introduit dans la version 0.20

Sélection Mouvement panoramique Zoom Rotation de la vue
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse RMB hold.svg
Appuyez le bouton gauche de la souris sur un objet que vous voulez sélectionner. Maintenir le bouton central de la souris, puis déplacer le pointeur. Utiliser la molette de la souris pour faire un zoom avant ou arrière. Appuyez sur le bouton droit de la souris, puis déplacez le pointeur.

Mode Touchpad

Dans la navigation Touchpad, le panoramique, le zoom et la rotation de la vue nécessitent une touche de modification en même temps que le pavé tactile.

Sélection Mouvement panoramique Zoom Rotation de la vue
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Touchpad LB.svg Maj+Touchpad.svg Page précédente, Page suivante Alt+Touchpad.svg
Cliquez avec le bouton gauche sur l'objet que vous souhaitez sélectionner. Maintenez la touche Maj enfoncée et déplacez le pointeur. Utiliser les touches Page précédente et Page suivante pour zoomer et dézoomer. Maintenez la touche Alt enfoncée, puis déplacez le pointeur.
Maj+Ctrl+Touchpad.svg Maj+Touchpad LB hold.svg
Autre possibilité, maintenez les touches Maj et Ctrl enfoncées, puis déplacez le pointeur. Autre possibilité, maintenez la touche Maj enfoncée ainsi que le bouton gauche, puis déplacez le pointeur.

Support matériel

FreeCAD supporte aussi quelques périphériques d'entrée 3D.

Mode recommandé pour macOS

Sur les MacBooks équipés d'un pavé tactile, la navigation Gesture fonctionne très bien mais les gestes ont une signification particulière :

  • Zoom : faire glisser avec deux doigts.
  • Rotation : faire glisser avec trois doigts.
  • Panoramique : Ctrl + trois doigts.

Développer un mode personnalisé

Le tutoriel Ajout d'une nouvelle option de navigation à la souris à FreeCAD oriente les développeurs qui souhaitent développer une option de navigation à la souris personnalisée. Une certaine familiarité avec la syntaxe C++ est requise.


Arrow-left.svg Page précédente : Premiers pas
Page suivante : Méthodes de sélection Arrow-right.svg