Mesh Tesselation

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Mesh FromPartShape and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский
Arrow-left.svg Page précédente : Mesh Export.svg Exporter un maillage
Page suivante : Affinage Mesh RemeshGmsh.svg Arrow-right.svg

Mesh FromPartShape.svg Mesh Tesselation ‏‎

Emplacement du menu
Maillages → Créer un maillage à partir d'une forme...
Ateliers
Mesh
Raccourci par défaut
Aucun
Introduit dans la version
-
Voir aussi
Aucun

Description

La commande Créer un maillage crée des objets maillés non paramétriques, Mesh Features, à partir de la forme d'objets (Part Features).

L'opération inverse est Part Forme à partir du maillage depuis l'Workbench Part.svg atelier Part.

Utilisation

  1. Sélectionnez éventuellement un ou plusieurs objets.
  2. Il existe plusieurs manières d'appeler la commande:
    • Appuyez sur le bouton Mesh FromPartShape.svg Mesh Tesselation de la forme.
    • Sélectionnez l'option Maillages → Mesh FromPartShape.svg Créer un maillage à partir de la forme... dans le menu.
  3. Le panneau des tâches Tessellation s'ouvre.
  4. Lorsque le panneau des tâches est ouvert, vous pouvez créer une nouvelle sélection ou modifier une sélection existante.
  5. Sélectionnez l'onglet du mailleur que vous souhaitez utiliser.
  6. Spécifiez les paramètres requis. Voir Mailleurs.
  7. Appuyez sur le bouton OK pour fermer le panneau des tâches et terminer la commande.

Mailleurs

Voici les mailleurs disponibles et leurs paramètres:

Mailleur standard

  • Déviation de surface: la déviation linéaire maximale d'une section de maillage par rapport à la surface de l'objet.
  • Déviation angulaire: la déviation angulaire maximale d'une section de maillage à la suivante . Ce paramètre est utilisé lors du maillage de surfaces courbes.
  • Ecart relatif de surface: si cochée, la déviation linéaire maximale d'un segment de maillage sera la Déviation de surface multipliée par la longueur du segment de maillage courant (bord).
  • Appliquer les couleurs de face au maillage: si coché, le maillage obtiendra les couleurs de face de l'objet.
  • Définir les segments par couleurs de face: si coché, les segments de maillage seront regroupés en fonction des couleurs des faces de l'objet. Ces groupes seront exportés pour les formats de sortie de maillage prenant en charge cette fonctionnalité (le format OBJ par exemple).

Mailleur Mefisto

  • Longueur maximale d'arêtes: la longueur maximale du bord du maillage. Une valeur plus petite donne un maillage plus fin. Si vous spécifiez 0 ou décochez la case, vous obtenez un maillage très grossier.
    • Si vous appuyez sur le bouton Estimation, le mailleur entrera une valeur estimée pour Longueur maximale d'arêtes. Cette valeur n'est pas très fiable si plusieurs objets ont été sélectionnés.

Mailleur Netgen

  • Fineness: sélectionnez une option pour la finesse du maillage:
    • Très grossier
    • Coarse
    • Modéré
    • Fine
    • Très bien
    • User defined: pour cette option, les paramètres suivants peuvent être spécifiés:
      • Graduation de la taille du maillage: une valeur plus petite donne un maillage plus fin. La valeur doit être comprise dans la plage 0.1 - 1.0.
      • Elément par arête: une valeur plus grande donne un maillage plus fin. La valeur doit être comprise dans la plage 0.2 - 10.0.
      • Elément par rayon de courbure: une valeur plus grande donne un maillage plus fin. La valeur doit être comprise dans la plage 0.2 - 10.
  • Optimiser la surface: si coché, la forme de la surface sera optimisée.
  • Eléments du second ordre: si coché, les éléments du second ordre seront générés résultant en un maillage plus fin.
  • Quad dominé: si coché, le maillage utilisera de préférence quadrilateral faces.

Mailleur Gmsh

Introduit dans la version 0.19

Pour les utilisateurs Linux: le module externe Gmsh est requis.

  • Maillage: sélectionnez une option de maillage:
    • Automatique
    • Adaptatif
    • Delaunay
    • Frontal
    • BAMG
    • Quadrangle frontal
    • Parallélogrammes
  • Taille maximale de l'élément: une valeur plus petite donne un maillage plus fin. Spécifiez 0 pour que cette taille soit automatiquement déterminée.
  • Taille minimale de l'élément: une valeur plus petite donne un maillage plus fin. La valeur doit être inférieure à Max. taille de l'élément. Spécifiez 0 pour que cette taille soit automatiquement déterminée.
  • Angle: semble ne pas être pris en charge pour le moment.
  • Path: appuyez sur le bouton ... et allez jusqu'au chemin gmsh.exe.
  • Si le processus de maillage prend trop de temps, vous pouvez appuyer sur le bouton Kill pour l'abandonner.
  • Appuyez sur le bouton Effacer pour supprimer les informations de la zone de texte.

Remarques

  • Cette commande n'est pas limitée aux objets créés avec l'atelier Part. Il peut créer un maillage à partir de n'importe quel objet qui a une forme, y compris des objets créés avec l'atelier Part.
  • La commande Std Exporter peut exporter des objets de forme directement vers un format de maillage.
  • Voir aussi: Tutoriel Exportation de fichier STL ou OBJ.

Préférences

Mailleur standard

  • Le paramètre Surface déviation est stocké: Outils → Editeur de paramètres... → BaseApp → Preferences → Mod → Mesh → Meshing → Standard → LinearDeflection.
  • Le paramètre Déviation angulaire est stocké: Outils → Editeur de paramètres... → BaseApp → Preferences → Mod → Mesh → Meshing → Standard → AngularDeflection.
  • Le paramètre Ecart relatif de surface est stocké: Outils → Editeur de paramètres... → BaseApp → Preferences → Mod → Mesh → Meshing → Standard → RelativeLinearDeflection.

Mailleur Gmsh

  • Le Parcours est stocké: Outils → Editeur de paramètres... → BaseApp → Preferences → Mod → Mesh → Meshing → gmshExe.

Propriétés

Voir: Mesh Feature.

Script

Voir aussi: FreeCAD Script de base.

Pour créer un objet maillé à partir d'un objet forme, utilisez la méthode meshFromShape du module MeshPart. Cette méthode a plusieurs signatures. La signature détermine le mailleur qui sera utilisé. L'exemple ci-dessous utilise la signature de maillage Mefisto.

import FreeCAD, Part, Mesh, MeshPart

cyl = FreeCAD.ActiveDocument.addObject("Part::Cylinder","Cylinder")
FreeCAD.ActiveDocument.recompute()

msh = FreeCAD.ActiveDocument.addObject("Mesh::Feature", "Mesh")
msh.Mesh = MeshPart.meshFromShape(Shape=cyl.Shape, MaxLength=1)
msh.ViewObject.DisplayMode = "Flat Lines"


Arrow-left.svg Page précédente : Mesh Export.svg Exporter un maillage
Page suivante : Affinage Mesh RemeshGmsh.svg Arrow-right.svg