Mesh: Esporta mesh

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Mesh Export and the translation is 80% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎magyar • ‎română • ‎русский
Arrow-left.svg Mesh Import.svg Importa mesh Pagina precedente:
Pagina successiva: Mesh da forma Mesh FromPartShape.svg Arrow-right.svg

Mesh Export.svg Esporta mesh

Nome nel codice
Mesh_Export
Posizione nel menu
Mesh → Esporta mesh...
Ambiente
Mesh
Avvio veloce
Nessuno
Introdotto nella versione
-
Vedere anche
Esporta, Importazione e Esportazione


Descrizione

Il comando Esporta mesh esporta un oggetto mesh in un formato file mesh. Sono supportati diversi formati di file.

Utilizzo

  1. Selezionare un singolo oggetto mesh.
  2. Esistono diversi modi per invocare il comando:
    • Premere il pulsante Mesh Export.svg Esporta mesh.
    • Selezionare l'opzione Mesh → Mesh Export.svg Esporta mesh... dal menu.
    • Selezionare l'opzione Mesh Export.svg Esporta mesh... dal menu contestuale della vista ad albero o della vista 3D.
  3. Selezionare il formato file corretto nella finestra di dialogo.
  4. Inserisci un nome file. Se nel passaggio precedente è stata selezionata l'opzione Tutti i file (*.*) e non si specifica un'estensione di file, viene utilizzata l'estensione .stl.
  5. Premere il pulsante Salva.

Note

  • Esistono alcune preferenze di esportazione correlate ai Formati mesh ma queste non si applicano a questo comando. Sono utilizzati dal comando Esporta.

Preferenze

  • L'ultima posizione del file utilizzato viene memorizzata in: Strumenti → Modifica parametri... → BaseApp → Preferences → General → FileOpenSavePath.

Script

Per esportare oggetti (inclusi gli oggetti mesh) in un formato file mesh, utilizzare il metodo export del modulo Mesh.

import FreeCAD
import Mesh

doc = FreeCAD.ActiveDocument

Mesh.export([doc.Cone, doc.Cylinder], 'D:/testfiles/mymodel.stl')


Arrow-left.svg Mesh Import.svg Importa mesh Pagina precedente:
Pagina successiva: Mesh da forma Mesh FromPartShape.svg Arrow-right.svg