Mesh: Aggiungi triangolo

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Mesh AddFacet and the translation is 50% complete.
Other languages:
English • ‎français • ‎italiano
Arrow-left.svg Mesh FillInteractiveHole.svg Chiudi il buco Pagina precedente:
Pagina successiva: Rimuovi componente Mesh RemoveComponents.svg Arrow-right.svg

Mesh AddFacet.svg Aggiungi triangolo

Nome nel codice
Mesh_AddFacet
Posizione nel menu
Mesh → Aggiungi triangolo
Ambiente
Mesh
Avvio veloce
Nessuno
Introdotto nella versione
-
Vedere anche
Riempi i buchi, Chiudi il buco


Descrizione

The Mesh AddFacet command adds faces along a boundary of an open mesh object. It can be used to fill holes.

Usage

  1. During the command edit mode will be active. In this mode it is impossible to rotate or pan the 3D view, although zooming still works. But you can temporarily switch out of edit mode with the Std ToggleNavigation command should you need to change the view.
  2. Select a single open mesh object.
  3. Select the Meshes → Mesh AddFacet.svg Add triangle option from the menu.
  4. If you hover over a vertex along a boundary of the mesh a yellow marker will appear and a left-click will select it.
  5. Select two additional points to define a triangular face. The order of the three points, clockwise or counterclockwise, determines the direction of the normal of the face.
  6. A menu pops up with the following options:
    • Add triangle: adds the face to the mesh.
    • Flip normal: flips the normal of the face. After selecting this option a left-click will again show the menu.
    • Clear: removes the selected points.
  7. Optionally add more faces.
  8. Choose Finish from the 3D view contex menu to finish the command.

Notes

  • For a clear indication of the orientation of the faces of mesh objects make sure the ViewLighting property of the mesh objects is set to One side. The color of the back side of their faces will then depend on the backlight settings: Edit → Preferences... → Display → 3D View → Backlight color - Intensity. See: Preferences Editor.


Arrow-left.svg Mesh FillInteractiveHole.svg Chiudi il buco Pagina precedente:
Pagina successiva: Rimuovi componente Mesh RemoveComponents.svg Arrow-right.svg