Создание двумерных чертежей

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Manual:Generating 2D drawings and the translation is 83% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎română • ‎русский
Этот урок использует последние возможности разрабатываемой версии FreeCAD 0.19.

Если Ваша модель не может быть напечатана или выфрезерована машиной напрямую, например, слишком велика (строение) или требует ручной сборки из готовых частей, Вам нужен способ показать, как это делается, человеку. В технических кругах (архитектура, инженерное дело и т.д.) это делается чертежами. Чертежи передаются человеку, ответственному за конечную сборку продукта, которые показывают ему, как это сделать.

Типичным примером могут служить инструкции сборки Ikea, архитектурные чертежи или синьки. Эти чертежи обычно содержат не только рисунки, но и аннотации, такие как комментарии, размеры, выноски, символы, которые помогают понять, что и как должно быть сделано.

В FreeCAD рабочим столом для создания таких чертежей является Workbench TechDraw.svg TechDraw/ru|верстак TechDraw.

Верстак TechDraw позволяет создать листы, пустые или содержащие предварительно сделанные шаблоны, уже содержащие рамки и основную надпись. На этих листах можно поместить виды ранее смоделированных Вами трёхмерных объектов, и сконфигурировать, как эти виды будут выглядеть на листе. Вы так же можете поместить на Ваш лист все виды аннотаций, такие как размерности, тексты, и прочие обычные символы, обычно используемые в техническом черчении.

Готовые чертёжные листы могут быть напечатаны или экспортированы в файлы форматов SVG, PDF или DXF.

В следующем примере мы посмотрим как создать простой чертёж модели стула, находящейся в библиотеке FreeCAD (Furniture → Chairs → IkeaLikeChair). Библиотека FreeCAD может быть легко добавлена к Вашей установке FreeCAD (смотрите главу установка данного руководства), или Вы можете просто загрузить модель с веб-страницы библиотеки, или через прямую ссылку внизу этой главы.

Exercise TechDraw 01.svg

  • Загрузите из библиотеки файл IkeaLikeChair. Можно выбрать между версией .FCStd с полной историей моделирования, или версией .step, создающей лишь объект, без истории. Поскольку нам больше не нужно модерировать стул, лучше взять версию .step, котороу легче манипулировать.

Parts library.jpg

  • Переключимся на Workbench TechDraw.svg верстак TechDraw
  • Нажмём на кнопку Techdraw-new-pick.svg Вставить новую страницу с помощью шаблона.
  • Выберем шаблон A4_Portrait_ISO7200TD. В окне FreeCAD откроется новая вкладка, показывающая новый лист.
  • В древе проекта (или вкладке модели) выделим модель стула. Она скорее всего будет названа как-то вроде "Open CASCADE STEP translator."
  • Нажмём кнопку TechDraw View.svg Вставить вид на страницу.
  • На нашей странице будет создан объект View. Выделите объект view в древе проекта и зададите ему следующие параметры на вкладке Данные комбинированного вида:
    • Под категорией Основание:
      • X: 70 mm
      • Y: 120 mm
      • Rotation: 0
      • Scale: 0.1
    • Под категорией Projection (нажмите стрелку вниз для модификации компонент x, y, и z этих параметров отдельно):
      • Direction: [0 0 1]
      • XDirection: [0 -1 0] (Change the y field first, then the x field)
  • Теперь у нас есть прекрасный вид нашего стула сверху. Нажмите кнопку Techdraw-toggleframe.svg Toggle для выключения View frames, labels, и vertices:

Exercise drawing 02.jpg

  • Повторим нашу операцию дважды, чтобы сделать ещё два вида. Установим значения X и Y, показывающие позиции наших видов на странице, чтобы показать их в стороне от вида сверху, и их направления, чтобы показать их с разных сторон. Придадим видам следующие параметры:
    • View001 (вид спереди): X: 70, Y: 220, Scale: 0.1, Rotation: 0, Direction: (-1,0,0), XDirection: (0,-1,0)
    • View002 (вид сбоку): X: 150, Y: 220, Scale: 0.1, Rotation: 0, Direction: (0,-1,0), XDirection: (1,0,0)
  • После этого у нас получится следующая страница:

Exercise TechDraw 04.png

  • При желании мы можем настроить наши виды. Мы можем просто повернуть трёхмерный вид вашей модели, и когда получите вид, который вы хотите, выберите модель в древе проекта и нажмите TechDraw View.svg вставку нового вида на страницу. Это автоматически вставит вид с желаемыми свойствами поворота и направления. Можно так же использовать инструмент TechDraw NewProjGroup.svg Projection Group.
  • We can tweak the aspect of our views if we want, for example we can change their Line Width property (under the View tab in the Combo View) to 0.5.

Теперь поместим на нашем чертеже размеры и выноски. Есть два пути для указания в модели размерностей: одно - указание размерностей внутри модели, используя инструмент Draft Dimension.svg Размер из верстака Draft, и поместить вид этих размеров на нашем листе с помощью инструмента Techdraw-draft-view.svg New Draft. По-другому мы можем делать это напрямую на чертёжном листе. Мы используем последний метод.

  • Нажмём на переключаемую кнопку Techdraw-toggleframe.svg для включения вершин.
  • Используем Ctrl + Клик левой кнопкой мыши для выбора двух вершин, между которыми Вы хотите измерить дистанцию.
  • Нажмём на кнопку TechDraw Dimension Length.svg Dimension Length.

Exercise TechDraw 05.png


  • Повторяйте операцию, пока все размеры, которые вы хотите указать, не будут размещены. Используйте инструменты TechDraw Dimension Vertical.svg Вертикальный размер и TechDraw Dimension Horizontal.svg Горизонтальный размер, если нужно.
  • Найдите минутку, чтобы взглянуть на параметры объекта Dimension в комбинированном представлении.
  • Обратите внимание, что если вы измеряете аксонометрический вид (например, изометрический) вместо прямой проекции (например, вида спереди), как мы сделали здесь, вам следует использовать инструмент TechDraw Dimension Link.svg Dimension Link, чтобы получить правильное измерение.

Exercise TechDraw 07.png

  • Теперь мы разместим две выноски, показанные на изображении выше, используя инструмент TechDraw Balloon.svg Balloon.

Exercise TechDraw 06.png

  1. Глядя на страницу в окне трёхмерного вида, выберите вид, к которому Balloon будет прикреплен, как показано на рисунке выше.
  2. Нажмите кнопку Balloon TechDraw Balloon.svg .
  3. Курсор теперь отображается в виде значка с изображением шарика. Нажмите на страницу, чтобы поместить исходную точку выноски в нужное место.
  4. Выноску можно перетащить в нужное положение.
  5. Измените свойства выноски, дважды щелкнув на значке его метки или объекте выноски в древе проекта. Откроется диалоговое окно Balloon Task. Установите в поле «Значение» нужный текст и измените выделение раскрывающегося меню «Символ» на None
  6. Нажмите OK
  7. Повторите операцию для второго выносного элемента.
  • Теперь мы заполним блок заголовка листа.
    • Убедитесь, что видимые рамки, метки и вершины видны. Если нет, нажмите кнопку Techdraw-toggleframe.svg.
    • Отредактируйте текст в каждом разделе заголовка листа, щелкнув по маленькому зеленому квадрату в левой части текста.

Теперь наша страница может быть экспортирована в SVG для дальнейшей работы в графических приложениях вроде inkscape, или в DXF. Выберите страницу в древовидном представлении, а затем выберите меню Файл → Экспортировать. Формат DXF может быть импортирован практически во все существующие двумерные приложения САПР. Страницы TechDraw так же могут быть распечатаны или экспортированы в PDF.

Загрузки

Читать далее

Watch turorials