Визуализация проекта

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Manual:Creating renderings and the translation is 83% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎română • ‎русский

В разговорах компьютерщиков слово рендеринг означает красивое изображение, получаемое из трёхмерной модели. Разумеется, мы можем сказать что трёхмерный вид FreeCAD уже красив. Однако всякий, кто видел современные голливудские картины, знает, что с помощью компьютера возможно создавать изображения, которые почти неотличимы от фотографий.

Разумеется, создание фотореалистичных изображений требует большой работы, кроме приложений, предлагающих специффичные инструменты для этой задачи, вроде точной настройки материалов и света. Поскольку FreeCAD это приложение для технического моделирования, он не имеет каких-либо совершенных инструментов рендеринга.

По счастью, мир открытых исходников предлагает много приложений для создания фотореалистичных изображений. Наиболее известный из них, вероятно, Blender, очень популярный и широко используемый в создании фильмов и игр. Объёмные модели могут быть легко экспортированы из FreeCAD в Blender, где Вы можете добавить реалистичные материалы и освещение, и создать окончательные изображения или даже анимацию.

Некоторые другие инструменты рендеринга с открытыми исходниками сделаны для использования в других приложениях, и берут на себя сложные вычисления для получения фотореалистичных изображений. С помощью своего верстака Raytracing FreeCAD может использовать два из этих инструментов: POV-Ray и Luxrender. POV-Ray - очень старый проект, считающийся классическим движком трассировки лучей, в то время как Luxrender более новый, и производит рендерингу без допущений. Оба имеют свои достоинства и недостатки, в зависимости от типа изображений, которые требуется визуализировать. Лучше всего познакомиться с этим, посмотрев примеры на вебсайтах этих программ.

Установка

Чтобы можно было использовать в FreeCAD верстак Raytracing, одно из этих приложений визуализации должно быть установлено в вашей системе. Обычно это просто. У обоих или есть установщики для многих платформ, или они уже включены в репозитории большинства дистрибутивов Linux.

Когда POV-Ray или Luxrender установлен, требуется установить путь к их исполняемому файлу в настройках FreeCAD. Это обычно требуется только в Windows или Mac. В Linux FreeCAD возьмёт их из стандартного местоположения. Положение исполняемых файлов povray или luxrender можно найти поиском файлов povray (или povray.exe в Windows) и luxrender (или luxrender.exe в Windows).

Exercise raytracing 01.jpg

На экране настройки мы можем так же установить желаемый размер создаваемого изображения.

Визуализация с помощью PovRay

Мы будем использовать стол, смоделированный в главе, посвящённой традиционному моделированию, для создания фотореалистичных изображений с помощью PovRay и Luxrender.

  • Начнём с загрузки файла table.FCStd, который был создан ранее или загружен по ссылке внизу этой главы.
  • Нажмём маленькую стрелку вниз возле кнопки Raytrace New.svg New Povray project, выбрав шаблон RadiosityNormal.
  • Появится сообщение, предупреждающее что текущий трёхмерный вид не в перспективной проекции, и визуализация будет выглядеть иначе. Скорректируйте это, выбрав Нет, затем выбрав в меню Вид->Перспективная проекция и выбрав шаблон RadiosityNormal снова.
  • Вы можете так же попробовать другие шаблоны после создания нового проекта, просто редактируя параметр Template.
  • Новый проект теперь создан:

Exercise raytracing 02.jpg

  • Новый проект получает точку зрения трёхмерного вида в момент нажатия кнопки. Мы можем в любой момент изменить вид и обновить сохранённую в проекте Povray точку зрения, нажав кнопку Raytrace ResetCamera.svg Reset camera.
  • Верстак Raytracing работает так же, как и Drawing Workbench: как только папка проекта создана, мы должны добавить в него Views нашего проекта. Мы можем сделать это выбором всех объектов, составляющих стол, и нажав кнопку Raytrace NewPartSegment.svg Вставить деталь:

Exercise raytracing 03.jpg

  • Вид получает значения цвета и прозрачности из оригинальных частей, но вы можете, при желании, изменить это в параметрах каждого вида.
  • Теперь мы готовы создать нашу первую визуализацию Povray. Нажмём кнопку Raytrace Render.svg Render.
  • Примечание для пользователей Windows: при получении (в Povray) предупреждения о том, что «I/O restrictions prohibit write access ...»
    • откройте Povray
    • выберите «"Options > Script I/O Restrictions"» и убедитесь, что для него установлено значение «No Restrictions»
    • повторить рендеринг
  • У Вас запросят имя и путь к файлу с изображением в формате .png, который создаст Povray.
  • Теперь Povray запустится и вычислит изображение.
  • Когда это будет готово, для закрытия окна Povray кликните изображение. Полученное изображение будет загружено в FreeCAD:

Exercise raytracing 04.jpg

Визуализация с помощью LuxRender

  • Визуализация с помощью Luxrender работает примерно так же. Мы можем оставить наш файл открытым и создать новый проект Luxrender в том же файле, или перезагрузить его, чтобы начать с нуля.
  • Нажмём маленькую стрелку вниз около кнопки Raytrace Lux.svg New Luxrender project и выберем шаблон LuxOutdoor.
  • Выберем все компоненты стола. Если у Вас в документе имеется проект Povray, выделите так же сам проект Luxrender, чтобы вид, созданный на следующем шаге, не выбрал по ошибке неправильный проект.
  • Нажмите кнопку Raytrace NewPartSegment.svg Вставить деталь.
  • Выделите проект Luxrender, и нажмите кнопку Raytrace Render.svg Render.
  • Luxrender работает не так, как Povray. Когда Вы запустите визуализатор, приложение Luxrender откроется и немедленно начнёт рендеринг:

Exercise raytracing 05.jpg

  • Если Вы оставите это окно открытым, Luxrender продолжит вычисление и визуализацию бесконечно уточняя изображение. От вас зависит решить, когда изображение достигнет должного качества и наступит время остановить рендеринг.
  • Существует множество настроек, с которыми можно будет поиграться на левой панели. Все эти настройки меняют вид отрисовываемого изображения на лету, без остановки процесса визуализации.
  • Когда Вы решите, что качество достаточно, нажмите Render->stop, а затем Файл->Export to image->Tonemapped low dynamic range для сохранения отрисованного изображения в файл .png.

Вы можете сильно расширить возможности рендеринга в FreeCAD, создав новые шаблоны Povray или Luxrender. Это описывается в документации модуля Raytracing.

Загрузки

Читать далее