Моделирование BIM

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Manual:BIM modeling and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎hrvatski • ‎italiano • ‎română • ‎русский

This documentation is not finished. Please help and contribute documentation.

Gui Command explains how tools should be documented. See Draft ShapeString for an example of a well documented tool. Browse Category:UnfinishedDocu to see incomplete pages like this one. See Category:Command Reference for all commands.

See WikiPages to learn about editing the wiki pages, and go to Help FreeCAD to learn about other ways in which you can contribute.

BIM расшифровывается как Building Information Modeling (Информационное моделирование зданий). Точное определение может различаться, но упрощённо можно сказать, что это о том, как сейчас моделируются здания и другие большие структуры вроде мостов, тоннелей и так далее. Модель BIM обычно базируется на трёхмерной модели, и так же включает серию дополнительных информационных слоёв, таких как информация о материалах, связи с другими объектами и моделями, или специальные инструкции по строительству или эксплуатации. Дополнительная информация разрешает включать все виды современных анализов модели, такие как структурная устойчивость, оценки стоимости и сроков строительства, или расчетов потребления энергии.

Верстак FreeCAD Arch предоставляет набор инструментов и возможностей для создания моделей BIM. Хотя он имеет другое применение, он сделан для работы в тесной интеграции с остальной частью FreeCAD: всё, что создано любым из прочих верстаков FreeCAD может превратиться в объект Arch, или послужить базой для объекта Arch.

Как в верстаке PartDesign, создаваемые в верстаке Arch объекты делаются для реализации в реальном мире. Следовательно, они должны быть твердотельными. Инструменты Arch обычно автоматически следят за этим, но есть так же утилиты, помогающие проверить пригодность объектов.

Верстак Arch так же включает все инструменты из верстака Draft, и использует его систему сеток и привязки. Перед началом желательно просмотреть страницу настроек верстаков Draft и Arch и установить желательные значения по умолчанию.

В этой главе мы посмотрим как моделировать это небольшое здание:

Exercise arch 01.jpg

и создадим его план и вид в разрезе:

Exercise arch 02.jpg

  • Создадим новый документ, и переключимся на верстак Arch.
  • Откроем меню Правка → Параметры → Draft → Grid and Snapping и установим расстояние между линиями сетки в 1000 mm мм, так что у нас будет метровая сетка, соответствующая размеру нашего строения.
  • На панели привязок убедимся, что кнопка Snap Grid.svg Сетка включена, так что мы можем использовать сетку насколько можно.
  • Установим Выбор плоскости на XY
  • Нарисуем четыре линии инструментом Draft Line.svg Линия. Координаты можно вводить вручную, или указывать точке в сетке с помощью мыши:
    • От точки (0,0) к точке (0,3)
    • От точки (0,3) к точке (4,3)
    • От точки (4,3) к точке (4,0)
    • От точки (4,0) к точке (0,0)

Exercise arch 03.jpg

Заметьте, что мы рисовали в одном направлении (по часовой стрелке). Это не обязательно, но гарантирует, что стены, которые мы потом создадим, будут иметь то же левое и правое направление. Вы можете подумать, что мы могли бы нарисовать здесь прямоугольник, и это правда. Но четыре линии позволяют нам лучше иллюстрировать, как добавить один объект в другой.

  • Выделите первую линию, затем нажмите кнопку Arch Wall.svg Wall.
  • Повторите для остальных трёх линий, пока не появится 4 стены.
  • Выделите 4 стены и установите параметр Height в 3,00 м и их Alignment в left. Если Вы рисовали линии стен не в рекомендованном выше порядке, у некоторых из них левая и правая стороны будут в противоположном направлении, и для них надо будет указать right. У Вас получится 4 пересекающиеся стены внутри базовых линий:

Exercise arch 04.jpg

Теперь нам надо объединить наши стены, так что они пересекаются правильно. Это не обязательно, если Вы рисовали так, что они уже чётко соединены, но здесь это надо, поскольку они пересекаются. В Arch это делается выбором одной из стен как "host", и добавлением других как "additions". Все объекты Arch могут присоединять любое число добавлений (объекты, чья геометрия добавляется к геометрии хоста), и вычитаний (объекты, чья геометрия вычитается). Добавления и вычитания объекта могут управляться в любое время двойным кликом на объекте в древе проекта.

  • Выделите четыре стены с нажатой кнопкой Ctrl, последняя будет выбрана хостом
  • Нажмите кнопку Arch Add.svg Add. Четыре стены превратятся в одну:

Exercise arch 05.jpg

Отдельные стены по-прежнему доступны, если раскрыть иерархию стен в древе проекта.

  • Теперь вставим дверь. В FreeCAD двери считаются особым видом окон, так что это делается инструментом Окно.
  • Начнём с выделения стены. Это не обязательно, но хорошая привычка. Если объект выделен при запуске этого инструмента, вы обязательно вставите окно в этот объект, даже если Вы захватите другой объект.
  • Установите Выбор плоскости в auto, чтобы мы не были ограничены полом
  • Нажмите кнопку Arch Window.svg Окно.
  • В панели создания окна выберите установку Simple door, и установите его Width в 0,9 м и его Height в 2,1 м
  • Убедитесь, что включена привязка Snap Near.svg Ближайшие, чтобы мы могли делать захват поверхностей.
  • Поместим наше окно примерно в середину передней поверхности стены:

Exercise arch 06.jpg

  • После клика наше окно будет помещено на нужную стену, но не там, где надо:

Exercise arch 07.jpg

  • Теперь мы можем установить точное положение раскрытием объектов стена и окно в древе проекта, и изменением параметра Placement базового эскиза двери. Установите его позицию в x = 2 м, y = 0, z = 0. Теперь наше окно точно там, где мы хотим:

Exercise arch 08.jpg

  • Повторим операцию, чтобы поместить окно: выделим стену, выберем инструмент Окно, выберем шаблон Open 2-pane, и поместим окно 1м x 1 м на ту же стену, что и дверь. Установим положение нижележащего эскиза в x = 0.6m, y = 0, z = 1.1m, чтобы верхняя линия окна была на одном уровне с дверью.

Exercise arch 09.jpg

Окна всегда строятся на эскизах. Можно легко создать своё окно созданием эскиза на поверхности и превращением его в окно его выделением и нажатием кнопки Окно. Затем параметры создания окна, то есть какие линии эскиза должны быть выдавлены и насколько, можно определить кликнув дважды по окну в дереве проекта. Давайте сделаем заготовку:

  • Установим рабочую плоскость в XY
  • Создадим Draft Rectangle.svg прямоугольник длинной 5 м и высотой 4m, и поместим его в позицию x = -0,5м, y = -0,5 м, z = 0.
  • Выделим прямоугольник
  • Кликнем инструмент Arch Structure.svg структура для создания плиты из прямоугольника
  • Установим параметр заготовки height в 0,2 м и его направление normal в (0,0,-1), поскольку мы хотим выдавливать вниз. Мы можем так же сместить его на 0,2 вниз, но лучше оставлять выдавленный объект в том же месте, где и его базовый профиль.
  • Установим параметр Role заготовки в slab. В FreeCAD это не обязательно, но важно для экспорта в IFC, поскольку гарантирует, что объект будет экспортирован в правильный тип IFC.

Exercise arch 10.jpg

  • Теперь используем одну из структуральных наборов для создания металлических балок. Кликнем кнопку Arch Structure.svg Структура, выберем набор HEB 180, и установим его высоту в . Поместим его куда-нибудь:

Exercise arch 11.jpg

  • Настройте её placement, установив Angle в 90° в осях (1,0,0), и position в x:90mm, y:3.5m, z:3.09m. Это поместит балку прямо на одной из боковых стен:

Exercise arch 12.jpg

  • Теперь эту балку надо продублировать несколько раз. Мы можем это сделать с помощью инструмента Draft Clone.svg клонирования, но лучше сделать все копии за раз как массив:
  • Выделим балку
  • Нажмём кнопку Draft Array.svg Array
  • Установим параметр массива Number X равным 6, оставив Y и Z равным 1
  • Раскроем параметр interval X, и нажмём маленькую иконку Bound-expression-unset.png expression в правой части поля X . Это откроет редактор выражений:

Exercise arch 13.jpg

  • Запишем в поле выражений (4m-180mm)/5 и нажмём OK. Это установит значение x в 0,764 м (при полной длине фасадной стены 4 м и ширине балки 180 мм, которая поэтому зовётся HEB180, чтобы уложить пять промежутков между балками в оставшемся пространстве):

Exercise arch 14.jpg

  • Теперь мы запросто сможем создать простую плиту поверх балок, рисуя прямоугольник прямо на верхней поверхности балок. Выделим верх одной из балок
  • Нажмём кнопку Draft SelectPlane.svg Выбор плоскости. Рабочая плоскость теперь совпадает с этой поверхностью.
  • Создадим Draft Rectangle.svg прямоугольник, захватив две противоположные точки крайних балок:

Exercise arch 15.jpg

  • Выделим прямоугольник
  • Нажмём кнопку Arch Structure.svg Структура и создадим плиту высотой 0,2 м.

Всё, наша модель готова. Теперь её надо организовать так, чтобы корректно экспортировать её в IFC. Формат IFC требует, чтобы все объекты здания были внутри создаваемого объекта, и, возможно, внутри истории. Это так же требует чтобы все строения помещались внутри участка, но экспортёр FreeCADа при необходимости добавляет участок по умолчанию, так что нам нет необходимости добавлять его здесь.

  • Выделим две плиты, стены и массив балок
  • Нажмём кнопку Arch Floor.svg Этаж
  • Выделим созданный нами этаж
  • Нажмём кнопку Arch Building.svg Здание

Теперь наша модель готова к экспорту:

Exercise arch 16.jpg

Формат IFC - одна из важнейших ценностей в свободном мире BIM, поскольку он позволяет обмениваться данными между любыми приложениями и участниками мира конструирования, в открытой манере (формат открыт, свободен и поддерживается независимым консорциумом). Экспорт вашей модели BIM в IFC гарантирует, что любой может увидеть и проанализировать его, вне зависимости от используемого приложения.

В FreeCAD импорт и экспорт в IFC производится через другое приложение, называемое IfcOpenShell. Чтобы экспортировать в IFC из FreeCAD, в вашей системе должен быть установлен пакет IfcOpenShell-python. Убедитесь, что выбрали тот, что использует ту же версию Python, что и FreeCAD. Версию Python, которую использует FreeCAD, можно узнать, открыв в нём панель View -> Panels -> Python console. Когда всё готово, можно экспортировать нашу модель:

  • Выделить головной объект для экспорта, это будет Building.
  • Выделить в меню File -> Export -> Industry Foundation Classes и сохранить свой файл.
  • Полученный файл IFC теперь может быть открыть множеством приложений и просмотрщиков (изображение ниже показывает открытый файл в свободном просмотрщике IfcPlusPlus). Проверка экспортированного файла в этом просмотрщике перед отправкой другим людям желательна, чтобы убедиться в корректности содержащихся в файле данных. Так же можно использовать FreeCAD для повторного открытия полученного файла IFC.

Exercise arch 17.jpg

Теперь поставим некоторые размеры. В отличие от предыдущей главы, где мы чертили размеры прямо на чертёжном листе, здесь мы используем другой метод, и поместим размеры прямо в трёхмерной модели. Эти размеры затем будут помещены на чертёжном листе автоматически. Сначала мы сделаем две группы наших размеров, одна для тех, что будет помещена на виде сверху, другая для вида со стороны фасада.

  • Правым кликом на документе в древе проекта создадим две новые группы: Plan dimensions и Elevation dimensions.
  • Установим рабочую плоскость в XY
  • Убедимся, что Snap WorkingPlane.svg привязка к рабочей плоскости включена, чтобы всё оставалось в её пределах.
  • Поставим пару Draft Dimension.png размеров, например, как на рисунке ниже. Нажатие Shift или Ctrl во время захвата размерных точек во время привязки даст дополнительные опции.

Exercise arch 18.jpg

  • Выделите все ваши размеры и перетащите их в группу Plan dimensions древа проектов
  • Установите рабочую плоскость в XZ, фронтальную вертикальную.
  • Повторите операцию, создав пару размеров, и поместив их в группу Elevation dimensions.

Exercise arch 19.jpg

Теперь приготовим набор видов нашей модели для размещения на странице чертежа. Это можно сделать с помощью инструментов верстака Drawing, как это делалось в предыдущей главе, но верстак Arch так же предлагает универсальный продвинутый инструмент для создания планов, сечений и фасадных видов, называемый Плоскость сечения. Теперь мы добавим две из этих сечений для создания вида сверху и фронтального вида.

  • Выделите строение в древе проекта
  • Нажмите кнопку Arch SectionPlane.svg Плоскость сечения.
  • Установите параметр Display Height в 5m, его Display Length в 6m, чтобы охватить наш дом (это не обязательно, но лучше выглядит, поскольку покажет естественно для чего он используется), и его Placement в x:2m, y:1.5m, z:1.5m.
  • Проверьте список объектов указываемых в Секущей плоскости двойным кликом в древе проекта. Секущие плоскости отрисовывают не все, а только выбранные объекты модели. Выбранные объекты Секущей плоскости могут быть изменены здесь.

Exercise arch 20.jpg

  • Повторите операцию для создания другого сечения, установите ту же длину и высоту экрана, и позицию в Placement, равную: x:2m, y:-2m, z:1.5m, angle: 90°, axis: x:1, y:0, z:0. Убедитесь, что эта новая секущая плоскость так же включает здание.

Exercise arch 21.jpg

Разработка верстака Drawing остановлена в FreeCAD 0.16, а в версии v0.17 был представлен новый верстак TechDraw, нацеленный на его замену. Верстак Drawing может быть удалён в будущих версиях. Используйте TechDraw Workbench вместо него.
  • Теперь у нас всё готово, и мы можем создать страницу Drawing. Начнём с переключения на верстак Drawing, и создадим новую Drawing Landscape A3.png страницу A3 (или выделим другую заготовку, по желанию).
  • Выделим первую секущую плоскость, использованную для вида сверху
  • Нажмём кнопку Drawing DraftView.png Draft View. Этот инструмент предлагает пару дополнительных возможностей, кроме стандартных для инструмента Drawing View, и поддерживает Секущие плоскости из верстака Arch.
  • Дадим новому виду следующие параметры:
    • X: 50
    • Y: 140
    • Scale: 0.03
    • Line width: 0.15
    • Show Cut True
    • Show Fill: True
  • Выделим другой вид, и создадим новый Draft View со следующими параметрами:
    • X: 250
    • Y: 150
    • Scale: 0.03
    • Rendering: Solid

Exercise arch 22.jpg

Теперь создадим ещё два вида Draft, по одному для каждой группы размеров.

  • Выделим группу Plan dimensions
  • Нажмём ryjgre Drawing DraftView.png Draft View.
  • Зададим новый вид со следующими параметрами:
    • X: 50
    • Y: 140
    • Scale: 0.03
    • Line width: 0.15
    • Font size: 10mm
  • Повторим операцию для другой группы со следующими параметрами:
    • X: 250
    • Y: 150
    • Scale: 0.03
    • Line width: 0.15
    • Font size: 10mm
    • Direction: 0,-1,0
    • Rotation: 90°

Наш лист теперь готов, и мы можем экспортировать его в формат SVG или DXF, или распечатать. Формат SVG вы можете открыть используя приложение для иллюстраций вроде Inkscape, где можно быстро преобразовать чертёж в презентационный рисунок. Он позволяет больше возможностей, чем DXF.

Загрузки

Сопутствующее