Manual07/fr

From FreeCAD Documentation
Jump to navigation Jump to search




Manuel



de



FreeCAD





Splash013.jpg




Ce manuel traite "Les utilitaires".


Draft



Cette page est spécialement destinée à l'impression, comme un gros document, donc, si vous lisez ceci en ligne, vous pourrez préférer aller directement à la version Aide en ligne, qui est plus facile à parcourir.

Outils utilitaires

Arrow-left.svg Page précédente: Draft Stretch.svg Etirer
Page suivante: Terminer la ligne Draft FinishLine.svg Arrow-right.svg

Draft SelectPlane.svg Draft Plan de travail

Emplacement du menu
Draft → Utilitaires → Plan de travail
Ateliers
Draft, Arch
Raccourci par défaut
W P
Introduit dans la version
-
Voir aussi
Draft Objet Proxy pour plan de travail, Draft Basculer l'affichage de la grille


Description

L'Workbench Draft.svg atelier Draft dispose d'un système de plan de travail qui vous permet d'indiquer un plan personnalisé dans la vue 3D sur lequel la prochaine commande Draft aura lieu. Il existe plusieurs méthodes pour définir le plan de travail :

  • Depuis une face sélectionnée
  • Depuis la vue courante
  • Depuis 3 vecteurs sélectionnés
  • D'un préréglage : dessus, de face ou latéral.
  • Aucun, auquel cas le plan de travail est adapté automatiquement à l'affichage actuel lorsque vous lancez une commande, ou à une face si vous commencez à dessiner sur une face existante.

WorkingPlane example.png

Différents plans de travail peuvent être définis sur lesquels seront dessiné des formes


Utilisation

Le bouton Draft SelectPlane.png Plan de travail est présent dans la barre d'outils Draft tray, qui apparaît seulement dans les ateliers Draft and Arch.

Sans élément sélectionné

  1. Appuyez sur le bouton Draft SelectPlane.svg Plan de travail, ou utilisez DraftUtilitiesDraft SelectPlane.svg Plan de travail dans le menu supérieur ou les raccourcis clavier W puis P
  2. Sélectionnez le décalage, l'espacement de la grille et les lignes principales
  3. Sélectionnez l'un des préréglages: View-top.svg XY (vue de dessus), View-front.svg XZ (vue de face), View-right.svg YZ (vue de côté), View-isometric.svg Vue ou View-axonometric.svg Auto.

Une fois le plan défini, le bouton changera pour indiquer le plan actif Draft SelectPlane.svg Vue de dessus, Draft SelectPlane.svg Vue de face, Draft SelectPlane.svg Vue de côté, Draft SelectPlane.png Auto, Draft SelectPlane.svg d(0.0,-1.0,0.0).

Vous pouvez afficher et masquer la grille avec les raccourcis G R.

Avec élément sélectionné

  1. Sélectionnez une face d'un objet existant dans la vue 3D ou maintenez la touche Ctrl et sélectionnez trois sommets d'un objet. Introduit dans la version 0.17
  2. Appuyez sur la touche Draft SelectPlane.svg Plan de travail ou faites un clic droit et sélectionnez Utilitaires → Draft SelectPlane.svg Plan de travail.

Le plan sera créé aligné sur la face de l'objet ou sur le plan défini par les trois sommets.

Options

  • Appuyez sur le bouton View-top.svg XY (Vue de dessus) pour définir le plan de travail sur le plan XY. Pour dessiner facilement sur ce plan, vous devez régler la vue vers le haut ou vers le bas (la normale est dans la direction Z positive ou négative). Appuyez sur 2 ou 5 pour passer rapidement à ces vues.
  • Appuyez sur le bouton View-front.svg XZ (Vue de face) pour définir le plan de travail sur le plan XZ. Pour dessiner facilement sur ce plan, vous devez régler la vue vers l’avant ou l’arrière (la normale est dans la direction Y négative ou positive). Appuyez sur 1 ou 4 pour basculer rapidement sur ces vues.
  • Appuyez sur le bouton View-right.svg YZ (Vue de côté) pour définir le plan de travail sur le plan YZ. Pour dessiner facilement sur ce plan, vous devez définir la vue du côté gauche ou du côté droit (la normale est dans la direction X positive ou négative). Appuyez sur 3 ou 6 pour basculer rapidement sur ces vues.
  • Appuyez sur le bouton View-isometric.svg Vue isométrique pour définir le plan de travail sur la vue 3D actuelle, perpendiculairement à l'axe de la caméra et passant par l'origine (0,0,0)
  • Appuyez sur le bouton View-axonometric.svg Auto pour désactiver le plan de travail actuel et définir automatiquement un plan de travail lorsqu'un outil est utilisé. Lorsqu'un outil de dessin est sélectionné, la grille est automatiquement mise à jour dans la vue actuelle. puis, si la vue est pivotée et qu'un autre outil est sélectionné, la grille se redessine dans la nouvelle vue. Cela équivaut à appuyer automatiquement sur le bouton View-isometric.svg Vue isométrique avant d'utiliser un outil.
  • Définissez la valeur "Offset" pour définir le plan de travail à une certaine distance perpendiculaire du plan que vous avez sélectionné.
  • Définissez la valeur "Espacement de la grille" pour définir l'espace entre chaque ligne de la grille.
  • Définissez la valeur "Ligne principale tous les" pour tracer une ligne légèrement plus épaisse dans la grille à la valeur définie. Par exemple, si l'espacement de la grille est de 0,5 m et s'il existe une ligne principale toutes les 20 lignes, il y aura une ligne légèrement plus épaisse tous les 10 m.
  • Cliquez sur la case à cocher "Plan central au centre de la vue" pour rapprocher le plan et la grille de la vue caméra dans la vue 3D.
  • Appuyez sur Echap ou sur le bouton Fermer pour annuler la commande en cours.

Script

Voir aussi: Draft API and Débuter avec les scripts. Voir WorkingPlane API.

Les objets du plan de travail peuvent facilement être créés et manipulés par macros et à partir de la console Python.

Vous pouvez accéder au plan de travail de la version actuelle et lui appliquer des transformations:

import FreeCAD as App
import FreeCADGui as Gui

workplane = App.DraftWorkingPlane

v1 = App.Vector(0, 0, 0)
v2 = App.Vector(1, 1, 1).normalize()

workplane.alignToPointAndAxis(v1, v2, 17)
Gui.Snapper.toggleGrid()
Gui.Snapper.toggleGrid()

Une commande Draft doit être émise après avoir changé le plan de travail pour mettre à jour la grille visible, par exemple, Draft Ligne ou simplement Draft Basculer l'affichage de la grille.

Vous pouvez créer vos propres plans et les utiliser indépendamment du plan de travail actuel. Ceci est utile si vous devez effectuer des calculs ou des projections dans ces autres plans.

import WorkingPlane

my_plane = WorkingPlane.plane()

v1 = App.Vector(0, 0, 0)
v2 = App.Vector(1, 1, 1).normalize()
my_plane.alignToPointAndAxis(v1, v2, 17)

projection = my_plane.projectPoint(App.Vector(10, 15, 2))
print(projection)

Pour afficher une nouvelle grille, utilisez un nouvel objet tracker. Configurez d'abord le plan de travail normal selon vos besoins puis créez un nouvel objet de suivi, puis définissez-le sur le plan actuel, puis vous pouvez l'activer ou le désactiver.

import FreeCAD as App
import DraftTrackers

App.DraftWorkingPlane.alignToPointAndAxis(App.Vector(0, 0, 0),
                                          App.Vector(1, 0, 0),
                                          0)

my_grid = DraftTrackers.gridTracker()
my_grid.set()
my_grid.on()
my_grid.off()

Cette grille est simplement une aide visuelle et ne permet pas de s'accrocher.

Pour avoir la possibilité de passer rapidement à différentes grilles, dans différentes positions, vous devez créer un Draft SetWorkingPlaneProxy.svg Draft Objet Proxy pour plan de travail,.

Arrow-left.svg Page précédente: Draft Stretch.svg Etirer
Page suivante: Terminer la ligne Draft FinishLine.svg Arrow-right.svg
Arrow-left.svg Page précédente: Draft SelectPlane.svg Plan de travail
Page suivante: Fermer la ligne Draft CloseLine.svg Arrow-right.svg

Draft FinishLine.svg Draft Terminer la ligne

Emplacement du menu
Draft → Outils filaires → Terminer la ligne
Ateliers
Draft, Arch
Raccourci par défaut
A
Introduit dans la version
-
Voir aussi
Draft Fermer la ligne, Draft Annuler le dernier segment


Description

Cette commande termine le tracé d'une ligne en la laissant ouverte.

Utilisation

Utilisation

  1. Commencez à dessiner un Draft Wire.svg Draft Filaire
  2. Lancez la commande Terminer la ligne de plusieurs manières:
    • Appuyez sur le bouton Draft FinishLine.svg Draft Terminer la ligne dans la barre d'outils Draft
    • Appuyez sur le raccourci clavier A
    • Utilisez l'entrée Draft → Outils de filaires → Terminer la ligne dans le menu Draft
Arrow-left.svg Page précédente: Draft SelectPlane.svg Plan de travail
Page suivante: Fermer la ligne Draft CloseLine.svg Arrow-right.svg

Cette documentation n'est pas terminée. SVP contribuez en traduisant la documentation.

Allez voir Draft ShapeString pour un modèle de documentation. Gui Command donne un aperçu des commandes. Et, pour voir d'autres commandes Liste des Commandes.

Allez sur Help FreeCAD ou comment faire pour contribuer.

Arrow-left.svg Page précédente: Draft FinishLine.svg Terminer la ligne

Draft CloseLine.svg Draft Fermer la ligne

Emplacement du menu
Draft → Outils de filaires → Fermer la ligne
Ateliers
Draft, Arch
Raccourci par défaut
O
Introduit dans la version
-
Voir aussi
Draft Terminer la ligne, Draft Annuler le dernier segment


Description

Cette commande termine le tracé d'une ligne et la ferme en traçant un segment de fermeture entre le dernier point et le premier.

Une ligne fermée peut être configurée pour afficher une face remplie si la propriété DataMake Face est à True.

Utilisation

  1. Commencer à dessiner votre Draft Filaire.
  2. Lancer la commande Fermer la ligne de plusieurs manières:
    • Appuyez sur le bouton Draft Lock.svg Fermer la ligne dans la barre d'outils Draft
    • Appuyez sur le raccourci clavier O
    • Utilisez l'entrée Draft → Outils de filaires → Fermer la ligne dans le menu Draft

Propriétés

  • DonnéesMake Face True ou False
Arrow-left.svg Page précédente: Draft FinishLine.svg Terminer la ligne
Arrow-left.svg Page précédente: Draft CloseLine.svg Fermer la ligne

Draft UndoLine.svg Draft Annuler le dernier segment

Emplacement du menu
Draft → Outils filaires → Annuler le dernier segment
Ateliers
Draft, Arch
Raccourci par défaut
Ctrl + Z
Introduit dans la version
-
Voir aussi
Draft Terminer la ligne, Draft Fermer la ligne


Description

Cette commande annule le dernier segment du Draft Fil en cour de construction.

Utilisation

  1. Commencez à dessiner un Draft Wire.svg Draft Fil.
  2. Lancer la commande Annuler la ligne de plusieurs manières:
    • Appuyez sur le bouton Draft UndoLine.png Annuler le dernier segment Draft dans la barre d'outils Draft
    • Appuyez sur le raccourci clavier Ctrl+Z
    • Utilisez l'entrée Draft → Outils de filaires → Annuler le dernier segment dans le menu Draft
Arrow-left.svg Page précédente: Draft CloseLine.svg Fermer la ligne

Draft ToggleConstructionMode.svg Draft Basculer en mode construction

Emplacement du menu
Draft → Utilitaires → Basculer en mode construction
Ateliers
Draft, Arch
Raccourci par défaut
Aucun
Introduit dans la version
-
Voir aussi
Draft Ajouter au groupe de construction


Description

L'Workbench Draft.svg atelier Draft dispose d'un mode de construction qui permet à l'utilisateur de dessiner des formes dans un Std Group.svg Std Groupe spécial, avec une couleur définie. La géométrie de construction est composée de lignes, de points et d'autres formes qui servent de références ou d'éléments d'accrochage utiles pour la construction de votre géométrie principale. La géométrie de construction peut être masquée (VueVisibility False) ou supprimée une fois qu'elle n'est plus nécessaire.

Draft construction mode example.jpg

Géométrie de construction en bleu aidant à définir le centre du cercle


Utilisation

  1. Appuyez sur le bouton Draft ToggleConstructionMode.png Basculer en mode construction.
  2. Dessinez des objets.
  3. Appuyez à nouveau sur le bouton Draft ToggleConstructionMode.png Basculer en mode construction pour revenir en mode normal.

Le bouton de mode de construction Draft Construction.svg est présent dans la barre d'outils La barre Draft qui apparaît uniquement dans les ateliers Workbench Draft.svg Draft et Workbench Arch.svg Arch.

La couleur et le nom du groupe peuvent être modifiés dans les Préférences Draft.

Propriétés

  • VueVisibility La géométrie de construction peut être masquée False ou supprimée lorsqu'elle n'est plus nécessaire. (Admin Edit: Exactitude de la révision)

Draft ToggleContinueMode.svg Draft Inverser le mode continuer

Emplacement du menu
Draft → Utilitaires → Inverser le mode continuer
Ateliers
Draft, Arch
Raccourci par défaut
Aucun
Introduit dans la version
-
Voir aussi
Draft Filaire, Draft BSpline


Description

De nombreux outils de création de géométrie à partir des ateliers Workbench Draft.svg Draft et Workbench Arch.svg Arch vous permettent d'activer la case à cocher Continuer. Si le mode Continuer est activé, l'outil de dessin redémarre une fois que vous avez terminé, ce qui vous permet de dessiner un autre objet avec le même outil sans appuyer à nouveau sur le bouton de l'outil.

Cela vous permet de créer plusieurs objets à la suite jusqu'à ce que vous désactiviez la case à cocher Continuer ou que vous quittiez l'outil.

Utilisation

  1. Appelez une commande telle que Draft Line.svg Draft Ligne ou Arch Wall.svg Arch Mur.
  2. Appuyez sur la case à cocher Draft ToggleContinueMode.svg Inverser le mode continuer Draft.
  3. Utilisez l'outil normalement, en plaçant différentes lignes ou murs, les uns après les autres.
  4. Appuyez sur Echap ou sur le bouton Fermer pour annuler la commande en cours. Les objets déjà placés resteront.

Draft Apply.svg Draft Appliquer le style

Emplacement du menu
Draft → Utilitaire → Appliquer aux objets sélectionnés
Ateliers
Draft, Arch
Raccourci par défaut
Aucun
Introduit dans la version
-
Voir aussi
Draft La barre


Description

Cet outil applique la couleur de trait et de face actuelle ainsi que le style de trait aux objets sélectionnés.

Draft Tray

La barre de Draft définit les propriétés de couleur des faces et des lignes ainsi que la largeur et la taille du texte


Utilisation

  1. Définissez les couleurs de trait et de face souhaitées ainsi que la largeur de trait dans le Draft La barre.
  2. Sélectionnez un ou plusieurs objets.
  3. Appuyez sur le bouton Draft Apply.svg Draft Appliquer aux objets sélectionnés ou faites un clic droit et sélectionnez Utilities → Draft Apply.svg Draft Appliquer aux objets sélectionnés.

Si vous avez déjà sélectionné un objet, vous pouvez modifier la couleur et la largeur de trait. Les modifications seront appliquées immédiatement sans appuyer sur le bouton Draft Apply.svg Appliquer aux objets sélectionnés.

Le bouton Draft Apply.svg Draft Appliquer aux objets sélectionnés est présent dans la barre d'outils Draft La barre qui n'apparaît que dans l'Workbench Draft.svg Atelier Draft et l'Workbench Arch.svg Atelier Arch.


Arrow-left.svg Page précédente: Draft Apply.svg Appliquer le style actuel
Page suivante: Ajouter au groupe Draft AddToGroup.svg Arrow-right.svg

Draft ToggleDisplayMode.svg Draft Bascule du mode d'affichage

Emplacement du menu
Draft → Utilitaires → Bascule le mode d'affichage
Ateliers
Draft, Arch
Raccourci par défaut
Shift + Space
Introduit dans la version
-
Voir aussi
Std Basculer la visibilité


Description

Cet outil définit la propriété VueDisplay Mode d'un objet sélectionné sur "Flat Lines" ou "Wireframe". Lorsque le mode "Wireframe" est actif, seuls les bords de l'objet sont visibles. Cela vous aide à sélectionner des objets obstrués par d'autres objets.

Draft ToggleDisplayMode example.png

L'objet au premier plan obstrue la vue de l'objet derrière par conséquent, le premier est réglé sur "Wireframe" pour faciliter la sélection de ce dernier


Utilisation

  1. Sélectionnez les objets.
  2. Faites un clic droit et sélectionnez Utilities → Draft ToggleDisplayMode.png Bascule du mode d'affichage ou appuyez sur Shift+Barre espace.


Arrow-left.svg Page précédente: Draft Apply.svg Appliquer le style actuel
Page suivante: Ajouter au groupe Draft AddToGroup.svg Arrow-right.svg

Draft AddToGroup.svg Draft Ajouter au groupe

Emplacement du menu
Draft → Utilities → Ajouter au groupe
Ateliers
Draft, Arch
Raccourci par défaut
Aucun
Introduit dans la version
-
Voir aussi
Draft Sélection groupée, Std Créer un groupe


Description

Cet outil affiche un menu déroulant vous permettant d'ajouter les objets sélectionnés à un groupe existant ou de les supprimer de leur groupe actuel.

Cet outil peut ajouter des objets à un Group.svg Std Groupe, un Group.svg Draft Groupe de construction ou un Draft VisGroup.svg Draft Groupe visuel.

Pour ajouter les objets directement au Group.svg Draft Groupe de construction, vous pouvez utiliser Draft AddConstruction.svg Draft Ajouter construction.

Utilisation

  1. Sélectionnez les objets que vous souhaitez organiser.
  2. Cliquez avec le bouton droit et sélectionnez Utilities → Draft AddToGroup.svg Déplacer dans un groupe.
  3. Sélectionnez le groupe souhaité ou cliquez sur Dégrouper.

Au moins un des objets Group.svg Std Créer un groupe, Group.svg Draft Basculer en mode construction ou Draft Groupe visuel doit exister avant d'utiliser cet outil.

Liens

Arrow-left.svg Page précédente: Draft AddToGroup.svg Ajouter au groupe
Page suivante: Basculer l'accrochage Draft ToggleSnap.svg Arrow-right.svg

Draft SelectGroup.svg Draft Sélection groupée

Emplacement du menu
Draft → Utilitaires → Sélectionner le groupe
Ateliers
Draft, Arch
Raccourci par défaut
Aucun
Introduit dans la version
-
Voir aussi
Std Créer un groupe, Draft Ajouter au groupe


Description

Cet outil vous permet de sélectionner le contenu d'un ou plusieurs groupes sélectionnés.

Utilisation

  1. Sélectionnez un ou plusieurs objets dans la vue 3D ou un ou plusieurs groupes dans la vue en arborescence.
  2. Faites un clic droit et sélectionnez Utilitaires → Draft SelectGroup.svg Sélectionner le groupe.
  3. Tous les objets appartenant au même groupe que les objets initialement sélectionnés seront sélectionnés.

Au moins un des groupes de Group.svg Créer un groupe Std, Group.svg Basculer en mode construction Draft ou Draft VisGroup.svg Groupe visuel Draft doit exister avant d'utiliser cet outil.

Liens


Arrow-left.svg Page précédente: Draft AddToGroup.svg Ajouter au groupe
Page suivante: Basculer l'accrochage Draft ToggleSnap.svg Arrow-right.svg

Draft ToggleSnap.svg Draft Basculer Accroche

Emplacement du menu
Draft → Accrochage → Activer/désactiver
Ateliers
Draft, Arch
Raccourci par défaut
Aucun
Introduit dans la version
-
Voir aussi
Draft Accrochage, Draft Activer/désactiver la grille


Description

Cette commande permet d'activer ou de désactiver globalement l'accrochage Draft.

Draft Tray

Barre Draft qui vous permet de définir le plan de travail et la grille pouvant être utilisés avec les options d'accrochage


Utilisation

  1. Appuyez sur le bouton Draft SelectPlane.svg Plan de travail Draft pour définir un plan de travail.
  2. Cliquez avec le bouton droit de la souris sur l’espace de la barre d’outils ou allez au menu Affichage → Barres d’outils et assurez-vous que la barre d’outils Accrochage Draft soit visible.
  3. Appuyez sur le bouton Draft Grid.svg Basculer l'affichage de la grille Draft pour afficher la grille.
  4. Appuyez sur le bouton Snap Lock.svg Basculer l'accrochage Draft pour rendre les méthodes de capture disponibles.

Le bouton Draft SelectPlane.svg Draft Plan de travail est présent dans la barre d’outils Draft La barre. Il n’apparaît que dans les ateliers Workbench Draft.svg Draft et Workbench Arch.svg Arch.

Arrow-left.svg Page précédente: Contrainte
FreeCAD.png

Description

Les outils Workbench Draft.svg Draft vous permettent de sélectionner des points et des distances en cliquant sur la Vue 3D avec le pointeur ou en entrant Draft des Coordonnées dans le panneau des tâches de l'outil.

Une autre façon de sélectionner des points consiste à effectuer un accrochage. Accrochage signifie "coller" votre prochain point sur un point ou une caractéristique existant d'un autre objet.

L'accrochage est disponible avec la plupart des outils des ateliers Draft et Arch, et peut être activé ou désactivé globalement avec le bouton Draft ToggleSnap.svg Activer/désactiver situé dans la barre d'outil accrochage qui peut être affichée via le menu: Affichage → Barres d'outils → Draft Snap.

Remarque: l'utilisation de plusieurs méthodes de capture en même temps peut être problématique; dans ce cas, essayez d'activer une seule méthode de capture.

Draft Snap example.jpg

Une ligne accrochée perpendiculairement à une autre ligne


Barre d'outils Accrochages de Draft

  • Draft ToggleSnap.svg Toggle snap: active ou désactive accrochage aux objets globalement.
  • Snap Endpoint.svg Terminaison: s'accroche aux extrémités des segments de ligne, d'arc et de spline.
  • Snap Midpoint.svg Milieu: s'aligne sur le point central des segments de ligne et d'arc.
  • Snap Center.svg Centre: s'aligne sur le point central des arcs et des cercles.
  • Snap Angle.svg Angle: s'accroche aux points cardinaux spéciaux des cercles et des arcs, à 45 ° et à 90 °.
  • Snap Intersection.svg Intersection: capture à l'intersection de deux segments de ligne ou d'arc. Passez la souris sur les deux objets souhaités pour activer leurs instantanés d'intersection.
  • Snap Perpendicular.svg Perpendiculaire: sur les segments de droite et d'arc, s'accroche perpendiculairement au dernier point.
  • Snap Extension.svg Extension: capture sur une ligne imaginaire qui s'étend au-delà des extrémités des segments de ligne. Passez la souris sur l'objet souhaité pour activer sa capture d'extension.
  • Snap Parallel.svg Parallèle: capture sur une ligne imaginaire parallèle à un segment de ligne. Passez la souris sur l'objet souhaité pour activer son accrochage parallèle.
  • Snap Special.svg Spécial: capture sur des points spéciaux définis par l'objet. Introduit dans la version 0.17
  • Snap Near.svg Le plus proche: capture le point ou l'arête le plus proche sur l'objet le plus proche.
  • Snap Ortho.svg Ortho: capture les lignes imaginaires qui traversent le dernier point et s'étendent à 0°, 45° et 90°.
  • Snap Grid.svg Grille: capture les intersections des lignes de la grille, si la grille est visible.
  • Snap WorkingPlane.svg Working plane: place toujours le point capturé sur le plan de plan courant même si vous attachez un point en dehors de ce plan de travail.
  • Snap Dimensions.svg Dimensions: affiche les dimensions X et Y temporaires lors de la capture.
  • Draft ToggleGrid.svg Toggle grid: active ou désactive la visibilité de la grille.

Capture "avancée"

  • Vous pouvez obtenir des emplacements de capture supplémentaires en combinant deux méthodes de capture telles que Ortho et Extension qui vous donneront un point de capture à l'intersection de leurs lignes imaginaires.
  • Vous pouvez obtenir d'autres emplacements d'accrochage en utilisant Contraintes c'est-à-dire en maintenant Shift ou en appuyant sur X, Y ou Z en dessinant.
  • Appuyez sur Q pendant que vous dessinez pour insérer un "point de maintien" à la position actuelle du curseur. Vous pourrez alors effectuer une capture orthogonale à ces points de maintien et aux intersections de leurs axes orthogonaux. Si la capture Centre est activée, vous pourrez également faire une capture à mi-distance entre deux points de maintien. Introduit dans la version 0.17

Options

  • La distance maximale à laquelle un point est considéré comme un point d'accrochage est spécifiée dans Draft Préférences et peut également être modifiée à la volée en appuyant sur [ (augmenter) ou ] (diminuer) les touches.
  • En appuyant sur A pendant le dessin, on verrouille l'angle actuel du segment de ligne dessiné. (Editeur: peut-être obsolète?)
Arrow-left.svg Page précédente: Contrainte
FreeCAD.png

Draft ToggleGrid.svg Draft Visibilité de la grille

Emplacement du menu
Draft → Utilitaires → Basculer l'affichage de la grille
Ateliers
Draft, Arch
Raccourci par défaut
G R
Introduit dans la version
-
Voir aussi
Draft Accrochage, Draft Activer/désactiver l'accrochage


Description

Cette commande permet d'afficher ou de masquer la grille définie dans les préférences Draft ou avec l'outil Plan de travail.

Draft Tray

Barre Draft qui vous permet de définir le plan de travail et la grille


Utilisation

  1. Pour définir l'apparence de la grille dans les Draft Preferences, allez au menu Édition → Préférences → Draft → Grille et ancrage, définissez les options "Taille de la grille", "Espacement de la grille" et "Ligne principale chaque" puis appuyez sur OK.
  2. Cliquez ensuite avec le bouton droit de la souris sur un objet brouillon et sélectionnez Utilitaires → Draft Grid.svg Basculer l'affichage de la grille.
  3. Ou cliquez avec le bouton droit de la souris sur un espace vide d'une barre d'outils ou ouvrez le menu Vue → Barres d'outils puis cochez la case Accrochage Draft
  4. Il existe plusieurs façons de rendre la grille visible:
  5. * Utilisez le raccourci clavier G puis R

Une autre façon de définir la grille consiste à définir le plan de travail.

  1. Appuyez sur le bouton Draft SelectPlane.svg Draft Plan de travail.
  2. Vous n'avez pas besoin de définir un nouveau plan, il vous suffit de changer les options "Espacement de la grille" et "Ligne principale tous les" et la grille se mettra à jour en temps réel.
  3. Appuyez ensuite sur Echap ou sur le bouton Fermer pour abandonner la commande tout en conservant la nouvelle grille.

Le bouton Draft SelectPlane.svg Draft Plan de travail est présent dans la barre d’outils Draft La barre, qui n’apparaît que dans les ateliers Workbench Draft.svg Draft et Workbench Arch.svg Arch.

Page suivante: Réparer Draft Heal.svg Arrow-right.svg

Draft ShowSnapBar.svg Draft Monter la barre d'accrochage

Emplacement du menu
Draft → Utilitaires → Monter la barre d'accrochage
Ateliers
Draft, Arch
Raccourci par défaut
Aucun
Introduit dans la version
-
Voir aussi
Draft Accrochage, Draft Basculer l'accrochage


Description

Cette commande affiche la barre d’outils Accrochage Draft qui contient le Draft Grid.svg Basculer l'affichage de la grille Draft et Snap Lock.svg Basculer l'accrochage Draft ainsi que les différentes méthodes de capture.

Utilisation

  • Cliquez avec le bouton droit sur un objet Draft et sélectionnez Utilitaires → Draft Snap.svg Monter la barre d'accrochage.
  • Ou cliquez avec le bouton droit de la souris sur un espace vide de la barre d’outils puis cochez la case Accrochage draft.
  • Ou allez dans le menu Affichage → Barres d'outils et cliquez sur la case à cocher Accrochage draft.
Page suivante: Réparer Draft Heal.svg Arrow-right.svg

Credits

FreeCAD Users Contributors.svg

<translate> FreeCAD would not be what it is without the generous contributions of many people. Here's an overview of the people and companies who contributed to FreeCAD over time. For credits for the third party libraries see the Third Party Libraries page.

Development

Project managers

Lead developers of the FreeCAD project: </translate>

<translate>

Main developers

People who work regularly on the FreeCAD code (retrieved from https://github.com/FreeCAD/FreeCAD/graphs/contributors): </translate>

<translate>

Other coders

Other people who contributed code to the FreeCAD project: </translate>

  • Barleyman
  • Berthold Grupp
  • dbtayl
  • Dmitry Chigrin
  • ezzieyguywuf
  • fandaL
  • Georg Wiora
  • Graeme van der Vlugt
  • itain
  • j-dowsett
  • Jacques-Antoine Gaudin
  • jcc242
  • jmaustpc
  • Joachim Zettler
  • jobermayr
  • Johan3DV
  • jonnor
  • keithsloan52
  • Ken Cline
  • Mandeep Singh
  • marktaff
  • Martin Burbaum
  • maurerpe
  • ovginkel
  • peterl94
  • plaes
  • poutine70
  • TheMarkster
  • qingfengxia
  • Remigiusz Fiedler (DXF-parser)
  • SebKuzminsky
  • tomate44
  • triplus
  • usakhelo

<translate>

Companies

Companies which donated code or developer time: </translate>

<translate>

Forum moderators

People in charge of the FreeCAD forum (retrieved from http://forum.freecadweb.org/memberlist.php?mode=team): </translate>

<translate>

Community

People from the community who put a lot of efforts in helping the FreeCAD project either by being active on the forum, keeping a blog about FreeCAD, making video tutorials, packaging FreeCAD for Windows/Linux/MacOS X, writing a FreeCAD book... (listed by alphabetical order) (retrieved from http://forum.freecadweb.org/memberlist.php?mode=&sk=d&sd=d#memberlist) </translate>

<translate>

Documentation writers

People who wrote the documentation on this wiki: </translate>

<translate>

Translators

People who helped to translate the FreeCAD application (retrieved from https://crowdin.com/project/freecad): </translate>

<translate>

Addons developers

Developers of FreeCAD addons (retrieved from https://github.com/FreeCAD/FreeCAD-addons): </translate>