Настройка интерфейса

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Interface Customization and the translation is 24% complete.
Outdated translations are marked like this.
Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎українська • ‎中文 • ‎中文(中国大陆)‎ • ‎日本語 • ‎한국어

This documentation is not finished. Please help and contribute documentation.

Gui Command explains how tools should be documented. See Draft ShapeString for an example of a well documented tool. Browse Category:UnfinishedDocu to see incomplete pages like this one. See Category:Command Reference for all commands.

See WikiPages to learn about editing the wiki pages, and go to Help FreeCAD to learn about other ways in which you can contribute.

Introduction

С тех пор как интерфейс FreeCAD стал базироваться на современном инструментарии Qt, он стал организован по последней моде. Виджеты, меню, панели инструментов и другие инструменты могут быть изменены, перемещены, обменены между верстаками, установки горячих клавиш можно изменять под себя, также как и сохранять и воспроизводить макросы. Окно настроек можно запустить из меню Tools -> Customize

Screenshot-customize.jpg

The Interface Customization dialog


Usage

The customization window is accessed from the Tools → Customize menu.

Настройки вкладок

Вкладка Commands позволяет Вам просмотреть все команды в FreeCAD, отсортированные по их категориям.

Во вкладке Keyboard, Вы можете просмотреть все ассоциации горячих клавиш в соответствии с каждой командой FreeCAD, и если Вы хотите изменить или назначить (связать) новую ассоциацию для любой команды. Это полезно если вы часто используете программу или определнынные команды (функции), и также желаете повысить эффективность, производительность, скорость, используя клавиатуру.

Пункты меню Toolbars и Toolbox bars позволяют изменять существуюшие панели инструментов, или создать свои.

Under the tab Worksbenches (Workbenches) the workbenches existing in FreeCAD are listed, on the left the currently passive, on the right the currently active workspaces. The status can be changed with the horizontal arrows.

File:UserdefSymbstrip.jpg

Under the tab Toolbars (Toolbars) on the left are the same command categories as under the map Commands. After clicking on a category the corresponding commands appear, which can be copied to the right side. Before you do this, select an active workspace to which you want to add an individual toolbar. First select a name for this toolbar with New (New...) before copying commands over to it. When this workspace is called later, this bar must be activated: View → Toolbars.

Remark: If "Global" (instead of a workspace) is selected on the right, the added toolbar can be activated in each workspace.


Пункт Macros позволяет управлять сохраненными Макросами.

Создайте свою панель инструментов для Вашего макроса по учебнику "Настроить панель инструментов"

Начиная с FreeCAD 0.16 доступен новый инструмент, который позволяет вам управлять Вашими верстаками

CustomizeWorkbenches.png

Пример

Для примера хода работ представим, что мы хотим иметь инструмент "Measure Linear" так же в индивидуальной панели в верстаке draft.

  • выберите "Tools -> Customize" в верхнем меню FreeCAD
  • выделите вкладку "Toolbars"
  • слева в ниспадающем меню выберите "Part"
  • в нижнем окне слева пролистайте до элемента "Measure Linear" и выберите его
  • справа в ниспадающем меню выберите "Draft"
  • кликните "New..." для создания новой панели инструментов и выберите для него имя
  • теперь выберите панель назначения в правом нижнем окне (нужно если у вас больше одной панели инструментов)
  • кликнув на голубой "стрелке вправо" (верхней иконке в средней колонке), Вы добавите выбранный элемент в выбранную панель инструментов

Примечания

Выбрав в ниспадающем меню справа "Global", Вы создадите панель, видимую во всех верстаках

Для добавления в панель установленного макроса Вам надо

  • выбрать "Macros" в ниспадающем меню на левой стороне
  • назначить текст меню, иконку (Pixmap) и так далее, используя меню "Tools -> Customize -> Macros"

Addons

Under construction icon-blue.svg
This documentation is work in progress. Please don't mark it as translatable since it will change the next hours and days.

There are other ways to customize the FreeCAD interface using its robust modular Addon repository through the AddonManager.svg Addon Manager. There are several Addons that allow for improved UI/UX. Below are some options created by users in the FreeCAD community.

Glass

https://www.youtube.com/watch?v=ny31diN1ZhM

  • Github repository: (link)
  • Forum discussion: (thread)

PieMenu

  • Github repository:

Launcher

ShortCut

RemBench

IconThemes

CubeMenu

Template:Std Base navi/ru Template:Interface navi/ru