Personalizzare l'interfaccia

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Interface Customization and the translation is 43% complete.
Outdated translations are marked like this.
Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎українська • ‎中文 • ‎中文(中国大陆)‎ • ‎日本語 • ‎한국어

Questa documentazione non è completa. Si prega dare un aiuto e contribuire alla documentazione.

Vedere Draft ShapeString per avere un esempio di comando ben documentato. Comandi della Gui fornisce una panoramica sui comandi. Vedere Lista dei comandi per gli altri comandi.

Per contribuire consultare la pagina Contribuire.

Arrow-left.svg Preferenze di Importa/Esporta Pagina precedente:
Pagina successiva: Editore delle proprietà Arrow-right.svg

Introduction

Dato che l'interfaccia di FreeCAD è basata sul moderno toolkit Qt, essa dispone di una organizzazione ottimale. Si possono modificare, spostare, condividere tra i vari ambienti di lavoro widget, menu, barre e altri strumenti. Si possono creare e modificare le scorciatoie da tastiera. Si possono registrare e riprodurre le macro.

La finestra di personalizzazione è accessibile dal menu Strumenti → Std DlgCustomize.png Personalizza':

MenuPersonalizza.png

The Interface Customization dialog


Usage

The customization window is accessed from the Tools → Customize menu.

La scheda Personalizza

La scheda Comandi consente di esplorare tutti i comandi disponibili in FreeCAD, organizzati per categorie.

In Tastiera, è possibile vedere le scorciatoie da tastiera associate a ogni comando di FreeCAD, e volendo, si può modificare o assegnare un nuovo collegamento a qualsiasi comando. Quando si usa sovente uno specifico ambiente di lavoro, questo permette di velocizzare il suo utilizzo tramite la tastiera.

La scheda Barre degli strumenti consente di modificare le barre degli strumenti esistenti, o di creare nuove barre degli strumenti personalizzate.

Nella scheda Ambienti sono elencati gli ambienti esistenti in FreeCAD, a sinistra quelli attualmente passivi, a destra quelli attualmente attivi. Lo stato può essere modificato con le frecce orizzontali.

File:UserdefSymbstrip.jpg

Nella scheda Barre degli strumenti a sinistra ci sono le stesse categorie di comandi della scheda Comandi. Dopo aver fatto clic su una categoria, vengono visualizzati i comandi corrispondenti, che possono essere copiati sul lato destro. Prima di eseguire questa operazione, selezionare un ambiente di lavoro attivo al quale si desidera aggiungere una data barra degli strumenti. Prima selezionare un nome per questa barra degli strumenti con Nuovo prima di copiare i comandi su di essa. Quando in un secondo momento questo ambiente viene chiamato, è necessario attivare questa barra: Visualizza → Barre degli strumenti.

Nota: se si seleziona "Globale" (anziché un ambiente) sulla destra, la barra degli strumenti aggiunta può essere attivata da qualsiasi ambiente.


La scheda Macro consente di gestire le Macro salvate in precedenza.

Le schede successive permettono di impostare le azioni di Spaceball (se installato)

Vedere anche il tutorial per creare la Barra personalizzata degli strumenti macro

Dalla versione 0.16 è disponibile un nuovo strumento che permette di gestire gli ambienti di lavoro.

CustomizeWorkbenches.png

Esempio

Come esempio del flusso di lavoro, supponiamo di voler avere la funzione "Misura Lineare" mostrata anche in una barra degli strumenti personalizzata nell'ambiente Draft.

  • dal menu principale di FreeCAD scegliere Strumenti → Personalizza
  • selezionare la tabella "Barre degli strumenti"
  • sul lato sinistro scegliere "Part" nel menu a discesa
  • sul lato sinistro della finestra scorrere in basso fino alla voce "Misura Lineare" e selezionarla
  • sul lato destro scegliere "Draft" nel menu a discesa
  • cliccare su Nuova... per creare una nuova barra degli strumenti e definire il suo nome
  • ora selezionare la barra degli strumenti di destinazione nella finestra in basso a destra (è necessario solo se si dispone di più di una barra degli strumenti)
  • cliccando sulla "Freccia destra" di colore blu (l'icona in alto nella fila centrale) si aggiunge la voce selezionata alla barra degli strumenti selezionata

Osservazioni:

  • quando si seleziona "Global" nel menu a tendina sulla parte di destra si crea una barra degli strumenti che sarà visibile in tutti gli ambienti

Per aggiungere ad una barra degli strumenti una macro installata è necessario

  • selezionare "Macro" nel menu a discesa sul lato sinistro
  • aver assegnato il testo del menu, l'icona (Pixmap) e così via utilizzando il menu Strumenti → Personalizza → Macro

Addons

Under construction icon-blue.svg
This documentation is work in progress. Please don't mark it as translatable since it will change the next hours and days.

There are other ways to customize the FreeCAD interface using its robust modular Addon repository through the AddonManager.svg Addon Manager. There are several Addons that allow for improved UI/UX. Below are some options created by users in the FreeCAD community.

Glass

https://www.youtube.com/watch?v=ny31diN1ZhM

  • Github repository: (link)
  • Forum discussion: (thread)

PieMenu

  • Github repository:

Launcher

ShortCut

RemBench

IconThemes

CubeMenu

Arrow-left.svg Preferenze di Importa/Esporta Pagina precedente:
Pagina successiva: Editore delle proprietà Arrow-right.svg