Interfejs użytkownika

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Interface and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎русский

Wprowadzenie

Interfejs FreeCAD oparty jest na Qt, znanym graficznym zestawie narzędzi interfejsu użytkownika (GUI), szczególnie używanym w Linuksie, ale dostępnym również w systemie Windows i MacOS.

FreeCAD interface base divisions.svg

Standardowy interfejs w wersji 0.19.


Główne okno aplikacji można podzielić z grubsza na 11 sekcji:

  1. Widok 3D.
  2. W górnej części Widok połączony, który zawiera Widok drzewa oraz Panel zadań.
  3. W dolnej części Widoku połączonoeg, jest do dyspozycji Edytor właściwości.
  4. Widok wyboru opcji.
  5. Widok raportu.
  6. Python console.
  7. Pasek stanu pracy.
  8. Obszar paska narzędzi, zobacz następujące informacje na pasku narzędziowym
  9. Przełącznik Środowiska pracy, który sam w sobie jest paskiem narzędzi.
  10. Menu standardowe.

Elementy interfejsu użytkownika

Podobnie jak wiele innych programów, FreeCAD zawiera standardowy pasek menu, a następnie serię pasków narzędzi i paneli, w których znajdują się narzędzia użytkownika.

Menu

Dostępne są następujące menu standardowe menu: Plik, Edycja, Widok, Narzędzia, Makro, Okna, Pomoc.

Paski narzędzi

Standardowe paski narzędzi, które pojawiają się w interfejsie to:

  • Pasek narzędzi do plików: narzędzia do pracy z plikami, otwierania dokumentów, kopiowania, wklejania, cofania i ponownego wykonywania czynności.
  • Pasek narzędzi Środowiska pracy: zawiera jeden widżet do wyboru aktywnego Środowiska pracy.
  • Pasek narzędzi Makro: narzędzia do nagrywania, edycji i wykonywania Makrodefinicji.
  • Pasek narzędzi widoku: narzędzia do kontrolowania wyglądu obiektów w Widok 3D.
  • Pasek narzędzi struktury: narzędzia do organizowania obiektów w dokumencie i tworzenia łączy do dodatkowych dokumentów.

Można je włączyć i wyłączyć klikając prawym przyciskiem myszy na puste miejsce na jednym z pasków narzędzi i wybierając żądany element, lub z menu Widok → Paski narzędzi.

Panele

Panelami głównymi, które umożliwiają pracę z obiektami są:

Z wyjątkiem widoku 3D, wszystkie te elementy można włączać i wyłączać klikając prawym przyciskiem myszy na puste miejsce w jednym z górnych pasków narzędzi i wybierając żądany element. Innym sposobem jest wybór menu Widok → Panele.

Aby aktywować i dezaktywować pasek stanu, użyj menu Widok → Pasek stanu.

Pozostałe elementy

Inne użyteczne interfejsy i okna zawierają:

  • Inspektor sceny: panel, który pokazuje węzły Coin3D tworzące scenegraph. Dla zaawansowanych użytkowników i programistów pomocne może być rozwiązywanie problemów związanych z bezpośrednią manipulacją sceną i obiektami utworzonymi w widok 3D.
  • Wykres zależności: okno pokazujące wykres zależności wszystkich obiektów w dokumencie, utworzonych za pomocą programu pomocniczego Graphviz. Pomocne jest rozpoznanie problemów w tworzeniu obiektów, takich jak zależności kołowe, które mogą nie być całkowicie widoczne z widok drzewa lub widok DAG.

Możliwość dostosowania

Paski narzędzi mogą mieć więcej lub mniej przycisków. Niestandardowe paski narzędzi można tworzyć w celu przygotowania mieszanki różnych narzędzi i przechowywania opracowanych makrodefinicji.

Opcje te znajdują się w menu, Narzędzia → Dostosuj. Patrz Dostosowywanie interfejsu.