Interfaccia

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Interface and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎русский

Introduzione

L'interfaccia di FreeCAD si basa su Qt, un noto toolkit di interfaccia utente grafica (GUI), particolarmente utilizzato in Linux, ma disponibile anche in Windows e MacOS.

FreeCAD interface base divisions.svg

Interfaccia standard di FreeCAD 0.19.


La finestra principale dell'applicazione può essere suddivisa approssimativamente in 11 sezioni:

  1. L'area della vista principale, che può contenere diverse finestre a schede
  2. La vista 3D, normalmente incorporata nell'area della vista principale
  3. La parte superiore della vista combinata, che include la vista ad albero e il pannello delle azioni
  4. La parte inferiore della vista combinata, che include l'editor delle proprietà
  5. La vista della selezione
  6. La vista dei report
  7. La console Python
  8. La barra di stato
  9. L'area della barra degli strumenti, vedere le informazioni seguenti sulla barra degli strumenti
  10. Il selettore degli ambienti, che a sua volta è una barra degli strumenti
  11. Il menu standard

Componenti dell'interfaccia

Come molti software, FreeCAD include una barra dei menu standard, quindi una serie di barre degli strumenti e pannelli in cui si trovano gli strumenti per l'utente.

Menu

I menu standard sono: File, Modifica, Visualizza, Strumenti, Macro, Finestre, Aiuto.

Barre degli strumenti

Le barre degli strumenti standard che appaiono nell'interfaccia sono:

  • Barra degli strumenti File: strumenti per lavorare con i file, aprire documenti, copiare, incollare, annullare e ripetere azioni.
  • Selettore degli ambienti: contiene un singolo widget per selezionare l'ambiente attivo.
  • Barra degli strumenti Macro: strumenti per registrare, modificare ed eseguire le macro.
  • Barra degli strumenti Visualizza: strumenti per controllare la modalità di visualizzazione degli oggetti nella vista 3D.
  • Barra degli strumenti Struttura: strumenti per organizzare gli oggetti nel documento e creare collegamenti a documenti aggiuntivi.

Questi possono essere attivati e disattivati facendo clic con il pulsante destro del mouse su uno spazio vuoto su una delle barre degli strumenti e scegliendo l'elemento desiderato, oppure dal menu Visualizza → Barre degli strumenti.

Pannelli

I pannelli principali che consentono di lavorare con gli oggetti sono:

Ad eccezione della vista 3D, tutto può essere attivato e disattivato facendo clic con il pulsante destro del mouse su uno spazio vuoto su una delle barre degli strumenti in alto e scegliendo l'elemento desiderato, oppure dal menu Visualizza → Pannelli.

Per attivare e disattivare la barra di stato utilizzare il menu Visualizza → Barra di stato.

Altro

Altre interfacce e finestre utili includono:

  • Ispettore di scena: un pannello che mostra i nodi Coin3D che compongono la scena grafica. Per utenti esperti e sviluppatori, può essere utile per risolvere le operazioni che manipolano direttamente la scena e gli oggetti creati nella Vista 3D.
  • Grafico delle dipendenze: una finestra che mostra il grafico delle dipendenze di tutti gli oggetti nel documento, creato con il programma ausiliario Graphviz. È utile per riconoscere i problemi nella creazione di oggetti, come le dipendenze circolari, che potrebbero non essere del tutto evidenti dalla vista ad albero o dalla vista DAG.

Personalizzazione

Le barre degli strumenti possono avere più o meno pulsanti e le barre degli strumenti personalizzate possono essere create con un mix di strumenti diversi e per ospitare le macro sviluppate.

Queste opzioni sono nel menu Strumenti → Personalizza. Vedere Personalizzare l'interfaccia.