Oberfläche

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Interface and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎русский

Einleitung

Die FreeCAD Oberfläche basiert auf Qt, einem sehr bekannten grafischen Anwenderschnittstellen Werkzeugsatz, insbesondere unter Linux verwendet, der aber auch unter Windows und MacOS verfügbar ist.

FreeCAD interface base divisions.png

Standard FreeCAD Oberfläche in v0.19.


Das Hauptfenster der Anwendung kann grob in 11 Abschnitte unterteilt werden:

  1. Der Hauptansichtsbereich, der verschiedene Registerkartenfenster enthalten kann
  2. Die 3D Ansicht, normalerweise eingebettet in den Hauptansichtsbereich
  3. Der obere Teil der Combo Ansicht, der die Baumansicht und Aufgabenleiste beinhaltet.
  1. Der untere Teil der Combo Ansicht, der den Eigenschaftseditor beinhaltet.
  2. Die Auswahlansicht
  3. Die Berichtsansicht
  4. Die Python Konsole
  5. Die Statusleiste
  6. Der Werkzeugleistenbereich, siehe folgende Informationen zu den Werkzeugleisten
  7. Der Arbeitsbereichsselektor, der selbst eine Werkzeugleiste ist.
  8. Das Standardmenü

Oberflächenkomponenten

Wie viele andere Programmstücke enthält FreeCAD eine Standardmenüleiste und dann eine Reihe von Werkzeugleisten und Eingabefeldern, in denen sich die Anwenderwerkzeuge befinden.

Menüs

Die Standard Menüs sind: Datei, Bearbeiten, Ansicht, Werkzeuge, Makro, Fenster, Hilfe.

Werkzeugleisten

Die Werkzeugleisten, die in der Oberfläche erscheinen, sind:

  • Datei Werkzeugleiste: Werkzeuge zum Arbeiten mit Dateien, Öffnen von Dokumenten, Kopieren, Einfügen, Rückgängigmachen und Wiederherstellen von Aktionen.
  • Arbeitsbereich Werkzeugleiste: Es enthält ein einziges Widget zur Auswahl der aktiven Arbeitsbereich.
  • Makro Werkzeugleiste: Werkzeuge zum Aufnehmen, Bearbeiten und Ausführen von Makros.
  • Ansicht Werkzeugleiste: Werkzeuge zur Steuerung der Darstellung von Objekten in der 3D Ansicht.
  • Struktur Werkzeugleiste: Werkzeuge zum Strukturieren von Objekten im Dokument und zum Erstellen von Verknüpfungen zu weiteren Dokumenten.

Diese können ein- und ausgeschaltet werden, durch Rechtsklick auf eine leere Stelle in einer der Werkzeugleisten und Auswahl des gewünschten Elements oder über das Menü Ansicht → Werkzeugleisten.

Konsolen

Die Hauptkonsolen, die das Arbeiten mit Objekten ermöglichen, sind

Mit Ausnahme der 3D Ansicht können alle Funktionen ein- und ausgeschaltet werden, indem man mit der rechten Maustaste auf einen leeren Bereich in einer der oberen Werkzeugleisten klicken und das gewünschte Element oder aus dem Menü Ansicht → Konsolen auswählen.

Um die Statusleiste zu aktivieren und zu deaktivieren, verwenden Sie das Menü Ansicht → Statusleiste.

Andere

Weitere nützliche Oberflächen und Fenster umfassen:

  • Scene Inspector: eine Konsole, die die Coin3D Knoten anzeigt, aus denen sich der scenegraph zusammensetzt. Für Erfahrene Anwender und Entwickler kann es sinnvoll sein, Vorgänge, die die Szene direkt manipulieren, und die in der 3D Ansicht erstellten Objekte zu beheben.
  • Abhängigkeitsgraph: ein Fenster, das den Abhängigkeitsgraphen aller Objekte im Dokument anzeigt, die mit dem Hilfsprogramm Graphviz erstellt wurden. Es ist hilfreich, Probleme bei der Erstellung von Objekten zu erkennen, wie z.B. zirkuläre Abhängigkeiten, die aus der Baumansicht oder der DAG Ansicht nicht ganz ersichtlich sind.

Anpassung

Werkzeugleisten können mehr oder weniger Schaltflächen haben, und benutzerdefinierte Werkzeugleisten können mit einer Mischung aus verschiedenen Werkzeugen erstellt werden, um entwickelte Makros zu speichern.

Diese Optionen befinden sich im Menü, Werkzeuge → Benutzerdefiniert. Siehe Schnittstellenanpassung.