Instalacja

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Installing and the translation is 100% complete.
Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎中文(中国大陆)‎ • ‎한국어

Wybierz system operacyjny dla FreeCAD

FreeCAD jest prawdziwą wieloplatformową aplikacją, opracowaną przy użyciu znanego na całym świecie frameworka Qt. Oznacza to, że FreeCAD wygląda i działa tak samo w systemach Linux, Mac i Windows. Jednak procedura instalacji jest indywidualna dla każdego z nich. Wybierz swój system operacyjny, aby uzyskać szczegółowe informacje na temat instalacji programu FreeCAD.

'Linux' 'Mac' 'Windows'
Instalacja w systemie Linux Instalacja w systemie Mac Instalacja w systemie Windows

Instalacja dodatków

Dokumentacja offline nie jest dostarczana ze wszystkimi instalatorami, ale jest dostępna jako osobny pakiet; patrz Instalacja pliku pomocy.

Poza standardowym Środowiskiem pracy dołączonym do FreeCAD, dostępna jest coraz większa kolekcja użytecznych dodatkowych Środowisk pracy i modułów udostępnianych w sieci przez członków społeczności. Trwają prace nad ich zebraniem i udostępnieniem w wygodny sposób. Wyszczególniono je poniżej.

Ponieważ te Środowiska pracy nie są częścią oficjalnego pakietu FreeCAD i nie są wspierane przez główny zespół FreeCAD, powinieneś przeczytać informacje dostarczone wraz z nimi, aby upewnić się, że wiesz, co instalujesz. Zgłoszenia błędów i prośby o funkcje powinny być kierowane bezpośrednio do każdego programisty dodatków.

Repozytoria dodatków programu FreeCAD

Od wersji FreeCAD 0.17, dodatkami można zarządzać bezpośrednio z menu Narzędzia, więc nie ma potrzeby instalowania wymienionego w tym miejscu makra.

Jest to zbiór użytecznych Środowisk pracy, wykorzystujących system submodułów git, który pozwala na zachowanie stale aktualizowanej zawartości. Repozytorium dodatków FreeCAD można znaleźć na stronie https://github.com/FreeCAD/FreeCAD-addons. Repozytorium to posiada własne makro instalatora, które może być uruchamiane z poziomu FreeCAD. Dostępne dodatki zostaną automatycznie wyświetlone, a w razie potrzeby pobrane i instalowane.

Od wersji FreeCAD 0.17 użyj więc wbudowanego Menadżera dodatków.

*Dla FreeCAD 0.16 i starszych, zainstaluj makro instalatora dodatków:

  1. Kliknij prawym przyciskiem myszy na addons_installer.FCMacro i wybierz Zapisz jako....
  2. Umieść plik pobranego makro w folderze FreeCAD Macros . Lokalizacja folderu FreeCAD Macros jest wskazana w menu Macros → Makra → Lokalizacja makr użytkownika:

Macro installer 01.jpg.

  1. Uruchom ponownie FreeCAD. Instalator dodatków pojawi się teraz w menu Macro → Makra i można go uruchomić klikając przycisk Execute:

Macro installer 02.jpg.

Dodatek pluginloader

Program Plugin Loader jest znacznie bardziej rozbudowanym sposobem instalacji i zarządzania dodatkową zawartością dla FreeCAD. Zainstaluj go za pomocą metody opisanej powyżej lub postępując zgodnie z instrukcjami na stronie pluginloader.

Pluginloader został zastąpiony przez Addon Manager.

Instalacja samodzielna

Większość zewnętrznych Środowisk pracy, programowanych jest w Pythonie. Dzięki temu mogą być łatwo zainstalowane ręcznie. Po prostu pobierz je (klikając przyciski na Github Clone or download lub Download ZIP) , i umieść je w folderze użytkownika FreeCAD/Mod (lub w folderze Macros, jeśli istnieje macros) . Pełne informacje znajdują się w instrukcjach na stronie każdego dodatku.

Uwagi dla użytkowników z systemem 32-bitowym i FreeCAD v0.16.6706


Po próbie instalacji, dodatkowe Środowiska pracy mogą nie być dostępne. W takim przypadku

Oprogramowanie zewnętrzne obsługiwane przez FreeCAD

FreeCAD obsługuje wiele zewnętrznych pakietów oprogramowania, które nie są dostarczane w pudełku. Oznacza to, że wystarczy zainstalować oprogramowanie i będzie ono automatycznie dostępne przy następnym uruchomieniu. Nie ma potrzeby ponownej kompilacji.
Ta sekcja ma na celu dostarczenie listy wszystkich takich pakietów oprogramowania wraz z informacjami, gdzie jest ono używane we FreeCAD i gdzie można je pobrać.

Wspierane

GraphViz

GraphViz to oprogramowanie typu open source do wizualizacji wykresów. We FreeCAD służy do generowania wykresów zależności poprzez Tools → Dependency Graph. Jego strona główna znajduje się pod adresem https://www.graphviz.org

OpenCAMLib

OpenCAMLib to biblioteka open source algorytmów produkcji wspomaganej komputerowo (CAM) i używana w programie FreeCAD Path. Zobacz jego stronę, aby uzyskać instrukcje instalacji.

OpenSCAD

Programator Solid 3D CAD Modeller jest kolejnym oprogramowaniem CAD, opartym na Konstrukcyjnej Geometrii Bryłowej (CSG). Oznacza to, że nie może on obsługiwać siatki, ale działa wyłącznie na geometrii bryłowej. FreeCAD może importować i eksportować pliki utworzone w OpenSCAD poprzez narzędzia Std: Import oraz Std: Eksport wybierając typy plików OpenSCAD CSG lub OpenSCAD format. Możesz pobrać OpenSCAD z https://www.openscad.org

GitPython

GitPython to biblioteka Pythona, która jest używana do interakcji z repozytoriami Gita. Addon Manager może używać tej biblioteki do importowania dodatków z repozytorium Git. Projekt jest hostowany na GitHub pod adresem https://github.com/gitpython-developers/GitPython.

Element końcowy

CalculiX

CalculiX jest zestawem dwóch kompletnych pakietów elementów skończonych:

  • CalculiX CrunchiX, lub calculix-ccx, jest rozwiązaniem FEM.
  • CalculiX GraphiX, lub calculix-cgx, jest interfejsem graficznym służącym do wyświetlania wyników pracy solwera.

Tylko solver jest obsługiwany przez FreeCAD. Dostęp do niego można uzyskać z FEM Workbench poprzez Solve → Solver CalculiX. FreeCAD obsługuje standardowy i eksperymentalny solver. CalculiX można pobrać ze strony http://calculix.de

Gmsh

Gmsh to automatyczny generator siatki elementów skończonych. Może być używany w FreeCAD z poziomu Środowiska pracy FEM poprzez Mesh → Siatka MES od kształtu przez Gmsh. Strona domowa Gmsh znajduje się pod adresem http://www.geuz.org/gmsh

Elmer

Elmer to symulator wykorzystujący wiele analiz fizycznych, uruchomiono go w 2005 roku. W FreeCAD jego moduły Grid i Solver mogą być używane przez FEM Workbench poprzez Solve->Solver Elmer. Strona główna projektu znajduje się pod adresem https://www.elmerfem.org i można go pobrać z GitHub https://github.com/ElmerCSC/elmerfem/releases.

FEniCS

FEniCS jest platformą obliczeniową do rozwiązywania równań różniczkowych cząstkowych (PDE), które są szeroko stosowane przy rozwiązywaniu problemów FEM. Jako taki może być wykorzystywany przez FEM. FreeCAD może importować i eksportować siatki FEniCS poprzez funkcje Std: Import oraz Std: Export wybierając format pliku FEM mesh fenics. Strona główna FEniCS znajduje się pod adresem https://fenicsproject.org.

Z88

Z88 jest kolejnym programem FEM, zawierającym mezher, solver i konwertery, które mogą być używane przez Środowisko pracy FreeCAD FEM. Można się do niego dostać przez Solve → Solver Z88. Z88 dystrybuuje kilka pakietów, które są ogólnie dostępne, ale mają zamknięte źródło. Jednakże Z88OS, opublikowany został na licencji open source, jest tym, czego potrzebuje FreeCAD. Strona domowa znajduje się pod adresem https://en.z88.de/. Z88OS jest również hostowany na GitHub pod adresem https://github.com/LSCAD/Z88OS, jeśli chcesz skompilować go samemu.

OpenFOAM

OpenFOAM to duży zbiór bibliotek do symulacji obliczeniowej dynamiki płynów (Computational Fluid Dynamics CFD). OpenFOAM może być używany przez zewnętrzne środowiska pracy, które zbudowane są na bazie FreeCAD do pracy jako preprocesor. Projekt znajduje się na stronie https://openfoam.org.

Formaty plików

CAD Exchanger

Aplikacja z zamkniętym źródłem kodu, do wymiany różnych formatów plików używanych w CAD. Możesz jej użyć do konwersji zastrzeżonych, zamkniętych formatów do formatu, który jest dostępny w FreeCAD. Witryna główna znajduje się pod adresem https://cadexchanger.com/, gdzie można pobrać wersję ewaluacyjną lub zakupić licencję.

DXF Importer

FreeCAD posiada własnego importera i eksportera plików DXF, który zaprogramowano w C++. Obecnie importer ten nie implementuje wszystkich funkcji formatu DXF. Jeśli polegasz na jeszcze nie zaimplementowanej funkcji, włącz starszego importera/eksportera opartego na Pythonie poprzez Edit → Preferencje → Import-Export poprzez aktywację opcji Użyj starszego importera pythona. Możesz wtedy wybrać opcję pozwalającą FreeCAD automatycznie pobrać potrzebne pliki lub pobrać je ze strony https://github.com/yorikvanhavre/Draft-dxf-importer. Wybranego importera/eksportera używa się wybierając Std: Import lub Std; Export i wybierając format pliku AutoDesk DXF 2D.

ODA File Converter

Konwerter plików ODA ma zastrzeżone, zamknięte źródła binarne i swobodnie dostępną aplikacją do importowania i eksportowania plików DWG i DXF. We FreeCAD można go używać za pośrednictwem funkcji Std: Import and Std: Export, po wybraniu typu pliku AutoDesk DWG 2D. Można go pobrać ze strony https://www.opendesign.com/guestfiles/oda_file_converter.

ifcOpenShell

IfcOpenShell jest biblioteką pracującą z plikami Industry Foundation Classes (IFC) używanymi w projektowaniu architektonicznym. Dostęp do niej można uzyskać zeŚrodowiska pracy Arch poprzez menu Arch → Narzędzia → Ifc Explorer. Jej strona główna znajduje się pod adresem http://ifcopenshell.org

pycollada

Pycollada, znana również jako python-collada, jest biblioteką Pythona do czytania i pisania dokumentów COLLADA, standardu wymiany scen i elementów 3D. Jeśli jest zainstalowana, można importować i eksportować sceny do i z plików COLLADA poprzez polecenia Std: Import i Std: Export wybierając typ pliku COLLADA. Projekt jest hostowany przez GitHub na stronie https://pycollada.github.io/ i można go pobrać na stronie https://github.com/pycollada/pycollada/releases/

Renderowanie

POVRay

POVRay jest znanym raytrakerem, który potrafi oddać fotorealistyczne obrazy. Jest to jeden z dwóch raytracerów obecnie wspieranych przez FreeCAD w Środowisku pracy Raytracing. POVRay można pobrać ze strony https://www.povray.org.

LuxCoreRender

LuxCoreRender, znany również jako LuxRender, jest jednym z dwóch obecnie obsługiwanych silników renderujących w programie FreeCAD. Jest on wykorzystywany w trakcie pracy na Raytracing. Obecnie tylko stary i opuszczony LuxRender-1.x jest obsługiwany przez FreeCAD. Jeśli chcesz pomóc w aktualizacji do nowego LuxCoreRender-2, skontaktuj się z zespołem Raytracing project. Pliki dla LuxRender-1.6 można pobrać ze strony LuxCoreRender GitHub pod adresem https://github.com/LuxCoreRender/LuxCore/releases Strona główna obecnego projektu LuxCoreRender znajduje się na https://www.luxcorerender.org.

Warto odwiedzić