Installation

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Installing and the translation is 100% complete.
Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎中文(中国大陆)‎ • ‎한국어
Arrow-left.svg Page précédente : A propos de FreeCAD
Page suivante : Premiers pas Arrow-right.svg

Choisissez votre système d'exploitation

FreeCAD est une application véritablement multi-plateforme, développée avec Qt de renommée mondiale.
Qu'est-ce que cela signifie, c'est que FreeCAD ressemble et agit de la même façon sur Windows, Linux et Mac. Toutefois, la procédure d'installation est un peu différente pour chaque système d'exploitation.
Choisissez votre système d'exploitation ci-dessous, pour avoir plus de détails sur la façon d'installer FreeCAD.

'Windows' 'Linux' 'Mac'
Installation sous Windows Installation sous Linux Installation sous Mac

Installation de contenus supplémentaires

La documentation hors-ligne n'est pas fournie avec tous les modes d'installation, mais elle est disponible séparément. Consultez la page Installation d'un fichier d'aide.

En plus des ateliers livrés par défaut avec FreeCAD, il existe une collection grandissante d'ateliers et de modules additionnels produits par des membres de la communauté et disponibles sur le Web. Plusieurs initiatives (listées ci-dessous) sont en cours pour les rassembler et les rendre disponibles de façon conviviale.

Puisque ces ateliers ne font pas partie de la version officielle de FreeCAD, et qu'ils ne sont pas supportés par l'équipe de développement, vous devriez lire l'information fournie dans chacune des pages de greffons avant de les installer, afin de savoir ce que vous installez. De plus, les rapports de bogues et les demandes de fonctionnalité devraient être adressés aux page de greffons.

Le dépôt FreeCAD-addons

À partir de FreeCAD 0.17, les addons peuvent être gérés directement à partir du menu Tools. Il n'est donc pas nécessaire d'installer la macro mentionnée ici.

Il s'agit d'un regroupement d'atelier utiles, utilisant le système de sous-modules Git, ce qui permet la mise à jour constante du contenu. Le dépôt FreeCAD-addons se trouve sur ce lien : https://github.com/FreeCAD/FreeCAD-addons . Ce dépôt propose une macro d'installation qui peut être lancée depuis FreeCAD ; celle-ci liste, télécharge et installe les greffons sélectionnés automatiquement. Pour installer la macro :

Avec FreeCAD 0.17 et supérieur, et utilisez Addon Manager.

*Avec FreeCAD 0.16 et les versions antérieures, installez la macro du programme d'installation de l'addon:

  1. Faire un clic droit sur addons_installer.FCMacro puis sélectionner « Enregistrer la cible du lien sous... »
  2. Sauvegarder la macro téléchargée dans votre dossier de macros FreeCAD. L'emplacement du dossier de macros est indiqué dans le menu Macros → Macros... → Emplacement des macros de l'utilisateur :

Macro installer 01.jpg

  1. Redémarrer FreeCAD. La macro addons_installer sera listée dans le menu Macros → Macros... et pourra être lancée en la sélectionnant puis en cliquant sur le bouton Lancer :

Macro installer 02.jpg

Le greffon pluginloader

Le greffon pluginloader (chargeur de greffons) est une méthode beaucoup plus élaborée d'installer et gérer le contenu additionnel dans FreeCAD. Installez-le selon la même méthode que pour le dépôt FreeCAD-addons, ou suivez les instructions (en anglais) sur la page pluginloader.

Le pluginloader a été remplacé par Addon Manager.

Installation manuelle

Les ateliers externes, quand ils sont pleinement programmés en langage python (ce qui est le cas de tous les ateliers actuels au moment d'écrire ces lignes) peuvent être aisément installés manuellement, simplement en les téléchargeant (habituellement en cliquant sur le boutonClone or download ou Download ZIP apparaissant sur la page de chacun des greffons quand ils sont hébergés sur GitHub), puis en les plaçant dans votre dossier FreeCAD/Mod (ou dans le dossier Macros s'il s'agit de macros). Reportez-vous aux instructions de chaque page greffon pour des instructions complètes.

Notes pour les utilisateur d'un système 32-bit et FreeCAD 0.16.6712

Après installation, des ateliers additionnels peuvent ne pas être accessibles. Dans ce cas

Logiciels externes supportés par FreeCAD

FreeCAD prend en charge de nombreux logiciels externes prêts à l'emploi. Cela signifie que vous devez simplement installer le logiciel et celui-ci sera automatiquement disponible au prochain démarrage. Il n'y a pas besoin de le recompiler. Cette section vise à fournir une liste de tous ces packages logiciels, ainsi que des informations sur les endroits où ils sont utilisés dans FreeCAD et sur les endroits où vous pouvez les récupérer.

Assistance

GraphViz

GraphViz est un logiciel de visualisation de graphe open source. Dans FreeCAD, il est utilisé pour générer des graphiques de dépendance via Outils → Graphique de dépendance.... Sa page d'accueil se trouve à l'adresse https://www.graphviz.org.

OpenCAMLib

OpenCAMLib est une librairie open source d'algorithmes de fabrication assistée par ordinateur (FAO) et utilisée dans l'atelier Path de FreeCAD. Voir sa page pour les instructions d'installation.

OpenSCAD

OpenSCAD est un modeleur 3D solide basé sur le paradigme Géométrie Solide Constructive (CSG), où le modèle est créé via un script. Il ne peut pas gérer les maillages, mais fonctionne exclusivement sur une géométrie solide. FreeCAD peut importer et exporter des fichiers créés à partir d'OpenSCAD via les outils Std Importer et Std Exporter en sélectionnant les OpenSCAD CSG format ou le OpenSCAD format types de fichier. Vous pouvez charger OpenSCAD sur https://www.openscad.org.

GitPython

GitPython est une bibliothèque pour interagir avec les référentiels Git. Le Gestionnaire de modules complémentaires peut utiliser cette bibliothèque pour importer des modules complémentaires à partir d'un dépôt Git. Le projet est hébergé sur GitHub voir https://github.com/gitpython-developers/GitPython.

Eléments finis

CalculiX

CalculiX est une suite de deux packages d'éléments finis:

  • CalculiX CrunchiX, ou calculix-ccx, est un FEM solveur.
  • CalculiX GraphiX, ou calculix-cgx, est une interface graphique pour afficher les résultats du solveur.

Seul le solveur est pris en charge par FreeCAD. On peut y accéder depuis l'atelier FEM par Solve → Solveur CalculiX. Il existe un solveur standard et un solveur expérimental supporté par FreeCAD. CalculiX peut être téléchargé à partir de calculix.de

Gmsh

Gmsh est un générateur automatique de maillage par éléments finis. Il peut être utilisé dans FreeCAD à partir de l'atelier FEM via Mesh → FEM Maillage à partir d'une forme avec Gmsh. La page d'accueil de Gmsh est http://www.geuz.org/gmsh.

Elmer

Elmer est un logiciel de simulation multi-physique, open source depuis 2005. Dans FreeCAD, ses modules Grid et Solver peuvent être utilisés par l'atelier FEM via Solve → Solveur Elmer. La page d'accueil du projet est à l'adresse https://www.elmerfem.org et peut être téléchargée à partir de GitHub à l'adresse https://github.com/ElmerCSC/elmerfem/releases.

FEniCS

FEniCS est une plate-forme informatique permettant de résoudre des équations aux dérivées partielles (PDEs), largement utilisées lors de la résolution de problèmes FEM. En tant que tel, il peut être utilisé par l'atelier FEM. FreeCAD peut importer et exporter des maillages FEniCS via Std Importer et Std Exporter en sélectionnant le format de fichier FEM mesh fenics. La page d'accueil de FEniCS se trouve sur https://fenicsproject.org.

Z88

Z88 est un autre programme FEM, contenant un mailleur, un solveur et des convertisseurs, qui peut être utilisé par l'atelier FEM de FreeCAD. Vous pouvez y accéder via Solve → Solveur Z88. Z88 distribue plusieurs paquets, qui sont tous disponibles gratuitement, mais sont des sources fermées. Cependant, le Z88OS, publié sous une licence open source, est ce dont FreeCAD a besoin. La page d'accueil est à l'adresse https://fr.z88.de/. Z88OS est également hébergé sur GitHub à https://github.com/LSCAD/Z88OS si vous désirez le compiler vous-même.

OpenFOAM

OpenFOAM est une vaste collection de bibliothèques pour les simulations de dynamique des fluides numérique (CFD). OpenFOAM peut être utilisé par ateliers externes qui s'appuient sur FreeCAD pour fonctionner comme un préprocesseur. Le projet réside sur https://openfoam.org.

Formats de fichiers

CAD Exchanger

Une application propriétaire fermée pour l’échange de divers formats de fichiers utilisés dans la CAO. Vous pouvez l'utiliser pour convertir des formats propriétaires exclusifs dans un format accessible par FreeCAD. La page d'accueil se trouve à l'adresse https://cadexchanger.com/ où vous pouvez télécharger une version d'évaluation ou acheter une licence pour l'application.

Importateur DXF

FreeCAD a un importateur et un exportateur natifs pour les fichiers DXF, programmés en C ++. Actuellement, cet importateur n'implémente pas toutes les fonctionnalités du format DXF. Si vous comptez sur une fonctionnalité non encore implémentée, vous activez un ancien importateur/exportateur basé sur python via Edition → Préférences → Import-Export en activant l'option Utiliser l'importateur python intégré. Vous pouvez ensuite choisir de laisser FreeCAD télécharger automatiquement les fichiers nécessaires ou les récupérer à l'adresse https://github.com/yorikvanhavre/Draft-dxf-importer. L'importateur/exportateur choisi est utilisé en sélectionnant Std Importer et Std Exporter et en choisissant le format de fichier AutoDesk DXF 2D.

Convertisseur de fichier ODA

Le convertisseur de fichier ODA est une application propriétaire, à source fermée, binaire et librement disponible pour importer et exporter des formats de fichier DWG et DXF. Dans FreeCAD, il peut être utilisé à partir des menus Std Importer et Std Exporter lorsque vous sélectionnez le type de fichier AutoDesk DWG 2D. Vous pouvez le télécharger à l'adresse https://www.opendesign.com/guestfiles/oda_file_converter.

ifcOpenShell

IfcOpenShell est une bibliothèque permettant de travailler avec le format de fichier Industry Foundation Classes (IFC) utilisé dans la conception architecturale. Vous pouvez y accéder à partir de l'atelier Arch via Arch → Utilitaires → Ifc Explorer. Sa page d'accueil est à http://ifcopenshell.org.

pycollada

Pycollada, également connu sous le nom de Python-collada, est une bibliothèque Python permettant de lire et d'écrire des documents COLLADA, un standard pour l'échange de scènes et d'éléments 3D. S'il est installé, vous pouvez importer et exporter des scènes vers et depuis des fichiers COLLADA à l'aide des commandes Std Importer et Std Exporter en sélectionnant le type de fichier COLLADA. Le projet est hébergé par GitHub sur https://pycollada.github.io/ et vous pouvez télécharger ses versions sur https://github.com/pycollada/pycollada/releases/.

Rendu

POVRay

POVRay est un traceur de rayons bien connu qui peut rendre des images photoréalistes. C'est l'un des deux traceurs de rayons actuellement pris en charge par FreeCAD dans l'atelier Raytracing. Vous pouvez télécharger POVRay à l’adresse https://www.povray.org.

LuxCoreRender

LuxCoreRender, également connu sous le nom de LuxRender, est l'un des deux moteurs de rendu actuellement pris en charge dans FreeCAD. Il est utilisé via le flux de travail de l'atelier Raytracing. Actuellement, seul LuxRender-1.x, ancien et abandonné, est pris en charge par FreeCAD. Les téléchargements pour LuxRender-1.6 peuvent être récupérés sur la page de publication du GitHub de LuxCoreRender à l'adresse https://github.com/LuxCoreRender/LuxCore/releases. La page d'accueil du projet LuxCoreRender en cours se trouve à https://www.luxcorerender.org.

Pages en relation

Arrow-left.svg Page précédente : A propos de FreeCAD
Page suivante : Premiers pas Arrow-right.svg