Installieren

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Installing and the translation is 30% complete.
Outdated translations are marked like this.
Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎中文(中国大陆)‎ • ‎한국어
Arrow-left.svg Über FreeCAD Vorherige:
Nächste: Erste Schritte Arrow-right.svg

Betriebssystem auswählen

FreeCAD ist eine echte Multi-Platform-Anwendung, die mit dem weltberühmten Qt-Framework entwickelt wurde. Das bedeutet, Aussehen und Verhalten von FreeCAD sind unter Windows, Linux und Mac OS gleich. Der Ablauf der Installation unterscheidet sich jedoch geringfügig zwischen den einzelnen Betriebssystemen. Wählen Sie Ihr Betriebssystem (s.u.), um mehr Details über die Installation von FreeCAD zu erhalten.

'Windows' 'Linux' 'Mac'
Installation für Windows Installation für Linux/Unix Installation für Mac

Installieren zusätzlicher Inhalte

Die lokal verfügbare Dokumentation ist nicht in allen Installationsoptionen enthalten, aber als separates Paket erhältlich; zu Details siehe Installieren von Hilfedateien.

Abgesehen von den Standard-Arbeitsbereichen, die mit FreeCAD gebündelt sind, gibt es eine wachsende Sammlung nützlicher zusätzlicher Workbenches und Module, die von Community-Mitgliedern im Internet zur Verfügung gestellt werden. Es sind Bemühungen im Gange, diese zu sammeln und Ihnen auf bequeme Weise zur Verfügung zu stellen. Welche Möglichkeiten Sie haben, ist unten aufgeführt.

Da diese Workbenches nicht Teil des offiziellen FreeCAD-Pakets sind und nicht vom Kern-FreeCAD-Team direkt unterstützt werden, sollten Sie die jeweils beigefügten Informationen lesen, bevor Sie sie installieren, um sicherzustellen, dass Sie wissen, was Sie installieren. Außerdem sollten Fehlerberichte und Feature-Anfragen direkt an den jeweiligen Addon-Entwickler gehen.

Das FreeCAD-Addon Repository

Seit FreeCAD 0.17 können die Addons direkt mit dem Werkzeuge-Menü verwaltet werden, so dass es nicht notwendig ist, das hier erwähnte Makro zu installieren.

Dies ist eine Sammlung von nützlichen Workbenches und Makros, die das GIT Submodul-System benutzen, welches es erlaubt, ständig aktualisierte Inhalte zu erhalten. Das FreeCAD-Addons-Repository finden Sie unter https://github.com/FreeCAD/FreeCAD-addons. Dieses Repository verfügt über ein Installer-Makro, das von FreeCAD aus gestartet werden kann und jedes der Add-Ons automatisch auflistet, herunterlädt und installiert.

Bei FreeCAD 0.17 und höher verwende das Addon Manager.

*Mit FreeCAD 0.16 und älteren Versionen installiere das Addon-Installationsmakro:

  1. # Klicke mit der rechten Maustaste auf [addons_installer.FCMacro and choose Save as...
  2. Platziere das heruntergeladene Makro in Deinem FreeCAD Macros Ordner'. Der Ordner FreeCAD Macros wird im MenüMakros → Makros → User macros location:

Macro installer 01.jpg

  1. Starte FreeCAD neu. Das Addons-Installationsprogramm wird nun im Menü Macro → Macros aufgelistet und kann durch Auswählen und Anklicken der Schaltfläche Execute gestartet werden:

Macro installer 02.jpg

Die Erweiterung für das Laden von Zusatzmodulen

Die Erweiterung für das Laden von Zusatzmodulen (pluginloader) ist eine viel besser ausgearbeitete Möglichkeit zusätzliche Inhalte für FreeCAD zu installieren und zu verwalten. Installieren Sie diese Erweiterung mit der obigen Methode oder folgen Sie den Anweisungen auf der pluginloader-Seite.

Die Zusatzmodullader Erweiterung wurde durch den Addon Manager ersetzt.

Manuelles installieren

Externe Arbeitsbereiche, wenn sie vollständig in Python programmiert sind (was die Mehrheit ausmacht), können einfach manuell installiert werden, indem man sie einfach herunterlädt (auf die Schaltflächen Clone oder Download oder Download ZIP auf GitHub klickt) und sie in den Benutzerordner FreeCAD/Mod (oder in den Ordner Makros legt, wenn es sich um MaKros handelt). Weitere Informationen finden Sie in den Anweisungen auf den einzelnen Addon-Seiten.

Anmerkungen für Nutzer mit 32-bit System und FreeCAD 0.16.6706

Nach Installationsversuchen sind die zusätzlichen Arbeitsbereiche möglicherweise nicht verfügbar. In diesem Fall

Externe, von FreeCAD unterstützte Anwendungen

FreeCAD unterstützt von Haus aus eine Menge externer Anwendungen. Das heißt, dass die Software nur installiert werden muss und beim nächsten Start automatisch verfügbar ist. Eine Neu-Kompilierung ist nicht notwendig. Dieser Abschnitt möchte eine Liste derartiger Anwendungen bereitstellen, zusammen mit Informationen darüber, wie sie in FreeCAD verwendet werden, und wo man sie beziehen kann.

FreeCAD supports a whole lot of external software packages out of the box. This means, you just need to install the software and it will be automatically available, the next time you start it. There's no need to recompile it. This section aims to provide a list of all such software packages, together with some information of where it's used in FreeCAD and where you can grab them.

Support

GraphViz

GraphViz ist eine Open Source-Software zur Visualisierung von Graphen. In FreeCAD wird sie verwendet um Abhängigkeitsgraphen über das Menü Werkzeuge → Abhängigkeitsgraph... zu erstellen. Die Homepage ist auf https://www.graphviz.org.

GraphViz is an open source graph visualization software. In FreeCAD it is used to generate dependency graphs through Tools → Dependency Graph. Its homepage is at https://www.graphviz.org

OpenCAMLib

Eine Open Source-Bibliothek, die Algorithmen für Computer Aided Manufacturing (CAM) bereitstellt. Sie wird in FreeCAD im Path-Arbeitsbereich verwendet. Die Homepage ist auf http://www.anderswallin.net/CAM/.

OpenCAMLib is an open source library of computer aided manufacturing (CAM) algorithms and used in the Path Workbench. See its page for installation instructions.

OpenSCAD

Der Programmers Solid 3D CAD Modellierer ist eine weitere CAD Software, die auf der Constructive Solid Geometry (CSG) Methode basiert. Das bedeutet, dass er keine Netze bearbeiten kann, sondern ausschließlich mit Festkörpergeometrie arbeitet. FreeCAD kann Dateien, die von OpenSCAD erzeugt wurden importieren und dessen Format exportieren, indem über das Menü Datei → Importieren und Datei → Exportieren eines der Dateiformate OpenSCAD CSG format oder OpenSCAD format ausgewählt wird. Man kann OpenSCAD über https://www.openscad.org/ beziehen.

OpenSCAD is solid 3D modeller based on the constructive solid geometry (CSG) paradigm, where the model is created through a script. It can not handle meshes, but operates exclusively on solid geometry. FreeCAD can import and export files created from OpenSCAD through the Std Import and Std Export tools by the selecting the OpenSCAD CSG format or the OpenSCAD format file types. You can get OpenSCAD from https://www.openscad.org.

GitPython

Eine Python-Bibliothek die zur Interaktion mit Git-Repositories verwendet wird. Diese Funktionalität befindet sich bei FreeCAD derzeit im Entwicklungsstadium. Der Addon-Manager kann diese Bibliothek verwenden, um Addons aus einem Git Repository zu installieren. Das Projekt wird auf GitHub unter https://github.com/gitpython-developers/GitPython entwickelt.

GitPython is a library to interact with Git repositories. The Addon Manager can use this library to import addons from a Git repository. The project is hosted on GitHub at https://github.com/gitpython-developers/GitPython.

Finite element

CalculiX

CalculiX ist eine Suite aus zwei Finite-Elemente Paketen. Die Eine, CalculiX GraphiX, oder calculix-cgx, ist eine GUI zur Darstellung der Ergebnisse des anderen Paketes, CalculiX CrunchiX, oder calculix-ccx, einem FEM Solver. Nur die letztere wird von FreeCAD unterstützt. Es kann in der FEM Workbench über Solve->Solver CalculiX verwendet werden. Es werden ein Standard und ein experimenteller Solver von FreeCAD unterstützt. CalculiX kann von http://calculix.de heruntergeladen werden.

CalculiX is a suite of two finite element packages:

  • CalculiX CrunchiX, or calculix-ccx, is a FEM solver.
  • CalculiX GraphiX, or calculix-cgx, is a GUI frontend to display the results of the solver.

Only the solver is supported by FreeCAD. It can be accessed from the FEM Workbench through Solve → Solver CalculiX. There's a standard and experimental solver supported by FreeCAD. CalculiX can be downloaded from http://calculix.de

Gmsh

Ein Netzgenerator zum automatisierten Erzeugen von 3D Finite Element Netzen. Er kann von FreeCAD durch die FEM Workbench über das Menü Mesh → FEM mesh from shape by gmsh verwendet werden. Die Homepage von gmsh ist http://www.geuz.org/gmsh.

Gmsh is an automatic finite element mesh generator. It can be used in FreeCAD from the FEM workbench through Mesh → FEM mesh from shape by Gmsh. The homepage of Gmsh is at http://www.geuz.org/gmsh

Elmer

Elmer ist eine Simulationssoftware für multiphysikalische Fragestellungen, deren Quellcode in 2005 veröffentlicht wurde. In FreeCAD werden ihre Grid und Solver Module von der FEM Workbench über das Menü Solve → Solver Elmer verwendet. Die Homepage des Projektes ist unter https://www.elmerfem.org und es kann über GitHub von https://github.com/ElmerCSC/elmerfem/releases/ heruntergeladen werden.

Elmer is a multi-physics simulation software, which was open sourced in 2005. In FreeCAD its Grid and Solver modules can be used by the FEM Workbench through Solve → Solver Elmer. The project's homepage is at https://www.elmerfem.org and it can be downloaded from GitHub at https://github.com/ElmerCSC/elmerfem/releases.

FEniCS

FEniCS ist eine Platform zur numerischen Berechnung der Lösungen von partiellen Differentialgleichungen (PDEs), welche bei der Lösung von FEM Problemen weit verbreitet sind. Als solche kann sie von der FEM Workbench verwendet werden. FreeCAD kann FEniCS Netze (meshes) über das Menü Datei → Importieren und Datei → Exportieren durch Wahl des FEM mesh fenics Dateiformats importieren und exportieren. Die Homepage von FEniCS ist über https://fenicsproject.org erreichbar.

FEniCS is a computing platform to solve partial differential equations (PDEs), which are widely used when solving FEM problems. As such it can be used by the FEM workbench. FreeCAD can import and export FEniCS meshes through Std Import and Std Export by selecting the FEM mesh fenics file format. The homepage of FEniCS is at https://fenicsproject.org.

Z88

Z88 ist ein weiteres FEM Programm, das einen Mesher (Netzgenerator), einen Solver, sowie einen Konverter beinhaltet, welches von FreeCAD's FEM Workbench verwendet werden kann. Es kann über das Menü Solve->Solver Z88 erreicht werden. Für Z88 sind mehrere Pakete erhältlich, die frei verfügbar, aber Closed-Source sind. Das Z88OS, welches von FreeCAD benötigt wird, ist jedoch unter einer Open-Source Lizenz erhältlich. Die Homepage ist unter https://z88.de/ erreichbar. Z88OS wird auch auf GitHub unter https://github.com/LSCAD/Z88OS bereitgestellt, falls man es selbst kompilieren möchte.

Z88 is another FEM program, containing a mesher, solver and converters, which can be used by FreeCAD's FEM workbench. It can be accessed through Solve → Solver Z88. Z88 distributes several packages, which all freely available, but are closed source. The Z88OS however, published under an open source license, is what is needed by FreeCAD. The homepage is at https://en.z88.de/. Z88OS is also hosted on GitHub at https://github.com/LSCAD/Z88OS, if you want to compile it yourself.

OpenFOAM

Eine Bibliothek zur Bearbeitung und Manipulation von Feldern (Field Operation and Manipulation - FOAM), welche in der numerischen Strömungssimulation (Computational Fluid Dynamics - CFD) verwendet wird. Daher wird OpenFOAM von der FEM Workbench von FreeCAD benötigt. Sie kann über das Menü Model → Fluid constraints erreicht werden. Das Projekt ist über https://openfoam.org/ erreichbar.

OpenFOAM is a large collection of libraries for computational fluid dynamics (CFD) simulations. OpenFOAM can be used by external workbenches that build on top of FreeCAD to work as a preprocessor. The project resides at https://openfoam.org.

File formats

CAD Exchanger

Eine proprietäre, closed-source Anwendung zum Austausch diverser im CAD Umfeld verwendeter Dateiformate. Sie kann verwendet werden, um proprietäre, nicht-öffentliche Dateiformate in solche zu konvertieren, die von FreeCAD verwendet werden können. Die Homepage ist unter https://cadexchanger.com/ erreichbar, wo auch eine Evaluierungsversion heruntergeladen, oder eine Lizenz erworben werden kann.

A proprietary, closed source application for exchanging various file formats used in CAD. You can use it to convert proprietary, closed formats into a format which is accessible by FreeCAD. The homepage is at https://cadexchanger.com/ where you can download an evaluation version or purchase a license for the application.

DXF Importer

FreeCAD verfügt über eine eingebaute Im- und Exportfunktion für DXF Dateien, die in C++ programmiert ist. Derzeit hat diese jedoch noch nicht alle Merkmale des DXF Formates implementiert. Falls diese Merkmale benötigt werden, kann ein älterer, in Python programmierter Importer/Exporter über Bearbeiten → Einstellungen → Import-Export durch Aktivieren der Option Verwende einen älteren Python-Importeur verwendet werden. Hier kann man auch angeben, ob FreeCAD diesen automatisch herunterlädt oder ob man die Dateien selbst von https://github.com/yorikvanhavre/Draft-dxf-importer beziehen möchte. Der gewählte Importer/Exporter wird über die Menus Datei → Importieren oder Datei → Exportieren verwendet, indem man das AutoDesk DXF 2D Dateiformat wählt.

FreeCAD has a native importer and exporter for DXF files, programmed in C++. Currently this importer does not implement all features of the DXF format. If you rely on a not yet implemented feature, you enable an older python based importer/exporter through Edit → Preferences → Import-Export by activating the Use legacy python importer option. You can then choose to let FreeCAD automatically download the needed files or you can grab them from https://github.com/yorikvanhavre/Draft-dxf-importer. The chosen importer and exporter is used by Std Import and Std Export and choosing the AutoDesk DXF 2D file format.

ODA File Converter

Der ODA Dateikonverter ist eine proprietäre, Closed-Source und binäre, aber frei verfügbare Anwendung zum Import und Export der DWG und DXF Dateiformate. In FreeCAD kann er über die Menüs Datei → Importieren sowie Datei → Exportieren verwendet werden, indem man das AutoDesk DWG 2D Dateiformat auswählt. Er kann von https://www.opendesign.com/guestfiles/oda_file_converter heruntergeladen werden.

The ODA file converter is a proprietary, closed source, binary and freely available application to import and export DWG and DXF file formats. In FreeCAD it can be used by Std Import and Std Export when you select the AutoDesk DWG 2D file type. It can be downloaded from https://www.opendesign.com/guestfiles/oda_file_converter.

ifcOpenShell

IfcOpenShell ist eine Bibliothek zur Verwendung des Industry Foundation Classes (IFC) Dateiformates, welches in der Architektur Verwendung findet. Sie kann über den Arch-Arbeitsbereich und das Menü Arch → Dienstprogramme → Ifc Explorer erreicht werden. Die Homepage ist http://ifcopenshell.org.

IfcOpenShell is a library for working with the Industry Foundation Classes (IFC) file format used in architectural design. It can be accessed from the Arch Workbench through Arch → Utilities → Ifc Explorer. It's homepage is at http://ifcopenshell.org.

pycollada

Pycollada, auch bekannt unter python-collada ist eine Python-Bibliothek zum Lesen und Schreiben von COLLADA-Dokumenten, einem Standard zum Austausch von 3D-Szenen und -Elementen. Falls sie installiert ist, kann man Szenen aus COLLADA-Dateien über das Menü Datei → Importieren und Datei → Exportieren importieren und exportieren, indem man das COLLADA Dateiformat auswählt. Das Projekt wird auf GitHub unter https://pycollada.github.io/ gehostet. Man kann die Releases von https://github.com/pycollada/pycollada/releases/ herunterladen.

Pycollada, also known as python-collada, is a Python library to read and write COLLADA documents, a standard for exchanging 3D scenes and elements. If it is installed you can import and export scenes to and from COLLADA files through Std Import and Std Export by selecting the COLLADA file type. The project is hosted in GitHub at https://pycollada.github.io/ and you can download the releases at https://github.com/pycollada/pycollada/releases/.

Rendering

POVRay

POVRay ist ein bekannter Raytracer zum Rendern von fotorealistischen Bildern. Er ist einer von zwei Raytracern, die derzeit von FreeCAD über den Raytracing-Arbeitsbereich unterstützt werden. Man kann POVRay von https://www.povray.org/ herunterladen.

POVRay is a well-known raytracer which can render photorealistic images. It is one of two raytracers currently supported by FreeCAD in the Raytracing Workbench. You can download POVRay from https://www.povray.org.

LuxCoreRender

LuxCoreRender, auch bekannt als LuxRender, ist einer von aktuell zwei unterstützten Render Engines in FreeCAD. Er wird durch den Workflow in der Raytracing Workbench verwendet. Derzeit wird nur die ältere Version LuxRender-1.x von FreeCAD unterstützt, welche aber nicht mehr weiterentwickelt wird. Falls Sie Interesse daran haben, den Code auf den neuen LuxCoreRender-2 zu aktualisieren, können Sie über das Raytracing Projekt-Team mit den Entwicklern in Verbindung treten. Downloads für LuxRender-1.6 können noch über die LuxCoreRender GitHub Release Seite unter https://github.com/LuxCoreRender/LuxCore/releases heruntergeladen werden. Die Homepage des aktuellen LuxCoreRender Projektes ist https://www.luxcorerender.org.

LuxCoreRender, also known as LuxRender, is one of two currently supported render engines in FreeCAD. It is used through the workflow on the Raytracing Workbench. Currently only the old and abandoned LuxRender-1.x is supported by FreeCAD. Downloads for LuxRender-1.6 can be grabbed from the LuxCoreRender GitHub release page at https://github.com/LuxCoreRender/LuxCore/releases. The homepage for the current LuxCoreRender project is at https://www.luxcorerender.org.

Related Pages

Arrow-left.svg Über FreeCAD Vorherige:
Nächste: Erste Schritte Arrow-right.svg