Ustawienia Importu i Eksportu

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Import Export Preferences and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎français • ‎italiano • ‎polski • ‎română • ‎русский

Wprowadzenie

FreeCAD może importować i eksportować wiele formatów plików. Dla niektórych formatów istnieją dedykowane ustawienia. Można je znaleźć w Edytorze ustawień, w menu Edycja → Preferencja → Import-Export.

Nie wszystkie karty preferencji importu i eksportu są domyślnie dostępne. W przypadku niektórych z nich należy najpierw wczytać Środowisko pracy.

Uwagi

Strona TechDraw

Wymienione tutaj opcje DXF i SVG nie są używane przez polecenia TechDraw ExportPageSVG.svg Eksport strony do SVG i TechDraw ExportPageDXF.svg Eksport strony do DXF w Środowisku Workbench TechDraw.svg TechDraw ani przez opcję eksportu TechDraw: Plik → Eksportuj → Technical Drawing (*.svg *.dxf *.pdf).

Pliki OpenSCAD

Preferencje dotyczące importu i eksportu dla plików OpenSCAD są wymienione w innej części Edytora ustawień. Zobacz OpenSCAD Preferences.

Powiązane

Dodatkowe informacje znajdują się na kolejnych stronach:

  • Import elsport: Tabela zawierająca listę wszystkich obsługiwanych formatów plików.
  • FreeCAD Howto Import Export: Zestawienie wszystkich obsługiwanych formatów plików: Lista poradników, które mogą pomóc użytkownikom w konwersji danych z jednego formatu do drugiego.

Dostępne preferencje

DAE

Format Collada DAE (Digital Asset Exchange) jest standardowym formatem plików do wymiany danych Mesh. FreeCAD może importować siatki z plików .dae i eksportować obiekty oparte na kształcie do formatu .dae.

Uwaga dla użytkowników Linuksa: Do obsługi tego formatu pliku, FreeCAD wymaga modułu pyCollada.

Dla formatu DAE można sprecyzować, co następuje:

Nazwa opis
Współczynnik skalowania Wszystkie wymiary w pliku będą przeskalowane z podanym współczynnikiem.
Mesher Ustawia program tworzenia siatki, który powinien być używany. Jeśli używasz Netgen, upewnij się, że jest dostępny. Można to sprawdzić za pomocą Środowiska pracy Workbench Mesh.svg Mesh i narzędzia tworzenie siatki używając Netgen. Jeśli nie jest dostępne, należy zainstalować inną wersję FreeCAD, skompilowaną z Netgen.
Tessellatcja Wartość teselacji, którą należy stosować z programami tworzenia siatki „Builtin” i „Mefisto”.
Grading Wartość stopniowania używana do tworzenia siatki przy użyciu „Netgen”. Ta wartość opisuje, jak szybko zmniejsza się rozmiar siatki. Gradient lokalnego rozmiaru oczek h (x) jest ograniczony przez abs (Δh (x)) ≤ 1 / wartość.
Segmenty na krawędź Maksymalna liczba segmentów dla krawędzi.
Segmenty na promień Liczba segmentów na promień.
Second order Zezwalaj na siatkę drugiego rzędu.
Optymalizuj Zezwalaj na optymalizację.
Zezwalaj na kwadraty Zezwalaj na czworoboczne ściany.

DWG

DWG (pochodzący od rysunku) jest zastrzeżonym, zamkniętym źródłowym, binarnym formatem pliku używanym do przechowywania dwu- i trójwymiarowych danych projektowych i metadanych. FreeCAD wymaga zewnętrznego konwertera plików ODA do przetwarzania plików DWG.

Dla formatu DWG można określić tylko ścieżkę do ODA. Uwaga: Wszystkie ustawienia formatu pliku DXF dotyczą również formatu DWG.

Nazwa Opis
Ścieżka do konwertera plików ODA (dawniej Teigha) Określa ścieżkę do konwertera plików ODA.

DXF

AutoCAD DXF (Drawing eXchange Format) jest zastrzeżonym formatem wymiany danych CAD pomiędzy AutoCAD a innymi programami.

Dla formatu DXF można sprecyzować, co następuje:

Nazwa Opis
Pokaż to okno dialogowe podczas importu i eksportu To okno dialogowe preferencji zostanie wyświetlone podczas importowania lub eksportowania plików DXF.
Użyj starszego importera Pythona Jeśli opcja jest zaznaczona, używany jest importer Python, w przeciwnym razie nowszy C++. Importer C++ jest szybszy, ale nie posiada jeszcze tak wielu funkcji.

Importer Pythona używa opcji Edycja → Preferencje... → Draft → Ustawienia ogólne → Wewnętrzny poziom dokładności. Aby uzyskać dokładny wynik importu, ustaw tę wartość na 8 lub wyższą.

Użyj starszego eksportera Python Jeśli opcja ta jest zaznaczona, stosowany jest Eksporter Python, w przeciwnym razie nowszy C++. Eksporter C++ jest szybszy, ale nie ma jeszcze tak wielu funkcjonalności. dostępne w wersji 0.19
Pozwól programowi FreeCAD na automatyczne pobieranie i aktualizację bibliotek DXF Poprzez zaznaczenie tego, pozwolisz FreeCAD pobrać Python Converter do importu i eksportu DXF. Ten konwerter nie może być dołączony do programu FreeCAD, ponieważ posiada on inną licencję.
Import Wybierz co będzie importowane.
Jeśli opcja teksty i wymiary jest odznaczona, teksty i mtexts nie będą importowane.

Jeśli punkty nie są zaznaczone, nie będą importowane.

Jeśli zaznaczono opcję układy graficzne, zaimportowane zostaną również obiekty obszaru papieru.

Sprawdź '*blokady, jeśli chcesz, aby nienazwane bloki (zaczynające się od a *) były również importowane.

Utwórz Wybierz, co zostanie utworzone.
Jeśli wybrano proste kształty części, to zostaną utworzone tylko standardowe obiekty części. Jest to najszybszy proces.

Jeśli wybrana jest opcja 'Obiekty szkicowe, to w miarę możliwości tworzone będą parametryczne obiekty szkicowe.

Jeśli wybrana zostanie opcja 'Szkice, w miarę możliwości będą tworzone szkice.

Scale factor to apply to imported files Współczynnik skalowania ma zastosowanie podczas importu plików DXF. Współczynnik to konwersja pomiędzy jednostką Twojego pliku DXF a milimetrami. Przykład: dla plików w milimetrach: 1, w centymetrach: 10, w metrach: 1000, w calach: 25,4, w stopach: 304.8.
Pobierz oryginalne kolory z pliku DXF Jeśli opcja jest zaznaczona, kolory będą pobierane z obiektów DXF, gdy tylko będzie to możliwe. W przeciwnym razie zostaną zastosowane kolory domyślne.
Połącz geometrie Jeśli opcja jest zaznaczona, FreeCAD będzie próbował łączyć przypadkowe obiekty w linie łamane. Zauważ, że może to chwilę potrwać!
Grupowanie warstw w bloki Jeśli opcja zostanie zaznaczona, obiekty z tych samych warstw zostaną połączone w bloki robocze, które wyświetlają się szybciej, ale są mniej edytowalne.
Stosuj standardową wielkość czcionki dla tekstów Jeśli opcja jest zaznaczona, importowane teksty uzyskają standardowy rozmiar Draft: Tekst, zamiast rozmiaru, który mają w dokumencie DXF.
Korzystanie z VisGroups / Stosowanie warstw Jeśli opcja zostanie zaznaczona, warstwy DXF będą importowane jako Draft: VisGroups (wersja 0.18 i poniżej) lub Draft: Layers (dostępne w wersji 0.19).
Importuj obwiednie kreskowania jako linie łamane Jeśli opcja zostanie zaznaczona, kreskowanie zostanie zamienione na proste linie łamane.
Renderuj polilinie o szerokości Jeśli opcja zostanie zaznaczona, i polilinie mają zdefiniowaną szerokość, będą renderowane jako zamknięte linie łamane o odpowiedniej szerokości.
Elipsy i splajny traktuj jako polilinie Eksport elips i splajnów jest słabo obsługiwany. Użyj tej opcji, aby wyeksportować je jako polilinie.

Ustawienie "Max Spline Segment' jest wówczas maksymalną długością każdego z segmentów polilinii. Jeśli jest on ustawiony na "0", cały splajn jest traktowany jako odcinek prosty.

Eksportuj obiekty 3D jako siatki polipowierzchni Jeśli opcja zostanie zaznaczona, wszystkie obiekty zawierające powierzchnie zostaną wyeksportowane jako polipowierzchnie 3D.
Eksportowe widoki rysunków jako bloki Jeśli opcja ta jest zaznaczona, widoki rysunkowe będą eksportowane jako bloki. Może się to nie udać w przypadku szablonów po DXF R12.
Projektuj wyeksportowane obiekty wzdłuż aktualnego kierunku widoku Jeśli opcja zostanie zaznaczona, eksportowane obiekty będą rzutowane tak, aby odzwierciedlały aktualny kierunek widoku.

IGES

Format pliku Initial Graphics Exchange Specification (IGES) jest formatem umożliwiającym cyfrową wymianę informacji pomiędzy systemami CAD. Po opublikowaniu formatu pliku STEP, rozwój IGES został wstrzymany w 1996 roku, ale nadal jest on obsługiwany przez wiele programów CAD. Pliki IGES mają rozszerzenie .iges lub .igs.

Zakładka IGES jest wyświetlana w preferencjach tylko wtedy, gdy masz uruchomione jedno ze Środowisk pracy Workbench Part.svg Part, Workbench PartDesign.svg PartDesign lub Workbench OpenSCAD.svg OpenSCAD lub jeśli wcześniej używałeś jednego z tych środowisk.

Dla formatu IGES można sprecyzować, co następuje:

Nazwa Opis
Jednostki przeznaczone do eksportu IGES Wybierz jakie jednostki będą używane podczas eksportowania plików IGES.
Zapisuj bryły i korpusy jako Wybierz, w jaki sposób mają być generowane bryły i powłoki.

Jeśli wybrano opcję Grupy powierzchni przyciętych (typ 144), będą one eksportowane jako powierzchnie przycięte.

Jeżeli wybrano opcję Bryły (typ 186) i Powłoki (typ 514) / tryb B-REP, to bryły zostaną wyeksportowane jako bryły manifold obiekt B-Rep, powłoki jako korpusy.

Pomijanie pustych pozycji. Jeśli opcja została zaznaczona, puste pozycje nie będa importowane.
Firma Jeśli pole nie jest puste, wprowadzony tekst zostanie użyty w nagłówku pliku IGES dla określenia nazwy firmy.
Autor Jeśli pole nie jest puste, wprowadzony tekst zostanie użyty w nagłówku pliku IGES dla określenia nazwy autora.
Produkt Jeśli pole nie jest puste, wprowadzony tekst zostanie użyty w nagłówku pliku IGES dla określenia nazwy produktu.

IFC

Industry Foundation Classes (IFC) to szeroko rozpowszechniony format wymiany danych pomiędzy aplikacjami BIM. Jest on używany w architekturze i inżynierii.

Uwaga dla użytkowników Linuksa: Do obsługi tego formatu pliku, FreeCAD wymaga modułu IfcOpenShell.

Dla formatu IFC można sprecyzować, co następuje:

Nazwa Opis
Pokaż to okno dialogowe podczas importu i eksportu To okno dialogowe preferencji zostanie wyświetlone podczas importowania lub eksportowania plików IFC.
Pokaż komunikaty o debugowaniu Wyświetla szczegółowe komunikaty debugowania podczas importowania i eksportowania plików IFC w panelu Widok raportu.
Tworzenie klonów, gdy obiekty mają wspólną geometrię Obiekty IFC mogą mieć tę samą definicję geometrii pomiędzy kilkoma obiektami, tylko ich rozmieszczenie jest różne. Tak więc gdy ta opcja jest włączona, klony są używane do osiągnięcia tego samego wyniku w FreeCAD. Jeden obiekt jest obiektem bazowym, pozostałe są klonami.
Importuj obiekty Arch IFC jako Co zostanie utworzone we FreeCAD dla obiektów arch IFC.
Import struct IFC objects as What will be created in FreeCAD for struct IFC objects.
Element główny Zaimportowane zostaną tylko podtypy określonego elementu. Zachowaj predefiniowany element IfcProduct aby zaimportować wszystkie elementy budowlane.
Oddzielne otwory Jeśli ta opcja jest zaznaczona, otwory będą importowane jako odjęcia, w przeciwnym razie otwory będą już odjęte od kształtów ścian.
Wykryj wytłoczenia Jeśli opcja zostanie zaznaczona, importer będzie próbował wykryć obecność wytłoczek. Należy pamiętać, że może to spowolnić proces.
Podział ścian wielowarstwowych Ściany działowe z wielu warstw.
Nazwy prefiksów z numerem ID Jeśli opcja jest zaznaczona, nazwy obiektów będą uzupełnione o numer IFC ID.
Łączenie materiałów o tej samej nazwie i tym samym kolorze Jeśli w pliku IFC znajduje się kilka materiałów o tej samej nazwie, będą one traktowane jako jeden.
Importuj właściwości Ifc w arkuszu kalkulacyjnym Jeśli opcja zostanie zaznaczona, każdy obiekt będzie miał swoje właściwości IFC przechowywane w obiekcie arkusza kalkulacyjnego.
Zezwalaj na nieprawidłowe kształty Jeśli opcja nie jest zaznaczona, nieprawidłowe kształty nie są importowane. dostępne w wersji 0.19
Lista wykluczeń Lista oddzielonych przecinkami podmiotów IFC które mają być wykluczone z importu.
Dopasuj widok podczas importowania Dopasuj widok podczas importu na importowane obiekty. Spowoduje to spowolnienie importu, ale można oglądać jego przebieg.
Importuj pełne definicje parametryczne FreeCAD, jeśli są dostępne Tworzy pełny model parametryczny na imporcie przy użyciu zapisanych właściwości obiektu FreeCAD.

Aby uzyskać parametry FreeCAD, model musi zostać wyeksportowany przy użyciu opcji Eksportuj pełny model parametryczny FreeCAD. dostępne w wersji 0.19

Wymuszenie eksportu jako Brep Niektóre przeglądarki IFC nie lubią obiektów eksportowanych jako wytłaczane. Użyj tej opcji, aby wyeksportować wszystkie obiekty jako geometria BREP. Należy jednak zauważyć, że czyni to obiekt nieparametrycznym. Unikaj eksportu jako Brep, jeśli to możliwe.
Używaj opcji triangulacji DAE Użyj opcji triangulacji ustawionych na stronie Opcje DAE.
Przy triangulacji połącz ścianki współpłaszczyznowe. Kształty zakrzywione, które nie mogą być przedstawione jako krzywe w IFC, są rozkładane na płaskie ścianki. Jeżeli jest to zaznaczone, wykonywane są dodatkowe obliczenia w celu połączenia ścianek współpłaszczyznowych.
Przechowuj uniwersalny identyfikator IFC w obiektach FreeCAD Przy eksporcie obiektów bez unikalnego ID (UID), wygenerowany UID zostanie zapisany wewnątrz obiektu FreeCAD do ponownego użycia przy następnym wyeksportowaniu tego obiektu. Prowadzi to do mniejszych różnic pomiędzy wersjami plików.
Użyj serializatora IfcOpenShell, jeśli jest dostępny IFCOpenShell to biblioteka, która pozwala na import plików IFC. Jej funkcja "serializer" pozwala nadać jej kształt OCC i wytworzyć odpowiednią geometrię IFC: NURBS, czołową, lub inna.
Zauważ, że serializer jest nadal funkcją eksperymentalną.
Eksportuj obiekty 2D jako IfcAnnotations Jeśli opcja zostanie zaznaczona, obiekty 2D będą eksportowane jako IfcAnnotation.
Eksportuj pełny model parametryczny FreeCAD Jeśli opcja jest zaznaczona, wszystkie właściwości obiektu FreeCAD będą przechowywane wewnątrz eksportowanych obiektów, co pozwoli na odtworzenie pełnego modelu parametrycznego przy ponownym imporcie za pomocą opcji Importuj pełne definicje parametryczne FreeCAD, jeśli są dostępne.
Ponownie wykorzystuj podobne elementy Jeśli opcja zostanie zaznaczona, podobne obiekty zostaną użyte tylko raz w pliku, jeśli to możliwe. Może to znacznie zmniejszyć rozmiar pliku, ale sprawi, że będzie on mniej czytelny.
Wyłącz IfcRectangleProfileDef Jeśli to możliwe, obiekty IFC, które są wyciągniętymi prostokątami, będą eksportowane jako IfcRectangleProfileDef. Jednakże niektóre inne aplikacje mogą mieć problemy z importem tej wielkości. Jeśli tak jest w Twoim przypadku, możesz to wyłączyć, a następnie wszystkie profile zostaną wyeksportowane jako IfcArbitraryClosedProfileDef.
Automatyczne wykrywanie i eksport jako standardowe przypadki, gdy ma to zastosowanie Niektóre typy IFC, takie jak IfcWall or IfcBeam mają specjalne standardowe wersje, jak na przykład: IfcWallStandardCase or IfcBeamStandardCase. Jeśli ta opcja jest włączona, FreeCAD automatycznie wyeksportuje takie obiekty jako przypadki standardowe, gdy spełnione zostaną niezbędne warunki. dostępne w wersji 0.19
Dodaj stronę domyślną, jeśli nie ma jej w dokumencie Podczas eksportu pliku IFC, jeśli w dokumencie FreeCAD nie ma żadnej strony, zostanie dodana strona domyślna. Standard IFC nie jest obowiązkowy, ale powszechną praktyką jest posiadanie co najmniej jednej takiej strony w pliku. dostępne w wersji 0.19
Dodaj domyślny budynek, jeśli nie ma go w dokumencie (brak standardu) Podczas eksportu pliku IFC, jeśli w dokumencie FreeCAD nie ma budynku, to zostanie dodany domyślny.

Ostrzeżenie: Standard IFC wymaga, aby w każdym pliku był co najmniej jeden budynek. Wyłączenie tej opcji spowoduje, że powstanie niestandardowy plik IFC.

Jednak w FreeCAD uważamy, że posiadanie budynku nie powinno być obowiązkowe, a ta opcja ma szansę na przedstawienie naszego punktu widzenia. dostępne w wersji 0.19

Dodaj domyślną kondygnację budynku, jeśli nie ma jej w dokumencie Podczas eksportu pliku IFC, jeśli w dokumencie FreeCAD nie ma kondygnacji budynku, zostanie dodana domyślna. Kondygnacja budynku nie jest obowiązkowa w standardzie IFC, ale powszechną praktyką jest posiadanie w pliku co najmniej jednej z nich. dostępne w wersji 0.19
IFC file units Wybierz jakie jednostki będą używane podczas eksportu plików IFC. dostępne w wersji 0.19

INP

INP jest formatem pliku wejściowego dla oprogramowania FEM Abaqus. Jest on używany dla CalculiX solvera w Środowisku pracy Workbench FEM.svg FEM.

Zakładka INP jest wyświetlana w preferencjach tylko wtedy, gdy używasz Środowiska pracy FEM lub gdy używałeś go wcześniej.

Dla formatu INP można sprecyzować, co następuje:

Nazwa Opis
Elementy siatki, które mają być eksportowane Wybierz, które parametry elementu siatki mają być eksportowane.

Jeśli wybrano Wszystkie, wszystkie elementy zostaną wyeksportowane.

Jeśli wybrana zostanie opcja 'Najwyższy, eksportowane będą tylko najwyższe elementy. Oznacza to wielkości dla siatki objętościowej i ścian dla siatki powłoki.

Jeśli wybrana zostanie opcja FEM, eksportowane będą tylko elementy FEM. Oznacza to tylko krawędzie nie należące do powierzchni i powierzchnie nie należące do objętości.

Eksportuj dane grupy Jeśli opcja jest zaznaczona, grupy siatek są również eksportowane. Każde wiązanie oraz, jeśli istnieją różne materiały, materiał składa się z dwóch grup siatki, ścianek i ich węzłów, w których stosowane jest to wiązanie lub materiał.

Formaty Mesh

Siatki są szczególnym rodzajem obiektu 3D, składającego się z trójkątnych powierzchni połączonych swoimi wierzchołkami i krawędziami. Są one szeroko stosowane do produkcji przyrostowej. FreeCAD dostarcza Workbench Mesh.svg Środowisko pracy Mesh do tworzenia i obsługi siatek. FreeCAD obsługuje kilka formatów plików mesh.

Zakładka Format Mesh jest wyświetlana w preferencjach tylko wtedy, gdy używasz Środowiska pracy Mesh lub gdy używałeś go wcześniej.

Dla formatów Mesh można sprecyzować, co następuje:

Nazwa Opis
Maksymalne odchylenie siatki Określenie maksymalnego odchylenia siatki od obiektu.
Eksport plików AMF z zastosowaniem kompresji Jeśli opcja jest zaznaczona, podczas zapisu pliku mesh w formacie AMF stosowana jest kompresja ZIP.

OCA

Format pliku OCA jest projektem społeczności, mającym na celu stworzenie wolnego, prostego i otwartego formatu pliku CAD. OCA jest w dużej mierze oparty na formacie pliku GCAD generowanym przez program gCAD3D. Oba formaty mogą być importowane we FreeCAD, a eksportowane przez FreeCAD pliki OCA mogą być otwierane w gCAD3D.

Dla formatu OCA można sprecyzować, co następuje:

Nazwa Opis
Import obszarów OCA Jeśli opcja zostanie zaznaczona, obszary (powierzchnie 3D) również zostaną zaimportowane.

STEP

Format pliku Standard for The Exchange of Product model data (STEP) to standard ISO dotyczący interpretacji komputerowej i wymiany informacji o wytwarzaniu produktu. STEP jest powszechnie używany do wymiany danych 3D między oprogramowaniem CAD. Pliki STEP mają rozszerzenie .step lub .stp. W przypadku plików skompresowanych używane jest rozszerzenie .stpz.

Zakładka STEP jest wyświetlana w preferencjach tylko wtedy, gdy masz uruchomione jedno ze Środowisk pracy Workbench Part.svg Part, Workbench PartDesign.svg PartDesign lub Workbench OpenSCAD.svg OpenSCAD lub jeśli wcześniej używałeś jednego z tych środowisk.

Dla formatu STEP można sprecyzować, co następuje:

Nazwa Opis
Jednostki przeznaczone do eksportu w formacie STEP Wybierz jednostki, które będą używane podczas eksportu plików STEP.
Zapisz krzywe w przestrzeni parametrycznej powierzchni Jeżeli opcja jest zaznaczona, to do pliku STEP zostaną zapisane krzywe parametryczne (krzywe w przestrzeni parametrycznej powierzchni). Odznaczenie tej opcji może być pomocne w zminimalizowaniu rozmiaru wynikowego pliku STEP.
Eksport niewidocznych obiektów Usuń zaznaczenie, aby pomijać obiekty niewidoczne podczas eksportu, co jest przydatne w programach CAD, które nie obsługują stylu niewidzialności STEP. dostępne w wersji 0.19
Eksport pojedynczych obiektów Zaznacz tę opcję, aby zachować informacje o położeniu podczas eksportu pojedynczego obiektu. Zauważ, że podczas ponownego importu pliku STEP, położenie zostanie zakodowane w geometrii kształtu, zamiast utrzymania go wewnątrz właściwości Umieszczenie. dostępne w wersji 0.19
Użyj starszego eksportera Skorzystaj ze starszego eksportera. dostępne w wersji 0.19
Schemat Wybierz, jaki protokół aplikacji (AP) STEP będzie używany do eksportu.

AP 203 jest protokołem do projektowania 3D części i zespołów mechanicznych z kontrolą konfiguracji.

AP 214 jest protokołem dla podstawowych danych dla procesów projektowania mechaniki samochodowej.

Włączyć łączenie zespołów STEP Jeśli opcja jest zaznaczona, podczas odczytu pliku zostanie wykonane połączenie związków. Proces ten jest wolniejszy, ale skutkuje zwiększeniem szczegółów.
Używaj LinkGroup Wybierz ta opcję aby uźyć kontenerów grupy App::LinkGroup zamiast App::Part. dostępne w wersji 0.19
Importowanie niewidocznych obiektów Wybierz tą opcję, aby zaimportować niewidoczne obiekty. dostępne w wersji 0.19
Ograniczyć liczbę obiektów Zmniejszenie liczby obiektów za pomocą tablic powiązań. dostępne w wersji 0.19
Rozwiń kształt związku Rozwiń złożone kształty za pomocą wielu brył. dostępne w wersji 0.19
Pokaż pasek postępu przy imporcie Pokaż pasek postępu w trakcie trwania importu. dostępne w wersji 0.19
Ignoruj nazwy poszczególnych instancji Nie należy używać nazw instancji. Przydatne dla niektórych starszych plików STEP z nieoznaczonymi nazwami instancji wygenerowanymi automatycznie. dostępne w wersji 0.19
Tryb Wybierz wymaganą strukturę dokumentu. dostępne w wersji 0.19

Jeden dokument

Montaż według dokumentu

Każde złożenie na odrębny dokument w podkatalogu

Obiekt na odrębny dokument

Każde obiekt na odrębny dokument w podkatalogu

Firma Jeśli pole nie jest puste, wprowadzony tekst zostanie użyty w nagłówku pliku STEP dla określenia danych firmy.
Autor Jeśli pole nie jest puste, wprowadzony tekst zostanie użyty w nagłówku pliku STEP dla określenia nazwy autora.
Produkt Jeśli pole nie jest puste, wprowadzony tekst zostanie użyty w nagłówku pliku STEP dla określenia danych produktu.

SVG

Skalowalna grafika wektorowa (Scalable Vector Graphics - SVG) to format obrazu wektorowego dla grafiki dwuwymiarowej. Obraz wektorowy może być skalowany do dowolnego rozmiaru bez utraty jego kształtu i szczegółów. Obraz SVG może być konwertowany do formatów bitmapowych takich jak PNG lub JPEG dla potrzeb późniejszego wydruku.

Dla formatu SVG można sprecyzować, co następuje:

Nazwa Opis
Tryb importu Wybierz, jak będą importowane kolory obiektów SVG i szerokości linii.

W przypadku wybrania opcji Brak (najszybszy) nie zostaną zaimportowane żadne ustawienia koloru i szerokości linii.

Jeśli wybrana jest opcja Użyj domyślnego koloru i szerokości linii FreeCAD użyje własnego (domyślnego) koloru i szerokości linii.

Jeśli wybrana jest opcja Oryginalny kolor i szerokość linii FreeCAD użyje koloru i szerokości linii pochodzącej z obiektów SVG.

Wyłącz skalowanie jednostek Jeśli opcja ta jest zaznaczona, nie będzie miała miejsca żadna konwersja jednostek. Jedna jednostka z pliku SVG zostanie przetłumaczona jako jeden milimetr.
Tryb eksportu Wybierz sposób, w jaki szkice są eksportowane do SVG.

Jeśli wybrano opcję Przetłumaczone (do drukowania i wyświetlania), obiekty SVG są umieszczane w grupie, która jest skalowana i przenoszona w odpowiednie miejsce w dokumencie SVG, aby zmieściła się w obszarze drukowania.

Jeżeli wybrana jest opcja Raw (dla CAM), to obiekty SVG są umieszczane w takim stanie, w jakim są - na tych samych współrzędnych co w modelu FreeCAD (eksport 1:1).

Przełóż kolor białej linii na czarną Jeśli opcja będzie zaznaczona, wszystkie białe linie pojawią się w pliku SVG w kolorze czarnym, aby zapewnić lepszą czytelność na białym tle.
Maksymalna długość segmentu dla łuków dyskretnych Wersje Open CASCADE starsze od 6.8 nie obsługują wyświetlania łuku. W tym przypadku łuki zostaną podzielone na małe odcinki linii. Wartość ta jest maksymalną długością segmentu.

VTK

Oprogramowanie Visualization Toolkit (VTK) jest otwartym, ogólnodostępnym systemem oprogramowania dla grafiki komputerowej 3D, przetwarzania obrazu i wizualizacji. Pliki VTK są wykorzystywane przez Środowisko pracy Workbench FEM.svg FEM dla przetwarzania końcowego wyników symulacji.

Zakładka VTK jest wyświetlana w preferencjach tylko wtedy, gdy używasz Środowiska pracy FEM lub gdy używałeś go wcześniej.

Dla formatu VTK można sprecyzować, co następuje:

Nazwa Opis
Który obiekt ma zostać zaimportowany Wybierz, które z obiektów mają być importowane.

Jeżeli jest wybrana opcja 'Obiekt wynikowy VTK, to zostanie zaimportowany obiekt wynikowy FreeCAD FEM VTK (odpowiadający obiektowi, który został wyeksportowany).

Jeżeli jest wybrany obiekt FEM mesh, to wyniki w pliku VTK zostaną pominięte, tylko dane mesh zostaną zaimportowane i zostanie utworzony obiekt FreeCAD FEM mesh.

Jeżeli jest wybrany "obiekt wynikowy FreeCAD, to importowane dane zostaną przekonwertowane na obiekt wynikowy FreeCAD FEM. Uwaga: to ustawienie wymaga dokładnych nazw komponentów wynikowych i dlatego działa poprawnie tylko z plikami VTK eksportowanymi z FreeCAD.