Préférences d'Import Export

From FreeCAD Documentation
(Redirected from Import Export Preference/fr)
Jump to navigation Jump to search
This page is a translated version of the page Import Export Preferences and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎português do Brasil • ‎română • ‎русский • ‎한국어

Introduction

FreeCAD peut importer et exporter de nombreux formats de fichiers. Pour certains formats, des préférences dédiées existent. Vous les trouverez dans l'Éditeur de préférences dans le menu Édition → Préférences → Import-Export.

Tous les onglets des préférences d'importation et d'exportation ne sont pas disponibles par défaut. Pour certains, un établi doit d'abord être chargé.

Remarques

Pages TechDraw

Les préférences DXF et SVG énumérées ici ne sont pas utilisées par les fonctions TechDraw ExportPageSVG.svg Exporter une page au format SVG et TechDraw ExportPageDXF.svg Exporter une page au format DXF de l'Workbench TechDraw.svg atelier TechDraw, ou par l'option d'exportation de TechDraw : Fichier → Exporter → Dessin technique (*.svg *.dxf *.pdf).

Fichiers OpenSCAD

Les préférences d'importation et d'exportation des fichiers OpenSCAD sont répertoriées dans une autre partie de l'Editeur de préférences. Voir les Préférences OpenSCAD.

En relation

Consultez les pages suivantes pour plus d'informations:

Préférences disponibles

DAE

Le format Collada DAE (Digital Asset Exchange) est un format de fichier standard pour l'échange de données de maillage. FreeCAD peut importer des maillages à partir de fichiers .dae et exporter des objets basés sur un Part au format .dae.

Remarque pour les utilisateurs de Linux: Pour gérer ce format de fichier, FreeCAD nécessite le module pyCollada.

Pour le format DAE, vous pouvez spécifier les éléments suivants :

Nom Description
Facteur d'échelle Toutes les dimensions du fichier seront mises à l'échelle avec le facteur spécifié.
Mailleur Définit le programme de maillage à utiliser. Si vous utilisez Netgen , assurez-vous qu'il est disponible. Cela peut être vérifié en utilisant Workbench Mesh.svg Atelier Mesh et Créer un maillage à l'aide de Netgen. S'il n'est pas disponible, une autre version de FreeCAD, compilée avec Netgen, doit être installée.
Tessellation Valeur de pavage à utiliser avec le programme de maillage Builtin et Mefisto.
Progressivité Valeur de classement à utiliser pour le maillage à l'aide de Netgen. Cette valeur décrit la vitesse à laquelle le maillage diminue. Le gradient du maillage local h(x) est lié par abs(Δh(x))≤1/value.
Segments par arête Nombre maximum de segments par bord.
Segments par rayon Nombre de segments par rayon.
Second ordre Autorise un maillage de second ordre.
Optimiser Permet l'optimisation.
Autoriser les quadrangles Autorise quadrilateral faces.

Preferences Import Export Tab DAE.png

DWG

DWG (à partir d'un dessin) est un format de fichier binaire propriétaire, à source fermée, permettant de stocker des données et des métadonnées de conception 2D et 3D. FreeCAD nécessite des convertisseurs externes pour traiter les fichiers DWG.

Remarque: tous les paramètres du format de fichier DXF s'appliquent également à DWG.

Pour le format DWG vous pouvez spécifier ce qui suit :

Nom Description
Méthode de conversion. Sélectionnez le convertisseur DWG à utiliser :
  • Automatique : FreeCAD va essayer de trouver un convertisseur automatiquement en suivant l'ordre du reste de cette liste.
  • LibreDWG : LibreDWG est une bibliothèque de lecture et d'écriture DWG open-source. Il lui manque le support de plusieurs entités DWG et ne donne pas toujours des résultats fidèles.
  • ODA Converter : ODA File Converter est un utilitaire gratuit fourni par l'Open Design Alliance. Il donne des résultats très bons et fiables.
  • QCAD pro : QCAD pro est la version payante de la plateforme de CAO 2D QCAD basée sur le format DXF. Son convertisseur DWG utilise les bibliothèques Teigha de l'OpenDesign Alliance et donne donc les mêmes bons résultats que le convertisseur de fichiers ODA.

Introduit dans la version 0.20

Chemin vers le convertisseur de fichiers. FreeCAD essaiera de trouver automatiquement le chemin du convertisseur DWG sélectionné. Si FreeCAD ne le trouve pas, vous pouvez spécifier le chemin de l'exécutable ici :
  • dwg2dxf.exe (LibreDWG)
  • ODAFileConverter.exe (Convertisseur de fichiers ODA)
  • dwg2dwg.exe (QCAD pro).

Introduit dans la version 0.20

Preferences Import Export Tab DWG.png

DXF

AutoCAD DXF (Drawing eXchange Format) est un format propriétaire permettant d'échanger des données CAO entre AutoCAD et d'autres programmes.

Pour le format DXF, vous pouvez spécifier les éléments suivants :

Nom Description
Afficher cette boîte de dialogue lors de l'importation et l'exportation Si cochée, cette boîte de dialogue de préférences s'affiche lors de l'importation ou de l'exportation de fichiers DXF.
Utiliser l'ancien importateur python S'il est coché, l'importateur Python est utilisé, sinon le plus récent C ++. L'importateur C ++ est plus rapide mais n'a pas encore autant de fonctionnalités.

L'importateur Python utilise la préférence Edition → Préférences... → Draft → Paramètres généraux → Niveau de précision interne. Pour un résultat d'importation précis, définissez cette valeur sur 8 ou plus.

Utiliser l'ancien importateur python Si coché, l'exportateur Python est utilisé, sinon le plus récent C++. L'exportateur C++ est plus rapide mais n'a pas encore autant de fonctionnalités. Introduit dans la version 0.19
Permettre à FreeCAD de télécharger et mettre à jour automatiquement les librairies DXF En cochant cette case, vous autoriserez FreeCAD à télécharger le convertisseur Python pour l'importation et l'exportation DXF. Ce convertisseur ne peut pas être fourni avec FreeCAD car il possède une licence logicielle différente.
Importation Sélectionnez ce qui sera importé.

Si textes et dimensions n'est pas coché, les textes et mtexts ne seront pas importés.

Si points n'est pas coché, les points ne seront pas importés.

Si layouts est coché, les objets d'espace papier seront également importés.

Cochez *blocs si vous voulez que les blocs anonymes (dont les noms commencent par un *) soient également importés.

Créer Sélectionnez ce qui sera créé.

Si Formes Part uniquement est sélectionné, seuls les objets Part standard seront créés. C'est le plus rapide.

Si Draft objects est sélectionné, les objets Draft paramétriques seront créés chaque fois que possible.

Si Sketches est sélectionné, les esquisses seront créées dans la mesure du possible.

Facteur d’échelle à appliquer aux fichiers importés Facteur d'échelle à appliquer aux fichiers DXF lors de l'importation. Le facteur est la conversion entre les unités de votre fichier DXF et les millimètres. Exemple: pour les fichiers en millimètres: 1, en centimètres: 10, en mètres: 1000, en pouces: 25,4, en pieds: 304,8.
Obtenez les couleurs d'origine du fichier DXF Si cette case est cochée, les couleurs seront récupérées des objets DXF dans la mesure du possible. Sinon, les couleurs par défaut seront appliquées.
Joindre la géométrie Si coché, FreeCAD essaiera de joindre des objets coïncidents dans des fils. Notez que cela peut prendre un certain temps!
Grouper les couches dans des blocs Si cette case est cochée, les objets des mêmes calques seront joints aux blocs de dépouille, qui s'affichent plus rapidement mais sont moins facilement modifiables.
Utiliser la taille de police standard pour les textes Si cette case est cochée, les textes importés auront la taille standard Draft Texte au lieu de la taille qu'ils ont dans le document DXF.
Utiliser les calques Si cette case est cochée, les couches DXF seront importées en tant que Draft Calque (Introduit dans la version 0.19).
Importation des contours de hachures comme filaires Si cette case est cochée, les hachures seront converties en fils simples.
Rendre les polylignes avec leur épaisseur Si cochée, si les polylignes ont une largeur définie, elles seront rendues comme des fils fermés avec la bonne largeur.
Traiter les ellipses et les splines comme polylignes L'exportation des ellipses et des splines est mal prise en charge. Utilisez plutôt cette option pour les exporter en tant que polylignes.

Le paramètre Nombre max de segment par spline est alors la longueur maximale de chacun des segments de polyligne. S'il est défini sur 0, la spline entière est traitée comme un segment droit.

Exporter des objets 3D comme des maillages multi-facettes Si cette case est cochée, tous les objets contenant des faces seront exportés en tant que polyfaces 3D.
Les vues de dessin seront exportées en tant que blocs Si cette case est cochée, les vues de dessin seront exportées sous forme de blocs. Cela peut échouer pour les modèles post DXF R12.
Projeter les objets exportés suivant la direction de la vue actuelle Si cette case est cochée, les objets exportés seront projetés pour refléter la direction en cours de la vue.

Preferences Import Export Tab DXF.png

IGES

Le format de fichier Initial Graphics Exchange Specification (IGES) est un format de fichier qui permet l'échange numérique d'informations entre les systèmes de CAO. Après la publication du format de fichier STEP, le développement IGES a été arrêté en 1996, mais il est toujours pris en charge par de nombreux programmes de CAO. Les fichiers IGES ont l'extension .iges ou .igs .

L'onglet IGES n'apparaît dans les préférences que si les Workbench Part.svg atelier Part, Workbench PartDesign.svg atelier PartDesign ou Workbench OpenSCAD.svg L'atelier OpenSCAD a été chargé dans la session FreeCAD en cours.

Pour le format IGES vous pouvez spécifier ce qui suit:

Nom Description
Unités pour l'exportation vers IGES Sélectionne quelle unité sera utilisée lors de l'exportation des fichiers IGES.
Exporter les solides et les coques comme Sélectionne le mode de sortie des solides et des coques.

Si Groupes de surfaces ajustées (type 144) est sélectionné, ils seront exportés en tant que surfaces ajustées.

Si Solides (type 186) et coques (type 514) / mode B-REP sont sélectionnés, les solides seront exportés en tant que 29 objets B-Rep solide multiple, des coques comme coques.

Ignorer les entités vides Si cette case est cochée, les entités vides ne seront pas importées.
Entreprise S'il n'est pas vide, le texte saisi sera utilisé dans l'en-tête du fichier IGES de l'entreprise.
Auteur S'il n'est pas vide, le texte saisi sera utilisé dans l'en-tête du fichier IGES pour l'auteur.
Produit S'il n'est pas vide, le texte saisi sera utilisé dans l'en-tête du fichier IGES pour le produit.

Preferences Import Export Tab IGES.png

IFC

Le format de fichier [IFC (Industry Foundation Classes)] est très répandu. Il permet l’échange de données entre les applications [BIM]. Il est utilisé en architecture et en ingénierie.

Remarque pour les utilisateurs de Linux: pour gérer ce format de fichier, FreeCAD nécessite le module IfcOpenShell.

Importation IFC

Pour l'importation du format IFC, vous pouvez spécifier les éléments suivants :

Nom Description
Afficher cette boîte de dialogue lors de l'importation et l'exportation Si cette case est cochée, ce dialogue de préférences s'affichera lors de l'importation de fichiers IFC.
Messages de débogage du moteur de rendu Affiche des messages de débogage détaillés lors de l'importation et de l'exportation de fichiers IFC dans la Vue rapport .
Créez des clones quand les objets partagent une géométrie Les objets IFC peuvent partager une même définition de géométrie entre plusieurs objets, seul leur placement est différent. Lorsque cette option est activée, les clones sont utilisés pour obtenir le même résultat dans FreeCAD. Un objet est l'objet de base, les autres sont des clones.
Nombre de cœurs à utiliser (expérimental) Spécifiez le nombre de cœurs de CPU à utiliser pour l'importation IFC. Le nombre maximum doit être inférieur au nombre de cœurs réellement disponibles. Utilisez 0 pour désactiver cette fonctionnalité. Introduit dans la version 0.19
Importer des objets d'architecture IFC comme Ce qui sera créé dans FreeCAD pour les objets IFC archivés.
Importer en tant qu'objets de structure IFC Ce qui sera créé dans FreeCAD pour les objets struct IFC.
Élément racine Seuls les sous-types de l'élément spécifié seront importés. Conservez l'élément prédéfini IfcProduct pour importer tous les éléments de construction.
Séparer des ouvertures Si cette case est cochée, les ouvertures seront importées en tant que soustractions, sinon les formes des murs auront déjà leurs ouvertures soustraites.
Détecter les extrusions Si cette case est cochée, l'importateur tentera de détecter les extrusions. Notez que cela pourrait ralentir les choses.
Parois multicouches fendues Murs séparés en plusieurs couches.
Préfixe des noms avec numéro ID Si cette case est cochée, les noms des objets seront précédés du numéro ID IFC.
Fusionner les matériaux avec le même nom et la même couleur Si plusieurs documents portant le même nom se trouvent dans le fichier IFC, ils seront traités comme un seul.
Importer les propriétés IFC dans la feuille de calcul Si cette case est cochée, chaque propriétés IFC de chaque objet sera stocké dans un objet de feuille de calcul.
Autoriser les formes non valides Si les formes invalides non cochées ne sont pas importées. Introduit dans la version 0.19
Exclure la liste Une liste séparée par des virgules entités IFC à exclure des importations.
Ajustement de vue lors de l’importation Ajuster la vue lors de l'importation sur les objets importés. Cela ralentira l'importation, mais on peut regarder l'importation.
Importer des définitions paramétriques FreeCAD complètes si disponibles Crée un modèle paramétrique complet lors de l'importation à l'aide des propriétés d'objet FreeCAD stockées.

Pour obtenir les propriétés de FreeCAD, le modèle doit avoir été exporté à l'aide de l'option Exporter le modèle paramétrique complet FreeCAD. Introduit dans la version 0.19

Remplacer "Projet", "Site", "Bâtiment" et "Étages" par un "Groupe" Si cette case est cochée, les groupes seront utilisés pour remplacer les objets mentionnés. Introduit dans la version 0.19

Preferences Import Export Tab IFC import.png

Exportation IFC

Pour l'exportation du format IFC, vous pouvez spécifier les éléments suivants :

Nom Description
Afficher cette boîte de dialogue lors de l'importation et l'exportation Si cette case est cochée, ce dialogue de préférences s'affichera lors de l'exportation de fichiers IFC.
Type d'export Sélectionnez la façon dont le modèle doit être exporté : en tant que Modèle standard, Analyse structurelle ou Standard + structurel. Introduit dans la version 0.19
Forcer l'export en Brep Certains visionneurs IFC n'aiment pas les objets exportés sous forme d'extrusions. Utilisez cette option pour forcer tous les objets à être exportés en tant que géométrie BREP. Mais évitez d'exporter en tant que Brep si possible, car cela rend les objets non paramétriques.
Utiliser l'option de triangulation actif dans les options du DAE Utiliser les options de triangulation définies dans la page des options DAE.
Joindre les faces coplanaires pendant la triangulation Les formes courbes qui ne peuvent pas être représentées comme des courbes dans l'IFC sont décomposées en facettes plates. Si cette case est cochée, un calcul supplémentaire est effectué pour joindre les facettes coplanaires.
Enregistre l'identifiant unique IFC dans l'objet FreeCAD Lorsque vous exportez des objets sans unique ID (UID), l'UID généré sera stocké dans l'objet FreeCAD pour être réutilisé lors de la prochaine exportation de l'objet. Cela permet de réduire les différences entre les versions de fichiers.
Utiliser le sérialiseur IfcOpenShell si disponible IFCOpenShell est une bibliothèque pour les fichiers IFC. Sa fonctionnalité sérialiseur peut produire une géométrie IFC valide à partir de formes OCC.

Remarquez que cette fonctionnalité est encore expérimentale.

Exporter des objets 2D comme IfcAnnotations Si cette case est cochée, les objets 2D seront exportés en tant qu'IfcAnnotation.
Exporter le modèle paramétrique complet FreeCAD Si cette case est cochée, toutes les propriétés des objets FreeCAD seront stockées dans les objets exportés, ce qui permettra de recréer un modèle paramétrique complet lors de la réimportation en utilisant l'option Importer les définitions paramétriques complètes de FreeCAD si disponibles.
Réutiliser les entités similaires Si cette option est cochée, les entités similaires seront utilisées une seule fois dans le fichier si possible. Cela peut réduire considérablement la taille du fichier, mais le rendra moins facile à lire.
Désactiver IfcRectangleProfileDef Dans la mesure du possible, les objets IFC qui sont des rectangles extrudés seront exportés en tant que IfcRectangleProfileDef. Pour les applications qui rencontrent des problèmes lors de l'importation de ces entités, sélectionnez cette option pour vous assurer que tous les profils sont exportés en tant que IfcArbitraryClosedProfileDef.
Détecter automatiquement et exporter comme cas standards lorsque cela est applicable Certains types IFC tels que IfcWall ou IfcBeam ont des versions standard spéciales comme IfcWallStandardCase ou IfcBeamStandardCase. Si cette option est sélectionnée, FreeCAD exportera automatiquement ces objets en tant que cas standard lorsque les conditions nécessaires seront remplies. Introduit dans la version 0.19
Ajouter un site par défaut si aucun n'est trouvé dans le document Lors de l'exportation d'un fichier IFC, si aucun site n'est trouvé dans le document FreeCAD, un site par défaut est ajouté. Un site n'est pas obligatoire selon la norme IFC, mais il est courant d'en avoir au moins un dans le fichier. Introduit dans la version 0.19
Ajoute un bâtiment par défaut si aucun n'est trouvé dans le document (pas de standard) Lors de l'exportation d'un fichier IFC, si aucun bâtiment n'est trouvé dans le document FreeCAD, un bâtiment par défaut est ajouté.

Avertissement: La norme IFC demande au moins un bâtiment dans chaque fichier. En désactivant cette option, vous produirez un fichier IFC non standard.

Cependant, chez FreeCAD, nous pensons que la possession d'un bâtiment ne devrait pas être obligatoire, et cette option est là pour avoir une chance de démontrer notre point de vue. Introduit dans la version 0.19

Ajoutez l'étage par défaut de bâtiment si un n'est pas trouvé dans le document Lors de l'exportation d'un fichier IFC, si aucun étage de bâtiment n'est trouvé dans le document FreeCAD, un étage par défaut est ajouté. Un étage de bâtiment n'est pas obligatoire selon la norme IFC, mais il est courant d'en avoir au moins un dans le fichier. Introduit dans la version 0.19
Les éléments de fichier IFC Sélectionnez les unités qui seront utilisées lors de l'exportation des fichiers IFC. Introduit dans la version 0.19

Preferences Import Export Tab IFC export.png

INP

INP est le format de fichier d’entrée pour le logiciel FEM Abaqus. Il est utilisé pour le solveur CalculiX dans l'atelier FEM.

L'onglet INP n'est affiché dans les préférences que si l'Workbench FEM.svg atelier FEM a été chargé dans la session FreeCAD en cours.

Pour le format INP vous pouvez spécifier ce qui suit :

Nom Description
Quels éléments de maillage exporter Sélectionnez les éléments du maillage qui doivent être exportés.

Si Tous est sélectionné, tous les éléments seront exportés.

Si Le plus haut est sélectionné, seuls les éléments les plus élevés seront exportés. Cela signifie des volumes pour un maillage de volume et des faces pour un maillage de coque.

Si FEM est sélectionné, seuls les éléments FEM seront exportés. Cela signifie uniquement les arêtes n'appartenant pas aux faces et les faces n'appartenant pas aux volumes.

Exporter les données du groupe Si cette case est cochée, les groupes de mailles sont également exportés. Chaque contrainte et, s'il existe des matériaux différents, le matériau se compose de deux groupes de mailles, faces et nœuds où la contrainte ou le matériau est appliqué.

Preferences Import Export Tab INP.png

Formats de maillage

Les maillages sont un type spécial d'objet 3D, composé de faces triangulaires reliées par leurs vertices (sommets) et leurs arêtes. Ils sont largement utilisés pour l'Impression 3D. FreeCAD fournit l'Workbench Mesh.svg atelier Mesh pour créer et gérer des maillages. FreeCAD prend en charge plusieurs formats de fichiers maillés.

L'onglet Formats de maillage n'est affiché dans les préférences que si l'Workbench Mesh.svg atelier Mesh a été chargé dans la session FreeCAD en cours.

Pour les formats Mesh vous pouvez spécifier ce qui suit:

Nom Description
Déviation maximale du maillage Spécification de la déviation maximale entre le maillage et l'objet.
Exporter les fichiers AMF en utilisant la compression Si coché, la compression ZIP est utilisée lors de l'écriture d'un fichier de maillage au format AMF.
Largeur Largeur de la page Asymptote. Introduit dans la version 0.19
Hauteur Hauteur de la page Asymptote. Introduit dans la version 0.19

Preferences Import Export Tab Mesh Formats.png

OCA

Le format de fichier OCA est un projet communautaire visant à créer un format de fichier CAO libre, simple et ouvert. OCA est largement basé sur le format de fichier GCAD généré par gCAD3D. Ces deux formats peuvent être importés dans FreeCAD et les fichiers OCA exportés par FreeCAD peuvent être ouverts dans gCAD3D.

Pour le format OCA vous pouvez spécifier ce qui suit:

Nom Description
Importer les aires OCA Si coché, les régions (faces 3D) seront aussi importées.

Preferences Import Export Tab OCA.png

STEP

Le format de fichier Standard for The Exchange of Product model (STEP) est une norme ISO pour la représentation interprétable par ordinateur et l'échange d'informations sur la fabrication des produits. STEP est couramment utilisé pour échanger des données 3D entre des logiciels de CAO. Les fichiers STEP ont l'extension .step ou .stp. Pour les fichiers compressés, l'extension .stpz est utilisée.

L'onglet STEP n'est affiché dans les préférences que si l'Workbench Part.svg atelier Part, l'Workbench PartDesign.svg atelier PartDesign ou l'Workbench OpenSCAD.svg atelier OpenSCAD a été chargé dans la session FreeCAD en cours.

Pour le format STEP vous pouvez spécifier ce qui suit:

Nom Description
Unités pour l'exportation STEP Sélectionnez les unités qui seront utilisées lors de l'exportation des fichiers STEP.
Enregistrer les courbes dans l’espace paramétrique de surface Si cochée, les courbes paramétriques (courbes dans l'espace paramétrique des surfaces) seront écrites dans le fichier STEP. Décocher l'option peut être utile pour réduire la taille du fichier STEP résultant.
Exportation d'objets invisibles Décochez cette case pour ignorer l'objet invisible lors de l'exportation, ce qui est utile pour les applications de CAO qui ne prennent pas en charge l'invisibilité du style STEP. Introduit dans la version 0.19
Exportation du placement d'un seul objet Cochez cette option pour conserver les informations de placement lors de l'exportation d'un seul objet. Veuillez noter que lors de la réimportation du fichier STEP, le placement sera encodé dans la géométrie de la forme, au lieu de le conserver dans la propriété Placement.. Introduit dans la version 0.19
Utiliser l'ancien exportateur Utilisez l'exportateur hérité. Introduit dans la version 0.19
Schéma Sélectionnez le protocole d'application STEP (AP) à utiliser pour l'exportation.

AP 203 est le protocole pour la conception 3D contrôlée par configuration de pièces et d'assemblages mécaniques.

AP 214 est le protocole des données de base pour les processus de conception mécanique automobile.

Activer la fusion de combiné STEP Si cette case est cochée, une fusion compound sera effectuée pendant la lecture du fichier. Ceci est plus lent mais donne des détails plus élevés.
Use LinkGroup Sélectionne cette option pour utiliser les conteneurs de groupe App::LinkGroup au lieu des conteneurs de groupe App::Part. Introduit dans la version 0.19
Import invisible objects Sélectionnez cette option pour importer des objets invisibles. Introduit dans la version 0.19
Reduce number of objects Réduit le nombre d'objets à l'aide de réseaux de liens. Introduit dans la version 0.19
Expand compound shape Développe des formes composées avec plusieurs solides. Introduit dans la version 0.19
Show progress bar when importing Affiche une barre de progression lors de l'importation. Introduit dans la version 0.19
Ignore instance names N'utilisez pas de noms d'instance. Utile pour certains fichiers STEP hérités avec des noms d'instance générés automatiquement sans signification. Introduit dans la version 0.19

Single document

Assembly per document

Assembly per document in sub-directory

Object per document

Object per document in sub-directory

Société Si ce n'est pas vide, le texte saisi sera utilisé dans l'en-tête du fichier STEP de l'entreprise.
Auteur Si ce n'est pas vide, le texte saisi sera utilisé dans l'en-tête du fichier STEP pour l'auteur.
Produit Si ce n'est pas vide, le texte saisi sera utilisé dans l'en-tête du fichier STEP du produit.

Preferences Import Export Tab STEP.png

SVG

SVG (Graphiques vectoriels évolutifs) est un format d'image vectorielle pour les graphiques en deux dimensions. Une image vectorielle peut être mise à l'échelle à n'importe quelle taille sans perdre sa forme ou ses détails. Une image SVG peut être convertie en formats bitmap comme PNG ou JPEG pour l'impression.

Pour le format SVG vous pouvez spécifier ce qui suit:

Nom Description
Import de style Sélectionnez la façon dont les couleurs des objets SVG et les largeurs de ligne seront importées.

Si Aucun (le plus rapide) est sélectionné, aucun paramètre de couleur ou de largeur de ligne ne sera importé.

Si Utiliser la couleur et la largeur de ligne par défaut est sélectionné, FreeCAD utilisera sa couleur et sa largeur de ligne par défaut.

Si Couleur et la largeur de ligne originales est sélectionné, FreeCAD utilisera la couleur et la largeur de ligne des objets SVG.

Désactiver les unités d'échelle Si cette case est cochée, aucune conversion d'unité ne se produira. Une unité dans le fichier SVG se traduira par un millimètre.
Style d'exportation Sélectionnez la façon dont les esquisses sont exportées vers SVG.

Si Inversé (pour impression et affichage) est sélectionné, les objets SVG sont encapsulés dans un groupe qui est mis à l'échelle et déplacé au bon endroit dans le document SVG pour tenir dans une zone imprimable.

Si Original (pour CAM) est sélectionné, les objets SVG sont placés tels quels - aux mêmes coordonnées que dans le modèle FreeCAD (exportation 1:1).

Imprimer les lignes blanches en noir Si coché, toutes les lignes blanches apparaîtront en noir dans le SVG pour une meilleure lisibilité sur fond blanc.
Longueur de segment maximum pour les arcs approximés Les versions de Open CASCADE antérieures à la version 6.8 ne prennent pas en charge la projection d'arc. Dans ce cas, les arcs seront discrétisés en petits segments de ligne. Cette valeur est la longueur maximale de segment.

Preferences Import Export Tab SVG.png

VTK

VTK (Visualization Toolkit) est un système logiciel libre et gratuit pour l'infographie 3D, traitement et visualisation d'images. Les fichiers VTK sont utilisés par l'Workbench FEM.svg atelier FEM pour le post-traitement des résultats de simulation.

L'onglet VTK n'est affiché dans les préférences que si l'Workbench FEM.svg atelier FEM a été chargé dans la session FreeCAD en cours.

Pour le format VTK vous pouvez spécifier ce qui suit:

Nom Description
Which object to import into Sélectionnez les objets à importer.

Si VTK result object est sélectionné, un objet résultat FreeCAD FEM VTK sera importé (égal à l'objet qui a été exporté).

Si FEM mesh object est sélectionné, les résultats dans le fichier VTK seront omis. Seules les données de maillage seront importées et un objet maillé FreeCAD FEM sera créé.

Si FreeCAD result object est sélectionné, les données importées seront converties en objet Résultat FreeCAD FEM. Remarque: ce paramètre a besoin des noms de composants de résultat exacts et donc il ne fonctionne correctement qu'avec les fichiers VTK exportés depuis FreeCAD.

Preferences Import Export Tab VTK.png