Import Export Einstellungen

From FreeCAD Documentation
(Redirected from Import Export Preference/de)
Jump to navigation Jump to search
This page is a translated version of the page Import Export Preferences and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎français • ‎italiano • ‎română • ‎русский

Einleitung

FreeCAD kann viele Dateiformate importieren und exportieren. Für einige Formate gibt es spezielle Einstellungen. Diese findest du im Voreinstellungseditor, im Menü Bearbeiten → Einstellungen → Import-Export.

Nicht alle Reiter für Import- und Exporteinstellungen sind standardmäßig verfügbar. Für einige muss zuerst ein Arbeitsbereich geladen werden.

Hinweise

TechDraw Seiten

Die hier aufgeführten DXF und SVG Einstellungen werden von der Datei TechDraw ExportPageSVG.svg nicht verwendet. Seite als SVG exportieren und TechDraw ExportPageDXF.svg Seite als DXF exportieren Befehle der Workbench TechDraw.svg TechDraw Arbeitsbereich oder durch die TechDraw Exportoption: Datei → Export → Technische Zeichnung (*.svg *.dxf *.pdf).

OpenSCAD Dateien

Die Import und Exporteinstellungen für OpenSCAD Dateien sind in einem anderen Teil des Einstellungseditor aufgelistet. Siehe OpenSCAD Einstellungen.

Verwandt

Weitere Informationen findest du auf den folgenden Seiten:

  • Import Export: Eine Tabelle mit allen unterstützten Dateiformaten.
  • FreeCAD Howto Import Export: Eine Tabelle mit allen unterstützten Dateiformaten: Eine Liste von Tutorien, die Anwendern bei der Konvertierung von Daten von einem Format in ein anderes helfen können.

Verfügbare Einstellungen

DAE

Das Collada DAE (Digital Asset Exchange) Format ist ein Standarddateiformat für den Austausch von Netz Daten. FreeCAD kann Netze aus .dae Dateien importieren und Form-basierte Objekte in das .dae Format exportieren.

Hinweis für Linux Anwender: Um mit diesem Dateiformat umgehen zu können, benötigt FreeCAD das pyCollada Modul.

Für das DAE Format kannst du folgendes festlegen:

Name Beschreibung
Skalierungsfaktor Alle Maße in der Datei werden mit dem angegebenen Faktor skaliert..
Mesher Legt das Netzbildungssprogramm das verwendet werden sollte fest. Wenn Netgen verwendet wird, stelle sicher, dass es verfügbar ist. Dies kann angehakt werden durch Workbench Mesh.svg Mesh Modul und Erstelle ein Netz Verwendung von Netgen. Wenn es nicht verfügbar ist, muss eine andere Version von FreeCAD, die mit Netgen kompiliert wurde, installiert werden.
Tesselierung Der Tesselierungswert zur Verwendung mit dem Builtin und dem Mefisto Netzprogramm.
Abstufung Der Sortierwert, der für die Netzbildung mit Netgen zu verwenden ist. Dieser Wert beschreibt, wie schnell die Netzgröße abnimmt. Der Gradient der lokalen Netzgröße h(x) ist durch abs(Δh(x)) ≤ 1/Wert gebunden..
Segmenten pro Kante Die maximale Anzahl von Segmenten pro Kante.
Segmente pro Radius Die Anzahl der Segmente pro Radius.
Zweite Ordnung Ermöglicht ein Netz zweiter Ordnung.
Optimieren Erlaubt Optimierung.
Allow quads Allow quadrilateral faces.

DWG

DWG (von Zeichnung) ist ein proprietäres, quellgeschlossenes, binäres Dateiformat, das zum Speichern von zwei- und dreidimensionalen Konstruktionsdaten und Metadaten verwendet wird. FreeCAD benötigt den externer ODA Dateikonverter, um DWG Dateien zu verarbeiten.

Für das DWG Format kannst du nur den Pfad zur ODA festlegen. Hinweis: Alle Einstellungen für das DXF Dateiformat gelten auch für DWG.

Name Beschreibung
Pfad zum ODA (ehemals Teigha) Dateikonverter Legt den Pfad zum ODA Dateikonverter fest.

DXF

AutoCAD DXF (Drawing eXchange Format) ist ein proprietäres Format zum Austausch von CAD Daten zwischen AutoCAD und anderen Programmen.

Für das DXF Format kannst du folgendes festlegen:

Name Beschreibung
Dieses Dialogfeld beim Importieren und Exportieren anzeigen Dieser Einstellungsdialog wird beim Importieren oder Exportieren von DXF Dateien angezeigt.
Alten Python Importeur verwenden Wenn angehakt, wird der Python Importer verwendet, ansonsten der neuere C++ . Der C++ Importeur ist schneller, hat aber noch nicht so viele Funktionen.

Der Python Importer verwendet die Bearbeiten → Einstellungen... → Entwurf → Allgemeine Einstellungen → Interne Genauigkeitsstufe Einstellung. Für ein genaues Importergebnis setze diesen Wert auf 8 oder höher.

Alten Python Exporter verwenden Wenn angehakt, wird der Python Exporter verwendet, andernfalls der neuere C++ Exporteur. Der C++ Exporteur ist schneller, verfügt jetzt aber noch nicht über so viele Funktionen. introduced in version 0.19
Ermöglicht FreeCAD das automatische Herunterladen und Aktualisieren der DXF Bibliotheken Durch anhaken, ermöglichst du FreeCAD, den Python Konverter für den DXF Import und Export herunterzuladen. Dieser Konverter kann nicht mit FreeCAD gebündelt werden, da er eine andere Softwarelizenz hat.
Import Wähle, was importiert werden soll.
Wenn Texte und Maße nicht angehakt ist, werden Texte und Mtexte nicht importiert.

Wenn Punkte nicht angehakt ist, werden keine Punkte importiert.

Wenn Layouts angehakt ist, werden Papierraumobjekte auch importiert.

Hake *Blöcke an, wenn du möchtest, dass die nicht bezeichneten Blöcke (die mit einem * beginnen) auch importiert werden.

Erstellen Wähle, was erstellt wird.
Wenn einfache Teileformen ausgewählt wird, werden nur Standardteilobjekte erstellt. Dies ist die schnellste.

Wenn Entwurfsobjekte ausgewählt wird, werden, wann immer möglich, parametrische Entwurfsobjekte erstellt.

Wenn Skizzen gewählt wird, werden, wann immer möglich, Skizzen erstellt.

Skalierungsfaktor zum anwenden auf importierte Dateien Skalierungsfaktor, der auf DXF Dateien beim Import angewendet wird. Der Faktor ist die Umrechnung zwischen der Einheit deiner DXF Datei und Millimetern. Beispiel: für Dateien in Millimetern: 1, in Zentimetern: 10, in Meter: 1000, in Zoll: 25.4, in Fuß: 304.8.
Originalfarben aus der DXF Datei erhalten Wenn angehakt, werden Farben aus den DXF Objekten abgerufen, wann immer dies möglich ist. Andernfalls werden Standardfarben angewendet.
Fügegeometrie Wenn angehakt, versucht FreeCAD, deckungsgleiche Objekte zu Drähten zu fügen. Beachte, dass dies eine Weile dauern kann!
Ebenen in Blöcke gruppieren Wenn angehakt, werden Objekte aus denselben Ebenen zu Entwurfsblöcken zusammengefügt, die schneller angezeigt, aber weniger leicht bearbeitet werden können.
Standard Schriftgröße für Texte verwenden Wenn angehakt, erhalten importierte Texte die Standardgröße Draft Text anstelle der Größe, die sie im DXF Dokument haben.
VisGroups verwenden / Ebenen verwenden Wenn angehakt, werden DXF Ebenen als Draft VisGroups importiert. (version 0.18 and below) oder Entwurf Schichten (introduced in version 0.19).
Importieren von Schraffurbegrenzungen als Drähte Wenn angehakt, werden Schraffuren in einfache Drähte umgewandelt..
Rendern von Polylinien mit Breite Wenn angehakt, wenn Polylinien eine festgelegte Breite haben, werden sie als geschlossene Drähte mit der richtigen Breite gerendert..
Ellipsen und Splines als Polylinien behandeln Der Export von Ellipsen und Splines wird nur unzureichend unterstützt. Verwende diese Option, um sie stattdessen als Polylinien zu exportieren.

Die Einstellung Max Spline Abschnitt ist dann die maximale Länge jedes der Polyliniensegmente. Wenn sie auf '0' gesetzt ist, wird der gesamte Spline als gerades Segment behandelt.

3D Objekte als Polyflächennetze exportieren Wenn angehakt, werden alle Objekte, die Flächen enthalten, als 3D Polyflächen exportiert..
Zeichnungsansichten als Blöcke exportieren Wenn angehakt, werden die Zeichnungsansichten als Blöcke exportiert. Dies könnte bei nach DXF R12 Vorlagen fehlschlagen.
Projekt exportierte Objekte entlang der aktuellen Ansichtsrichtung Wenn angehakt, werden die exportierten Objekte so projiziert, dass sie die aktuelle Blickrichtung widerspiegeln.

IGES

Das Initial Graphics Exchange Specification (IGES) Dateiformat ist ein Dateiformat, das den digitalen Austausch von Informationen zwischen CAD Systemen ermöglicht. Nach der Veröffentlichung des Dateiformats STEP wurde die Entwicklung von IGES 1996 eingestellt, aber es wird immer noch von vielen CAD Programmen unterstützt. IGES Dateien haben die .iges oder .igs Erweiterung.

Der Reiter IGES wird nur in den Einstellungen angezeigt, wenn du im Workbench Part.svg Part, Workbench PartDesign.svg PartDesign oder Workbench OpenSCAD.svg OpenSCAD Arbeitsbereich oder wenn du vorher schon einmal in einem dieser Arbeitsbereiche warst.

Für das IGES Format kannst du folgendes festlegen:

Name Beschreibung
Einheiten für den Export in IGES Wähle, welche Einheit beim Export von IGES Dateien verwendet werden soll.
Schreibe Körper und Schalen als Wähle, wie Solids und Schalen ausgegeben werden sollen.

Wenn Gruppen von gestutzten Oberflächen (Typ 144) ausgewählt wird, werden sie exportiert als gestutzte Oberfläche.

Wenn Solids (Typ 186) und Schalen (Typ 514) / B-REP-Modus ausgewählt wird, werden Solids als manifold solid B-Rep object, Schalen als Schale exportiert.

Leere Entitäten überspringen Wenn angehakt, leere Entitäten werden nicht importiert..
Firma Wenn nicht leer, wird der eingegebene Text im IGES Dateikopf für die Firma verwendet.
Autor Wenn nicht leer, wird der eingegebene Text im IGES-Dateikopf für den Autor verwendet.
Produkt Wenn nicht leer, wird der eingegebene Text im IGES Dateikopf für das Produkt verwendet.

IFC

Industry Foundation Classes (IFC) ist ein weit verbreitetes Format für den Datenaustausch zwischen BIM Anwendungen. Es wird in der Architektur und im Ingenieurwesen verwendet..

Hinweis für Linux Anwender: Um mit diesem Dateiformat umgehen zu können, benötigt FreeCAD das IfcOpenShell Modul.

Für das IFC Format kannst du folgendes festlegen:

Name Beschreibung
Dieses Dialogfeld beim Importieren und Exportieren anzeigen Dieser Einstellungsdialog wird beim Importieren oder Exportieren von IFC Dateien angezeigt.
Fehlerdiagnosenachrichten anzeigen Zeigt ausführliche Fehlerdiagnosemeldungen während des Imports und Exports von IFC Dateien in der Berichtsansicht Paneel.
Klone erstellen, wenn Objekte eine gemeinsame Geometrie besitzen IFC Objekte können die gleiche Geometriedefinition für mehrere Objekte gemeinsam nutzen, nur ihre Platzierung ist unterschiedlich. Wenn diese Option aktiviert ist, werden also Klone verwendet, um in FreeCAD das gleiche Ergebnis zu erzielen. Ein Objekt ist das Basisobjekt, die anderen sind Klone.
Import arch IFC Objekte als Was wird in FreeCAD für arch IFC Objekte erstellt.
Struktur IFC Objekte importieren als Was wird in FreeCAD für Struktur IFC Objekte erstellt.
Root Element Es werden nur Untertypen des angegebenen Elements importiert. Behalte das vordefinierte Element IfcProdukt bei, um alle Gebäudeelemente zu importieren.
Separate Öffnungen Wenn angehakt, werden Öffnungen als Subtraktionen importiert, andernfalls werden bei Wandformen die Öffnungen bereits subtrahiert.
Extrusionen erkennen Wenn angehakt, versucht der Importeur, Extrusionen zu erkennen. Beachte, dass dies die Dinge verlangsamen könnte.
Mehrschichtige Wände teilen Geteilte Wände aus mehreren Schichten.
Vorangestellte Bezeichnung mit ID Nummer Wenn angehakt, wird den Objektnamen die IFC D Nummer vorangestellt.
Materialien mit gleichem Namen und gleicher Farbe zusammenführen Wenn mehrere Materialien mit demselben Namen in der IFC Datei gefunden werden, werden sie als eines behandelt.
Ifc Eigenschaften in Tabelle importieren Wenn angehakt, werden die IFC Eigenschaften jedes Objekts in einem Tabellenkalkulationsobjekt gespeichert.
Ungültige Formen erlauben Wenn nicht angehakt werden ungültige Formen nicht importiert. introduced in version 0.19
Ausschlussliste Eine durch Komma getrennte Liste von IFC Einheiten, die von Importen ausgeschlossen werden sollen.
Ansicht einpassen während des importierens Ansicht einpassen beim Import auf die importierten Objekte. Dadurch wird der Import verlangsamt, aber man kann den Import beobachten.
Vollständige parametrische FreeCAD Definitionen importieren, falls verfügbar} Erstellt beim Import ein vollparametrisches Modell unter Verwendung gespeicherter FreeCAD Objekteigenschaften.

Um die FreeCAD Eigenschaften zu erhalten, muss das Modell mit der Option Vollständiges parametrisches FreeCAD Modell exportieren exportiert worden sein. introduced in version 0.19

Erzwinge Export als Brep Einige IFC Betrachter mögen keine Objekte, die als Extrusionen exportiert werden. Verwende dies, um zu erzwingen, dass alle Objekte als BREP Geometrie exportiert werden. Bitte beachte jedoch, daß das Objekt dadurch nicht parametrisch wird. Vermeide wenn möglich den Export als Brep.
Verwende Optionen für DAE Triangulation Triangulationsoptionen verwenden, die auf der Seite DAE Optionen gesetzt sind.
Koplanare Facetten bei der Triangulation verbinden Gekrümmte Formen, die in der IFC nicht als Kurven dargestellt werden können, werden in flache Facetten zerlegt. Wenn dies aktiviert ist, wird eine zusätzliche Berechnung durchgeführt, um koplanare Facetten zu verbinden.
Universelle IFC ID in FreeCAD Objekten speichern Beim Export von Objekten ohne Eindeutige ID (UID) wird die generierte UID innerhalb des FreeCAD Objekts gespeichert und beim nächsten Export des Objekts wiederverwendet. Dies führt zu kleineren Unterschieden zwischen den Dateiversionen.
Verwende IfcOpenShell Serialisierer wenn verfügbar IFCOpenShell ist eine Bibliothek, die den Import von IFC Dateien ermöglicht. Ihre Serialisierer-Funktionalität erlaubt es, ihr eine OCC Form zu geben, und sie erzeugt eine geeignete IFC Geometrie: NURBS, facettiert oder irgendetwas anderes.
Bitte beachte, daß es sich bei der Serialisierungsfunktion noch um eine experimentelle Funktion handelt.
2D Objekte als IfcAnmerkungen exportieren Wenn angehakt, werden 2D Objekte als IfcAnmerkung exportiert.
Vollständiges parametrisches FreeCAD Modell exportieren Wenn angehakt,, werden alle FreeCAD Objekteigenschaften in den exportierten Objekten gespeichert, so dass mit der Option Importiere vollständige parametrische FreeCAD Definitionen wenn verfügbar beim erneuten Import ein vollständig parametrisches Modell erstellt werden kann.
Wiederverwendung ähnlicher Einheiten Wenn markiert, werden ähnliche Einheiten möglichst nur einmal in der Datei verwendet. Dies kann die Dateigröße stark reduzieren, macht die Datei aber weniger gut lesbar.
Ausschalten IfcRechteckProfilDef Wenn möglich, werden IFC Objekte, die extrudierte Rechtecke sind, als IfcRechteckProfilDef exportiert. Einige andere Anwendungen könnten jedoch Probleme haben, diese Einheit zu importieren. Wenn dies bei dir der Fall ist, kannst du dies deaktivieren, und dann werden alle Profile als IfcArbitraryClosedProfileDef exportiert.
Auto-Erkennung und Export als Standardfälle, falls anwendbar Einige IFC Typen wie IfcWall oder IfcBeam haben spezielle Standardversionen wie IfcWallStandardCase oder IfcBeamStandardCase. Wenn diese Option eingeschaltet ist, exportiert FreeCAD solche Objekte automatisch als Standardfall, wenn die notwendigen Bedingungen erfüllt sind. introduced in version 0.19
Standardseite hinzufügen, falls eine solche im Dokument nicht gefunden wird Wenn beim Exportieren einer IFC Datei kein Standort im FreeCAD Dokument gefunden wird, wird eine Standarddatei hinzugefügt. Ein Standort ist nach dem IFC Standard nicht zwingend erforderlich, aber es ist gängige Praxis, mindestens einen in der Datei zu haben. introduced in version 0.19
Standardgebäude hinzufügen, falls eines im Dokument nicht gefunden wird (kein Standard) Wenn beim Export einer IFC Datei kein Gebäude im FreeCAD Dokument gefunden wird, wird ein Standard Gebäude hinzugefügt.

Warnung: Der IFC Standard verlangt mindestens ein Gebäude in jeder Datei. Wenn diese Option ausgeschaltet wird, erzeugst du eine nicht dem Standard entsprechende IFC Datei.

Bei FreeCAD sind wir jedoch der Meinung, dass ein Gebäude zu haben nicht zwingend erforderlich sein sollte, und diese Option ist dazu da, um die Möglichkeit zu haben, unseren Standpunkt aufzuzeigen. introduced in version 0.19

Standard Geschoss hinzufügen, falls eines nicht im Dokument gefunden wird Wenn beim Export einer IFC Datei kein Gebäudegeschoss im FreeCAD Dokument gefunden wird, wird ein Standard Geschoss hinzugefügt. Der IFC Standard schreibt kein Gebäudegeschoss vor, aber es ist gängige Praxis, mindestens ein Gebäudegeschoss in der Datei zu haben. introduced in version 0.19
IFC Dateieinheiten Wähle aus, welche Einheit beim Exportieren von IFC Dateien verwendet werden soll. introduced in version 0.19

INP

INP ist das Eingabedateiformat für die FEM Software Abaqus. Es wird für den CalculiX Löser im Workbench FEM.svg FEM Arbeitsbereich verwendet.

Der Reiter INP wird in den Einstellungen nur angezeigt, wenn du in der FEM Arbeitsbereich bist oder wenn du schon einmal in diesem Arbeitsbereich warst.

Für das INP Format kannst du folgendes festlegen:

Name Beschreibung
Welche Netzelemente sollen exportiert werden Wähle, welche Netzelementparameter exportiert werden sollen.

Wenn Alle ausgewählt wird, werden alle Elemente exportiert.

Wenn Höchste ausgewählt wird, werden nur die höchsten Elemente exportiert. Dies bedeutet Volumen für ein Volumennetz und Flächen für ein Schalennetz.

Wenn FEM ausgewählt ist, werden nur FEM Elemente exportiert. Dies bedeutet, dass nur Kanten, die nicht zu Flächen gehören, und Flächen, die nicht zu Volumen gehören, exportiert werden.

Gruppendaten exportieren Wenn angehakt, werden auch Netzgruppen exportiert. Jede Beschränkung und, falls es verschiedene Materialien gibt, besteht das Material aus zwei Netzgruppen, Flächen und Knoten, auf die die Beschränkung oder das Material angewendet wird.

Netzformate

Netze sind eine besondere Art von 3D Objekten, die aus dreieckigen Flächen bestehen, die durch ihre Knoten und Kanten verbunden sind. Sie werden häufig für additive Fertigung verwendet. FreeCAD bietet die Workbench Mesh.svg Mesh Arbeitsbereich zum Erstellen und Bearbeiten von Netzen. FreeCAD unterstützt verschiedene Netzdateiformate.

Der Reiter Netzformate wird in den Einstellungen nur angezeigt, wenn du in der Netz Arbeitsbereich bist oder wenn du schon einmal in diesem Arbeitsbereich warst.

Für die Netzformate kannst du folgendes festlegen:

Name Beschreibung
Maximale Netzabweichung Festlegung der maximalen Abweichung zwischen dem Netz und dem Objekt.
Export von AMF Dateien mit Komprimierung Wenn angehakt, wird beim Schreiben einer Netz Datei im AMF Format eine ZIP Komprimierung verwendet.

OCA

Das OCA Dateiformat ist ein Gemeinschaftsprojekt zur Erstellung eines freien, einfachen und offenen CAD Dateiformats. OCA basiert weitgehend auf dem von gCAD3D erzeugten GCAD Dateiformat. Beide Formate können in FreeCAD importiert und die von FreeCAD exportierten OCA Dateien können in gCAD3D geöffnet werden.

Für das OCA Format kannst du folgendes festlegen:

Name Beschreibung
OCA Bereiche importieren Wenn angehakt, werden die Bereiche (3D Flächen) auch importiert.

STEP

Das (STEP) Dateiformat Norm für den Austausch von Produktmodelldaten (engl.: Standard for The Exchange of Product model data) ist eine ISO Norm für die computerinterpretierbare Darstellung und den Austausch von Informationen zur Produktherstellung. STEP wird häufig zum Austausch von 3D Daten zwischen CAD Software verwendet. STEP Dateien haben die .step oder .stp Erweiterung . Bei gepackten Dateien wird die Erweiterung .stpz verwendet.

Der Reiter STEP wird in den Einstellungen nur angezeigt, wenn du dich in der Workbench Part.svg Part, Workbench PartDesign.svg PartDesign oder Workbench OpenSCAD.svg OpenSCAD Arbeitsbereich oder wenn du schon einmal in einer dieser Arbeitsbereiche warst.

Für das STEP Format kannst du Folgendes festlegen:

Name Beschreibung
Einheiten für den Export von STEP Wähle, welche Einheiten beim Export von STEP Dateien verwendet werden sollen.
Kurven im parametrischen Raum der Oberfläche ausschreiben Wenn angehakt, werden parametrische Kurven (Kurven im parametrischen Raum von Oberflächen) in die STEP Datei geschrieben. Abwählen der Option kann hilfreich sein, um die Größe der resultierenden STEP Datei zu minimieren.
Ausgeblendete Objekte exportieren Dies abwählen, um ausgeblendete Objekte beim Export zu überspringen, was für CADs nützlich ist, die die Unsichtbarkeits STEP Formgebung nicht unterstützen.. introduced in version 0.19
Einzelne Objektplatzierung exportieren Anhaken dieser Option, um die Platzierungsinformationen beim Export eines einzelnen Objekts beizubehalten. Bitte beachte, dass beim erneuten Import der STEP Datei die Platzierung in die Formgeometrie kodiert wird, anstatt sie innerhalb der Platzierungseigenschaften zu behalten.. introduced in version 0.19
Alten Exporteur verwenden Verwende den Alten Exporteur. introduced in version 0.19
Schema Wähle, welches STEP Anwendungsprotokoll (AP) für den Export verwendet werden soll.

AP 203 ist das Protokoll für konfigurationsgesteuerte 3D Konstruktionen von mechanischen Teilen und Baugruppen.

AP 214 ist das Protokoll für Kerndaten für automobilmechanische Konstruktionsprozesse.

aktiviere STEP Verbund zusammenführen Wenn angehakt, ein Verbund wird während des Dateilesens zusammengeführt. Dies ist langsamer, führt aber zu höheren Details.
VerknüpfeGruppe verwenden Wähle dies, um App::LinkGroup Gruppencontainer anstelle von App::Part Gruppencontainern zu verwenden. introduced in version 0.19
Ausgeblendete Objekte importieren Wähle dies, um ausgeblendete Objekte zu importieren. introduced in version 0.19
Anzahl der Objekte reduzieren Reduziere die Anzahl der Objekte mit Hilfe von verknüpften Anordnungen. introduced in version 0.19
Verbundform aufklappen Aufklappen von Verbundformen mit mehreren Solids. introduced in version 0.19
Fortschrittsbalken beim Importieren anzeigen Beim Importieren einen Fortschrittsbalken anzeigen. introduced in version 0.19
Instanznamen ignorieren Verwende keine Instanznamen. Nützlich für einige alte STEP Dateien mit nicht aussagekräftigen, automatisch generierten Instanznamen. introduced in version 0.19
Modus Wähle die notwendige Dokumentstruktur. introduced in version 0.19

Einzeldokument

Zusammenstellung pro Dokument

Zusammenstellung pro Dokument im Unterverzeichnis

Objekt pro Dokument

Objekt pro Dokument im Unterverzeichnis

Firma Wenn nicht leer, wird der eingegebene Text im STEP Dateikopf für die Firma verwendet.
Autor Wenn nicht leer, wird der eingegebene Text in der Kopfzeile der STEP Datei für den Autor verwendet.
Produkt Wenn nicht leer, wird der eingegebene Text im Kopf der STEP Datei für das Produkt verwendet.

SVG

Skalierbare Vektorgrafiken (SVG) ist ein Vektorbild Format für zweidimensionale Grafiken. Ein Vektorbild kann auf jede beliebige Größe skaliert werden, ohne seine Form oder Details zu verlieren. Ein SVG Bild kann für den Druck in Bitmap Formate wie PNG oder JPEG umgewandelt werden.

Für das SVG Format kannst du folgendes festlegen:

Name Beschreibung
Importstil Wähle, wie SVG Objektfarben und Linienbreiten importiert werden sollen.

Wenn Keine (schnellste) ausgewählt wird, werden keine Farben und Linienbreiteneinstellungen importiert.

Wenn Standardfarbe und -linienbreite verwenden ausgewählt wird, verwendet FreeCAD seine Standardfarbe und -linienbreite.

Wenn Originalfarbe und Linienbreite ausgewählt wird, verwendet FreeCAD die Farbe und Linienbreite aus den SVG Objekten.

Deaktiviere Einheitenskalierung Wenn angehakt, erfolgt keine Umrechnung von Einheiten. Eine Einheit in der SVG Datei wird als ein Millimeter übersetzt..
Exportstil Wähle, wie Skizzen in SVG exportiert werden.

Wenn Übersetzt (für Druck & Anzeige) ausgewählt ist, werden SVG Objekte in einer Gruppe eingeschlossen, die skaliert und an die richtige Stelle im SVG Dokument verschoben wird, um in einen druckbaren Bereich zu passen.

Wenn Raw (für CAM) ausgewählt wird, werden SVG Objekte so platziert, wie sie sind - an den gleichen Koordinaten wie im FreeCAD Modell (1:1-Export).

Weiße Linienfarbe nach Schwarz übersetzen} Wenn diese Option angehaktist, werden alle weißen Linien im SVG zur besseren Lesbarkeit vor weißem Hintergrund in schwarz angezeigt.
Max Segmentlänge für diskretisierte Bögen Versionen von Open CASCADE, die älter als Version 6.8 sind, unterstützen keine Bogenprojektion. In diesem Fall werden Bögen in kleine Liniensegmente diskretisiert. Dieser Wert ist die maximale Segmentlänge.

VTK

Das Visualisierungwerkzeugkasten (VTK) (Visualization Toolkit, engl.) ist ein quelloffenes, frei verfügbares Softwaresystem für 3D Computergrafik, Bildverarbeitung und Visualisierung. VTK Dateien werden von der Workbench FEM.svg FEM Arbeitsbereich für die Nachbearbeitung von Simulationsergebnissen.

Der Reiter VTK wird in den Einstellungen nur angezeigt, wenn du in der FEM Arbeitsbereich bist oder wenn du schon einmal in diesem Arbeitsbereich warst.

Für das VTK Format kannst du folgendes festlegen:

Name Beschreibung
Welches Objekt soll importiert werden Wähle, welche Objekte importiert werden sollen.

Wenn VTK Ergebnisobjekt ausgewählt wird, wird ein FreeCAD FEM VTK Ergebnisobjekt importiert (entspricht dem Objekt, das exportiert wurde).

Wenn FEM Netzobjekt ausgewählt wird, werden die Ergebnisse in der VTK Datei weggelassen, es werden nur die Netzdaten importiert und ein FreeCAD FEM Netzobjekt erzeugt.

Wenn FreeCAD Ergebnisobjekt ausgewählt wird, werden die importierten Daten in ein FreeCAD FEM Ergebnisobjekt umgewandelt. Hinweis: diese Einstellung benötigt die exakten Namen der Ergebniskomponenten und funktioniert daher nur ordnungsgemäß mit VTK Dateien , die aus FreeCAD exportiert wurden.