Comment installer des ateliers supplémentaires

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page How to install additional workbenches and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎русский
Base ExampleCommandModel.png Tutoriel
Thème
Programmation
Niveau
Programmeur moyen
Temps d'exécution estimé
15 minutes
Auteur(s)
r-frank
Version de FreeCAD
Toutes versions
Fichier(s) exemple(s)
aucun


Description

Les utilisateurs expérimentés ont étendu FreeCAD avec divers ateliers externes personnalisés qui ne sont pas intégrés dans le code source principal mais qui sont faciles à installer sur une distribution FreeCAD existante. Ici, nous allons couvrir les méthodes d'installation pour les différents systèmes d'exploitation.

Remarque: à partir de la version 0.17, FreeCAD propose un AddonManager.svg Gestionnaire des addons dans le menu Outils → Gestionnaire d'Addon. Il permet d'installer à la fois des macros et des ateliers. Les instructions ci-dessous ne sont nécessaires que si vous souhaitez installer manuellement un atelier. Cela peut être nécessaire si, pour une raison quelconque, le Gestionnaire d'Addon ne fonctionne pas mais que vous avez accès à l'atelier téléchargé en tant que package .zip.

Installation sous Windows

Comment installer des ateliers et des modules complémentaires supplémentaires sous Windows

Obsolète

Note: l'utilisation de "addons-installer" n'est plus recommandé. L'utilisation de Addon Manager qui se trouve dans tous les systèmes est la manière recommandée.

Utilisez addons-installer from Github.

Au cours de Google Summer of Code 2016, l'étudiant Mandeep Singh a commencé à travailler sur une version améliorée (disponible ici) mais cette version doit encore être améliorée avant de pouvoir être pleinement intégrée à FreeCAD.

Installation manuelle

Remarque: cette méthode est possible mais pas nécessaire avec l'introduction de Gestionnaire des addons. Néanmoins les informations ici peuvent encore être utiles à certains.

  • Téléchargez l'atelier depuis github en cliquant sur le bouton Clone ou Download sur la page github (coin supérieur droit) et en choisissant "Télécharger ZIP"
  • Dézippez l'archive téléchargée sur votre disque dur local
  • Dans FreeCAD, localisez le chemin de la macro en choisissant Édition → Préférences → Général → Macro et recherchez le «Chemin de la macro»
  • Supposons que votre connexion Windows est «nom_utilisateur», le chemin par défaut de la macro est %APPDATA%\FreeCAD\ qui est couramment C:\Users\nom_utilisateur\Appdata\Roaming\FreeCAD
  • Dans le répertoire-macro, créez (s'il n'est pas déjà présent) un dossier appelé "Mod"
  • Dans le dossier Mod, créez un dossier avec le nom de l'atelier, par exemple “Curves”
  • Déplacez maintenant les fichiers et sous-dossiers décompressés de l'atelier dans le dossier de l'atelier qui vient d'être créé.
  • Après le redémarrage de FreeCAD, vous devriez maintenant avoir une entrée dans le sélecteur d'atelier

Recommandation supplémentaire pour la mise à jour des ateliers

Sur Windows, lors de la mise à jour d'un atelier déjà installé, Windows conserve les anciens fichiers .py converti en .pyc. Étant donné que cela peut entraîner des problèmes de compatibilité, il est recommandé de désinstaller l'atelier, de redémarrer FreeCAD et d'installer la nouvelle version de cet atelier.


Installation sous Linux

Comment installer des ateliers et des modules complémentaires supplémentaires sous Linux

Utiliser git

Ajout de community-ppa dans le gestionnaire ppa.
Installation des ateliers via le gestionnaire de paquets synaptique.

$ sudo apt-get install git python-numpy python-pyside
$ mkdir ~/.FreeCAD/Mod
$ cd ~/.FreeCAD/Mod
$ git clone  https://github.com/tomate44/CurvesWB.git

Dans FreeCAD, vous aurez maintenant une nouvel atelier appelé "CurvesWB". Une fois installé, utilisez git pour les mises à jour:

$ cd ~/.FreeCAD/Mod/CurvesWB
$ git pull
$ rm *.pyc

Installation manuelle

Remarque: cette méthode est possible mais pas nécessaire avec l'introduction de Gestionnaire des addons. Néanmoins les informations ici peuvent encore être utiles à certains.

  • Téléchargez le plan de travail depuis github en cliquant sur le bouton Clone ou Download sur la page github (coin supérieur droit) et en choisissant "Télécharger ZIP"
  • Dézippez l'archive téléchargée sur votre disque dur local
  • Dans FreeCAD, localisez le chemin de la macro en choisissant Édition → Préférences → Général → Macro et recherchez le «Chemin de la macro»
  • Par défaut, le répertoire des macros est le répertoire ./.FreeCAD/ (masqué) de votre répertoire personnel
  • Dans le macro-répertoire, créez (s'il n'est pas déjà présent) un dossier appelé “Mod
  • Dans le dossier Mod/, créez un dossier avec le nom du plan de travail, par exemple “Curves”
  • Déplacez maintenant les fichiers et sous-dossiers décompressés du plan de travail dans le dossier du plan de travail qui vient d'être créé.
  • Après le redémarrage de FreeCAD, vous devriez maintenant avoir une entrée dans le sélecteur d'atelier


Installation sur Mac

Comment installer des ateliers et des modules complémentaires supplémentaires sous MacOS

Installation manuelle

Remarque: cette méthode est possible mais pas nécessaire avec l'introduction de Gestionnaire des addons. Néanmoins les informations ici peuvent encore être utiles à certains.

Pour cet exemple, supposons que vous ayez choisi l'Atelier Courbes comme atelier externe que vous souhaitez installer:

  • Choisissez et téléchargez le référentiel git de votre plan de travail externe choisi sous forme de fichier ZIP
  • En supposant que FreeCAD est installé dans /Applications/FreeCAD/v0.xx", accédez à /Applications/FreeCAD/v0.xx" dans le navigateur et sélectionnez FreeCAD.app
  • RMB et sélectionnez "Afficher le contenu du paquet", une nouvelle fenêtre apparaîtra avec un dossier nommé "Contenu"
  • Un clic unique sur le dossier "Contenu" et sélectionnez le dossier "Mod"
  • Dans le dossier "Mod" créez un nouveau dossier nommé "Curves"
  • Dézippez le répertoire téléchargé dans le dossier "Contents/Mod/Curves"

Dysfonctionnement généralités

  • N'utilisez pas de caractères spéciaux (par exemple des trémas allemands) dans votre nom d'utilisateur Windows, sinon FreeCAD ne reconnaîtra pas les fichiers et dossiers dans le chemin de la macro.
  • Si vous avez déjà configuré un nom d'utilisateur avec des caractères spéciaux, créez un nouveau nom d'utilisateur ou pointez le chemin de la macro vers un répertoire n'utilisant pas de caractères spéciaux.
  • Allez dans Outils → Personnaliser... → Ateliers et assurez-vous que l'atelier n'est pas défini sur invisible.
  • Avec les systèmes 32 bits et FreeCAD 0.16.6706, après les tentatives d'installation, les ateliers supplémentaires peuvent ne pas être disponibles. Dans ce cas