Wie man zusätzliche Arbeitsbereiche installiert

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page How to install additional workbenches and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎русский

Base ExampleCommandModel.png Tutorial

Thema
Programmierung
Niveau
Mittelmäßiger Programmierer
Zeit zum Abschluss
15 Minuten
Autor
r-frank
FreeCAD version
Alle
Beispieldatei(en)
keine


Beschreibung

Intensivnutzer haben FreeCAD um verschiedene kundenspezifische externe Arbeitsbereiche erweitert, die nicht in den FreeCAD Quellcodekern integriert sind, sind aber leicht auf einer bestehenden FreeCAD Installation zu installieren. Hier werden wir die Installationsmethoden für die verschiedenen Betriebssysteme behandeln.

Hinweis: Ab Version 0.17 verfügt FreeCAD über einen AddonManager.svg Erweiterungsverwalter im Werkzeuge → Erweiterungsverwalter Menü, das die Installation sowohl von Makros als auch von Workbenches erlaubt. Die folgenden Anweisungen sind nur erforderlich, wenn du einen Arbeitsbereich manuell installieren möchtest. Dies könnte notwendig sein, wenn aus irgendeinem Grund der Erweiterungsverwalter nicht funktioniert, du aber Zugriff auf den als .zip Paket heruntergeladenen Arbeitsbereich hast.

Installation unter Windows

Wie man zusätzliche Arbeitsbereiche und Erweiterungen unter Windows installiert

Veraltet

Hinweis: Die Verwendung des "Erweiteruns-Installierers" wird nicht mehr empfohlen. Die Verwendung des Erweiterungsverwalters in allen Systemen ist der empfohlene Weg.

Benutze den addons-installer von Github.

Während des Google Summer of Code 2016 begann der Student Mandeep Singh mit der Arbeit an einer verbesserten Version (hier verfügbar), die jedoch noch weitere Bearbeitung benötigt, bevor sie vollständig in FreeCAD integriert werden kann.

Manuelle Installation

Hinweis: Diese Methode ist mit der Einführung des Erweiterungsverwalters möglich, aber nicht notwendig. Nichtsdestotrotz können die Informationen hier für einige noch nützlich sein.

  • Lade den Arbeitsbereich von github herunter, durch anklicken auf die Schaltfläche Clone oder Download auf der github Seite (obere rechte Ecke) klickest und "Download ZIP" wählst
  • Entpacke das heruntergeladene Archiv auf deiner lokalen Festplatte
  • Suche innerhalb von FreeCAD den Makropfad, durch Wahl von Bearbeiten → Einstellungen → Allgemein→ Makro und nach dem "Makropfad" suchen.
  • Angenommen, dein Windows-Login ist "Benutzername", dann ist der Standard Makropfad %APPDATA%\FreeCAD\, der normalerweise C:\Users\username\Appdata\Roaming\FreeCAD ist.
  • Erstelle innerhalb des Makro-Verzeichnisses einen Ordner (falls nicht bereits vorhanden) namens "Mod"
  • Lege innerhalb des Ordners Mod einen Ordner mit dem Namen des Arbeitsbereichs an, z.B. "Curves".
  • Verschiebe nun die entpackten Dateien und Unterordner des Arbeitsbereichs in den soeben erstellten Arbeitsbereichs-Ordner
  • Nach dem Neustart von FreeCAD solltest du nun einen Eintrag im Arbeitsbereichsanwähler haben

Zusätzliche Empfehlung zur Aktualisierung von Arbeitsbereichen

Unter Windows behält Windows beim Aktualisieren eines bereits installierten Arbeitsbereichs die alten .py Dateien als .pyc. Da dies zu Problemen führen kann, wird empfohlen, den Arbeitsbereich zu deinstallieren, FreeCAD neu zu starten und die neue Version des Arbeitsbereichs zu installieren.


Installation unter Linux

Wie man zusätzliche Arbeitsbereiche und Erweiterungen unter Linux installiert

Benutzung von git

Hinzufügen der community-ppa innerhalb des ppa-manager.
Installation der Arbeitsbereiche über synaptische Paketmanager.

$ sudo apt-get install git python-numpy python-pyside
$ mkdir ~/.FreeCAD/Mod
$ cd ~/.FreeCAD/Mod
$ git clone  https://github.com/tomate44/CurvesWB.git

In FreeCAD hast du nun einen neuen Arbeitsbereichs-Eintrag namens "CurvesWB". Nach der Installation kannst du git verwenden, um auf die neueste Version zu aktualisieren:

$ cd ~/.FreeCAD/Mod/CurvesWB
$ git pull
$ rm *.pyc

Manuelle Installation

Hinweis: Diese Methode ist mit der Einführung des Erweiterungsverwalters möglich, aber nicht notwendig. Nichtsdestotrotz können die Informationen hier für einige noch nützlich sein.

  • Lade den Arbeitsbereich von github durch Klicken auf die Schaltfläche Clone oder Download auf der github Seite (obere rechte Ecke) und Auswahl von "Download ZIP"
  • Entpacke das heruntergeladene Archiv auf deiner lokalen Festplatte
  • Ermittle innerhalb von FreeCAD den Makropfad,durch wählen von Bearbeiten→ Einstellungen → Allgemein → Makro und schau nach dem ”Makropfad”
  • Standardmäßig ist das Makro Verzeichnis das (versteckte) ./.FreeCAD/ Verzeichnis in deinem Home-Verzeichnis
  • Erstelle innerhalb des Makro-Verzeichnisses (falls nicht bereits vorhanden) einen Ordner namens "Mod"
  • Erstelle innerhalb des Mod/ Ordners einen Ordner mit dem Namen des Arbeitsbereichs, zum Beispiel "Curves"
  • Verschiebe nun die entpackten Dateien und Unterordner des Arbeitsbereichs in den soeben erstellten Arbeitsbereichs-Ordner
  • Nach dem Neustart von FreeCAD solltest du nun einen Eintrag im Arbeitsbereichswähler haben


Installation auf Mac

Wie man zusätzliche Arbeitsbereiche und Erweiterungen auf MacOS installiert

Manuelle Installation

Hinweis: Diese Methode ist mit der Einführung des Erweiterungsverwalters möglich, aber nicht notwendig. Nichtsdestotrotz können die Informationen hier für einige noch nützlich sein.

Der Einfachheit halber für dieses Beispiel, sage du hast die Arbeitsbereich Kurven als den externen Arbeitsbereich gewählt, den du installieren möchtest:

  • Wähle das git Repositorium des von dir gewählten externen Arbeitsbereichs aus und lade es als ZIP Datei herunter
  • Angenommen, FreeCAD ist in /Applications/FreeCAD/v0.xx" installiert, gehe zu /Applications/FreeCAD/v0.xx" im Browser und wähle FreeCAD.app aus.
  • RechteMausTaste und wähle von "Paket Inhalt Anzeigen", ein neues Fenster erscheint mit einem Ordner namens "Contents".
  • Einmal Klick auf den Ordner "Contents" und wähle den Ordner "Mod".
  • Erstelle im Ordner "Mod" einen neuen Ordner namens "Curves"
  • Entpacke das heruntergeladene Repositorium im Ordner "Contents/Mod/Curves".

Allgemeine Fehlerbehebung

  • Verwende keine Sonderzeichen (z.B. deutsche Umlaute) in deinem Windows Benutzernamen, da FreeCAD sonst Dateien und Ordner im Makropfad nicht erkennt.
  • Wenn Du bereits einen Benutzernamen mit Sonderzeichen eingerichtet hast, erstelle entweder einen neuen Benutzernamen oder zeige den Makropfad auf ein Verzeichnis ohne Sonderzeichen.
  • Gehe zu Werkzeuge → Anpassen → Arbeitsbereiche und stelle sicher, dass der Arbeitsbereich nicht auf ausgeblendet gesetzt ist.
  • Mit 32-Bit System und FreeCAD 0.16.6706, nach dem Versuch der Installation sind die zusätzlichen Arbeitsbereiche möglicherweise nicht verfügbar. In diesem Fall