FreeCAD interface/it

From FreeCAD Documentation
Jump to navigation Jump to search

Pagina provvisoria

In questa e nella pagina Comandi per categorie si cerca di fornire una panoramica sintetica degli strumenti e delle opzioni disponibili in FreeCAD.

L'interfaccia di FreeCAD

Primo avvio

Al primo avvio, dopo la sua installazione, FreeCAD carica l'interfaccia di base e visualizza lo Start center che permette di passare rapidamente a uno degli ambienti di lavoro più comuni, di aprire uno dei file recenti, oppure di vedere le ultime novità dal mondo di FreeCAD. La schermata iniziale dei successivi riavvii può essere definita nelle preferenze.

Startcenter it 014.png


I pannelli dell'interfaccia di FreeCAD

Quando si avvia un ambiente vengono caricati altri moduli, appaiono i pulsanti degli strumenti specifici e l'interfaccia assume un aspetto simile a quello della figura sottostante.

FreeCAD interface.png

L'interfaccia principale di FreeCAD si compone essenzialmente dei seguenti pannelli:

  1. La vista 3D, l'area di lavoro, che visualizza gli oggetti contenuti nel documento
  2. La vista ad albero del pannello Vista Combinata che mostra la gerarchia e lo storico della costruzione di tutti gli oggetti del documento
  3. L'editore delle proprità che consente di visualizzare e modificare le proprietà degli oggetti selezionati
  4. La finestra del Registro degli eventi dove FreeCAD stampa i messaggi di avviso o i rapporti di errore
  5. La console di Python dove sono visibili tutti i comandi eseguiti da FreeCAD, e in cui è possibile inserire il codice python
  6. Il selettore degli Ambienti che mostra quello attivo


Barra dei menu dell'interfaccia principale

Menubar.png
  • File: gestione dei documenti
  • Modifica: gestione degli oggetti e delle preferenze
  • Visualizza: gestione della visualizzazione e ancoraggio dei pannelli
  • Strumenti: gestione delle utility
  • Macro: gestione degli script
  • Finestre: gestione delle finestre della scena 3D
  • Aiuto: accedere alla documentazione

Barra degli strumenti principali e comuni

Toolbar1.png

Questa barra raccoglie gli strumenti di uso frequente e consente di eseguire velocemente azioni comuni. In Linux probabilmente appare per prima e in Windows si trova subito sotto la barra dei menu. Contiene:

  • Le azioni standard dei menu File e Modifica del documento
  • Il pulsante Std Refresh.png Aggiorna la vista
  • Il selettore degli ambienti
  • I pulsanti per alcune viste preconfigurate (dall'alto, laterale, frontale, ecc) accessibili dal menu Visualizza → Viste standard oppure tramite i pratici comandi veloci dei tasti numerici ( 1, 2, 3 etc...)
  • Il menu Stile del disegno
  • Lo strumento di dimensionamento


Barre degli strumenti specifici

Toolbar2.png

Contengono gli strumenti specifici dei vari ambienti di lavoro, quindi sono molto diverse tra di loro. A volte propongono degli strumenti apparentemente uguali, in questi casi si deve confrontare il loro funzionamento per capire quale è meglio utilizzare, per esempio gli smussi di Part e di PartDesign.

Per questi strumenti consultare la descrizione del relativo ambiente.


Menu contestuali

I menu contestuali si aprono cliccando con il tasto destro sull'elemento.

  • Nella vista 3D
  • Su un oggetto nell'albero della Vista combinata
  • Nella barra degli strumenti
  • Nel campo dei rapporti o messaggi (report view). Consente di copiare il contenuto
  • Nel campo della console python. Consente di copiare e salvare lo storico
  • Sulla radice del documento
  • Su un ramo del documento


Altri comandi importanti


Preferenze e Personalizzare l'interfaccia

Il sistema delle preferenze di FreeCAD si trova nel menu Modifica → Preferenze. Si possono impostare i seguenti gruppi di preferenze:

Oltre a impostare le preferenze è possibile modificare in modo più radicale l'interfaccia. La finestra di personalizzazione è accessibile dal menu Strumenti → Personalizza.


Tastiera e mouse


La maggior parte delle azioni sono eseguite in modo totalmente automatico, invece altre richiedono che l'utente interagisca con la macchina per essere terminate efficacemente. Le finestre di dialogo permettono tale interazione.

  • Sketcher: Orientamento dello schizzo, Inserimento e modifica dei valori, ...
  • Arch: Opzioni parete, Componenti, ...
  • Draft: Inserimento dati, ...
  • Drawing: Dati della proiezione, Percorso per inserire un simbolo, ...
  • Part: Impostare l'estrusione, la rivoluzione, la simmetria, .....
  • PartDesign: Parametri raccordo, parametri di sformo, ...
  • Openscad: Parametri primitive, Mesh boolean,
  • ...

Altre finestre di dialogo riguardano:


Finestre delle proprietà

Struttura del documento