Réglage fin

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Fine-tuning and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎português do Brasil • ‎русский

Cette page contient différents réglages et paramètres que vous pouvez utiliser pour affiner votre installation FreeCAD ou pour résoudre certains problèmes.

Option paramètres

L'Editeur de préférences FreeCAD du menu Édition → Préférences est couramment utilisé pour définir et manipuler le tableau des paramètres de FreeCAD.

Cependant, il est également possible d'accéder, de modifier et de créer des paramètres manuellement, à l'aide du Editeur de paramètres situé dans le menu Outils → Editer paramètres....

La liste ci-dessous répertorie les paramètres qui ne sont pas accessibles via l’éditeur de préférences mais que vous pouvez définir manuellement (situé dans BaseApp/Preferences)

  • Addons/developerMode (booléen) : Défini à true pour activer le mode développeur du Gestionnaire d'Addon. Voir Métadonnées du package.
  • Bitmaps/Theme/ThemeSearchPaths (booléen) : Défini à false pour que FreeCAD utilise ses icônes incluses au lieu du thème des icônes du système sous Linux.
  • Dialog/DontUseNativeColorDialog (booléen) : Paramètre de la boîte de dialogue du sélecteur de couleur. Mettez-le à false si vous voulez que FreeCAD utilise la boîte de dialogue de couleur natif de votre système plutôt que la boîte de dialogue de couleur Qt. La valeur par défaut est true.
  • Dialog/DontUseNativeDialog' (booléen) : Paramètre de dialogue de fichier. Définissez-le à false si vous voulez utiliser la boîte de dialogue native de fichier lors de l'ouverture de fichiers ou à true pour utiliser la boîte de dialogue File Picker de Qt. La valeur par défaut dépend d'un paramètre de compilation : #define (USE_QT_FILEDIALOG).
  • Dialog/DontUseNativeFontDialog (booléen) : Utilisé par la commande Draft Formes à partir de texte. Mettez la valeur false pour utiliser la boîte de dialogue de la police native. La valeur par défaut est true.
  • DockWindows/DAGView/Enabled (booléen) : Défini à true pour activer un widget dockable beta de la Vue DAG. Après avoir changé la valeur du paramètre, un redémarrage de FreeCAD est nécessaire pour que le widget soit disponible dans la liste des vues/panneaux.
  • DockWindows/PropertyView/Enabled (booléen) : Défini à true pour activer un widget ancrable de l'Éditeur de propriétés indépendant de la vue combinée. Après avoir changé la valeur du paramètre, un redémarrage de FreeCAD est nécessaire pour que le widget soit disponible dans la liste des vues/panneaux.
  • Document/AutoNameDynamicProperty (booléen) : Mettre à true pour que FreeCAD renomme automatiquement les propriétés dynamiques avec un nom spécifié invalide au lieu de lancer une exception. Notez que le code Python n'aura pas accès au nouveau nom.
  • DockWindows/TreeView/Enabled (booléen) : Défini à true pour activer un widget ancrable de la vue en arborescence indépendant de la vue combinée. Après avoir changé la valeur du paramètre, un redémarrage de FreeCAD est nécessaire pour que le widget soit disponible dans la liste des vues/panneaux.
  • Document/ChangeViewProviderTouchDocument (booléen) : Défini à false pour que les changements de visibilité des éléments ne marquent pas le document comme modifié.
  • Document/SaveThumbnailFix (booléen) : Défini à true pour corriger un problème avec Qt5 qui empêche la génération de miniatures de fichiers .FCStd.
  • General/LockToolBars (booléen) : Défini à true pour empêcher les barres d'outils d'être déplaçables et pour cacher les petites poignées de déplacement. Surtout utilisé en conjonction avec des feuilles de style qui rendent les barres d'outils verticales.
  • General/RecentIncludesExported (booléen) : Défini à true pour inclure les fichiers exportés dans la liste des fichiers récents. La valeur par défaut est false.
  • General/RecentIncludesImported (booléen) : Défini à false pour exclure les fichiers importés de la liste des fichiers récents. La valeur par défaut est true.
  • Macro/DuplicateFrom001 : (booléen) : Défini à true pour toujours commencer à chercher le nom de fichier de macro dupliqué suggéré avec @001 au lieu du @NNN en cours, le cas échéant. La valeur par défaut est false.
  • Macro/DuplicateIgnoreExtraNote (booléen) : Défini à true pour ignorer la note supplémentaire lors de la suggestion d'un nom de fichier de macro dupliqué. La note supplémentaire est le texte du nom de fichier qui suit "@NNN" et précède ".FCMacro". Exemple : "my_macro@005.my_note.FCMacro". Si true, le nom de fichier suivant suggéré est "my_macro@006.FCMacro". S'il est défini sur false, le prochain nom de fichier suggéré est "my_macro@006.my_note.FCMacro". Pour être reconnu comme une note supplémentaire, le texte doit commencer par un point (".") après le "@NNN". Sinon, par exemple, "my_macro@006_my_note.FCMacro" se voit suggérer "my_macro@006_my_note@001.FCMacro" comme nouveau nom de fichier, ce qui peut être souhaitable dans certains cas. La valeur par défaut est false.
  • Macro/ReplaceSpaces (booléen) : Mettez la valeur false si vous ne voulez pas que les espaces dans vos noms de fichiers soient automatiquement convertis en caractères de soulignement lorsque vous créez, renommez ou dupliquez une macro. Cela n'affecte pas les fichiers existants, mais uniquement lors de la création d'un nouveau fichier ou du renommage ou de la duplication d'un fichier existant. La valeur par défaut est true.
  • MainWindow/ClearMenuBar (booléen) : Défini à true pour effacer la barre de menu lors du changement d'atelier, utile lors de l'utilisation d'un menu global, car elle peut ne pas être mise à jour lors du changement d'atelier et peut être rapidement encombrée par les entrées de menu de chaque atelier. La valeur par défaut est false. Sous macOS, elle est effacée dans les deux sens pour contourner un bogue de Qt.
  • MainWindow/ToolBarNameAsToolTip (booléen) : Défini à false pour ne pas obtenir le nom de la barre d'outils comme infobulle. La valeur par défaut est true.
  • Mod/Draft/defaultCameraHeight (entier) : Définit la hauteur de la caméra lorsque Draft démarre dans un document vide. 0 désactive, la valeur par défaut de FreeCAD est 5, bon quand on travaille en millimètres, une bonne hauteur pour le travail en arc est 4500.
  • Mod/Part/ParametricRefine (booléen) : Défini à false pour que Part Affiner la forme crée une copie indépendante plutôt qu'une copie liée. La valeur par défaut est true.
  • Mod/PartDesign/AdditiveHelixPreview (booléen) : Défini à true pour s'assurer qu'une hélice additive qui n'intersecte pas le corps est visible dans l'aperçu. La valeur par défaut est false.
  • Mod/PartDesign/SubtractiveHelixPreview (booléen) : Défini à true pour qu'une hélice soustractive qui n'intersecte pas le corps soit visible dans l'aperçu. La valeur par défaut est true.
  • Mod/PartDesign/SwitchToTask (booléen) : Défini à false pour empêcher l'atelier PartDesign de passer au panneau Tâche au démarrage. La valeur par défaut est true.
  • Mod/PartDesign/SwitchToWB (booléen) : Définissez-le sur false pour empêcher l'appel automatique de l'atelier PartDesign lorsqu'un PartDesign Corps est activé. La valeur par défaut est true.
  • Mod/Sketcher/RadiusDiameterConstraintDisplayBaseAngle (flottant) : Définit l'angle (par rapport à l'horizontale) utilisé pour afficher les contraintes de rayon/diamètre dans Sketcher au moment de la création. La valeur par défaut est de 15 degrés (si aucune valeur n'est définie).
  • Mod/Sketcher/RadiusDiameterConstraintDisplayAngleRandomness (flottant) : Définit un angle aléatoire sur la valeur ci-dessus. La valeur est la plage de l'angle aléatoire, centrée sur l'angle de base. La valeur par défaut est 0 degré -- désactivé -- (si aucune valeur n'est définie).
  • PropertyView/AutoTransactionView (booléen) : Défini à true pour que les modifications des propriétés de l'onglet View soient ajoutées à la pile d'annulation (et donc annulables). La valeur par défaut est false.
  • Selection/AutoShowSelectionView (booléen) : Défini à true pour que le volet de la vue de sélection s'affiche automatiquement lorsque vous sélectionnez quelque chose. La valeur par défaut est false.
  • Selection/singleClickFeatureSelect (booléen) : Défini à false pour désactiver la sélection en un seul clic d'une fonction dans PartDesign. La valeur par défaut est true.
  • TreeView/TreeViewStretchDescription (booléen) : Défini à true pour étirer la colonne 'Description' dans la Vue en arborescence vers le bord droit du volet. La valeur par défaut est false.
  • View/Dimensions3dColor (chaîne) : Définit une valeur de couleur au format hexa #RRGGBB pour modifier la couleur d'affichage des dimensions directes dans Part Mesure linéaire.
  • View/DimensionsAngularColor (chaîne) : Définit une valeur de couleur au format hexa #RRGGBB pour modifier la couleur d'affichage de la dimension angulaire dans Part Mesure angulaire.
  • View/DimensionsDeltaColor (chaîne) : Définit une valeur de couleur au format hexa #RRGGBB pour modifier la couleur d'affichage des dimensions orthogonales dans Part Mesure linéaire.
  • View/NavigationDebug (booléen) : Active la sortie de débogage des styles de navigation (à partir de la v0.19, seul le style de navigation Gesture a quelque chose à dire).
  • View/SavePicture (chaîne) : Défini à FramebufferObject, PixelBuffer ou CoinOffscreenRenderer pour différentes méthodes de production d'images à partir de la vue 3D.

Exportation du nom de fichier par défaut

  • General/ExportDefaultFilenameMultiple (chaîne de caractères): définit le nom de fichier par défaut à utiliser lors de l'exportation d'objets multiples. La valeur par défaut est "%F".
  • General/ExportDefaultFilenameSingle (chaîne de caractères): définit le nom de fichier par défaut à utiliser lors de l'exportation d'un objet unique. La valeur par défaut est "%F-%P-".

Ces deux options permettent l'insertion automatique de diverses informations dans le nom du fichier, en utilisant les caractères de format suivants :

  • %F - le nom du fichier .FCStd (ou l'étiquette, si elle n'est pas encore enregistrée)
  • %Lx - l'étiquette du ou des objets sélectionnés, séparés par le caractère 'x'.
  • %Px - l'étiquette du ou des objets sélectionnés et de leur premier parent, séparés par le caractère 'x'.
  • %U - la date et l'heure, en UTC, ISO 8601
  • %D - la date et l'heure, dans le fuseau horaire local, ISO 8601

Tous les autres caractères sont traités littéralement. Si le nom de fichier résultant est illégal, il sera modifié lors de la sauvegarde, les caractères illégaux étant remplacés par le trait de soulignement (_).

Couleurs des étiquettes de contraintes dans Sketcher

L'étiquette dans Sketcher qui affiche l'état en cours des contraintes (par exemple, "Underconstrained", "Overconstrained", "Fully Constrained", etc...) peut être stylisée sur une base par état, soit à l'aide de la feuille de style Qt, soit via les préférences de l'utilisateur. Les préférences de l'utilisateur sont prioritaires si elles ont été définies (dans Mod/Sketcher/General) :

  • EmptySketchMessageColor - Valeur par défaut à 50% d'opacité noire.
  • UnderconstrainedMessageColor - Noir par défaut
  • MalformedConstraintMessageColor - Rouge par défaut
  • ConflictingConstraintMessageColor - Rouge par défaut
  • RedundantConstraintMessageColor - Rouge orangé par défaut
  • PartiallyRedundantConstraintMessageColor - Bleu royal par défaut
  • SolverFailedMessageColor - Rouge par défaut
  • FullyConstrainedMessageColor - Vert par défaut

En rapport avec la souris

  • General/ComboBoxWheelEventFilter (booléen) : Défini à true pour que les widgets ne captent pas l'événement de la molette de la souris et empêchent le défilement des zones défilantes. Nécessite le redémarrage de FreeCAD pour être pris en compte.
  • View/GestureMoveThreshold (entier): le curseur de la souris à distance (px) doit se déplacer pour entrer dans les modes de rotation ou de panoramique du style de navigation Gesture. La valeur par défaut est 5.
  • View/GestureRollFwdCommand, View/GestureRollBackCommand (chaîne): commandes à exécuter par des gestes de roulis de bouton de la souris de style de navigation Gesture.
  • View/GestureTapHoldTimeout (entier): définit le temps d'attente (en millisecondes) pour passer en mode panoramique dans le style de navigation Gesture. Il peut être utile de l'augmenter s'il est difficile de faire glisser la géométrie dans l'esquisse. La valeur par défaut est 700.

Raccourci clavier

Touche Echap

  • General/TasksKeyEsc (booléen): Créez et mettez à false pour désactiver la touche Echap sortant du Panneau des tâches dans tous les ateliers (c'est-à-dire si le panneau des tâches a le focus). Remarque: remplacé par Sketcher Préférences.
  • Mod/Sketcher/ViewKeyEsc (booléen): Créez et mettez à false pour désactiver les problèmes de la touche Echap en appuyant une à plusieurs fois, lors de l'échappement de la création de géométrie/contraintes mode continue. (voir fil de discussion)

Ateliers particuliers

  • L'Workbench TechDraw.svg atelier TechDraw dispose de plusieurs options masquées décrits dans TechDraw Préférences.
  • L'Workbench Path.svg atelier Path a une option pour activer les fonctionnalités expérimentales documentées dans Path Fonctions expérimentales.
  • L'Workbench BIM.svg atelier BIM:
    • Mod/BIM/DefaultPageScale (flottant): mise à l'échelle par défaut pour les nouvelles pages TechDraw créées à partir de l'atelier BIM, au cas où le modèle ne contiendrait pas de champ de texte modifiable (insensible au texte) "Échelle" ou "Mise à l'échelle".

En relation