Fine-tuning

From FreeCAD Documentation
Jump to navigation Jump to search
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski

This page holds different settings and parameters that you can use to fine-tune your FreeCAD installation or overcome problems.

Option parameters

The FreeCAD Preferences Editor under menu Edit → Preferences is commonly used to set and manipulate the FreeCAD parameters table.

However, it is also possible to access, modify and create parameters manually, using the Parameter Editor found under menu Tools → Edit parameters.

The list below shows parameters that are not accessible via the preferences editor, but that you can set manually (located in BaseApp/Preferences)

  • DockWindows/DAGView/Enabled (boolean): Set to true to enable a beta DAG view dockable widget. After changing the parameter value, a FreeCAD restart is needed so the widget is available in the View/Panels list.
  • DockWindows/PropertyView/Enabled (boolean): Set to true to enable a Property View dockable widget independent from the Combo View. After changing the parameter value, a FreeCAD restart is needed so the widget is available in the View/Panels list.
  • DockWindows/TreeView/Enabled (boolean): Set to true to enable a Tree View dockable widget independent from the Combo View. After changing the parameter value, a FreeCAD restart is needed so the widget is available in the View/Panels list.
  • Document/ChangeViewProviderTouchDocument (boolean) : Set to false so items visibility changes won't mark the document as changed.
  • Document/SaveThumbnailFix (boolean): Set to true to fix a problem with Qt5 that prevents the generation of .FCStd file thumbnails.
  • General/RecentIncludesExported (boolean): Set to true to include exported files in the Recent Files list. Defaults to false.
  • General/RecentIncludesImported (boolean): Set to false to exclude imported files from the Recent Files list. Defaults to true.
  • Mod/Draft/defaultCameraHeight (int) : Sets the height of the camera when Draft starts in an empty document. 0 disables, FreeCAD default is 5, good when working in millimeters, a good height for arch work is 4500.
  • Mod/Part/ParametricRefine (boolean) : Set to false so Part RefineShape creates an independent copy rather than a linked one. Defaults to true.
  • Mod/PartDesign/AdditiveHelixPreview (boolean): Set to true to ensure an additive helix that does not intersect the body is visible in the preview. Defaults to false.
  • Mod/PartDesign/SubtractiveHelixPreview (boolean): Set to true to ensure a subtractive helix that does not intersect the body is visible in the preview. Defaults to true.
  • Mod/PartDesign/SwitchToTask (boolean): Set to false to prevent the PartDesign Workbench from switching to the Task panel when starting. Defaults to true.
  • Mod/PartDesign/SwitchToWB (boolean): Set to false to prevent the PartDesign Workbench to be automatically called when a PartDesign Body is activated. Defaults to true.
  • PropertyView/AutoTransactionView (boolean) : Set to true so changes of View tab properties are added to the undo stack (hence are undoable). Defaults to false.
  • View/NavigationDebug (boolean) : enables debug output of navigation styles (as of v0.19, only Gesture navigation style has something to say).
  • View/NaviStepByTurn (integer) : Defines how many incremental steps (notches) to complete a turn when using the arrows of the NaviCube. If value isn't defined, it defaults to 8, which means each increment rotates of 360/8 = 45 deg.
  • View/SavePicture (string): Set to FramebufferObject, PixelBuffer or CoinOffscreenRenderer for different methods to produce images from the 3D view.

Export Default Filename

  • General/ExportDefaultFilenameMultiple (string): Set the default filename to use when exporting multiple objects. Defaults to "%F".
  • General/ExportDefaultFilenameSingle (string): Set the default filename to use when exporting a single object. Defaults to "%F-%P-".

Both of these options support the automatic insertion of various pieces of information into the filename, using the following format characters:

  • %F - the name of the .FCStd file (or the label, if it is not saved yet)
  • %Lx - the label of the selected object(s), separated by character 'x'
  • %Px - the label of the selected object(s) and their first parent, separated by character 'x'
  • %U - the date and time, in UTC, ISO 8601
  • %D - the date and time, in local timezone, ISO 8601

Any other characters are treated literally. If the resulting filename is illegal it will be changed on saving, with illegal characters replaced by the underscore (_).

Mouse related

  • General/ComboBoxWheelEventFilter (boolean) : Set to true so widgets do not catch mouse wheel event and prevent scrollable areas to be scrolled.
  • View/GestureMoveThreshold (integer) : the distance (px) mouse cursor has to move to enter rotation or pan modes of Gesture navigation style. Default is 5.
  • View/GestureRollFwdCommand, View/GestureRollBackCommand (string) : commands to be executed by mouse button roll gestures of Gesture navigation style.
  • View/GestureTapHoldTimeout (integer) : sets for how long to wait (in milliseconds) to enter pan mode in Gesture navigation style. It can be helpful to increase it if dragging geometry in sketcher is difficult. Default is 700.

Keyboard Shortcuts

Escape Key

  • General/TasksKeyEsc (boolean) : Create and set to false to disable the ESC key exiting the Task panel in all workbenches (that is if the task panel has focus). Note: Superceded by Sketcher Preferences.
  • Mod/Sketcher/ViewKeyEsc (boolean) : Create and set to false to disable ESC key issues with pressing one to many times, when escaping sketcher geometry/constraints creation continue mode (see forum thread)

Specific Workbenches

Related