FEM SolverElmer/ru

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page FEM SolverElmer and the translation is 25% complete.
Outdated translations are marked like this.
Other languages:
English • ‎français • ‎italiano • ‎polski • ‎português do Brasil • ‎русский
Arrow-left.svg Назад: FEM SolverCalculiX.svg Solver CalculiX
Далее: Solver Z88 FEM SolverZ88.svg Arrow-right.svg

Fem-elmer.svg FEM SolverElmer

Системное название
FEM SolverElmer
Расположение в меню
Solve → solver Elmer
Верстаки
FEM
Быстрые клавиши
Нет
Представлено в версии
-
См. также
FEM Solver CalculiX, FEM Solver Z88, Учебник МКЭ

Описание

Elmer - это программное обеспечение для мультифизического моделирования с открытым исходным кодом, которое в основном разрабатывается CSC - IT Center for Science (CSC). Разработка Elmer началась в 1995 году в сотрудничестве с финскими университетами, исследовательскими институтами и промышленностью. После публикации с открытым исходным кодом в 2005 году использование и развитие Elmer стало международным.

Элмер включает, в частности, физические модели гидродинамики, строительной механики, электромагнетизма, теплопередачи и акустики. Они описываются уравнениями в частных производных, которые Элмер решает методом конечных элементов (МКЭ). https://www.csc.fi/web/elmer

Создание объекта SolverElmer в контейнере анализа в FreeCAD дает доступ к уравнениям Elmer для простого или мультифизического анализа.

Since FreeCAD already has an extensive integration of FEM SolverCalculiX.svg Calculix and FEM SolverZ88.svg Z88 as solvers for mechanical and thermo-mechanical analysis, Elmer will be preferred for Computational Fluid Dynamics (CFD), Heat, Electrostatics, Magnetostatics and Electrical Forces. It can also be used for mechanical FEA through the Elasticity equation or any combination of the aforementioned equations.

Установка

Elmer requires two components to be interfaced with FreeCAD:

  • ElmerGrid is the interface handling meshes
  • ElmerSolver is handling the computation.

There are standalone programs for both of these applications but their installation and usage are beyond the scope of the FreeCAD integration.

  1. Go to the CSC binaries resources for Elmer: binaries OR CSC binaries
  2. Download and install the version best suited to your Operating System (Windows 64 bits or Linux)
  3. In FreeCAD go to Edit → Preferences → FEM → Elmer
  4. Link the correct path for both ElmerGrid and ElmerSolver
    Elmer Tab in FEM Preferences

    Above: Elmer preferences dialog menu showing fields to locate important Elmer binaries on Windows OS

You are ready to use Elmer in FreeCAD.

Использование

  1. Switch to the Workbench FEM.svg FEM Workbench
  2. Create an Analysis container by pressing the FEM Analysis.svg icon.
  3. Create a FEM Solver for Elmer, by pressing the FEM SolverElmer.svg icon.
    • Note: A successful analysis will require at least a Model (2D or 3D), a Material (Fluid or Solid), a Mesh, Equations and Boundary conditions
    Elmer typical file tree.png

    Above: Example of a tree view once a Solver for Elmer is activated

  4. Edit the parameters for the solver in the Property editor Data tab of the SolverElmer object in the model tree view
  5. Double-click on the FEM SolverElmer.svg SolverElmer object to prepare an analysis run
    ElmerSolver TaskPanel.png

    Above: Dialog box to run an Elmer analysis

  6. Select the path to write the analysis in by clicking ...
  7. Click Write to write the case files in the directory selected previously
  8. Click Run to start the analysis

About Equations

  • To perform the analysis of a particular physical behavior, an Equation must be used (Flow, Heat, Electrostatics...)
  • Disambiguation: The term Equation is used in FreeCAD to describe the different physical mechanisms, the term Solver is used in all Elmer documents. Thus when using in FreeCAD the "Flow Equation", in reality Elmer uses the "Flow Solver" to find a solution to the Navier-Stokes equation.
  • One or several equations can be used at once with Elmer by simply adding the equation object under the SolverElmer object, thus performing multi-physics analyses:
  1. Click on the FEM SolverElmer.svg SolverElmer object in the model tree view
  2. Select an equation:

Notes

  • Parameters for the Solver and for the Equations are independently set through the Property editor Data tab of their respective objects in the tree view.
  • Each equation will have a priority, for example, if trying see the effect of a convective flow of hot air, the equation for Flow should be solved with higher priority than Heat, otherwise the solver will first solve Heat through conduction and then Flow.
  • 2D vs 3D cases: Elmer can be used to solve both 2D and 3D cases. However, when defining a 2D case, the faces need to be mapped in the XY plane of FreeCAD, otherwise the solver will try to compute a 3D case on a face, and normal vectors will be under-defined. Further information can be found in the FreeCAD forums: https://forum.freecadweb.org/viewtopic.php?f=18&t=48175

Документация

The following link gives access to the full documentation for Elmer. This includes the manuals as well as tutorials. Note that documentation and files appended with "gui" generally concern the usage of the Elmer GUI and not the FreeCAD implementation of Elmer.


Arrow-left.svg Назад: FEM SolverCalculiX.svg Solver CalculiX
Далее: Solver Z88 FEM SolverZ88.svg Arrow-right.svg