FEM Pipeline à partir du résultat

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page FEM PostPipelineFromResult and the translation is 100% complete.
Other languages:
English • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎русский

FEM PostPipelineFromResult.svg FEM Pipeline à partir du résultat

Emplacement du menu
Résultats → Afficher le pipeline à partir du résultat
Ateliers
FEM
Raccourci par défaut
Aucun
Introduit dans la version
0.17
Voir aussi
FEM Tutoriel

Description

Pipeline est un objet résultat, qui crée une nouvelle représentation graphique des résultats de l'analyse FEM sur la pièce analysée. Il ajoute une échelle de couleurs et des options d'affichage.

Utilisation

  1. Sélectionnez un objet résultat.
  2. Cliquez sur le bouton FEM PostPipelineFromResult.svg, ou sélectionnez l'option Résultats → FEM PostPipelineFromResult.svg Afficher le pipeline à partir du résultat dans le menu.
  3. Un nouvel objet appelé "Pipeline" est ajouté à votre analyse.
  4. Double-cliquez sur le nouvel objet Pipeline dans la Vue en arborescence et sélectionnez un mode d'affichage et le champ de résultat. Par exemple, pour le mode Surface et le champ Contrainte de von Mises, le pipeline aura l'aspect suivant :

Pipeline.PNG

Si vous ne voyez aucun modèle dans la zone graphique, allez dans et activez Edition → Préférences → Affichage → Vue 3D → Rendu → Couleur du rétroéclairage.

Si vous utilisez un dérivé du [SI] du système d'unités de FreeCAD, les valeurs de l'échelle de sortie sont également basées sur les unités SI. Cela signifie que le déplacement est en mètre, la contrainte est en Pascal et la température est en Kelvin.

Propriétés

Boîte de dialogue

Cette Boîte de dialogue de pipeline a les paramètres suivants :

  • Mode : Comment dessiner les résultats. Les modes possibles sont
    • Outline : Le contour du maillage du résultat. En fait, n'affiche aucun résultat mais seulement les bords du maillage.
    • Nodes : Les nœuds du maillage résultat
    • Surface : C'est la valeur par défaut et elle affiche la surface de la maille résultante.
    • Surface with Edges : Comme Surface mais avec les bords du contour du maillage et les lignes de connexion des noeuds du maillage de surface.
  • Champ : La propriété du résultat à dessiner.
  • Vecteur : N'est actif que si Champ est un vecteur. Vous pouvez choisir d'afficher le vecteur Magnitude ou ses composantes X, Y, Z.

Echelle

Si vous double-cliquez sur l'échelle, vous obtenez cette boîte de dialogue de paramétrage :

SIMTUT 05.PNG

et vous pouvez ses propriétés :

  • Dégradé : Vous pouvez sélectionner l'ordre inversé du gradient de couleur par défaut, Rouge-Blanc-Bleu, Noir-Blanc ou Blanc-Noir.
  • Style : L'option par défaut Flux utilise la gamme complète des dégradés de couleurs. L'option Zéro n'utilise que la gamme de couleurs du gradient en partant de la couleur qui afficherait la valeur moyenne jusqu'au maximum.
  • Visibilité : L'option Sortie griséee colorera en gris tous les nœuds de la maille dont les valeurs sont en dehors de la plage minimum/maximum définie. L'option Sortie transparente rendra ces mailles transparentes.
  • Gamme de paramètres : Les valeurs minimales et maximales sont remplies automatiquement. Vous pouvez les modifier, cependant assurez-vous de savoir ce que vous faites. Vous pouvez également modifier le nombre de décimales affichées et le nombre d'étiquettes réparties sur la plage de paramètres.

Éditeur de propriétés

Dans l'éditeur de propriétés, vous pouvez définir dans l'onglet Vue les paramètres de la boîte de dialogue. Dans l'onglet Données, vous pouvez également définir ces paramètres :

  • DonnéesMode : Comment les filtres utilisés dans le pipeline seront traités. Ces modes possibles sont :
    • Serial : Dans ce mode, chaque filtre prend le filtre précédent comme entrée. L'ordre est donc l'ordre de création. Le premier filtre créé prend le pipeline en entrée. Sa propriété Input est donc vide.
    • Parallel : Dans ce mode, tous les filtres prennent le pipeline en entrée.
    • Custom : Introduit dans la version 0.20 C'est le mode par défaut et il garde les entrées des filtres telles qu'elles sont. Il permet donc d'avoir, par exemple, deux filtres qui prennent le pipeline en entrée, et un troisième filtre qui prend l'un des deux filtres en entrée.

Limitations

La représentation en pipeline des résultats (appelée VTK) sur la partie affichée est différente des résultats en gradient de couleur qui sont visibles lorsque vous terminez la solution. Les valeurs de l'échelle de gradient ne peuvent pas être appliquées à l'objet de résultat de solution.